New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot import GEDCOM from GENi due to leading blanks #166

Closed
haralduna opened this Issue Sep 29, 2016 · 3 comments

Comments

Projects
None yet
2 participants
@haralduna

haralduna commented Sep 29, 2016

I just learned from a user that GEDCOM exports from GENi contain leading blanks (for readability) and that gedcom4j fails to import such lines.

From the GEDCOM 5.5 standard:
Leading white space (tabs, spaces, and extra line terminators) preceding a GEDCOM line should be ignored by the reading system. Systems generating GEDCOM should not place any white space in front of the GEDCOM line.

I am attaching a simple GEDCOM export from GENi demonstrating the issue.
geni-test.txt

I think GENi is a pretty huge player in the market so it would be nice if import was working.

@frizbog

This comment has been minimized.

Owner

frizbog commented Sep 29, 2016

Confirmed to be a problem with UTF8 encoded files. This had been addressed way earlier in issue #57 but that file used ANSEL encoding.

frizbog added a commit that referenced this issue Sep 29, 2016

frizbog added a commit that referenced this issue Sep 29, 2016

@frizbog frizbog added this to the Release 4.0.0 milestone Sep 29, 2016

@frizbog

This comment has been minimized.

Owner

frizbog commented Sep 29, 2016

Fixed in 3.2.2-SNAPSHOT of 2016-09-29T08:04:22-04:00
Fixed in 4.0.0-SNAPSHOT of 2016-09-29T08:07:37-04:00

@frizbog frizbog self-assigned this Sep 29, 2016

@frizbog

This comment has been minimized.

Owner

frizbog commented Sep 29, 2016

Released in v3.2.2

@frizbog frizbog closed this Sep 29, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment