Fixed required_ruby_version in gemspec #9

Merged
merged 1 commit into from Aug 9, 2012

Conversation

Projects
None yet
2 participants
Collaborator

gr4y commented Aug 9, 2012

Hi,

it's me again. I added the new version you released today to my Gemfile and ran the bundle update command. I was a little puzzled when Bundler told me this:

Installing mongoid-minitest (0.1.0) 
Gem::InstallError: mongoid-minitest requires Ruby version = 1.9.3.
An error occured while installing mongoid-minitest (0.1.0), and Bundler cannot continue.
Make sure that `gem install mongoid-minitest -v '0.1.0'` succeeds before bundling.

In fact I am using ruby 1.9.3-p194, so I took a look into the gemspec and found the line which causes the problem. Based on the rubygems doc I played around with the required_ruby_version and found out that this would do the trick:

gem.required_ruby_version = '>= 1.9.3'

Installing on 1.9.2 doesn't work now, but installing on 1.9.3 works. By the way: Why are you requiring 1.9.3? I ran the test suite on an ruby 1.9.2-p320 and nothing failed there. And as far as I saw neither mongoid nor minitest is requiring 1.9.3. :-)

frodsan pushed a commit that referenced this pull request Aug 9, 2012

Merge pull request #9 from gr4y/master
Fixed required_ruby_version in gemspec

@frodsan frodsan merged commit 1d4e294 into frodsan:master Aug 9, 2012

Owner

frodsan commented Aug 9, 2012

Hey, thanks again. I'm removing that from the gemspec. From now on, you can install the gem no matter what version of ruby you are using. I have no tested on other versions (including Travis), that's why I just wanted to support 1.9.3. If it works in 1.9.2, it's fine too. I'm not currently working with mongoid, but I want to keep improving this gem. Do you want to have contributor access?

btw, I released 0.1.1 :)

Collaborator

gr4y commented Aug 10, 2012

Hi,

You are welcome. Contributor access could be very helpful. :)
I would like to fix some of the open issues.

Am 09.08.2012 um 22:31 schrieb Francesco Rodríguez notifications@github.com:

Hey, thanks again. I'm removing that from the gemspec. From now on, you can install the gem no matter what version of ruby you are using. I have no tested on other versions (including Travis), that's why i just wanted to support 1.9.3. If it works in 1.9.2, it's fine too. I'm not currently working with mongoid, but i want to keep improving this gem. Do you want to have contributor access?

btw, I released 0.1.1 :)


Reply to this email directly or view it on GitHub.

Owner

frodsan commented Aug 10, 2012

Hi Sascha,

I already add you to the collaborators list, so i guess you have commit access.
If you have any questions, don't hesitate to ask :)

Cheers!

Francesco

Collaborator

gr4y commented Aug 10, 2012

Thank you! I am looking forward to diving into the code. :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment