Skip to content


Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP


Fixed required_ruby_version in gemspec #9

merged 1 commit into from

2 participants



it's me again. I added the new version you released today to my Gemfile and ran the bundle update command. I was a little puzzled when Bundler told me this:

Installing mongoid-minitest (0.1.0) 
Gem::InstallError: mongoid-minitest requires Ruby version = 1.9.3.
An error occured while installing mongoid-minitest (0.1.0), and Bundler cannot continue.
Make sure that `gem install mongoid-minitest -v '0.1.0'` succeeds before bundling.

In fact I am using ruby 1.9.3-p194, so I took a look into the gemspec and found the line which causes the problem. Based on the rubygems doc I played around with the required_ruby_version and found out that this would do the trick:

gem.required_ruby_version = '>= 1.9.3'

Installing on 1.9.2 doesn't work now, but installing on 1.9.3 works. By the way: Why are you requiring 1.9.3? I ran the test suite on an ruby 1.9.2-p320 and nothing failed there. And as far as I saw neither mongoid nor minitest is requiring 1.9.3. :-)

@frodsan frodsan merged commit 1d4e294 into frodsan:master

Hey, thanks again. I'm removing that from the gemspec. From now on, you can install the gem no matter what version of ruby you are using. I have no tested on other versions (including Travis), that's why I just wanted to support 1.9.3. If it works in 1.9.2, it's fine too. I'm not currently working with mongoid, but I want to keep improving this gem. Do you want to have contributor access?

btw, I released 0.1.1 :)


Hi Sascha,

I already add you to the collaborators list, so i guess you have commit access.
If you have any questions, don't hesitate to ask :)




Thank you! I am looking forward to diving into the code. :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Aug 9, 2012
  1. @gr4y
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  mongoid-minitest.gemspec
2  mongoid-minitest.gemspec
@@ -15,7 +15,7 @@ do |gem|
gem.require_paths = ['lib']
gem.version = Mongoid::MiniTest::VERSION
- gem.required_ruby_version = '1.9.3'
+ gem.required_ruby_version = '>= 1.9.3'
gem.add_dependency 'minitest', '~> 3.3.0'
gem.add_dependency 'mongoid' , '~> 3.0.2'
Something went wrong with that request. Please try again.