Permalink
Browse files

Upgraded YUI Compressor to 2.4.2

  • Loading branch information...
cgriego committed Nov 19, 2008
1 parent b4dd3ff commit a1f2e8c1f0b3cd3be58e33c02f502e74683dfffd
Showing with 7 additions and 5 deletions.
  1. +6 −4 blender.gemspec
  2. +1 −1 lib/front_end_architect/blender.rb
  3. BIN lib/yui/yuicompressor.jar
View
@@ -1,10 +1,12 @@
+# -*- encoding: utf-8 -*-
+
Gem::Specification.new do |s|
s.name = %q{blender}
- s.version = "0.21"
+ s.version = "0.22"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Blake Elshire", "Chris Griego"]
- s.date = %q{2008-10-21}
+ s.date = %q{2008-11-18}
s.default_executable = %q{blend}
s.description = %q{Blender is like ant or make for the front-end. It aggregates and compresses CSS and/or JavaScript assets for a site into efficient, production-ready files.}
s.email = %q{blender@front-end-architect.com}
@@ -17,14 +19,14 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
s.requirements = ["Java, v1.4 or greater"]
s.rubyforge_project = %q{blender}
- s.rubygems_version = %q{1.2.0}
+ s.rubygems_version = %q{1.3.1}
s.summary = %q{Blender outputs efficient, production-ready CSS and/or JavaScript assets.}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 2
- if current_version >= 3 then
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<mime-types>, [">= 1.15"])
s.add_runtime_dependency(%q<colored>, [">= 1.1"])
s.add_development_dependency(%q<hoe>, [">= 1.8.0"])
@@ -18,7 +18,7 @@
module FrontEndArchitect
class Blender
- VERSION = '0.21'
+ VERSION = '0.22'
FILTER_REGEX = /filter: ?[^?]+\(src=(['"])([^\?'"]+)(\?(?:[^'"]+)?)?\1,[^?]+\1\);/im
IMPORT_REGEX = /@import(?: url\(| )(['"]?)([^\?'"\)\s]+)(\?(?:[^'"\)]+)?)?\1\)?(?:[^?;]+)?;/im
View
Binary file not shown.

0 comments on commit a1f2e8c

Please sign in to comment.