Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

paket update for fake runner FSharp.Core 4.7 #2373

Merged
merged 2 commits into from Aug 17, 2019

Conversation

@drssoccer55
Copy link
Contributor

commented Aug 13, 2019

Response to error message saying FAKE runner uses FSharp.Core 4.6 instead of latest FSharp.Core. I've worked around it locally but think the runner should be updated.

Following instructions from issue 2001

Forked, cloned, paket update, and submitted PR.

@drssoccer55

This comment has been minimized.

Copy link
Contributor Author

commented Aug 13, 2019

image

Whoops forgot this update broke me too. Will have to update FAKE to get rid of the namespace.

@drssoccer55

This comment has been minimized.

Copy link
Contributor Author

commented Aug 14, 2019

Travis CI build failed. Looks like an issue for generate docs where it is trying to execute a command with a list of dlls and failing because it is an empty list. Unclear to me at the moment why paket update broke this.

https://travis-ci.org/fsharp/FAKE/builds/571432477?utm_source=github_status&utm_medium=notification

could not parse [|"metadataformat"; "--generate"; "--outdir"; "./docs/apidocs/v5/legacy";
    "--layoutRoots"; "./help/templates/legacy"; "./help/templates";
    "./help/templates/reference"; "--sourceRepo";
    "https://github.com/fsharp/FAKE/blob/master"; "--sourceFolder";
    "/home/travis/build/fsharp/FAKE"; "--parameters"; "api-docs-prefix";
    "/apidocs/v5/legacy/"; "CurrentPage"; "APIReference"; "page-description";
    "FAKE - F# Make"; "page-author";
    "Steffen Forkmann, Mauricio Scheffer, Colin Bull, Matthias Dittrich";
    "project-author";
    "Steffen Forkmann, Mauricio Scheffer, Colin Bull, Matthias Dittrich";
    "github-link"; "https://github.com/fsharp/FAKE"; "version";
    "5.15.5-alpha.local.1"; "project-github"; "http://github.com/fsharp/FAKE";
    "project-nuget"; "https://www.nuget.org/packages/FAKE"; "root";
    "https://fake.build"; "project-name"; "FAKE - F# Make"; "--dllfiles"|]
  missing required option 'dllFiles' or invalid option value
@matthid

This comment has been minimized.

Copy link
Collaborator

commented Aug 17, 2019

Thanks for looking into this! Sometimes it's really frustrating to get things working again after paket update ...

@matthid

This comment has been minimized.

Copy link
Collaborator

commented Aug 17, 2019

One problem might be that FSharp.Core no longer supports netstandard1.6 and we still build some stuff for netstandard1.6. I'll take a look

@matthid matthid referenced this pull request Aug 17, 2019
@matthid matthid merged commit 76aa04b into fsharp:release/next Aug 17, 2019
2 of 3 checks passed
2 of 3 checks passed
continuous-integration/travis-ci/pr The Travis CI build failed
Details
FAKE-CI #1220 succeeded
Details
continuous-integration/appveyor/pr AppVeyor build succeeded
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.