Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Deprecating Full Framework version of FSAC #506

Open
Krzysztof-Cieslak opened this issue Nov 18, 2019 · 0 comments
Open

Deprecating Full Framework version of FSAC #506

Krzysztof-Cieslak opened this issue Nov 18, 2019 · 0 comments
Labels

Comments

@Krzysztof-Cieslak
Copy link
Contributor

@Krzysztof-Cieslak Krzysztof-Cieslak commented Nov 18, 2019

I think we all agree that in terms of tooling host .Net Core is better, more stable target. And that .Net Core is a future of .Net. So my proposal would be to remove multi-targeting from FSAC, and target just .Net Core as runtime platform.

Keep in mind it doesn't mean dropping support for Full Framework projects, it just means you need .Net SDK to run FSAC.

juergenhoetzel added a commit to juergenhoetzel/emacs-fsharp-mode that referenced this issue Nov 24, 2019
Full Framework version of FSAC is deprecated:
fsharp/FsAutoComplete#506
juergenhoetzel added a commit to juergenhoetzel/emacs-fsharp-mode that referenced this issue Nov 24, 2019
Full Framework version of FSAC is deprecated:
fsharp/FsAutoComplete#506
juergenhoetzel added a commit to juergenhoetzel/emacs-fsharp-mode that referenced this issue Nov 24, 2019
Full Framework version of FSAC is deprecated:
fsharp/FsAutoComplete#506
juergenhoetzel added a commit to juergenhoetzel/emacs-fsharp-mode that referenced this issue Nov 30, 2019
Full Framework version of FSAC is deprecated:
fsharp/FsAutoComplete#506
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.