Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

configure.ac: warn if not using Mono >= 2.11.5

This version of mono is the first one which has the necessary fixes
to make xbuild work with F#, so let's warn the user just in case she
needs this functionality.

The commit in question is:
mono/mono@cca3cb1
  • Loading branch information...
commit a4ea68d97be0854f65ae165688bb70f0d4098cec 1 parent 46179e5
@knocte knocte authored
Showing with 6 additions and 0 deletions.
  1. +6 −0 configure.ac
View
6 configure.ac
@@ -14,6 +14,12 @@ fi
PKG_CHECK_MODULES([MONO], [mono >= 2.9])
+PKG_CHECK_MODULES([MONO_2_12],
+ [mono >= 2.11.5], HAVE_MONO_2_12_OR_HIGHER=yes, HAVE_MONO_2_12_OR_HIGHER=no)
+
+if test "x$HAVE_MONO_2_12_OR_HIGHER" = "xno" ; then
+ AC_MSG_WARN([Mono 2.11.5 or higher is recommended, for better MSBuild (xbuild) compatibility])
+fi
# Checks for libraries.
Please sign in to comment.
Something went wrong with that request. Please try again.