Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Allow build on unsupported GOOS #424

Merged
merged 1 commit into from Jan 25, 2022
Merged

Conversation

tklauser
Copy link
Contributor

@tklauser tklauser commented Jan 24, 2022

In cases where fsnotify is a transitive dependency of a package, it
might need to be built on platforms not supported (yet), e.g. aix.
Provide an empty implemention for these cases, so depending packages
don't need to add workarounds.

Replaces #314

fsnotify_unsupported.go Outdated Show resolved Hide resolved
In cases where fsnotify is a transitive dependency of a package, it
might need to be built on platforms not supported (yet), e.g. aix.
Provide an empty implemention for these cases, so depending packages
don't need to add workarounds.

Replaces fsnotify#314
@tklauser tklauser mentioned this pull request Jan 24, 2022
Copy link

@sagikazarmark sagikazarmark left a comment

LGTM

@nathany nathany merged commit bfa0135 into fsnotify:main Jan 25, 2022
24 checks passed
@tklauser tklauser deleted the build-unsupported branch Jan 25, 2022
@arp242 arp242 mentioned this pull request Jul 21, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

4 participants