New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

beta 11 not compatible with FAKE 5.0 #471

Open
jackfoxy opened this Issue Jun 11, 2018 · 5 comments

Comments

Projects
None yet
3 participants
@jackfoxy
Contributor

jackfoxy commented Jun 11, 2018

Conflict detected:

  • FSharp.Formatting 3.0.0-beta11 requested package FSharp.Compiler.Service: >= 22.0.3 < 23.0*
  • Fake.Runtime 5.0.0 requested package FSharp.Compiler.Service: >= 23.0.3
@matthid

This comment has been minimized.

Member

matthid commented Jun 11, 2018

The problem is that the package is not compatible with netstandard, and fake is now netcore only. So we need to port this library...

In the meantime you can use the command line tool of fsharp.formatting (for example look at fake repository)

@matthid

This comment has been minimized.

Member

matthid commented Jun 11, 2018

(What I’m saying is: even if we update the dependency or you would fallback to older fake packages it wouldn’t work)

@wallymathieu

This comment has been minimized.

Member

wallymathieu commented Jun 11, 2018

What is needed in order to get FSharp.Formatting to be on netstandard?

@jackfoxy

This comment has been minimized.

Contributor

jackfoxy commented Jun 11, 2018

Does this involve more than just a multi-targeted dotnet core SDK project?

@matthid

This comment has been minimized.

Member

matthid commented Jun 11, 2018

Updating the build to dotnet sdk is the first step yes, and then we will see what we need in order to function on netcore. I'd assume other issues will pop up along the way.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment