New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Specifying prereleases does not work with pessimistic version constraint #1252

Closed
agross opened this Issue Nov 23, 2015 · 0 comments

Comments

Projects
None yet
1 participant
@agross
Contributor

agross commented Nov 23, 2015

depfile:

nuget Shizzle ~> 1.0 alpha

There are no released packages yet (i.e. non-prerelease).

± ./paket.sh install
Paket version 2.22.5.0
Resolving packages for group Main:
Paket failed with:
        There was a version conflict during package resolution.
  Resolved packages:
  Could not resolve package Shizzle :
   - Dependencies file requested: >= 1.0 < 2.0
   - Available versions:
     - 1.0.0-alpha002
     - 1.0.0-alpha001

  Please try to relax some conditions.

It works when this is in the depfile:

nuget Shizzle >= 1.0 alpha

@forki forki closed this in c3dd55c Nov 24, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment