Incorrect package dependencies graph resolution #1359

Closed
mexx opened this Issue Jan 8, 2016 · 1 comment

Comments

Projects
None yet
2 participants
@mexx
Member

mexx commented Jan 8, 2016

Start with paket.dependencies as here

source https://www.nuget.org/api/v2

nuget Freya.Router
> paket install

Paket version 2.41.1.0
Resolving packages for group Main:
 - Freya.Router 2.0.203
 - Aether 7.0.2
 - Hekate 1.0.1
 - Arachne.Http 2.3.27
 - Freya.Core 2.0.203
 - Freya.Lenses.Http 2.0.203
 - Freya.Recorder 2.0.203
 - Arachne.Uri.Template 2.3.27
 - Arachne.Core 2.3.27
 - Arachne.Language 2.3.27
 - Arachne.Uri 2.3.27
 - FParsec 1.0.2
Locked version resolution written to .\paket.lock
6 seconds - ready.

Results in paket.lock:

NUGET
  remote: https://www.nuget.org/api/v2
  specs:
    Aether (7.0.2)
    Arachne.Core (2.3.27)
      FParsec
    Arachne.Http (2.3.27)
      Arachne.Core (>= 2.3.27)
      Arachne.Language (>= 2.3.27)
      Arachne.Uri (>= 2.3.27)
      FParsec
    Arachne.Language (2.3.27)
      Arachne.Core (>= 2.3.27)
      FParsec
    Arachne.Uri (2.3.27)
      Arachne.Core (>= 2.3.27)
      FParsec
    Arachne.Uri.Template (2.3.27)
      Arachne.Core (>= 2.3.27)
      Arachne.Uri (>= 2.3.27)
      FParsec
    FParsec (1.0.2)
    Freya.Core (2.0.203)
      Aether (>= 7.0.0 < 8.0.0)
    Freya.Lenses.Http (2.0.203)
      Aether (>= 7.0.0 < 8.0.0)
      Arachne.Http (>= 2.3.25)
      Freya.Core (>= 2.0.203)
    Freya.Recorder (2.0.203)
      Aether (>= 7.0.0 < 8.0.0)
      Freya.Core (>= 2.0.203)
    Freya.Router (2.0.203)
      Aether (>= 7.0.0 < 8.0.0)
      Arachne.Http (>= 2.3.25)
      Arachne.Uri.Template
      Freya.Core (>= 2.0.203)
      Freya.Lenses.Http (>= 2.0.203)
      Freya.Recorder (>= 2.0.203)
      Hekate (>= 1.0.0 < 2.0.0)
    Hekate (1.0.1)
      Aether (>= 7.0.1)

Now extend paket.dependencies to

source https://www.nuget.org/api/v2

nuget Freya.Router
nuget Chiron
> paket install

Paket version 2.41.1.0
Resolving packages for group Main:
 - Chiron 6.0.1
 - Freya.Router 2.0.203
 - Freya.Router 2.0.202
 - Aether 8.0.2
 - FParsec 1.0.2
 - Arachne.Http 2.3.27
 - Freya.Core 2.0.203
 - Freya.Lenses.Http 2.0.203
 - Freya.Recorder 2.0.203
 - Arachne.Uri.Template 2.3.27
 - Hekate 1.0.1
 - Hekate 3.0.0
 - Freya.Core 2.0.202
 - Freya.Router 2.0.201
 - Freya.Router 2.0.200
 - Freya.Router 2.0.199
 - Freya.Router 2.0.198
 - Freya.Router 2.0.195
 - FSharp.Core 4.0.0.1
 - Freya.Router 2.0.194
 - Freya.Router 2.0.193
 - Freya.Router 2.0.192
 - Freya.Router 2.0.191
 - Freya.Router 2.0.189
 - Freya.Router 1.0.185
 - Chiron 6.0.0
 - Hekate 2.0.1
 - Hekate 2.0.0
 - Aether 8.0.1
 - Aether 8.0.0
 - Aether 8.0.0-rc2
 - Hekate 2.0.0-rc2
 - Arachne.Core 2.3.27
 - Arachne.Language 2.3.27
 - Arachne.Uri 2.3.27
Locked version resolution written to .\paket.lock
6 seconds - ready.

Results in paket.lock:

NUGET
  remote: https://www.nuget.org/api/v2
  specs:
    Aether (8.0.0-rc2)
    Arachne.Core (2.3.27)
      FParsec
    Arachne.Http (2.3.27)
      Arachne.Core (>= 2.3.27)
      Arachne.Language (>= 2.3.27)
      Arachne.Uri (>= 2.3.27)
      FParsec
    Arachne.Language (2.3.27)
      Arachne.Core (>= 2.3.27)
      FParsec
    Arachne.Uri (2.3.27)
      Arachne.Core (>= 2.3.27)
      FParsec
    Arachne.Uri.Template (2.3.27)
      Arachne.Core (>= 2.3.27)
      Arachne.Uri (>= 2.3.27)
      FParsec
    Chiron (6.0.0)
      Aether (>= 8.0.0 < 9.0.0)
      FParsec (>= 1.0.0 < 2.0.0)
    FParsec (1.0.2)
    Freya.Core (2.0.203)
      Aether (>= 7.0.0 < 8.0.0)
    Freya.Lenses.Http (2.0.203)
      Aether (>= 7.0.0 < 8.0.0)
      Arachne.Http (>= 2.3.25)
      Freya.Core (>= 2.0.203)
    Freya.Recorder (2.0.203)
      Aether (>= 7.0.0 < 8.0.0)
      Freya.Core (>= 2.0.203)
    Freya.Router (2.0.201)
      Aether (8.0.0-rc2)
      Arachne.Http (>= 2.3.25)
      Arachne.Uri.Template
      Freya.Core (>= 2.0.201)
      Freya.Lenses.Http (>= 2.0.201)
      Freya.Recorder (>= 2.0.201)
      Hekate (2.0.0-rc2)
    Hekate (2.0.0-rc2)
      Aether (8.0.0-rc2)

Please note!
Aether is resolved to 8.0.0-rc2, but Freya.Core in 2.0.203 requires Aether (>= 7.0.0 < 8.0.0)

@forki forki added the bug label Jan 10, 2016

@forki forki closed this in 0369f5d Jan 10, 2016

@mexx

This comment has been minimized.

Show comment
Hide comment
@mexx

mexx Jan 10, 2016

Member

Thanks, it's now working as expected.

Member

mexx commented Jan 10, 2016

Thanks, it's now working as expected.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment