New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Paket will download all dependencies of a nuget package even though framework has been specified #1494

Closed
theggelund opened this Issue Mar 1, 2016 · 1 comment

Comments

Projects
None yet
2 participants
@theggelund

theggelund commented Mar 1, 2016

I have specified a framework limitation in my paket.dependencies file

framework: net461
source nuget_repo
nuget simpleinjector

When I add a dependency with framework specific dependencies [SimpleInjector] other than my framework, paket will download all dependencies for all frameworks

image

This is from simpleinjector nuspec file
image

Issue is reproduced here -> download_issue Run reproduce.bat

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Mar 1, 2016

Member

you nuspec file file looks like that:

<dependencies>
  <group targetFramework=".NETFramework4.0" />
  <group targetFramework="WindowsPhone8.0" />
  <group targetFramework="Windows8.0" />
  <group targetFramework="Unsupported0.0">
    <dependency id="System.Collections" version="4.0.10" />
    <dependency id="System.Collections.Concurrent" version="4.0.10" />
    <dependency id="System.Diagnostics.Debug" version="4.0.10" />
    <dependency id="System.Globalization" version="4.0.10" />
    <dependency id="System.IO" version="4.0.10" />
    <dependency id="System.Linq" version="4.0.0" />
    <dependency id="System.Linq.Expressions" version="4.0.10" />
    <dependency id="System.Reflection" version="4.0.10" />
    <dependency id="System.Reflection.Extensions" version="4.0.0" />
    <dependency id="System.Reflection.TypeExtensions" version="4.0.0" />
    <dependency id="System.Runtime" version="4.0.20" />
    <dependency id="System.Runtime.Extensions" version="4.0.10" />
    <dependency id="System.Threading" version="4.0.10" />
    <dependency id="System.Threading.Tasks" version="4.0.10" />
  </group>
  <group targetFramework="MonoTouch0.0" />
  <group targetFramework="MonoAndroid0.0" />
</dependencies>

where is the "unsupported" coming from?

Member

forki commented Mar 1, 2016

you nuspec file file looks like that:

<dependencies>
  <group targetFramework=".NETFramework4.0" />
  <group targetFramework="WindowsPhone8.0" />
  <group targetFramework="Windows8.0" />
  <group targetFramework="Unsupported0.0">
    <dependency id="System.Collections" version="4.0.10" />
    <dependency id="System.Collections.Concurrent" version="4.0.10" />
    <dependency id="System.Diagnostics.Debug" version="4.0.10" />
    <dependency id="System.Globalization" version="4.0.10" />
    <dependency id="System.IO" version="4.0.10" />
    <dependency id="System.Linq" version="4.0.0" />
    <dependency id="System.Linq.Expressions" version="4.0.10" />
    <dependency id="System.Reflection" version="4.0.10" />
    <dependency id="System.Reflection.Extensions" version="4.0.0" />
    <dependency id="System.Reflection.TypeExtensions" version="4.0.0" />
    <dependency id="System.Runtime" version="4.0.20" />
    <dependency id="System.Runtime.Extensions" version="4.0.10" />
    <dependency id="System.Threading" version="4.0.10" />
    <dependency id="System.Threading.Tasks" version="4.0.10" />
  </group>
  <group targetFramework="MonoTouch0.0" />
  <group targetFramework="MonoAndroid0.0" />
</dependencies>

where is the "unsupported" coming from?

@forki forki closed this in 7d29ffe Mar 1, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment