Support referencing netstandard packages #1614

Closed
CumpsD opened this Issue Apr 16, 2016 · 0 comments

Comments

Projects
None yet
2 participants
@CumpsD
Contributor

CumpsD commented Apr 16, 2016

Description

Right now, we don't support the netstandard things yet. If I understand it correctly, it is fine to reference these from .NET 4.6 (for example) if it matches the right netstandard.

Repro steps

  • Make a console app (net462)
  • Use this:
source https://www.myget.org/F/aspnetvnext/api/v3/index.json
source https://www.nuget.org/api/v2/
nuget Microsoft.AspNetCore.Server.Kestrel 1.0.0-rc2-20466

Expected behavior

These references should be present: https://github.com/CumpsD/kestrel-classic/blob/master/src/KestrelClassic.fsproj#L80-L130

Actual behavior

netstandard is not referenced.

Known workarounds

Manually update .fsproj to add references.

Related information

Seems we can map them:

Does this mean if I target net462, Paket would have to also look for netstandard15 (and lower) and netcoreapp10?

@forki forki closed this in 0fdf6c4 Apr 17, 2016

@forki forki added the enhancement label Apr 17, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment