New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Suddenly getting out of sync errors. #1760

Closed
halcwb opened this Issue Jun 26, 2016 · 5 comments

Comments

Projects
None yet
2 participants
@halcwb
Contributor

halcwb commented Jun 26, 2016

Description

Trying to rebuild previously successful builds on travis or appveyor now result in an out of sync error.

Repro steps

Please provide the steps required to reproduce the problem

See: https://travis-ci.org/halcwb/GenBuild/builds/139350018

Expected behavior

Should build as this previously was no problem.

Actual behavior

Please provide a description of the actual behavior you observe.

Known workarounds

Delete paket.lock and run install again.

Related information

All environments, same problem. See also: #1750.

@halcwb

This comment has been minimized.

Show comment
Hide comment
@halcwb

halcwb Jun 26, 2016

Contributor

I cannot fix this!! I have rebuild the lock file, verified it works on my local machine. Push it and let travis do the build, but fails. I have the paket.lock file also in my repository.

Contributor

halcwb commented Jun 26, 2016

I cannot fix this!! I have rebuild the lock file, verified it works on my local machine. Push it and let travis do the build, but fails. I have the paket.lock file also in my repository.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jun 26, 2016

Member

Please show the dependencies file and the lock file. Also please downgrade
to 3.1.x for now. Sorry for the inconvenience. I'll try to fix tomorrow as
first thing
On Jun 26, 2016 16:11, "Casper" notifications@github.com wrote:

I cannot fix this!! I have rebuild the lock file, verified it works on my
local machine. Push it and let travis do the build, but fails. I have the
paket.lock file also in my repository.


You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub
#1760 (comment),
or mute the thread
https://github.com/notifications/unsubscribe/AADgNHDwMzfb3VbQMHIwLuil8POWVK5Hks5qPoikgaJpZM4I-jdL
.

Member

forki commented Jun 26, 2016

Please show the dependencies file and the lock file. Also please downgrade
to 3.1.x for now. Sorry for the inconvenience. I'll try to fix tomorrow as
first thing
On Jun 26, 2016 16:11, "Casper" notifications@github.com wrote:

I cannot fix this!! I have rebuild the lock file, verified it works on my
local machine. Push it and let travis do the build, but fails. I have the
paket.lock file also in my repository.


You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub
#1760 (comment),
or mute the thread
https://github.com/notifications/unsubscribe/AADgNHDwMzfb3VbQMHIwLuil8POWVK5Hks5qPoikgaJpZM4I-jdL
.

@halcwb

This comment has been minimized.

Show comment
Hide comment
@halcwb

halcwb Jun 26, 2016

Contributor

Ok, I got it by setting the paket.version env variable to an older version. The failing dependencies and lock file look like:

redirects: on
source https://nuget.org/api/v2

// group build

nuget FSharp.Formatting
nuget Fake
nuget SourceLink.Fake
nuget Newtonsoft.Json
nuget Npm

github fsharp/FAKE modules/Octokit/Octokit.fsx

github halcwb/GenBuild /scripts/targets.fsx
github halcwb/GenBuild /scripts/travis.fsx
github halcwb/GenBuild /scripts/appveyor.fsx

// group project

nuget FSPowerPack.Community
nuget Informedica.GenUnits.Lib
nuget Suave
nuget Suave.Testing

// group test

nuget FsUnit
nuget NUnit < 3.0
nuget NUnit.Runners < 3.0
nuget Unquote
nuget FsCheck
nuget FsCheck.NUnit

and:

REDIRECTS: ON
NUGET
  remote: https://www.nuget.org/api/v2
    FAKE (4.29.2)
    FsCheck (2.5)
      FSharp.Core (>= 3.1.2.5)
    FsCheck.NUnit (2.5)
      FsCheck (>= 2.5)
      NUnit (>= 2.6.4 < 2.7)
      NUnit.Runners (>= 2.6.4 < 2.7)
    FSharp.Compiler.Service (2.0.0.6)
    FSharp.Core (4.0.0.1)
    FSharp.Formatting (2.14.4)
      FSharp.Compiler.Service (2.0.0.6)
      FSharpVSPowerTools.Core (>= 2.3 < 2.4)
    FSharpVSPowerTools.Core (2.3)
      FSharp.Compiler.Service (>= 2.0.0.3)
    FSPowerPack.Community (3.0)
      FSPowerPack.Linq.Community
      FSPowerPack.Metadata.Community
      FSPowerPack.Parallel.Seq.Community
    FSPowerPack.Core.Community (3.0)
    FSPowerPack.Linq.Community (3.0)
      FSPowerPack.Core.Community
    FSPowerPack.Metadata.Community (3.0)
      FSPowerPack.Core.Community
    FSPowerPack.Parallel.Seq.Community (3.0)
      FSPowerPack.Core.Community
    FsUnit (1.4.1)
      FSharp.Core (>= 3.1.2.5)
      NUnit (2.6.4)
    Fuchu (1.0.3)
      FSharp.Core (>= 3.1.2.1)
    Informedica.GenUnits.lib (0.4.5-beta)
      FSPowerPack.Community
      Informedica.GenUtils.Lib
    Informedica.GenUtils.Lib (0.4.2-beta)
      FSPowerPack.Community
    Microsoft.Bcl (1.1.10) - framework: net10, net11, net20, net30, net35, net40, net40-full
      Microsoft.Bcl.Build (>= 1.0.14)
    Microsoft.Bcl.Build (1.0.21) - import_targets: false, framework: net10, net11, net20, net30, net35, net40, net40-full
    Microsoft.Net.Http (2.2.29) - framework: net10, net11, net20, net30, net35, net40, net40-full
      Microsoft.Bcl (>= 1.1.10)
      Microsoft.Bcl.Build (>= 1.0.14)
    Newtonsoft.Json (8.0.3)
    Node.js (5.3)
    NoGit (0.1)
      Node.js (>= 0.12)
    Npm (3.5.2)
      Node.js (>= 0.12.7)
      NoGit (>= 0.1)
    NUnit (2.6.4)
    NUnit.Runners (2.6.4)
    Octokit (0.20)
      Microsoft.Net.Http  - framework: net10, net11, net20, net30, net35, net40, net40-full
    SourceLink.Fake (1.1)
    Suave (1.1.3)
      FSharp.Core (>= 3.1.2.5)
    Suave.Testing (1.1.3)
      FSharp.Core (>= 3.1.2.5)
      Fuchu (>= 1.0.2)
      Suave (>= 1.1.3)
    Unquote (3.1.1)
GITHUB
  remote: fsharp/FAKE
    modules/Octokit/Octokit.fsx (c063bf415dac7f7d4df4c37fe76badce76cae3c3)
      Octokit
  remote: halcwb/GenBuild
    scripts/appveyor.fsx (aed42e1638bbbfbec57e1df989944f1a50df4064)
    scripts/targets.fsx (aed42e1638bbbfbec57e1df989944f1a50df4064)
    scripts/travis.fsx (aed42e1638bbbfbec57e1df989944f1a50df4064)

Contributor

halcwb commented Jun 26, 2016

Ok, I got it by setting the paket.version env variable to an older version. The failing dependencies and lock file look like:

redirects: on
source https://nuget.org/api/v2

// group build

nuget FSharp.Formatting
nuget Fake
nuget SourceLink.Fake
nuget Newtonsoft.Json
nuget Npm

github fsharp/FAKE modules/Octokit/Octokit.fsx

github halcwb/GenBuild /scripts/targets.fsx
github halcwb/GenBuild /scripts/travis.fsx
github halcwb/GenBuild /scripts/appveyor.fsx

// group project

nuget FSPowerPack.Community
nuget Informedica.GenUnits.Lib
nuget Suave
nuget Suave.Testing

// group test

nuget FsUnit
nuget NUnit < 3.0
nuget NUnit.Runners < 3.0
nuget Unquote
nuget FsCheck
nuget FsCheck.NUnit

and:

REDIRECTS: ON
NUGET
  remote: https://www.nuget.org/api/v2
    FAKE (4.29.2)
    FsCheck (2.5)
      FSharp.Core (>= 3.1.2.5)
    FsCheck.NUnit (2.5)
      FsCheck (>= 2.5)
      NUnit (>= 2.6.4 < 2.7)
      NUnit.Runners (>= 2.6.4 < 2.7)
    FSharp.Compiler.Service (2.0.0.6)
    FSharp.Core (4.0.0.1)
    FSharp.Formatting (2.14.4)
      FSharp.Compiler.Service (2.0.0.6)
      FSharpVSPowerTools.Core (>= 2.3 < 2.4)
    FSharpVSPowerTools.Core (2.3)
      FSharp.Compiler.Service (>= 2.0.0.3)
    FSPowerPack.Community (3.0)
      FSPowerPack.Linq.Community
      FSPowerPack.Metadata.Community
      FSPowerPack.Parallel.Seq.Community
    FSPowerPack.Core.Community (3.0)
    FSPowerPack.Linq.Community (3.0)
      FSPowerPack.Core.Community
    FSPowerPack.Metadata.Community (3.0)
      FSPowerPack.Core.Community
    FSPowerPack.Parallel.Seq.Community (3.0)
      FSPowerPack.Core.Community
    FsUnit (1.4.1)
      FSharp.Core (>= 3.1.2.5)
      NUnit (2.6.4)
    Fuchu (1.0.3)
      FSharp.Core (>= 3.1.2.1)
    Informedica.GenUnits.lib (0.4.5-beta)
      FSPowerPack.Community
      Informedica.GenUtils.Lib
    Informedica.GenUtils.Lib (0.4.2-beta)
      FSPowerPack.Community
    Microsoft.Bcl (1.1.10) - framework: net10, net11, net20, net30, net35, net40, net40-full
      Microsoft.Bcl.Build (>= 1.0.14)
    Microsoft.Bcl.Build (1.0.21) - import_targets: false, framework: net10, net11, net20, net30, net35, net40, net40-full
    Microsoft.Net.Http (2.2.29) - framework: net10, net11, net20, net30, net35, net40, net40-full
      Microsoft.Bcl (>= 1.1.10)
      Microsoft.Bcl.Build (>= 1.0.14)
    Newtonsoft.Json (8.0.3)
    Node.js (5.3)
    NoGit (0.1)
      Node.js (>= 0.12)
    Npm (3.5.2)
      Node.js (>= 0.12.7)
      NoGit (>= 0.1)
    NUnit (2.6.4)
    NUnit.Runners (2.6.4)
    Octokit (0.20)
      Microsoft.Net.Http  - framework: net10, net11, net20, net30, net35, net40, net40-full
    SourceLink.Fake (1.1)
    Suave (1.1.3)
      FSharp.Core (>= 3.1.2.5)
    Suave.Testing (1.1.3)
      FSharp.Core (>= 3.1.2.5)
      Fuchu (>= 1.0.2)
      Suave (>= 1.1.3)
    Unquote (3.1.1)
GITHUB
  remote: fsharp/FAKE
    modules/Octokit/Octokit.fsx (c063bf415dac7f7d4df4c37fe76badce76cae3c3)
      Octokit
  remote: halcwb/GenBuild
    scripts/appveyor.fsx (aed42e1638bbbfbec57e1df989944f1a50df4064)
    scripts/targets.fsx (aed42e1638bbbfbec57e1df989944f1a50df4064)
    scripts/travis.fsx (aed42e1638bbbfbec57e1df989944f1a50df4064)

@halcwb

This comment has been minimized.

Show comment
Hide comment
@halcwb

halcwb Jun 27, 2016

Contributor

Wouldn't it be better if bootstrapper downloaded a proven stable version instead of the latest version? This would prevent the above problem for the larger part.

Contributor

halcwb commented Jun 27, 2016

Wouldn't it be better if bootstrapper downloaded a proven stable version instead of the latest version? This would prevent the above problem for the larger part.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jun 27, 2016

Member

you can already do this. just add a version to the bootstrapper command line call.

Member

forki commented Jun 27, 2016

you can already do this. just add a version to the bootstrapper command line call.

@forki forki closed this in a21602d Jun 27, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment