New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Minor] Paket Pack: confusing yellow diagnostic #2164

Closed
0x53A opened this Issue Mar 2, 2017 · 7 comments

Comments

Projects
None yet
3 participants
@0x53A
Contributor

0x53A commented Mar 2, 2017

The full project source is here: https://github.com/0x53A/Expecto.Xunit

image

Why is there no text after : and why is it printed three times?

@smoothdeveloper

This comment has been minimized.

Show comment
Hide comment
@smoothdeveloper

smoothdeveloper Mar 2, 2017

Contributor

@0x53A good point, could you try with verbose option?

Contributor

smoothdeveloper commented Mar 2, 2017

@0x53A good point, could you try with verbose option?

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Mar 2, 2017

Member

wtf!? expecto.xunit? please noooo.

Member

forki commented Mar 2, 2017

wtf!? expecto.xunit? please noooo.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Mar 2, 2017

Member

;-)

Member

forki commented Mar 2, 2017

;-)

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Mar 2, 2017

Member

This project doesn't build for me. So I can't call pack

image

Member

forki commented Mar 2, 2017

This project doesn't build for me. So I can't call pack

image

@0x53A

This comment has been minimized.

Show comment
Hide comment
@0x53A

0x53A Mar 2, 2017

Contributor

@smoothdeveloper with verbose:
image

@forki: This is not what you probably think, it is an adapter to run the great new expecto tests with the legacy xunit console runner :)

If you want to build it, I think you need to manually call paket restore from cmd. (The namespace Xunit is not defined points to missing assemblies).
I used the paket VS extension to initialize the project, but that didn't seem to add the restore targets file, will take a look in the evening ...

Contributor

0x53A commented Mar 2, 2017

@smoothdeveloper with verbose:
image

@forki: This is not what you probably think, it is an adapter to run the great new expecto tests with the legacy xunit console runner :)

If you want to build it, I think you need to manually call paket restore from cmd. (The namespace Xunit is not defined points to missing assemblies).
I used the paket VS extension to initialize the project, but that didn't seem to add the restore targets file, will take a look in the evening ...

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Mar 2, 2017

Member

Can you please attach a zip with everything already built? Or mail me?

Member

forki commented Mar 2, 2017

Can you please attach a zip with everything already built? Or mail me?

@0x53A

This comment has been minimized.

Show comment
Hide comment
@0x53A

0x53A Mar 2, 2017

Contributor

sure, here:
Expecto.XUnit.zip

in the root call .paket\paket.exe pack output nugets minimum-from-lock-file --verbose

Contributor

0x53A commented Mar 2, 2017

sure, here:
Expecto.XUnit.zip

in the root call .paket\paket.exe pack output nugets minimum-from-lock-file --verbose

@0x53A 0x53A changed the title from [Minor] Paket Push: confusing yellow diagnostic to [Minor] Paket Pack: confusing yellow diagnostic Mar 2, 2017

@forki forki closed this in da1a643 Mar 13, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment