New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Paket > 5.4.8 does not work with Klondike 2.0.0 anymore #2504

Closed
Kazark opened this Issue Jul 10, 2017 · 83 comments

Comments

4 participants
@Kazark
Contributor

Kazark commented Jul 10, 2017

Description

I use two NuGet remotes: an internal NuGet server running Klondike 2.0.0 and nuget.org. Paket versions between 5.5.0 and the latest (5.5.3 currently; I can't get 5.6.0; was it unreleased?) When I went to run

paket outdated

or paket remove... then I get an error like:

Paket failed with:
-> Unable to retrieve package versions for 'Foo'
-> Could not find versions for package Foo on any of ["https://www.nuget.org/api/v2"; "http://nuget.internal.local/api/odata"].
        -  Source 'https://www.nuget.org/api/v2' yielded (0): []
                -  Request 'https://api.nuget.org/v3-flatcontainer/Foo/index.json?semVerLevel=2.0.0' finished with: []
                -  Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='Foo'' was skipped because 'ProtocolNotCached'
                -  Request 'https://www.nuget.org/api/v2/Packages()?semVerLevel=2.0.0&$filter=tolower(Id) eq 'foo'' was skipped because 'ProtocolNotCached'
        -  Source 'http://nuget.internal.local/api/odata' yielded no results
                -  Request 'http://nuget.internal.local/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Foo'' was skipped because 'ProtocolNotCached'
                -  Request 'http://nuget.internal.local/api/odata/Packages()?semVerLevel=2.0.0&$filter=tolower(Id) eq 'foo'' finished with error
                -> Could not retrieve data from 'http://nuget.internal.local/api/odata/Packages%28%29?semVerLevel=2.0.0&$filter=tolower%28Id%29%20eq%20%27foo%27&$skip=20'
                -> WebException: The remote server returned an error: (404) Not Found.

where Foo is the name of one of my internal packages and nuget.internal.local is the name of my Klondike server (actual names differ; these are replaced). This prevents me from using Paket for anything that requires interrogating versions.

When I manually run a GET against http://nuget.internal.local/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Foo', I get results, as always. The Klondike server is up; I can browse it.

I have been using Paket with this internal NuGet server for 15 months without any problems, and when I revert to Paket 5.4.8, the issue goes away.

Expected behavior

Still be able to use packages on the Klondike 2.0.0 server.

Actual behavior

Paket errors out on practically anything but restore.

Known workarounds

Revert back to Paket 5.4.8.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 10, 2017

Member

Yes paket 5.6 was deleted because of trouble,

so very last working version is 5.4.8?

Member

forki commented Jul 10, 2017

Yes paket 5.6 was deleted because of trouble,

so very last working version is 5.4.8?

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 10, 2017

Contributor

Yes, 5.4.8. 5.5.0, 5.5.1 and 5.5.3 are all not good. I forget if I tried 5.5.2; I can if you want.

Contributor

Kazark commented Jul 10, 2017

Yes, 5.4.8. 5.5.0, 5.5.1 and 5.5.3 are all not good. I forget if I tried 5.5.2; I can if you want.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 10, 2017

Member

I think it's #2485 - can you please check these urls?

Member

forki commented Jul 10, 2017

I think it's #2485 - can you please check these urls?

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 10, 2017

Contributor

@forki yep, that's it. Adding the () after Packages changes the response from 200 to 404. Thanks for finding it so quick.

Contributor

Kazark commented Jul 10, 2017

@forki yep, that's it. Adding the () after Packages changes the response from 200 to 404. Thanks for finding it so quick.

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jul 10, 2017

Member

We still haven't looked up the spec, it might be just a bug in https://github.com/themotleyfool/Klondike

Member

matthid commented Jul 10, 2017

We still haven't looked up the spec, it might be just a bug in https://github.com/themotleyfool/Klondike

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jul 10, 2017

Member

@Kazark Can you open an issue there and link back, maybe they have more insights?

Member

matthid commented Jul 10, 2017

@Kazark Can you open an issue there and link back, maybe they have more insights?

@forki forki closed this in 3e803de Jul 10, 2017

@forki forki reopened this Jul 10, 2017

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 10, 2017

Member

3e803de is a workaround - after @matthid fixed the "push" bug in paket 5.6 we can try this out. it's not nice, but in order to keep backwards compat we need to hack...

Member

forki commented Jul 10, 2017

3e803de is a workaround - after @matthid fixed the "push" bug in paket 5.6 we can try this out. it's not nice, but in order to keep backwards compat we need to hack...

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 10, 2017

Contributor

@forki Thank you!

Contributor

Kazark commented Jul 10, 2017

@forki Thank you!

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jul 10, 2017

Member

@forki I don't think maintaining a list of nuget urls and do what's best for the particular nuget feed is not a sustainable long term solution. I'd argue that we just implement the specs and if there are none we just do what nuget.exe does and get rid of all our performance tricks (it's questionable if they actually yield anything at this time)

Member

matthid commented Jul 10, 2017

@forki I don't think maintaining a list of nuget urls and do what's best for the particular nuget feed is not a sustainable long term solution. I'd argue that we just implement the specs and if there are none we just do what nuget.exe does and get rid of all our performance tricks (it's questionable if they actually yield anything at this time)

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jul 10, 2017

Member

This means we need to open #2472 again?

Member

matthid commented Jul 10, 2017

This means we need to open #2472 again?

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 10, 2017

Member

nuget.exe does work

that's the problem

Member

forki commented Jul 10, 2017

nuget.exe does work

that's the problem

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jul 10, 2017

Member

But nuget.exe is working on both I'd assume, so we need to figure out what nuget is doing and do the same...

Member

matthid commented Jul 10, 2017

But nuget.exe is working on both I'd assume, so we need to figure out what nuget is doing and do the same...

@bhugot

This comment has been minimized.

Show comment
Hide comment
@bhugot

bhugot Jul 10, 2017

Contributor

I think we should revert my PR and if it s only warning keep it as it is

Contributor

bhugot commented Jul 10, 2017

I think we should revert my PR and if it s only warning keep it as it is

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 10, 2017

Member

Can you please create a pr. Would also need revert my last commit

Member

forki commented Jul 10, 2017

Can you please create a pr. Would also need revert my last commit

@forki forki closed this in d773456 Jul 10, 2017

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 11, 2017

Member

@Kazark please retry with latest

Member

forki commented Jul 11, 2017

@Kazark please retry with latest

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

@forki Still not working with 5.6.4, actually. :s

Contributor

Kazark commented Jul 11, 2017

@forki Still not working with 5.6.4, actually. :s

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

Just realized that the error looks slightly different now. Here is the new error:

Paket failed with:
-> Unable to retrieve package versions for 'Foo'
-> Could not find versions for package Foo on any of ["https://www.nuget.org/api/v2"; "http://nuget.internal.local/api/odata"].
        -  Source 'https://www.nuget.org/api/v2' yielded (0): []
                -  Request 'https://api.nuget.org/v3-flatcontainer/foo/index.json?semVerLevel=2.0.0' finished with: []
                -  Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='Foo'' was cancelled (another one was faster)
                -  Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'Foo'' was cancelled (another one was faster)
        -  Source 'http://nuget.internal.local/api/odata' yielded no results
                -  Request 'http://nuget.internal.local/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Foo'' finished with error
                -> Could not retrieve data from 'http://nuget.internal.local/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27Foo%27&$skip=100'
                -> RequestFailedException: Request to 'http://nuget.internal.local/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Foo'&$skip=100' failed with: 'NotFound'
                -  Request 'http://nuget.internal.local/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'Foo'' was skipped because 'ProtocolNotCached'
Contributor

Kazark commented Jul 11, 2017

Just realized that the error looks slightly different now. Here is the new error:

Paket failed with:
-> Unable to retrieve package versions for 'Foo'
-> Could not find versions for package Foo on any of ["https://www.nuget.org/api/v2"; "http://nuget.internal.local/api/odata"].
        -  Source 'https://www.nuget.org/api/v2' yielded (0): []
                -  Request 'https://api.nuget.org/v3-flatcontainer/foo/index.json?semVerLevel=2.0.0' finished with: []
                -  Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='Foo'' was cancelled (another one was faster)
                -  Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'Foo'' was cancelled (another one was faster)
        -  Source 'http://nuget.internal.local/api/odata' yielded no results
                -  Request 'http://nuget.internal.local/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Foo'' finished with error
                -> Could not retrieve data from 'http://nuget.internal.local/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27Foo%27&$skip=100'
                -> RequestFailedException: Request to 'http://nuget.internal.local/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Foo'&$skip=100' failed with: 'NotFound'
                -  Request 'http://nuget.internal.local/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'Foo'' was skipped because 'ProtocolNotCached'
@forki

This comment has been minimized.

Show comment
Hide comment
Member

forki commented Jul 11, 2017

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

@forki hm, not sure I understand the question; the package that is causing the trouble is only in my local NuGet server.

Contributor

Kazark commented Jul 11, 2017

@forki hm, not sure I understand the question; the package that is causing the trouble is only in my local NuGet server.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 11, 2017

Member

oups yes sorry.
the urls below are the interesting ones. Can you check these? Any idea what might be wrong there?

Member

forki commented Jul 11, 2017

oups yes sorry.
the urls below are the interesting ones. Can you check these? Any idea what might be wrong there?

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

Will do. In a meeting right now but will get back ASAP after that.

Contributor

Kazark commented Jul 11, 2017

Will do. In a meeting right now but will get back ASAP after that.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

@forki so here's the weird thing. Only the second URL in the bottom block of URLs fails, with a 404. I'm getting 200 on all the others when I run them through a REST client. Confused.

Contributor

Kazark commented Jul 11, 2017

@forki so here's the weird thing. Only the second URL in the bottom block of URLs fails, with a 404. I'm getting 200 on all the others when I run them through a REST client. Confused.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 11, 2017

Member

and the others have correct looking data in it?

/cc @matthid

Member

forki commented Jul 11, 2017

and the others have correct looking data in it?

/cc @matthid

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

Let's see. Just grabbed 5.6.6... the first URL returns a 200 with results that appear to be all the versions of the package...

Contributor

Kazark commented Jul 11, 2017

Let's see. Just grabbed 5.6.6... the first URL returns a 200 with results that appear to be all the versions of the package...

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

The second link still fails with 404...

Contributor

Kazark commented Jul 11, 2017

The second link still fails with 404...

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

Oh wait, the second one is only failing because of %28%29. When I paste the third one, which I just realized is the same URL but with () unescaped, I get a 200! The results appear to be some of the more recent versions of the package...

Contributor

Kazark commented Jul 11, 2017

Oh wait, the second one is only failing because of %28%29. When I paste the third one, which I just realized is the same URL but with () unescaped, I get a 200! The results appear to be some of the more recent versions of the package...

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

and the last one returns successfully, but only gives a few versions of the package, and they are very early versions. Let me look at the output of the first one again, more closely...

Contributor

Kazark commented Jul 11, 2017

and the last one returns successfully, but only gives a few versions of the package, and they are very early versions. Let me look at the output of the first one again, more closely...

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

Ah, okay, I see what's going on. Even though these URLs are all returning 200, they are only returning fragments of the whole list of the package's versions. In the first one, it is only returning the first, early set of versions, not the more recent versions (though the first request returns far more versions than the third).

Contributor

Kazark commented Jul 11, 2017

Ah, okay, I see what's going on. Even though these URLs are all returning 200, they are only returning fragments of the whole list of the package's versions. In the first one, it is only returning the first, early set of versions, not the more recent versions (though the first request returns far more versions than the third).

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 11, 2017

Member

yes that's paging at work. maybe that's broken now

Member

forki commented Jul 11, 2017

yes that's paging at work. maybe that's broken now

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

The odd thing is that when I manually set the version back to one that was returned in the first request, it still doesn't work.

Contributor

Kazark commented Jul 11, 2017

The odd thing is that when I manually set the version back to one that was returned in the first request, it still doesn't work.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

Yeah even when I set the package version by manually changing the paket.lock to some really really old version of the package that doesn't work. FWIW.

Contributor

Kazark commented Jul 11, 2017

Yeah even when I set the package version by manually changing the paket.lock to some really really old version of the package that doesn't work. FWIW.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

Let me know if there's any other info I can get you.

Contributor

Kazark commented Jul 11, 2017

Let me know if there's any other info I can get you.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 11, 2017

Member

I think we need a repro here.

Member

forki commented Jul 11, 2017

I think we need a repro here.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

Seems like it. Let me play with it a bit more and see if I can get you more info.

Contributor

Kazark commented Jul 11, 2017

Seems like it. Let me play with it a bit more and see if I can get you more info.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

Huh, okay, important: it's not every package on my local Klondike server. When I take out the package it was choking on (which was the first package it was looking at from the local NuGet server) and all its transitive dependencies and anything else that depended on it, I'm able to run paket outdated.

Contributor

Kazark commented Jul 11, 2017

Huh, okay, important: it's not every package on my local Klondike server. When I take out the package it was choking on (which was the first package it was looking at from the local NuGet server) and all its transitive dependencies and anything else that depended on it, I'm able to run paket outdated.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 11, 2017

Contributor

There are 150 versions of that package in the Klondike server.

Contributor

Kazark commented Jul 11, 2017

There are 150 versions of that package in the Klondike server.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

Finally got a repro for you.

paket.dependencies:

source https://www.nuget.org/api/v2
source http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata
framework: net451

nuget FooBarBazQux
nuget Autofac

paket.lock:

RESTRICTION: == net451
NUGET
  remote: https://www.nuget.org/api/v2
    Autofac (4.6)
  remote: http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata
    FooBarBazQux (0.1.29)

Run paket outdated with latest Paket. You get:

image

Contributor

Kazark commented Jul 12, 2017

Finally got a repro for you.

paket.dependencies:

source https://www.nuget.org/api/v2
source http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata
framework: net451

nuget FooBarBazQux
nuget Autofac

paket.lock:

RESTRICTION: == net451
NUGET
  remote: https://www.nuget.org/api/v2
    Autofac (4.6)
  remote: http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata
    FooBarBazQux (0.1.29)

Run paket outdated with latest Paket. You get:

image

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 12, 2017

Member

I get:

image

Member

forki commented Jul 12, 2017

I get:

image

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

Okay, so are you saying there might be something going on on our internal network?

Contributor

Kazark commented Jul 12, 2017

Okay, so are you saying there might be something going on on our internal network?

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 12, 2017

Member

I invite others to test as well!

Member

forki commented Jul 12, 2017

I invite others to test as well!

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

I'll run a test from the VM itself rather than on my machine and see what happens.

Contributor

Kazark commented Jul 12, 2017

I'll run a test from the VM itself rather than on my machine and see what happens.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

I've confirmed your results on the VM itself, indicating this is somehow also tied into our internal network here. Advice for further steps?

Contributor

Kazark commented Jul 12, 2017

I've confirmed your results on the VM itself, indicating this is somehow also tied into our internal network here. Advice for further steps?

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 12, 2017

Member

try outdated -v on both systems and diff the results.

Member

forki commented Jul 12, 2017

try outdated -v on both systems and diff the results.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

Local log resulting from paket --verbose outdated > paket.log:

Paket version 5.6.9
found: C:\Users\kazark\fix\paket.dependencies
Parsing C:\Users\kazark\fix\paket.dependencies
Resolving packages for group Main:
   0 packages in resolution.
   2 requirements left
     - Autofac,  (from C:\Users\kazark\fix\paket.dependencies)
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve Autofac  (from C:\Users\kazark\fix\paket.dependencies)
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac''
Starting request to 'https://api.nuget.org/v3/index.json'
Starting request to 'https://api.nuget.org/v3/index.json'
Starting request to 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0'
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Source 'https://www.nuget.org/api/v2' yielded (0): [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0' finished with: [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded (0): [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' finished with: [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)

 - Autofac 4.6.0
Starting request to 'https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0')'
Response from https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0'):

<?xml version="1.0" encoding="utf-8"?><feed xml:base="https://www.nuget.org/api/v2" xmlns="http://www.w3.org/2005/Atom" xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices" xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata" xmlns:georss="http://www.georss.org/georss" xmlns:gml="http://www.opengis.net/gml"><id>http://schemas.datacontract.org/2004/07/</id><title /><updated>2017-07-12T15:52:14Z</updated><link rel="self" href="https://www.nuget.org/api/v2/Packages" /><entry><id>https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')</id><category term="NuGetGallery.OData.V2FeedPackage" scheme="http://schemas.microsoft.com/ado/2007/08/dataservices/scheme" /><link rel="edit" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><link rel="self" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><title type="text">Autofac</title><updated>2017-05-16T12:38:51Z</updated><author><name>Autofac Contributors</name></author><content type="application/zip" src="https://www.nuget.org/api/v2/package/Autofac/4.6.0" /><m:properties><d:Id>Autofac</d:Id><d:Version>4.6.0</d:Version><d:NormalizedVersion>4.6.0</d:NormalizedVersion><d:Authors>Autofac Contributors</d:Authors><d:Copyright m:null="true" /><d:Created m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Created><d:Dependencies>::net45|NETStandard.Library:[1.6.0, ):netstandard1.1|System.ComponentModel:[4.0.1, ):netstandard1.1</d:Dependencies><d:Description>Autofac is an IoC container for Microsoft .NET. It manages the dependencies between classes so that applications stay easy to change as they grow in size and complexity.</d:Description><d:DownloadCount m:type="Edm.Int32">5364726</d:DownloadCount><d:GalleryDetailsUrl>https://www.nuget.org/packages/Autofac/4.6.0</d:GalleryDetailsUrl><d:IconUrl>https://cloud.githubusercontent.com/assets/1156571/13684110/16b8f152-e6bf-11e5-84ae-22c66c6d351a.png</d:IconUrl><d:IsLatestVersion m:type="Edm.Boolean">true</d:IsLatestVersion><d:IsAbsoluteLatestVersion m:type="Edm.Boolean">true</d:IsAbsoluteLatestVersion><d:IsPrerelease m:type="Edm.Boolean">false</d:IsPrerelease><d:Language m:null="true" /><d:LastUpdated m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:LastUpdated><d:Published m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Published><d:PackageHash>Y+7B007u3cYpjU4THI9/i2pSyRnHjZtRJOrjGiHYPH5C32jJZ5njWjgLVnI6nmsYjUrYcWjXLfB13J3ztd37cw==</d:PackageHash><d:PackageHashAlgorithm>SHA512</d:PackageHashAlgorithm><d:PackageSize m:type="Edm.Int64">265621</d:PackageSize><d:ProjectUrl>http://autofac.org/</d:ProjectUrl><d:ReportAbuseUrl>https://www.nuget.org/packages/Autofac/4.6.0/ReportAbuse</d:ReportAbuseUrl><d:ReleaseNotes>Release notes are at https://github.com/autofac/Autofac/releases</d:ReleaseNotes><d:RequireLicenseAcceptance m:type="Edm.Boolean">false</d:RequireLicenseAcceptance><d:Summary m:null="true" /><d:Tags>autofac di ioc dependencyinjection</d:Tags><d:Title m:null="true" /><d:VersionDownloadCount m:type="Edm.Int32">125567</d:VersionDownloadCount><d:MinClientVersion m:null="true" /><d:LastEdited m:null="true" /><d:LicenseUrl>http://www.opensource.org/licenses/mit-license.php</d:LicenseUrl><d:LicenseNames m:null="true" /><d:LicenseReportUrl m:null="true" /></m:properties></entry></feed>
   Found Explored Package  Autofac 4.6.0
   1 packages in resolution.
     - Autofac, 4.6.0
   1 requirements left
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve FooBarBazQux  (from C:\Users\kazark\fix\paket.dependencies)
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Source 'https://www.nuget.org/api/v2' yielded (0): []
 - Request 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0' finished with: []
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded no results
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' finished with: System.Exception: Could not retrieve data from 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100' ---> Paket.Utils+RequestFailedException: Request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100' failed with: 'NotFound'
   at Paket.Utils.failIfNoSuccess@441-5.Invoke(RequestFailedInfo _arg1)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.args@825-1.Invoke(a a)
   --- End of inner exception stack trace ---
   at Paket.Utils.getFromUrl@622-8.Invoke(Exception _arg4)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.callA@841.Invoke(AsyncParams`1 args)
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was skipped because 'ProtocolNotCached'

Trial1 (NuGet.GetVersions) did not yield any results, trying again.
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Performance:
 - Resolver: 16 seconds (1 runs)
    - Runtime: 125 milliseconds
    - Blocked (retrieving package versions): 15 seconds (2 times)
    - Blocked (retrieving package details): 825 milliseconds (1 times)
 - Average Request Time: 752 milliseconds
 - Number of Requests: 11
 - Runtime: 17 seconds

VM log resulting from paket --verbose outdated > paket.log:

Paket version 5.6.9
found: C:\Users\kazark\fix\paket.dependencies
Parsing C:\Users\kazark\fix\paket.dependencies
Resolving packages for group Main:
   0 packages in resolution.
   2 requirements left
     - Autofac,  (from C:\Users\kazark\fix\paket.dependencies)
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve Autofac  (from C:\Users\kazark\fix\paket.dependencies)
Starting request to 'https://api.nuget.org/v3/index.json'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac''
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Starting request to 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Source 'https://www.nuget.org/api/v2' yielded (0): [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0' finished with: [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded (0): [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' finished with: [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)

 - Autofac 4.6.0
Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Source 'https://www.nuget.org/api/v2' yielded (0): []
 - Request 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0' finished with: []
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded no results
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' finished with: System.Exception: Could not retrieve data from 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100' ---> Paket.Utils+RequestFailedException: Request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100' failed with: 'NotFound'
   at Paket.Utils.failIfNoSuccess@441-5.Invoke(RequestFailedInfo _arg1)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.args@825-1.Invoke(a a)
   --- End of inner exception stack trace ---
   at Paket.Utils.getFromUrl@622-8.Invoke(Exception _arg4)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.callA@841.Invoke(AsyncParams`1 args)
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was skipped because 'ProtocolNotCached'

Trial1 (NuGet.GetVersions) did not yield any results, trying again.
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Starting request to 'https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0')'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Response from https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0'):

<?xml version="1.0" encoding="utf-8"?><feed xml:base="https://www.nuget.org/api/v2" xmlns="http://www.w3.org/2005/Atom" xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices" xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata" xmlns:georss="http://www.georss.org/georss" xmlns:gml="http://www.opengis.net/gml"><id>http://schemas.datacontract.org/2004/07/</id><title /><updated>2017-07-12T15:53:54Z</updated><link rel="self" href="https://www.nuget.org/api/v2/Packages" /><entry><id>https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')</id><category term="NuGetGallery.OData.V2FeedPackage" scheme="http://schemas.microsoft.com/ado/2007/08/dataservices/scheme" /><link rel="edit" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><link rel="self" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><title type="text">Autofac</title><updated>2017-05-16T12:38:51Z</updated><author><name>Autofac Contributors</name></author><content type="application/zip" src="https://www.nuget.org/api/v2/package/Autofac/4.6.0" /><m:properties><d:Id>Autofac</d:Id><d:Version>4.6.0</d:Version><d:NormalizedVersion>4.6.0</d:NormalizedVersion><d:Authors>Autofac Contributors</d:Authors><d:Copyright m:null="true" /><d:Created m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Created><d:Dependencies>::net45|NETStandard.Library:[1.6.0, ):netstandard1.1|System.ComponentModel:[4.0.1, ):netstandard1.1</d:Dependencies><d:Description>Autofac is an IoC container for Microsoft .NET. It manages the dependencies between classes so that applications stay easy to change as they grow in size and complexity.</d:Description><d:DownloadCount m:type="Edm.Int32">5364726</d:DownloadCount><d:GalleryDetailsUrl>https://www.nuget.org/packages/Autofac/4.6.0</d:GalleryDetailsUrl><d:IconUrl>https://cloud.githubusercontent.com/assets/1156571/13684110/16b8f152-e6bf-11e5-84ae-22c66c6d351a.png</d:IconUrl><d:IsLatestVersion m:type="Edm.Boolean">true</d:IsLatestVersion><d:IsAbsoluteLatestVersion m:type="Edm.Boolean">true</d:IsAbsoluteLatestVersion><d:IsPrerelease m:type="Edm.Boolean">false</d:IsPrerelease><d:Language m:null="true" /><d:LastUpdated m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:LastUpdated><d:Published m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Published><d:PackageHash>Y+7B007u3cYpjU4THI9/i2pSyRnHjZtRJOrjGiHYPH5C32jJZ5njWjgLVnI6nmsYjUrYcWjXLfB13J3ztd37cw==</d:PackageHash><d:PackageHashAlgorithm>SHA512</d:PackageHashAlgorithm><d:PackageSize m:type="Edm.Int64">265621</d:PackageSize><d:ProjectUrl>http://autofac.org/</d:ProjectUrl><d:ReportAbuseUrl>https://www.nuget.org/packages/Autofac/4.6.0/ReportAbuse</d:ReportAbuseUrl><d:ReleaseNotes>Release notes are at https://github.com/autofac/Autofac/releases</d:ReleaseNotes><d:RequireLicenseAcceptance m:type="Edm.Boolean">false</d:RequireLicenseAcceptance><d:Summary m:null="true" /><d:Tags>autofac di ioc dependencyinjection</d:Tags><d:Title m:null="true" /><d:VersionDownloadCount m:type="Edm.Int32">125567</d:VersionDownloadCount><d:MinClientVersion m:null="true" /><d:LastEdited m:null="true" /><d:LicenseUrl>http://www.opensource.org/licenses/mit-license.php</d:LicenseUrl><d:LicenseNames m:null="true" /><d:LicenseReportUrl m:null="true" /></m:properties></entry></feed>
   Found Explored Package  Autofac 4.6.0
   1 packages in resolution.
     - Autofac, 4.6.0
   1 requirements left
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve FooBarBazQux  (from C:\Users\kazark\fix\paket.dependencies)
Performance:
 - Resolver: 1 second (1 runs)
    - Runtime: 147 milliseconds
    - Blocked (retrieving package details): 541 milliseconds (1 times)
    - Blocked (retrieving package versions): 592 milliseconds (1 times)
    - Not Blocked (retrieving package versions): 1 times
 - Average Request Time: 156 milliseconds
 - Number of Requests: 10
 - Runtime: 2 seconds

Definitely different but I don't understand the internals of Paket well enough to make sense out of it.

Contributor

Kazark commented Jul 12, 2017

Local log resulting from paket --verbose outdated > paket.log:

Paket version 5.6.9
found: C:\Users\kazark\fix\paket.dependencies
Parsing C:\Users\kazark\fix\paket.dependencies
Resolving packages for group Main:
   0 packages in resolution.
   2 requirements left
     - Autofac,  (from C:\Users\kazark\fix\paket.dependencies)
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve Autofac  (from C:\Users\kazark\fix\paket.dependencies)
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac''
Starting request to 'https://api.nuget.org/v3/index.json'
Starting request to 'https://api.nuget.org/v3/index.json'
Starting request to 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0'
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Source 'https://www.nuget.org/api/v2' yielded (0): [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0' finished with: [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded (0): [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' finished with: [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)

 - Autofac 4.6.0
Starting request to 'https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0')'
Response from https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0'):

<?xml version="1.0" encoding="utf-8"?><feed xml:base="https://www.nuget.org/api/v2" xmlns="http://www.w3.org/2005/Atom" xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices" xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata" xmlns:georss="http://www.georss.org/georss" xmlns:gml="http://www.opengis.net/gml"><id>http://schemas.datacontract.org/2004/07/</id><title /><updated>2017-07-12T15:52:14Z</updated><link rel="self" href="https://www.nuget.org/api/v2/Packages" /><entry><id>https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')</id><category term="NuGetGallery.OData.V2FeedPackage" scheme="http://schemas.microsoft.com/ado/2007/08/dataservices/scheme" /><link rel="edit" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><link rel="self" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><title type="text">Autofac</title><updated>2017-05-16T12:38:51Z</updated><author><name>Autofac Contributors</name></author><content type="application/zip" src="https://www.nuget.org/api/v2/package/Autofac/4.6.0" /><m:properties><d:Id>Autofac</d:Id><d:Version>4.6.0</d:Version><d:NormalizedVersion>4.6.0</d:NormalizedVersion><d:Authors>Autofac Contributors</d:Authors><d:Copyright m:null="true" /><d:Created m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Created><d:Dependencies>::net45|NETStandard.Library:[1.6.0, ):netstandard1.1|System.ComponentModel:[4.0.1, ):netstandard1.1</d:Dependencies><d:Description>Autofac is an IoC container for Microsoft .NET. It manages the dependencies between classes so that applications stay easy to change as they grow in size and complexity.</d:Description><d:DownloadCount m:type="Edm.Int32">5364726</d:DownloadCount><d:GalleryDetailsUrl>https://www.nuget.org/packages/Autofac/4.6.0</d:GalleryDetailsUrl><d:IconUrl>https://cloud.githubusercontent.com/assets/1156571/13684110/16b8f152-e6bf-11e5-84ae-22c66c6d351a.png</d:IconUrl><d:IsLatestVersion m:type="Edm.Boolean">true</d:IsLatestVersion><d:IsAbsoluteLatestVersion m:type="Edm.Boolean">true</d:IsAbsoluteLatestVersion><d:IsPrerelease m:type="Edm.Boolean">false</d:IsPrerelease><d:Language m:null="true" /><d:LastUpdated m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:LastUpdated><d:Published m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Published><d:PackageHash>Y+7B007u3cYpjU4THI9/i2pSyRnHjZtRJOrjGiHYPH5C32jJZ5njWjgLVnI6nmsYjUrYcWjXLfB13J3ztd37cw==</d:PackageHash><d:PackageHashAlgorithm>SHA512</d:PackageHashAlgorithm><d:PackageSize m:type="Edm.Int64">265621</d:PackageSize><d:ProjectUrl>http://autofac.org/</d:ProjectUrl><d:ReportAbuseUrl>https://www.nuget.org/packages/Autofac/4.6.0/ReportAbuse</d:ReportAbuseUrl><d:ReleaseNotes>Release notes are at https://github.com/autofac/Autofac/releases</d:ReleaseNotes><d:RequireLicenseAcceptance m:type="Edm.Boolean">false</d:RequireLicenseAcceptance><d:Summary m:null="true" /><d:Tags>autofac di ioc dependencyinjection</d:Tags><d:Title m:null="true" /><d:VersionDownloadCount m:type="Edm.Int32">125567</d:VersionDownloadCount><d:MinClientVersion m:null="true" /><d:LastEdited m:null="true" /><d:LicenseUrl>http://www.opensource.org/licenses/mit-license.php</d:LicenseUrl><d:LicenseNames m:null="true" /><d:LicenseReportUrl m:null="true" /></m:properties></entry></feed>
   Found Explored Package  Autofac 4.6.0
   1 packages in resolution.
     - Autofac, 4.6.0
   1 requirements left
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve FooBarBazQux  (from C:\Users\kazark\fix\paket.dependencies)
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Source 'https://www.nuget.org/api/v2' yielded (0): []
 - Request 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0' finished with: []
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded no results
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' finished with: System.Exception: Could not retrieve data from 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100' ---> Paket.Utils+RequestFailedException: Request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100' failed with: 'NotFound'
   at Paket.Utils.failIfNoSuccess@441-5.Invoke(RequestFailedInfo _arg1)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.args@825-1.Invoke(a a)
   --- End of inner exception stack trace ---
   at Paket.Utils.getFromUrl@622-8.Invoke(Exception _arg4)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.callA@841.Invoke(AsyncParams`1 args)
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was skipped because 'ProtocolNotCached'

Trial1 (NuGet.GetVersions) did not yield any results, trying again.
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Performance:
 - Resolver: 16 seconds (1 runs)
    - Runtime: 125 milliseconds
    - Blocked (retrieving package versions): 15 seconds (2 times)
    - Blocked (retrieving package details): 825 milliseconds (1 times)
 - Average Request Time: 752 milliseconds
 - Number of Requests: 11
 - Runtime: 17 seconds

VM log resulting from paket --verbose outdated > paket.log:

Paket version 5.6.9
found: C:\Users\kazark\fix\paket.dependencies
Parsing C:\Users\kazark\fix\paket.dependencies
Resolving packages for group Main:
   0 packages in resolution.
   2 requirements left
     - Autofac,  (from C:\Users\kazark\fix\paket.dependencies)
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve Autofac  (from C:\Users\kazark\fix\paket.dependencies)
Starting request to 'https://api.nuget.org/v3/index.json'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac''
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Starting request to 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Source 'https://www.nuget.org/api/v2' yielded (0): [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0' finished with: [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded (0): [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' finished with: [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)

 - Autofac 4.6.0
Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Source 'https://www.nuget.org/api/v2' yielded (0): []
 - Request 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0' finished with: []
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded no results
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' finished with: System.Exception: Could not retrieve data from 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100' ---> Paket.Utils+RequestFailedException: Request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100' failed with: 'NotFound'
   at Paket.Utils.failIfNoSuccess@441-5.Invoke(RequestFailedInfo _arg1)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.args@825-1.Invoke(a a)
   --- End of inner exception stack trace ---
   at Paket.Utils.getFromUrl@622-8.Invoke(Exception _arg4)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.callA@841.Invoke(AsyncParams`1 args)
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was skipped because 'ProtocolNotCached'

Trial1 (NuGet.GetVersions) did not yield any results, trying again.
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Starting request to 'https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0')'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Response from https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0'):

<?xml version="1.0" encoding="utf-8"?><feed xml:base="https://www.nuget.org/api/v2" xmlns="http://www.w3.org/2005/Atom" xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices" xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata" xmlns:georss="http://www.georss.org/georss" xmlns:gml="http://www.opengis.net/gml"><id>http://schemas.datacontract.org/2004/07/</id><title /><updated>2017-07-12T15:53:54Z</updated><link rel="self" href="https://www.nuget.org/api/v2/Packages" /><entry><id>https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')</id><category term="NuGetGallery.OData.V2FeedPackage" scheme="http://schemas.microsoft.com/ado/2007/08/dataservices/scheme" /><link rel="edit" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><link rel="self" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><title type="text">Autofac</title><updated>2017-05-16T12:38:51Z</updated><author><name>Autofac Contributors</name></author><content type="application/zip" src="https://www.nuget.org/api/v2/package/Autofac/4.6.0" /><m:properties><d:Id>Autofac</d:Id><d:Version>4.6.0</d:Version><d:NormalizedVersion>4.6.0</d:NormalizedVersion><d:Authors>Autofac Contributors</d:Authors><d:Copyright m:null="true" /><d:Created m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Created><d:Dependencies>::net45|NETStandard.Library:[1.6.0, ):netstandard1.1|System.ComponentModel:[4.0.1, ):netstandard1.1</d:Dependencies><d:Description>Autofac is an IoC container for Microsoft .NET. It manages the dependencies between classes so that applications stay easy to change as they grow in size and complexity.</d:Description><d:DownloadCount m:type="Edm.Int32">5364726</d:DownloadCount><d:GalleryDetailsUrl>https://www.nuget.org/packages/Autofac/4.6.0</d:GalleryDetailsUrl><d:IconUrl>https://cloud.githubusercontent.com/assets/1156571/13684110/16b8f152-e6bf-11e5-84ae-22c66c6d351a.png</d:IconUrl><d:IsLatestVersion m:type="Edm.Boolean">true</d:IsLatestVersion><d:IsAbsoluteLatestVersion m:type="Edm.Boolean">true</d:IsAbsoluteLatestVersion><d:IsPrerelease m:type="Edm.Boolean">false</d:IsPrerelease><d:Language m:null="true" /><d:LastUpdated m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:LastUpdated><d:Published m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Published><d:PackageHash>Y+7B007u3cYpjU4THI9/i2pSyRnHjZtRJOrjGiHYPH5C32jJZ5njWjgLVnI6nmsYjUrYcWjXLfB13J3ztd37cw==</d:PackageHash><d:PackageHashAlgorithm>SHA512</d:PackageHashAlgorithm><d:PackageSize m:type="Edm.Int64">265621</d:PackageSize><d:ProjectUrl>http://autofac.org/</d:ProjectUrl><d:ReportAbuseUrl>https://www.nuget.org/packages/Autofac/4.6.0/ReportAbuse</d:ReportAbuseUrl><d:ReleaseNotes>Release notes are at https://github.com/autofac/Autofac/releases</d:ReleaseNotes><d:RequireLicenseAcceptance m:type="Edm.Boolean">false</d:RequireLicenseAcceptance><d:Summary m:null="true" /><d:Tags>autofac di ioc dependencyinjection</d:Tags><d:Title m:null="true" /><d:VersionDownloadCount m:type="Edm.Int32">125567</d:VersionDownloadCount><d:MinClientVersion m:null="true" /><d:LastEdited m:null="true" /><d:LicenseUrl>http://www.opensource.org/licenses/mit-license.php</d:LicenseUrl><d:LicenseNames m:null="true" /><d:LicenseReportUrl m:null="true" /></m:properties></entry></feed>
   Found Explored Package  Autofac 4.6.0
   1 packages in resolution.
     - Autofac, 4.6.0
   1 requirements left
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve FooBarBazQux  (from C:\Users\kazark\fix\paket.dependencies)
Performance:
 - Resolver: 1 second (1 runs)
    - Runtime: 147 milliseconds
    - Blocked (retrieving package details): 541 milliseconds (1 times)
    - Blocked (retrieving package versions): 592 milliseconds (1 times)
    - Not Blocked (retrieving package versions): 1 times
 - Average Request Time: 156 milliseconds
 - Number of Requests: 10
 - Runtime: 2 seconds

Definitely different but I don't understand the internals of Paket well enough to make sense out of it.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

I had a coworker run a test and he reproduced your results, not my results. This is a personal problem! :'(

Contributor

Kazark commented Jul 12, 2017

I had a coworker run a test and he reproduced your results, not my results. This is a personal problem! :'(

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 12, 2017

Member

so both succeeded?

Member

forki commented Jul 12, 2017

so both succeeded?

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 12, 2017

Member

run paket clear-cache!

Member

forki commented Jul 12, 2017

run paket clear-cache!

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 12, 2017

Member

and then paket install -f

Member

forki commented Jul 12, 2017

and then paket install -f

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 12, 2017

Member

then outdated again

Member

forki commented Jul 12, 2017

then outdated again

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

image

Contributor

Kazark commented Jul 12, 2017

image

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 12, 2017

Member

nice - yet another issue (but not important now)

Member

forki commented Jul 12, 2017

nice - yet another issue (but not important now)

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

Weird, I really would have thought this was a caching problem on my machine, given that it doesn't seem to be an internal network problem, but after running clear-cache again until it succeeded, I still get the problem.

Contributor

Kazark commented Jul 12, 2017

Weird, I really would have thought this was a caching problem on my machine, given that it doesn't seem to be an internal network problem, but after running clear-cache again until it succeeded, I still get the problem.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

Yeah oddly the clear-cache issue seemed to be resolved by running it with --verbose! Or maybe it was just repetition.

Contributor

Kazark commented Jul 12, 2017

Yeah oddly the clear-cache issue seemed to be resolved by running it with --verbose! Or maybe it was just repetition.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

So here's my stderr when I run outdated with --verbose (not included in the log above);

Paket failed with:
-> Unable to retrieve package versions for 'FooBarBazQux'
   StackTrace:
        at Paket.PackageResolver.getVersionsBlock@943-1.Invoke(PackageName packageName)
        at Paket.PackageResolver.getCompatibleVersions$cont@491(ResolverStep currentStep, GroupName groupName, PackageRequirement currentRequirement, FSharpFunc`2 getVersionsF, Boolean globalOverride, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives, Unit unitVar)
        at Paket.PackageResolver.getCompatibleVersions(ResolverStep currentStep, GroupName groupName, PackageRequirement currentRequirement, FSharpFunc`2 getVersionsF, Boolean globalOverride, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives)
        at Paket.PackageResolver.step@989[a](UpdateMode updateMode, GroupName groupName, FSharpOption`1 globalStrategyForTransitives, FSharpOption`1 globalStrategyForDirectDependencies, FrameworkRestrictions globalFrameworkRestrictions, FSharpFunc`2 getVersionsRaw, FSharpFunc`2 getPreferredVersionsRaw, FSharpFunc`2 getPackageDetailsRaw, FSharpSet`1 specialPrereleaseSettings, FSharpSet`1 cliToolSettings, ResolverRequestQueue workerQueue, Int32 taskTimeout, ConcurrentDictionary`2 startedGetPackageDetailsRequests, FSharpFunc`2 getPackageDetailsBlock, ConcurrentDictionary`2 startedGetVersionsRequests, FSharpFunc`2 getVersionsBlock, FSharpOption`1 packageFilter, IDictionary`2 rootSettings, FSharpSet`1 lockedPackages, Stage stage, StackPack stackpack, IEnumerable`1 compatibleVersions, StepFlags flags)
        at Paket.PackageResolver.Resolve[a](FSharpFunc`2 getVersionsRaw, FSharpFunc`2 getPreferredVersionsRaw, FSharpFunc`2 getPackageDetailsRaw, GroupName groupName, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives, FrameworkRestrictions globalFrameworkRestrictions, FSharpSet`1 rootDependencies, UpdateMode updateMode)
        at <StartupCode$Paket-Core>.$DependenciesFile.resolveGroup@212-1.Invoke(GroupName groupName, c _arg1)
        at Microsoft.FSharp.Collections.MapTreeModule.mapiOpt[a,b,c](FSharpFunc`3 f, MapTree`2 m)
        at Microsoft.FSharp.Collections.FSharpMap`2.Map[b](FSharpFunc`2 f)
        at Paket.FindOutdated.FindOutdated@30.Invoke(LockFile _arg1)
        at Chessie.ErrorHandling.Trial.fSuccess@66-11[p,r,q](FSharpFunc`2 f, p x, FSharpList`1 msgs)
        at Paket.FindOutdated.ShowOutdated(Boolean strict, Boolean includingPrereleases, FSharpOption`1 groupName, PaketEnv environment)
        at <StartupCode$Paket-Core>.$PublicAPI.fSuccess@1-3[c](FSharpFunc`2 f, PaketEnv x, FSharpList`1 msgs)
        at Paket.Dependencies.Process[c](FSharpFunc`2 f)
        at Paket.Program.main@722-11.Invoke(ParseResults`1 results)
        at Paket.Program.processWithValidation[T](Boolean silent, FSharpFunc`2 validateF, FSharpFunc`2 commandF, ParseResults`1 result)
        at Paket.Program.processCommand[a](Boolean silent, FSharpFunc`2 commandF, ParseResults`1 result)
        at Paket.Program.main$cont@708(ParseResults`1 results, Boolean silent, Boolean fromBootstrapper, Unit unitVar)
        at Paket.Program.main()
-> Could not find versions for package FooBarBazQux on any of ["https://www.nuget.org/api/v2";
    "http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata"].
        -  Source 'https://www.nuget.org/api/v2' yielded (0): []
                -  Request 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0' finished with: []
                -  Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' was cancelled (another one was faster)
                -  Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was cancelled (another one was faster)
        -  Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded no results
                -  Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' finished with error
                -> Could not retrieve data from 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
                -> RequestFailedException: Request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100' failed with: 'NotFound'
                -  Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was skipped because 'ProtocolNotCached'
Contributor

Kazark commented Jul 12, 2017

So here's my stderr when I run outdated with --verbose (not included in the log above);

Paket failed with:
-> Unable to retrieve package versions for 'FooBarBazQux'
   StackTrace:
        at Paket.PackageResolver.getVersionsBlock@943-1.Invoke(PackageName packageName)
        at Paket.PackageResolver.getCompatibleVersions$cont@491(ResolverStep currentStep, GroupName groupName, PackageRequirement currentRequirement, FSharpFunc`2 getVersionsF, Boolean globalOverride, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives, Unit unitVar)
        at Paket.PackageResolver.getCompatibleVersions(ResolverStep currentStep, GroupName groupName, PackageRequirement currentRequirement, FSharpFunc`2 getVersionsF, Boolean globalOverride, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives)
        at Paket.PackageResolver.step@989[a](UpdateMode updateMode, GroupName groupName, FSharpOption`1 globalStrategyForTransitives, FSharpOption`1 globalStrategyForDirectDependencies, FrameworkRestrictions globalFrameworkRestrictions, FSharpFunc`2 getVersionsRaw, FSharpFunc`2 getPreferredVersionsRaw, FSharpFunc`2 getPackageDetailsRaw, FSharpSet`1 specialPrereleaseSettings, FSharpSet`1 cliToolSettings, ResolverRequestQueue workerQueue, Int32 taskTimeout, ConcurrentDictionary`2 startedGetPackageDetailsRequests, FSharpFunc`2 getPackageDetailsBlock, ConcurrentDictionary`2 startedGetVersionsRequests, FSharpFunc`2 getVersionsBlock, FSharpOption`1 packageFilter, IDictionary`2 rootSettings, FSharpSet`1 lockedPackages, Stage stage, StackPack stackpack, IEnumerable`1 compatibleVersions, StepFlags flags)
        at Paket.PackageResolver.Resolve[a](FSharpFunc`2 getVersionsRaw, FSharpFunc`2 getPreferredVersionsRaw, FSharpFunc`2 getPackageDetailsRaw, GroupName groupName, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives, FrameworkRestrictions globalFrameworkRestrictions, FSharpSet`1 rootDependencies, UpdateMode updateMode)
        at <StartupCode$Paket-Core>.$DependenciesFile.resolveGroup@212-1.Invoke(GroupName groupName, c _arg1)
        at Microsoft.FSharp.Collections.MapTreeModule.mapiOpt[a,b,c](FSharpFunc`3 f, MapTree`2 m)
        at Microsoft.FSharp.Collections.FSharpMap`2.Map[b](FSharpFunc`2 f)
        at Paket.FindOutdated.FindOutdated@30.Invoke(LockFile _arg1)
        at Chessie.ErrorHandling.Trial.fSuccess@66-11[p,r,q](FSharpFunc`2 f, p x, FSharpList`1 msgs)
        at Paket.FindOutdated.ShowOutdated(Boolean strict, Boolean includingPrereleases, FSharpOption`1 groupName, PaketEnv environment)
        at <StartupCode$Paket-Core>.$PublicAPI.fSuccess@1-3[c](FSharpFunc`2 f, PaketEnv x, FSharpList`1 msgs)
        at Paket.Dependencies.Process[c](FSharpFunc`2 f)
        at Paket.Program.main@722-11.Invoke(ParseResults`1 results)
        at Paket.Program.processWithValidation[T](Boolean silent, FSharpFunc`2 validateF, FSharpFunc`2 commandF, ParseResults`1 result)
        at Paket.Program.processCommand[a](Boolean silent, FSharpFunc`2 commandF, ParseResults`1 result)
        at Paket.Program.main$cont@708(ParseResults`1 results, Boolean silent, Boolean fromBootstrapper, Unit unitVar)
        at Paket.Program.main()
-> Could not find versions for package FooBarBazQux on any of ["https://www.nuget.org/api/v2";
    "http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata"].
        -  Source 'https://www.nuget.org/api/v2' yielded (0): []
                -  Request 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0' finished with: []
                -  Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' was cancelled (another one was faster)
                -  Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was cancelled (another one was faster)
        -  Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded no results
                -  Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' finished with error
                -> Could not retrieve data from 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
                -> RequestFailedException: Request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100' failed with: 'NotFound'
                -  Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was skipped because 'ProtocolNotCached'
@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 12, 2017

Member

ok now it's better. now try the urls. Something is wrong with these urls on your machine

(and always run with -f so that you skip the cache)

Member

forki commented Jul 12, 2017

ok now it's better. now try the urls. Something is wrong with these urls on your machine

(and always run with -f so that you skip the cache)

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

-f? I haven't been able to find that option. Running with 5.6.10, it has randomly worked exactly one time so far. However I cannot get it to work again.

Contributor

Kazark commented Jul 12, 2017

-f? I haven't been able to find that option. Running with 5.6.10, it has randomly worked exactly one time so far. However I cannot get it to work again.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 12, 2017

Member
Member

forki commented Jul 12, 2017

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 12, 2017

Contributor

Okay, I gotta pause for a bit, but will get back to you.

Contributor

Kazark commented Jul 12, 2017

Okay, I gotta pause for a bit, but will get back to you.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 13, 2017

Contributor

Ergh, one of my coworkers just saw this now, too. Rats, I was hoping it was enough of a personal problem that I didn't have to be super aggressive about trying to get it fixed.

Contributor

Kazark commented Jul 13, 2017

Ergh, one of my coworkers just saw this now, too. Rats, I was hoping it was enough of a personal problem that I didn't have to be super aggressive about trying to get it fixed.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 13, 2017

Member

@Kazark is there a way to reproduce it on that vm outside of your network?

Member

forki commented Jul 13, 2017

@Kazark is there a way to reproduce it on that vm outside of your network?

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 13, 2017

Contributor

Not that I have been able to discover

Contributor

Kazark commented Jul 13, 2017

Not that I have been able to discover

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 13, 2017

Contributor

I will get back to you with the update -f -v information as soon as I can come up for a breath

Contributor

Kazark commented Jul 13, 2017

I will get back to you with the update -f -v information as soon as I can come up for a breath

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 13, 2017

Contributor

No way, it just happened on the VM when I ran paket update -f -v!! Also, my coworker also experienced it 3 times with Paket 5.4.8, though it stopped happening after that. He also hit the cache clear bug.

Contributor

Kazark commented Jul 13, 2017

No way, it just happened on the VM when I ran paket update -f -v!! Also, my coworker also experienced it 3 times with Paket 5.4.8, though it stopped happening after that. He also hit the cache clear bug.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 13, 2017

Member

Ok. Good. Will try again tomorrow.

Member

forki commented Jul 13, 2017

Ok. Good. Will try again tomorrow.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 13, 2017

Contributor

Here is the failure from the VM:

Paket failed with:
-> Unable to retrieve package versions for 'FooBarBazQux'
   StackTrace:
        at Paket.PackageResolver.getVersionsBlock@943-1.Invoke(PackageName packageName)
        at Paket.PackageResolver.getCompatibleVersions$cont@491(ResolverStep currentStep, GroupName groupName, PackageRequirement currentRequirement, FSharpFunc`2 getVersionsF, Boolean globalOverride, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives, Unit unitVar)
        at Paket.PackageResolver.getCompatibleVersions(ResolverStep currentStep, GroupName groupName, PackageRequirement currentRequirement, FSharpFunc`2 getVersionsF, Boolean globalOverride, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives)
        at Paket.PackageResolver.step@989[a](UpdateMode updateMode, GroupName groupName, FSharpOption`1 globalStrategyForTransitives, FSharpOption`1 globalStrategyForDirectDependencies, FrameworkRestrictions globalFrameworkRestrictions, FSharpFunc`2 getVersionsRaw, FSharpFunc`2 getPreferredVersionsRaw, FSharpFunc`2 getPackageDetailsRaw, FSharpSet`1 specialPrereleaseSettings, FSharpSet`1 cliToolSettings, ResolverRequestQueue workerQueue, Int32 taskTimeout, ConcurrentDictionary`2 startedGetPackageDetailsRequests, FSharpFunc`2 getPackageDetailsBlock, ConcurrentDictionary`2 startedGetVersionsRequests, FSharpFunc`2 getVersionsBlock, FSharpOption`1 packageFilter, IDictionary`2 rootSettings, FSharpSet`1 lockedPackages, Stage stage, StackPack stackpack, IEnumerable`1 compatibleVersions, StepFlags flags)
        at Paket.PackageResolver.Resolve[a](FSharpFunc`2 getVersionsRaw, FSharpFunc`2 getPreferredVersionsRaw, FSharpFunc`2 getPackageDetailsRaw, GroupName groupName, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives, FrameworkRestrictions globalFrameworkRestrictions, FSharpSet`1 rootDependencies, UpdateMode updateMode)
        at <StartupCode$Paket-Core>.$DependenciesFile.resolveGroup@212-1.Invoke(GroupName groupName, c _arg1)
        at Microsoft.FSharp.Collections.MapTreeModule.mapiOpt[a,b,c](FSharpFunc`3 f, MapTree`2 m)
        at Microsoft.FSharp.Collections.FSharpMap`2.Map[b](FSharpFunc`2 f)
        at Paket.UpdateProcess.selectiveUpdate[a](Boolean force, FSharpFunc`2 getSha1, FSharpFunc`2 getVersionsF, FSharpFunc`2 getPackageDetailsF, FSharpFunc`2 getRuntimeGraphFromPackage, LockFile lockFile, DependenciesFile dependenciesFile, UpdateMode updateMode, SemVerUpdateMode semVerUpdateMode)
        at Paket.UpdateProcess.SelectiveUpdate(DependenciesFile dependenciesFile, FSharpOption`1 alternativeProjectRoot, UpdateMode updateMode, SemVerUpdateMode semVerUpdateMode, Boolean force)
        at Paket.UpdateProcess.SmartInstall(DependenciesFile dependenciesFile, UpdateMode updateMode, UpdaterOptions options)
        at <StartupCode$Paket-Core>.$PublicAPI.Update@242.Invoke(Unit unitVar0)
        at Paket.Utils.RunInLockedAccessMode[a](String rootFolder, FSharpFunc`2 action)
        at Paket.Program.main@726-15.Invoke(ParseResults`1 results)
        at Paket.Program.processWithValidation[T](Boolean silent, FSharpFunc`2 validateF, FSharpFunc`2 commandF, ParseResults`1 result)
        at Paket.Program.processCommand[a](Boolean silent, FSharpFunc`2 commandF, ParseResults`1 result)
        at Paket.Program.main$cont@708(ParseResults`1 results, Boolean silent, Boolean fromBootstrapper, Unit unitVar)
        at Paket.Program.main()
-> Could not find versions for package FooBarBazQux on any of ["https://www.nuget.org/api/v2";
    "http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata"].
        -  Source 'https://www.nuget.org/api/v2' yielded (0): []
                -  Request 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0' finished with: []
                -  Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' was cancelled (another one was faster)
                -  Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was cancelled (another one was faster)
        -  Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded no results
                -  Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' finished with error
                -> Could not retrieve data from 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
                -> RequestFailedException: Request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100' failed with: 'NotFound'
                -  Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was skipped because 'ProtocolNotCached'

Along with this log (I had redirected stdout):

Paket version 5.6.10
found: C:\Users\kazark\fix\paket.dependencies
Parsing C:\Users\kazark\fix\paket.dependencies
Resolving packages for group Main:
   0 packages in resolution.
   2 requirements left
     - Autofac,  (from C:\Users\kazark\fix\paket.dependencies)
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve Autofac  (from C:\Users\kazark\fix\paket.dependencies)
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac''
Starting request to 'https://api.nuget.org/v3/index.json'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Starting request to 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0'
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Source 'https://www.nuget.org/api/v2' yielded (0): []
 - Request 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0' finished with: []
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded no results
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' finished with: System.Exception: Could not retrieve data from 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100' ---> Paket.Utils+RequestFailedException: Request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100' failed with: 'NotFound'
   at Paket.Utils.failIfNoSuccess@441-5.Invoke(RequestFailedInfo _arg1)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.args@825-1.Invoke(a a)
   --- End of inner exception stack trace ---
   at Paket.Utils.getFromUrl@622-8.Invoke(Exception _arg4)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.callA@841.Invoke(AsyncParams`1 args)
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was skipped because 'ProtocolNotCached'

Trial1 (NuGet.GetVersions) did not yield any results, trying again.
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Source 'https://www.nuget.org/api/v2' yielded (0): [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0' finished with: [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded (0): [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' finished with: [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)

Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
 - Autofac 4.6.0
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Starting request to 'https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0')'
Response from https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0'):

<?xml version="1.0" encoding="utf-8"?><feed xml:base="https://www.nuget.org/api/v2" xmlns="http://www.w3.org/2005/Atom" xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices" xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata" xmlns:georss="http://www.georss.org/georss" xmlns:gml="http://www.opengis.net/gml"><id>http://schemas.datacontract.org/2004/07/</id><title /><updated>2017-07-13T15:47:28Z</updated><link rel="self" href="https://www.nuget.org/api/v2/Packages" /><entry><id>https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')</id><category term="NuGetGallery.OData.V2FeedPackage" scheme="http://schemas.microsoft.com/ado/2007/08/dataservices/scheme" /><link rel="edit" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><link rel="self" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><title type="text">Autofac</title><updated>2017-05-16T12:38:51Z</updated><author><name>Autofac Contributors</name></author><content type="application/zip" src="https://www.nuget.org/api/v2/package/Autofac/4.6.0" /><m:properties><d:Id>Autofac</d:Id><d:Version>4.6.0</d:Version><d:NormalizedVersion>4.6.0</d:NormalizedVersion><d:Authors>Autofac Contributors</d:Authors><d:Copyright m:null="true" /><d:Created m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Created><d:Dependencies>::net45|NETStandard.Library:[1.6.0, ):netstandard1.1|System.ComponentModel:[4.0.1, ):netstandard1.1</d:Dependencies><d:Description>Autofac is an IoC container for Microsoft .NET. It manages the dependencies between classes so that applications stay easy to change as they grow in size and complexity.</d:Description><d:DownloadCount m:type="Edm.Int32">5402927</d:DownloadCount><d:GalleryDetailsUrl>https://www.nuget.org/packages/Autofac/4.6.0</d:GalleryDetailsUrl><d:IconUrl>https://cloud.githubusercontent.com/assets/1156571/13684110/16b8f152-e6bf-11e5-84ae-22c66c6d351a.png</d:IconUrl><d:IsLatestVersion m:type="Edm.Boolean">true</d:IsLatestVersion><d:IsAbsoluteLatestVersion m:type="Edm.Boolean">true</d:IsAbsoluteLatestVersion><d:IsPrerelease m:type="Edm.Boolean">false</d:IsPrerelease><d:Language m:null="true" /><d:LastUpdated m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:LastUpdated><d:Published m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Published><d:PackageHash>Y+7B007u3cYpjU4THI9/i2pSyRnHjZtRJOrjGiHYPH5C32jJZ5njWjgLVnI6nmsYjUrYcWjXLfB13J3ztd37cw==</d:PackageHash><d:PackageHashAlgorithm>SHA512</d:PackageHashAlgorithm><d:PackageSize m:type="Edm.Int64">265621</d:PackageSize><d:ProjectUrl>http://autofac.org/</d:ProjectUrl><d:ReportAbuseUrl>https://www.nuget.org/packages/Autofac/4.6.0/ReportAbuse</d:ReportAbuseUrl><d:ReleaseNotes>Release notes are at https://github.com/autofac/Autofac/releases</d:ReleaseNotes><d:RequireLicenseAcceptance m:type="Edm.Boolean">false</d:RequireLicenseAcceptance><d:Summary m:null="true" /><d:Tags>autofac di ioc dependencyinjection</d:Tags><d:Title m:null="true" /><d:VersionDownloadCount m:type="Edm.Int32">125567</d:VersionDownloadCount><d:MinClientVersion m:null="true" /><d:LastEdited m:null="true" /><d:LicenseUrl>http://www.opensource.org/licenses/mit-license.php</d:LicenseUrl><d:LicenseNames m:null="true" /><d:LicenseReportUrl m:null="true" /></m:properties></entry></feed>
   Found Explored Package  Autofac 4.6.0
   1 packages in resolution.
     - Autofac, 4.6.0
   1 requirements left
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve FooBarBazQux  (from C:\Users\kazark\fix\paket.dependencies)
Performance:
 - Resolver: 1 second (1 runs)
    - Runtime: 166 milliseconds
    - Blocked (retrieving package details): 491 milliseconds (1 times)
    - Blocked (retrieving package versions): 734 milliseconds (1 times)
    - Not Blocked (retrieving package versions): 1 times
 - Average Request Time: 123 milliseconds
 - Number of Requests: 10
 - Runtime: 2 seconds
Contributor

Kazark commented Jul 13, 2017

Here is the failure from the VM:

Paket failed with:
-> Unable to retrieve package versions for 'FooBarBazQux'
   StackTrace:
        at Paket.PackageResolver.getVersionsBlock@943-1.Invoke(PackageName packageName)
        at Paket.PackageResolver.getCompatibleVersions$cont@491(ResolverStep currentStep, GroupName groupName, PackageRequirement currentRequirement, FSharpFunc`2 getVersionsF, Boolean globalOverride, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives, Unit unitVar)
        at Paket.PackageResolver.getCompatibleVersions(ResolverStep currentStep, GroupName groupName, PackageRequirement currentRequirement, FSharpFunc`2 getVersionsF, Boolean globalOverride, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives)
        at Paket.PackageResolver.step@989[a](UpdateMode updateMode, GroupName groupName, FSharpOption`1 globalStrategyForTransitives, FSharpOption`1 globalStrategyForDirectDependencies, FrameworkRestrictions globalFrameworkRestrictions, FSharpFunc`2 getVersionsRaw, FSharpFunc`2 getPreferredVersionsRaw, FSharpFunc`2 getPackageDetailsRaw, FSharpSet`1 specialPrereleaseSettings, FSharpSet`1 cliToolSettings, ResolverRequestQueue workerQueue, Int32 taskTimeout, ConcurrentDictionary`2 startedGetPackageDetailsRequests, FSharpFunc`2 getPackageDetailsBlock, ConcurrentDictionary`2 startedGetVersionsRequests, FSharpFunc`2 getVersionsBlock, FSharpOption`1 packageFilter, IDictionary`2 rootSettings, FSharpSet`1 lockedPackages, Stage stage, StackPack stackpack, IEnumerable`1 compatibleVersions, StepFlags flags)
        at Paket.PackageResolver.Resolve[a](FSharpFunc`2 getVersionsRaw, FSharpFunc`2 getPreferredVersionsRaw, FSharpFunc`2 getPackageDetailsRaw, GroupName groupName, FSharpOption`1 globalStrategyForDirectDependencies, FSharpOption`1 globalStrategyForTransitives, FrameworkRestrictions globalFrameworkRestrictions, FSharpSet`1 rootDependencies, UpdateMode updateMode)
        at <StartupCode$Paket-Core>.$DependenciesFile.resolveGroup@212-1.Invoke(GroupName groupName, c _arg1)
        at Microsoft.FSharp.Collections.MapTreeModule.mapiOpt[a,b,c](FSharpFunc`3 f, MapTree`2 m)
        at Microsoft.FSharp.Collections.FSharpMap`2.Map[b](FSharpFunc`2 f)
        at Paket.UpdateProcess.selectiveUpdate[a](Boolean force, FSharpFunc`2 getSha1, FSharpFunc`2 getVersionsF, FSharpFunc`2 getPackageDetailsF, FSharpFunc`2 getRuntimeGraphFromPackage, LockFile lockFile, DependenciesFile dependenciesFile, UpdateMode updateMode, SemVerUpdateMode semVerUpdateMode)
        at Paket.UpdateProcess.SelectiveUpdate(DependenciesFile dependenciesFile, FSharpOption`1 alternativeProjectRoot, UpdateMode updateMode, SemVerUpdateMode semVerUpdateMode, Boolean force)
        at Paket.UpdateProcess.SmartInstall(DependenciesFile dependenciesFile, UpdateMode updateMode, UpdaterOptions options)
        at <StartupCode$Paket-Core>.$PublicAPI.Update@242.Invoke(Unit unitVar0)
        at Paket.Utils.RunInLockedAccessMode[a](String rootFolder, FSharpFunc`2 action)
        at Paket.Program.main@726-15.Invoke(ParseResults`1 results)
        at Paket.Program.processWithValidation[T](Boolean silent, FSharpFunc`2 validateF, FSharpFunc`2 commandF, ParseResults`1 result)
        at Paket.Program.processCommand[a](Boolean silent, FSharpFunc`2 commandF, ParseResults`1 result)
        at Paket.Program.main$cont@708(ParseResults`1 results, Boolean silent, Boolean fromBootstrapper, Unit unitVar)
        at Paket.Program.main()
-> Could not find versions for package FooBarBazQux on any of ["https://www.nuget.org/api/v2";
    "http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata"].
        -  Source 'https://www.nuget.org/api/v2' yielded (0): []
                -  Request 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0' finished with: []
                -  Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' was cancelled (another one was faster)
                -  Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was cancelled (another one was faster)
        -  Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded no results
                -  Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' finished with error
                -> Could not retrieve data from 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
                -> RequestFailedException: Request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100' failed with: 'NotFound'
                -  Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was skipped because 'ProtocolNotCached'

Along with this log (I had redirected stdout):

Paket version 5.6.10
found: C:\Users\kazark\fix\paket.dependencies
Parsing C:\Users\kazark\fix\paket.dependencies
Resolving packages for group Main:
   0 packages in resolution.
   2 requirements left
     - Autofac,  (from C:\Users\kazark\fix\paket.dependencies)
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve Autofac  (from C:\Users\kazark\fix\paket.dependencies)
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac''
Starting request to 'https://api.nuget.org/v3/index.json'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Starting request to 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0'
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Source 'https://www.nuget.org/api/v2' yielded (0): []
 - Request 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0' finished with: []
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded no results
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'' finished with: System.Exception: Could not retrieve data from 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100' ---> Paket.Utils+RequestFailedException: Request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100' failed with: 'NotFound'
   at Paket.Utils.failIfNoSuccess@441-5.Invoke(RequestFailedInfo _arg1)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.args@825-1.Invoke(a a)
   --- End of inner exception stack trace ---
   at Paket.Utils.getFromUrl@622-8.Invoke(Exception _arg4)
   at Microsoft.FSharp.Control.AsyncBuilderImpl.callA@841.Invoke(AsyncParams`1 args)
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'FooBarBazQux'' was skipped because 'ProtocolNotCached'

Trial1 (NuGet.GetVersions) did not yield any results, trying again.
Starting request to 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux''
Source 'https://www.nuget.org/api/v2' yielded (0): [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://api.nuget.org/v3-flatcontainer/autofac/index.json?semVerLevel=2.0.0' finished with: [4.6.0 ; 4.5.0 ; 4.4.0 ; 4.3.0 ; 4.2.1 ; 4.2.0 ; 4.1.1 ; 4.1.0 ; 4.0.1 ; 4.0.0 ; 4.0.0-rc3-316 ; 4.0.0-rc3-309 ; 4.0.0-rc3-293 ; 4.0.0-rc3-286 ; 4.0.0-rc3-280 ; 4.0.0-rc2-240 ; 4.0.0-rc1-177 ; 4.0.0-beta8-157 ; 4.0.0-beta7-130 ; 4.0.0-beta6-110 ; 4.0.0-beta5-90 ; 4.0.0-alpha2 ; 4.0.0-alpha1 ; 3.5.2 ; 3.5.0 ; 3.4.1 ; 3.4.0 ; 3.3.1 ; 3.3.0 ; 3.2.0 ; 3.1.5 ; 3.1.4 ; 3.1.3 ; 3.1.1 ; 3.1.0 ; 3.0.2 ; 3.0.1 ; 3.0.0 ; 3.0.0-beta2 ; 3.0.0-beta ; 2.6.3.862 ; 2.6.2.859 ; 2.6.1.841 ; 2.5.2.830 ; 2.5.1.827 ; 2.4.5.724 ; 2.4.4.705 ; 2.4.3.700 ; 2.4.2.696 ; 2.3.2.632 ; 2.2.4.900]
 - Request 'https://www.nuget.org/api/v2/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' was cancelled (another one was faster)
 - Request 'https://www.nuget.org/api/v2/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)
Source 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata' yielded (0): [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='Autofac'' finished with: [2.2.4.900 ; 2.3.2.632 ; 2.4.2.696 ; 2.4.3.700 ; 2.4.4.705 ; 2.4.5.724 ; 2.5.1.827 ; 2.5.2.830 ; 2.6.1.841 ; 2.6.2.859 ; 2.6.3.862 ; 3.0.0 ; 3.0.0-beta ; 3.0.0-beta2 ; 3.0.1 ; 3.0.2 ; 3.1.0 ; 3.1.1 ; 3.1.3 ; 3.1.4 ; 3.1.5 ; 3.2.0 ; 3.3.0 ; 3.3.1 ; 3.4.0 ; 3.4.1 ; 3.5.0 ; 3.5.2 ; 4.0.0 ; 4.0.0-alpha1 ; 4.0.0-alpha2 ; 4.0.0-beta5-90 ; 4.0.0-beta6-110 ; 4.0.0-beta7-130 ; 4.0.0-beta8-157 ; 4.0.0-rc1-177 ; 4.0.0-rc2-240 ; 4.0.0-rc3-280 ; 4.0.0-rc3-286 ; 4.0.0-rc3-293 ; 4.0.0-rc3-309 ; 4.0.0-rc3-316 ; 4.0.1 ; 4.1.0 ; 4.1.1 ; 4.2.0 ; 4.2.1 ; 4.3.0 ; 4.4.0 ; 4.5.0 ; 4.6.0]
 - Request 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/Packages?semVerLevel=2.0.0&$filter=Id eq 'Autofac'' was cancelled (another one was faster)

Request failed with '404': 'https://api.nuget.org/v3-flatcontainer/foobarbazqux/index.json?semVerLevel=2.0.0'
Starting request to 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById%28%29?semVerLevel=2.0.0&id=%27FooBarBazQux%27&$skip=100'
 - Autofac 4.6.0
Request failed with '404': 'http://klondikepaket.eastus.cloudapp.azure.com:8080/api/odata/FindPackagesById()?semVerLevel=2.0.0&id='FooBarBazQux'&$skip=100'
Starting request to 'https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0')'
Response from https://www.nuget.org/api/v2/Packages?$filter=(tolower(Id) eq 'autofac') and (NormalizedVersion eq '4.6.0'):

<?xml version="1.0" encoding="utf-8"?><feed xml:base="https://www.nuget.org/api/v2" xmlns="http://www.w3.org/2005/Atom" xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices" xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata" xmlns:georss="http://www.georss.org/georss" xmlns:gml="http://www.opengis.net/gml"><id>http://schemas.datacontract.org/2004/07/</id><title /><updated>2017-07-13T15:47:28Z</updated><link rel="self" href="https://www.nuget.org/api/v2/Packages" /><entry><id>https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')</id><category term="NuGetGallery.OData.V2FeedPackage" scheme="http://schemas.microsoft.com/ado/2007/08/dataservices/scheme" /><link rel="edit" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><link rel="self" href="https://www.nuget.org/api/v2/Packages(Id='Autofac',Version='4.6.0')" /><title type="text">Autofac</title><updated>2017-05-16T12:38:51Z</updated><author><name>Autofac Contributors</name></author><content type="application/zip" src="https://www.nuget.org/api/v2/package/Autofac/4.6.0" /><m:properties><d:Id>Autofac</d:Id><d:Version>4.6.0</d:Version><d:NormalizedVersion>4.6.0</d:NormalizedVersion><d:Authors>Autofac Contributors</d:Authors><d:Copyright m:null="true" /><d:Created m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Created><d:Dependencies>::net45|NETStandard.Library:[1.6.0, ):netstandard1.1|System.ComponentModel:[4.0.1, ):netstandard1.1</d:Dependencies><d:Description>Autofac is an IoC container for Microsoft .NET. It manages the dependencies between classes so that applications stay easy to change as they grow in size and complexity.</d:Description><d:DownloadCount m:type="Edm.Int32">5402927</d:DownloadCount><d:GalleryDetailsUrl>https://www.nuget.org/packages/Autofac/4.6.0</d:GalleryDetailsUrl><d:IconUrl>https://cloud.githubusercontent.com/assets/1156571/13684110/16b8f152-e6bf-11e5-84ae-22c66c6d351a.png</d:IconUrl><d:IsLatestVersion m:type="Edm.Boolean">true</d:IsLatestVersion><d:IsAbsoluteLatestVersion m:type="Edm.Boolean">true</d:IsAbsoluteLatestVersion><d:IsPrerelease m:type="Edm.Boolean">false</d:IsPrerelease><d:Language m:null="true" /><d:LastUpdated m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:LastUpdated><d:Published m:type="Edm.DateTime">2017-05-16T12:38:51.003</d:Published><d:PackageHash>Y+7B007u3cYpjU4THI9/i2pSyRnHjZtRJOrjGiHYPH5C32jJZ5njWjgLVnI6nmsYjUrYcWjXLfB13J3ztd37cw==</d:PackageHash><d:PackageHashAlgorithm>SHA512</d:PackageHashAlgorithm><d:PackageSize m:type="Edm.Int64">265621</d:PackageSize><d:ProjectUrl>http://autofac.org/</d:ProjectUrl><d:ReportAbuseUrl>https://www.nuget.org/packages/Autofac/4.6.0/ReportAbuse</d:ReportAbuseUrl><d:ReleaseNotes>Release notes are at https://github.com/autofac/Autofac/releases</d:ReleaseNotes><d:RequireLicenseAcceptance m:type="Edm.Boolean">false</d:RequireLicenseAcceptance><d:Summary m:null="true" /><d:Tags>autofac di ioc dependencyinjection</d:Tags><d:Title m:null="true" /><d:VersionDownloadCount m:type="Edm.Int32">125567</d:VersionDownloadCount><d:MinClientVersion m:null="true" /><d:LastEdited m:null="true" /><d:LicenseUrl>http://www.opensource.org/licenses/mit-license.php</d:LicenseUrl><d:LicenseNames m:null="true" /><d:LicenseReportUrl m:null="true" /></m:properties></entry></feed>
   Found Explored Package  Autofac 4.6.0
   1 packages in resolution.
     - Autofac, 4.6.0
   1 requirements left
     - FooBarBazQux,  (from C:\Users\kazark\fix\paket.dependencies)

  Trying to resolve FooBarBazQux  (from C:\Users\kazark\fix\paket.dependencies)
Performance:
 - Resolver: 1 second (1 runs)
    - Runtime: 166 milliseconds
    - Blocked (retrieving package details): 491 milliseconds (1 times)
    - Blocked (retrieving package versions): 734 milliseconds (1 times)
    - Not Blocked (retrieving package versions): 1 times
 - Average Request Time: 123 milliseconds
 - Number of Requests: 10
 - Runtime: 2 seconds
@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 13, 2017

Contributor

Not wanting to be annoying, just keeping a record of what's going on: another coworker just hit this.

Contributor

Kazark commented Jul 13, 2017

Not wanting to be annoying, just keeping a record of what's going on: another coworker just hit this.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 13, 2017

Member

Yeah. Will take a look tomorrow morning. Hope I can reproduce.

Member

forki commented Jul 13, 2017

Yeah. Will take a look tomorrow morning. Hope I can reproduce.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 13, 2017

Contributor

Okay great. Thanks so much.

Contributor

Kazark commented Jul 13, 2017

Okay great. Thanks so much.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 14, 2017

Member

good news: I was able to reproduce with -f param and then easily found the root cause. fix is in paket 5.6.11

the problem was that klondike returns encoded URIs in the OData response. I guess it's actually correct in doing that. But if we just try to follow that link then we get 404. So we actually have to unencode that thing.

Member

forki commented Jul 14, 2017

good news: I was able to reproduce with -f param and then easily found the root cause. fix is in paket 5.6.11

the problem was that klondike returns encoded URIs in the OData response. I guess it's actually correct in doing that. But if we just try to follow that link then we get 404. So we actually have to unencode that thing.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 14, 2017

Contributor

@forki super, thanks for working on this. I will give it a spin. The explanation makes sense.

Contributor

Kazark commented Jul 14, 2017

@forki super, thanks for working on this. I will give it a spin. The explanation makes sense.

@Kazark

This comment has been minimized.

Show comment
Hide comment
@Kazark

Kazark Jul 14, 2017

Contributor

Hurrah! Thanks so much. I no longer see the bug.

Contributor

Kazark commented Jul 14, 2017

Hurrah! Thanks so much. I no longer see the bug.

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 14, 2017

Member

heureka!

Member

forki commented Jul 14, 2017

heureka!

@bhugot

This comment has been minimized.

Show comment
Hide comment
@bhugot

bhugot Jul 14, 2017

Contributor

Good job guys

Contributor

bhugot commented Jul 14, 2017

Good job guys

@matthid matthid added this to NuGet API & Performance in Breaking Changes Aug 3, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment