New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fail when generate load scripts and version in path #2534

Closed
fpellet opened this Issue Jul 17, 2017 · 5 comments

Comments

Projects
None yet
3 participants
@fpellet

fpellet commented Jul 17, 2017

Description

With last release (5.7.0, no error before), I have an error when I install or restore dependencies.
After several tests, I have this error only if I specify "version_in_path" flag and generate load script on a group.

Repro steps

paket.dependencies

framework: net462

source https://api.nuget.org/v3/index.json

nuget xunit.runner.visualstudio >= 2.2 version_in_path: true


group Build
    framework: net462

    source https://api.nuget.org/v3/index.json

    generate_load_scripts: true

    nuget FAKE

Run paket install

I have output :

Paket version 5.7.0
Skipping resolver for group Main since it is already up-to-date
Resolving packages for group Build:
 - FAKE 4.62.5
Locked version resolution written to C:\projet\test\paket.lock
Installing into projects:
 - Creating model and downloading packages.
Could not detect any platforms from '_common'
Performance:
 - Resolver: 1 second (1 runs)
    - Runtime: 145 milliseconds
    - Blocked (retrieving package details): 45 milliseconds (1 times)
    - Blocked (retrieving package versions): 1 second (1 times)
 - Disk IO: 13 milliseconds
 - Average Request Time: 363 milliseconds
 - Number of Requests: 2
 - Runtime: 3 seconds
Paket failed with:
-> DirectoryNotFoundException: Could not find a part of the path 'C:\projet\test\packages\xunit.runner.visualstudio'.

Expected behavior

No error

Actual behavior

Error :

Paket failed with:
-> DirectoryNotFoundException: Could not find a part of the path 'C:\projet\test\packages\xunit.runner.visualstudio'.

Known workarounds

None

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jul 17, 2017

Member

what's the last version that worked for you?

Member

forki commented Jul 17, 2017

what's the last version that worked for you?

@fpellet

This comment has been minimized.

Show comment
Hide comment
@fpellet

fpellet Jul 17, 2017

5.6.12 works fine
5.7.0 and 5.7.1 failed

fpellet commented Jul 17, 2017

5.6.12 works fine
5.7.0 and 5.7.1 failed

@forki forki closed this in 1efeae3 Jul 17, 2017

@fpellet

This comment has been minimized.

Show comment
Hide comment
@fpellet

fpellet Jul 17, 2017

Cool, thanks !

fpellet commented Jul 17, 2017

Cool, thanks !

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jul 17, 2017

Member

Reopening because I think we need a test for this feature interaction.

Member

matthid commented Jul 17, 2017

Reopening because I think we need a test for this feature interaction.

@matthid matthid reopened this Jul 17, 2017

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jul 20, 2017

Member

Will find it with the label

Member

matthid commented Jul 20, 2017

Will find it with the label

@matthid matthid closed this Jul 20, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment