New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CLI Tools aren't being restored properly now #2854

Closed
TheAngryByrd opened this Issue Oct 18, 2017 · 8 comments

Comments

Projects
None yet
2 participants
@TheAngryByrd
Contributor

TheAngryByrd commented Oct 18, 2017

Description

CLI Tools aren't being restored properly now. I'm getting errors like Version for packagedotnet-monocould not be resolved when trying to run a tool https://github.com/fsprojects/Paket/releases/tag/5.117.0 seems to be the culprit.

Repro steps

Please provide the steps required to reproduce the problem

paket.depedencies includes a dotnet tool like clitool dotnet-mono 0.2.1 and include that in your paket.references

Do a dotnet restore dotnet build dance then try to use that tool.

I'll try to get a github repo repro.

Expected behavior

dotnet tools are there

Actual behavior

dotnet tools appear to not be there

Known workarounds

Revert to earlier version

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Oct 18, 2017

Member

ok I'll revert

Member

forki commented Oct 18, 2017

ok I'll revert

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Oct 18, 2017

Member

can you please retry?

Member

forki commented Oct 18, 2017

can you please retry?

@TheAngryByrd

This comment has been minimized.

Show comment
Hide comment
@TheAngryByrd

TheAngryByrd Oct 18, 2017

Contributor

seems to work 🎸

Contributor

TheAngryByrd commented Oct 18, 2017

seems to work 🎸

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Oct 19, 2017

Member

Could you please retry with latest and latest paket.restore.targets? I'm not sure if I broke cli tools. /cc @matthid

Member

forki commented Oct 19, 2017

Could you please retry with latest and latest paket.restore.targets? I'm not sure if I broke cli tools. /cc @matthid

@TheAngryByrd

This comment has been minimized.

Show comment
Hide comment
@TheAngryByrd

TheAngryByrd Oct 19, 2017

Contributor

Everything seems broke :(
Paket version 5.119.3

 error FS0074: The type referenced through 'System.Object' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Runtime'.
Contributor

TheAngryByrd commented Oct 19, 2017

Everything seems broke :(
Paket version 5.119.3

 error FS0074: The type referenced through 'System.Object' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Runtime'.
@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Oct 19, 2017

Member
Member

forki commented Oct 19, 2017

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Oct 20, 2017

Member

@TheAngryByrd are you around on skype?

Member

forki commented Oct 20, 2017

@TheAngryByrd are you around on skype?

@TheAngryByrd

This comment has been minimized.

Show comment
Hide comment
@TheAngryByrd

TheAngryByrd Oct 20, 2017

Contributor

I'll be at work in about 45 mins if you can wait till then.

Contributor

TheAngryByrd commented Oct 20, 2017

I'll be at work in about 45 mins if you can wait till then.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment