Join GitHub today
lowest_matching no longer respected from v5.125.3 and onwards #3032
It seems that lowest_matching was respected until 5.124.1 but starting from 5.125.3 and up to the latest version (5.133.0) it doesn't work anymore (for us).
We have the following line in our solution:
This should resolve to Newtonsoft.Json 9.0.1 but any NuGets created in that solution should declare a NuGet dependency of [9.0.1, 11.0) (i.e. both 9.x and 10.x). Starting from Paket 5.125.3, it resolves to Newtonsoft.Json 10.0.3.
The supplied dependency should resolve to package Newtonsoft.Json 9.0.1
The supplied dependency resolves to package Newtonsoft.Json 10.0.3
Using Paket version 5.124.1
I just tried with this
Latest Paket (5.133.0) resolves both to 9.0.1.
The question is what the parser thinks the constraint is. If it is equal to
looks like someone explicitly supported it
Its seems I have wandered into quite a fundamental issue as to what the dependency syntax should be. I too found that line to be rather odd. But let's get back to the issue at hand. I switched to the following more accepted syntax, but the same bug persists:
Since it works for all of you as a standalone dependency, I must assume it has to do with other dependencies in our
As you can see, the package resolution order is a bit different, and different version of
Both versions produce the exact same
BTW, since when did you have that awesome