New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Looking for a way to reference different versions of FSharp.Core in multi-targeted projects #3045

Closed
eiriktsarpalis opened this Issue Feb 14, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@eiriktsarpalis
Member

eiriktsarpalis commented Feb 14, 2018

Description

Multi-targeting provides an excellent means to author libraries that target both .NET classic and .NET standard frameworks. However, I am missing a way to specify different versions of FSharp.Core per target using paket. This is an important requirement, since I do not want to force FSharp.Core >= 4.2 on consumers of the net4x build.

Repro steps

Using the code from this commit, run paket install.

Expected behavior

Should complete successfully.

Actual behavior

Fails with the following error:

Paket failed with
-> Installation Errors :
   Package FSharp.Core is referenced in different versions in C:\Users\eirik.tsarpalis\Source\Repos\Repro\Library\Library.fsproj (4.3.1 vs 4.0.0.1), (inspect the lockfile for details) to resolve this either add all dependencies to a single group (to get a unified resolution) or use a condition on both groups and control compilation yourself.

Known workarounds

Either stop using multi-targetting, or use the nuget client.

forki added a commit that referenced this issue Feb 14, 2018

@forki

This comment has been minimized.

Member

forki commented Feb 14, 2018

see #3046

@eiriktsarpalis

This comment has been minimized.

Member

eiriktsarpalis commented Feb 14, 2018

Awesome, thanks!

@forki forki closed this in #3046 Feb 14, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment