New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

taskTimeout was increased to 180,000 ms #2456

Merged
merged 2 commits into from Jun 25, 2017

Conversation

Projects
None yet
3 participants
@vik-borisov
Contributor

vik-borisov commented Jun 22, 2017

Restoring the package was unsuccessful with a low-speed network connection

vik-borisov added some commits Jun 22, 2017

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jun 22, 2017

Member

Not sure if this is the correct approach here... 30s is already quite a lot of time for a request to finish. Even with a slow connection.
Maybe this is related to our new request preloading... Maybe we start just too many requests in parallel for the same server?

Member

matthid commented Jun 22, 2017

Not sure if this is the correct approach here... 30s is already quite a lot of time for a request to finish. Even with a slow connection.
Maybe this is related to our new request preloading... Maybe we start just too many requests in parallel for the same server?

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jun 25, 2017

Member

@vik-borisov is this against nuget.org?

Member

forki commented Jun 25, 2017

@vik-borisov is this against nuget.org?

@vik-borisov

This comment has been minimized.

Show comment
Hide comment
@vik-borisov

vik-borisov Jun 25, 2017

Contributor

no, it is myget

Contributor

vik-borisov commented Jun 25, 2017

no, it is myget

@forki forki merged commit d98a974 into fsprojects:master Jun 25, 2017

1 of 2 checks passed

continuous-integration/travis-ci/pr The Travis CI build failed
Details
continuous-integration/appveyor/pr AppVeyor build succeeded
Details
@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jun 25, 2017

Member

and it was restore that failed - the download. right?

Member

forki commented Jun 25, 2017

and it was restore that failed - the download. right?

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jun 25, 2017

Member

To be honest this change is completely unrelated to restore. And even if it would help - I still think it's the wrong way :)

Member

matthid commented Jun 25, 2017

To be honest this change is completely unrelated to restore. And even if it would help - I still think it's the wrong way :)

@forki

This comment has been minimized.

Show comment
Hide comment
@forki

forki Jun 25, 2017

Member

that's why I asked. I have no problem with increasing an already arbitray timeout. but wonder if the reported issue is actually restore

Member

forki commented Jun 25, 2017

that's why I asked. I have no problem with increasing an already arbitray timeout. but wonder if the reported issue is actually restore

@vik-borisov

This comment has been minimized.

Show comment
Hide comment
@vik-borisov

vik-borisov Jun 25, 2017

Contributor

Yes, the restore will fail. But then I increased the environment variable PAKET_RESOLVER_TASK_TIMEOUT to 180,000, then the problem was solved

Contributor

vik-borisov commented Jun 25, 2017

Yes, the restore will fail. But then I increased the environment variable PAKET_RESOLVER_TASK_TIMEOUT to 180,000, then the problem was solved

@vik-borisov

This comment has been minimized.

Show comment
Hide comment
@vik-borisov

vik-borisov Jun 25, 2017

Contributor

If i use package local cache or i use version 4, i have no problem

Contributor

vik-borisov commented Jun 25, 2017

If i use package local cache or i use version 4, i have no problem

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jun 25, 2017

Member

But restore/download is actually repeated 3 times, was that reported by paket?
That the environment variable helped probably was just an accident?

Member

matthid commented Jun 25, 2017

But restore/download is actually repeated 3 times, was that reported by paket?
That the environment variable helped probably was just an accident?

@vik-borisov

This comment has been minimized.

Show comment
Hide comment
@vik-borisov

vik-borisov Jun 25, 2017

Contributor

The environment variable is a workaround, but it works for me and my colleagues

Contributor

vik-borisov commented Jun 25, 2017

The environment variable is a workaround, but it works for me and my colleagues

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jun 25, 2017

Member

Can you show the failing output?

Member

matthid commented Jun 25, 2017

Can you show the failing output?

@vik-borisov

This comment has been minimized.

Show comment
Hide comment
@vik-borisov

vik-borisov Jun 25, 2017

Contributor

Well, I'll try to reproduce this error

Contributor

vik-borisov commented Jun 25, 2017

Well, I'll try to reproduce this error

@vik-borisov

This comment has been minimized.

Show comment
Hide comment
@vik-borisov

vik-borisov Jun 25, 2017

Contributor

Paket failed with:
-> There was a version conflict during package resolution. Resolved packages:
- StimulReport.Base 2015.1.0.0 Conflict detected:
- Dependencies file requested package StimulReport.Web: 2015.1 - Available versions:
- (2016.2.0.0, [https://myget.org]) - (2016.1.0.1, [https://myget.org])
- (2016.1.0.0, [https://myget.org]) - (2015.1.0.0, [https://myget.org])>Please try to relax some conditions or resolve the conflict manually (see http://fsprojects.github.io/Paket/nuget-dependencies.html#Use-exactly-this-version-constraint).
StackTrace: в Paket.PackageResolver.ResolutionModule.getModelOrFail(Resolution res)
в Paket.UpdateProcess.groups@129-6.Invoke(GroupName groupName, DependenciesGroup dependenciesGroup) в Microsoft.FSharp.Collections.MapTreeModule.mapiOpt[a,b,c](FSharpFunc3 f, MapTree2 m)
в Microsoft.FSharp.Collections.FSharpMap`2.Map[b](FSharpFunc`2 f) в Paket.UpdateProcess.selectiveUpdate[a](Boolean force, FSharpFunc2 getSha1, FSharpFunc2 getVersionsF, FSharpF
unc`2 getPackageDetailsF, FSharpFunc`2 getRuntimeGraphFromPackage, LockFile lockFile, DependenciesFile dependenciesFile, UpdateMode updateMode, SemVerUpdateMode semVerUpdateMode)
в Paket.UpdateProcess.SelectiveUpdate(DependenciesFile dependenciesFile, FSharpOption`1 alternativeProjectRoot,UpdateMode updateMode, SemVerUpdateMode semVerUpdateMode, Boolean force)
в Paket.UpdateProcess.SmartInstall(DependenciesFile dependenciesFile, UpdateMode updateMode, UpdaterOptions options)
в <StartupCode$Paket-Core>.$PublicAPI.Update@238.Invoke(Unit unitVar0) в Paket.Utils.RunInLockedAccessMode[a](String rootFolder, FSharpFunc2 action) `` в Paket.Program.main@471-15.Invoke(ParseResults1 results)
в Paket.Program.processWithValidation[T](Boolean silent, FSharpFunc`2 validateF, FSharpFunc`2 commandF, ParseResults1 result) `` в Paket.Program.main$cont@453(ParseResults1 results, Boolean silent, Boolean fromBootstrapper, Unit unitVar)
в Paket.Program.main()-> Unable to retrieve package details for 'StimulReport.Web'-2015.1.0.0
StackTrace: в Paket.PackageResolver.getPackageDetailsBlock@869.Invoke(FSharpList1 sources, GroupName groupName, PackageName `` packageName, SemVerInfo semVer) `` в Paket.PackageResolver.explorePackageConfig(FSharpFunc2 getPackageDetailsBlock, PackageConfig pkgConfig)
-> TimeoutException: Waited 30 seconds for a request to finish. Check the following sources, they might be rate limiting and stopped responding:
- https://myget.org - https://myget.org
- https://myget.org - https://myget.org

Contributor

vik-borisov commented Jun 25, 2017

Paket failed with:
-> There was a version conflict during package resolution. Resolved packages:
- StimulReport.Base 2015.1.0.0 Conflict detected:
- Dependencies file requested package StimulReport.Web: 2015.1 - Available versions:
- (2016.2.0.0, [https://myget.org]) - (2016.1.0.1, [https://myget.org])
- (2016.1.0.0, [https://myget.org]) - (2015.1.0.0, [https://myget.org])>Please try to relax some conditions or resolve the conflict manually (see http://fsprojects.github.io/Paket/nuget-dependencies.html#Use-exactly-this-version-constraint).
StackTrace: в Paket.PackageResolver.ResolutionModule.getModelOrFail(Resolution res)
в Paket.UpdateProcess.groups@129-6.Invoke(GroupName groupName, DependenciesGroup dependenciesGroup) в Microsoft.FSharp.Collections.MapTreeModule.mapiOpt[a,b,c](FSharpFunc3 f, MapTree2 m)
в Microsoft.FSharp.Collections.FSharpMap`2.Map[b](FSharpFunc`2 f) в Paket.UpdateProcess.selectiveUpdate[a](Boolean force, FSharpFunc2 getSha1, FSharpFunc2 getVersionsF, FSharpF
unc`2 getPackageDetailsF, FSharpFunc`2 getRuntimeGraphFromPackage, LockFile lockFile, DependenciesFile dependenciesFile, UpdateMode updateMode, SemVerUpdateMode semVerUpdateMode)
в Paket.UpdateProcess.SelectiveUpdate(DependenciesFile dependenciesFile, FSharpOption`1 alternativeProjectRoot,UpdateMode updateMode, SemVerUpdateMode semVerUpdateMode, Boolean force)
в Paket.UpdateProcess.SmartInstall(DependenciesFile dependenciesFile, UpdateMode updateMode, UpdaterOptions options)
в <StartupCode$Paket-Core>.$PublicAPI.Update@238.Invoke(Unit unitVar0) в Paket.Utils.RunInLockedAccessMode[a](String rootFolder, FSharpFunc2 action) `` в Paket.Program.main@471-15.Invoke(ParseResults1 results)
в Paket.Program.processWithValidation[T](Boolean silent, FSharpFunc`2 validateF, FSharpFunc`2 commandF, ParseResults1 result) `` в Paket.Program.main$cont@453(ParseResults1 results, Boolean silent, Boolean fromBootstrapper, Unit unitVar)
в Paket.Program.main()-> Unable to retrieve package details for 'StimulReport.Web'-2015.1.0.0
StackTrace: в Paket.PackageResolver.getPackageDetailsBlock@869.Invoke(FSharpList1 sources, GroupName groupName, PackageName `` packageName, SemVerInfo semVer) `` в Paket.PackageResolver.explorePackageConfig(FSharpFunc2 getPackageDetailsBlock, PackageConfig pkgConfig)
-> TimeoutException: Waited 30 seconds for a request to finish. Check the following sources, they might be rate limiting and stopped responding:
- https://myget.org - https://myget.org
- https://myget.org - https://myget.org

@vik-borisov

This comment has been minimized.

Show comment
Hide comment
@vik-borisov

vik-borisov Jun 25, 2017

Contributor

This error is reproduced for version 5.1.7. For version 5.2.1 works fine

Contributor

vik-borisov commented Jun 25, 2017

This error is reproduced for version 5.1.7. For version 5.2.1 works fine

@matthid

This comment has been minimized.

Show comment
Hide comment
@matthid

matthid Jun 25, 2017

Member

But this means you are doing paket install or paket update and not paket restore...

Member

matthid commented Jun 25, 2017

But this means you are doing paket install or paket update and not paket restore...

@vik-borisov

This comment has been minimized.

Show comment
Hide comment
@vik-borisov

vik-borisov Jun 25, 2017

Contributor

yes, now i was used paket update.

Contributor

vik-borisov commented Jun 25, 2017

yes, now i was used paket update.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment