Skip to content
Permalink
Browse files

update maven dependencies

  • Loading branch information...
fstab committed Nov 18, 2018
1 parent 2e60a88 commit 5510ef3a7b919e92795d580da5da0589dba9e92f
@@ -32,22 +32,22 @@
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>javax.servlet-api</artifactId>
<version>3.1.0</version>
<version>4.0.1</version>
<scope>provided</scope><!-- provided by the Servlet container -->
</dependency>

<!-- tests -->
<dependency>
<groupId>org.junit.jupiter</groupId>
<artifactId>junit-jupiter-api</artifactId>
<version>5.0.0-RC2</version>
<version>5.3.1</version>
<scope>test</scope>
</dependency>

<dependency>
<groupId>com.squareup.okhttp</groupId>
<groupId>com.squareup.okhttp3</groupId>
<artifactId>okhttp</artifactId>
<version>2.7.5</version>
<version>3.11.0</version>
<scope>test</scope>
</dependency>

@@ -60,7 +60,7 @@
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-failsafe-plugin</artifactId>
<version>2.20</version>
<version>2.22.1</version>
</plugin>
</plugins>
</pluginManagement>
@@ -84,7 +84,7 @@
<plugin>
<groupId>io.fabric8</groupId>
<artifactId>docker-maven-plugin</artifactId>
<version>0.21.0</version>
<version>0.27.2</version>
<configuration>
<verbose>true</verbose><!-- print build steps to stdout -->
<images>
@@ -98,13 +98,13 @@
<runCmds>
<run>apt-get update ; apt-get upgrade -y</run>
<run>apt-get install -y curl git neovim sudo</run>
<run>curl --silent --location --cookie "oraclelicense=accept-securebackup-cookie" -O http://download.oracle.com/otn-pub/java/jdk/8u171-b11/512cd62ec5174c3487ac17c61aaa89e8/jdk-8u171-linux-x64.tar.gz</run>
<run>tar xfz jdk-8u171-linux-x64.tar.gz</run>
<run>curl --silent -O http://ftp.fau.de/apache/maven/maven-3/3.5.3/binaries/apache-maven-3.5.3-bin.tar.gz</run>
<run>tar xfz apache-maven-3.5.3-bin.tar.gz</run>
<run>curl --silent --location --cookie "oraclelicense=accept-securebackup-cookie" -O http://download.oracle.com/otn-pub/java/jdk/8u192-b12/750e1c8617c5452694857ad95c3ee230/jdk-8u192-linux-x64.tar.gz</run>
<run>tar xfz jdk-8u192-linux-x64.tar.gz</run>
<run>curl --silent -O http://ftp.fau.de/apache/maven/maven-3/3.6.0/binaries/apache-maven-3.6.0-bin.tar.gz</run>
<run>tar xfz apache-maven-3.6.0-bin.tar.gz</run>
<run>
echo 'export JAVA_HOME="/opt/jdk1.8.0_171"' >> /etc/profile.d/java.sh ; \
echo 'export MAVEN_HOME="/opt/apache-maven-3.5.3"' >> /etc/profile.d/java.sh ; \
echo 'export JAVA_HOME="/opt/jdk1.8.0_192"' >> /etc/profile.d/java.sh ; \
echo 'export MAVEN_HOME="/opt/apache-maven-3.6.0"' >> /etc/profile.d/java.sh ; \
echo 'export PATH="$JAVA_HOME/bin:$PATH"' >> /etc/profile.d/java.sh ; \
echo 'export PATH="$MAVEN_HOME/bin:$PATH"' >> /etc/profile.d/java.sh ;
</run>
@@ -113,9 +113,9 @@
</runCmds>
<user>promagent</user>
<env>
<JAVA_HOME>/opt/jdk1.8.0_171</JAVA_HOME>
<MAVEN_HOME>/opt/apache-maven-3.5.3</MAVEN_HOME>
<PATH>/opt/jdk1.8.0_171/bin:/opt/apache-maven-3.5.3/bin:$PATH</PATH>
<JAVA_HOME>/opt/jdk1.8.0_192</JAVA_HOME>
<MAVEN_HOME>/opt/apache-maven-3.6.0</MAVEN_HOME>
<PATH>/opt/jdk1.8.0_192/bin:/opt/apache-maven-3.6.0/bin:$PATH</PATH>
</env>
</build>
</image>
@@ -32,22 +32,22 @@
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>javax.servlet-api</artifactId>
<version>3.1.0</version>
<version>4.0.1</version>
<scope>provided</scope><!-- provided by the Servlet container -->
</dependency>

<!-- tests -->
<dependency>
<groupId>org.junit.jupiter</groupId>
<artifactId>junit-jupiter-api</artifactId>
<version>5.0.0-RC2</version>
<version>5.3.1</version>
<scope>test</scope>
</dependency>

<dependency>
<groupId>com.squareup.okhttp</groupId>
<groupId>com.squareup.okhttp3</groupId>
<artifactId>okhttp</artifactId>
<version>2.7.5</version>
<version>3.11.0</version>
<scope>test</scope>
</dependency>

@@ -14,16 +14,17 @@

package io.promagent.it;

import com.squareup.okhttp.*;
import org.junit.jupiter.api.Assertions;
import org.junit.jupiter.api.Test;
import static org.junit.jupiter.api.Assertions.assertEquals;
import static org.junit.jupiter.api.Assertions.assertTrue;

import java.util.Arrays;
import java.util.List;
import java.util.stream.Collectors;

import static org.junit.jupiter.api.Assertions.assertEquals;
import static org.junit.jupiter.api.Assertions.assertTrue;
import okhttp3.MediaType;
import okhttp3.OkHttpClient;
import okhttp3.Request;
import okhttp3.RequestBody;
import okhttp3.Response;
import org.junit.jupiter.api.Test;

public class SpringIT {

@@ -14,15 +14,15 @@

package io.promagent.it;

import com.squareup.okhttp.OkHttpClient;
import com.squareup.okhttp.Request;
import com.squareup.okhttp.Response;
import org.junit.jupiter.api.Assertions;
import org.junit.jupiter.api.Test;
import static org.junit.jupiter.api.Assertions.assertTrue;

import java.util.Arrays;

import static org.junit.jupiter.api.Assertions.assertTrue;
import okhttp3.OkHttpClient;
import okhttp3.Request;
import okhttp3.Response;
import org.junit.jupiter.api.Assertions;
import org.junit.jupiter.api.Test;

public class WildflyIT {

@@ -21,8 +21,7 @@
<project.build.outputEncoding>UTF-8</project.build.outputEncoding>
<maven.compiler.source>1.8</maven.compiler.source>
<maven.compiler.target>1.8</maven.compiler.target>
<junit5.version>5.0.0-RC2</junit5.version>
<junit5.surefire.version>1.0.0-RC2</junit5.surefire.version>
<junit5.version>5.3.1</junit5.version>
</properties>

<modules>
@@ -38,7 +37,7 @@
<dependency>
<groupId>io.prometheus</groupId>
<artifactId>simpleclient_common</artifactId>
<version>0.0.26</version>
<version>0.5.0</version>
</dependency>
<dependency>
<groupId>org.junit.jupiter</groupId>
@@ -52,23 +51,11 @@
<build>
<pluginManagement>
<plugins>
<!-- enable JUnit5 unit tests -->
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-surefire-plugin</artifactId>
<version>2.20</version>
<dependencies>
<dependency>
<groupId>org.junit.platform</groupId>
<artifactId>junit-platform-surefire-provider</artifactId>
<version>${junit5.surefire.version}</version>
</dependency>
<dependency>
<groupId>org.junit.jupiter</groupId>
<artifactId>junit-jupiter-engine</artifactId>
<version>${junit5.version}</version>
</dependency>
</dependencies>
<!-- Native support for the JUnit platform was introduced with 2.22.0, so make sure we use this or later as the surefire plugin version -->
<version>2.22.1</version>
</plugin>
</plugins>
</pluginManagement>
@@ -20,7 +20,7 @@
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>javax.servlet-api</artifactId>
<version>3.1.0</version>
<version>4.0.1</version>
<scope>provided</scope> <!-- provided by the servlet container -->
</dependency>
</dependencies>
@@ -31,13 +31,13 @@
<dependency>
<groupId>net.bytebuddy</groupId>
<artifactId>byte-buddy</artifactId>
<version>1.7.9</version>
<version>1.9.4</version>
</dependency>

<dependency>
<groupId>commons-io</groupId>
<artifactId>commons-io</artifactId>
<version>2.5</version>
<version>2.6</version>
</dependency>

<dependency>
@@ -54,14 +54,14 @@
<dependency>
<groupId>org.mockito</groupId>
<artifactId>mockito-core</artifactId>
<version>2.13.0</version>
<version>2.23.0</version>
<scope>test</scope>
</dependency>

<dependency>
<groupId>javax.servlet</groupId>
<artifactId>javax.servlet-api</artifactId>
<version>3.1.0</version>
<version>4.0.1</version>
<scope>test</scope>
</dependency>

@@ -38,21 +38,21 @@
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-plugin-api</artifactId>
<version>3.5.2</version>
<version>3.6.0</version>
<scope>provided</scope>
</dependency>

<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-core</artifactId>
<version>3.5.2</version>
<version>3.6.0</version>
<scope>provided</scope>
</dependency>

<dependency>
<groupId>org.apache.maven.plugin-tools</groupId>
<artifactId>maven-plugin-annotations</artifactId>
<version>3.5</version>
<version>3.6.0</version>
<scope>provided</scope>
</dependency>

0 comments on commit 5510ef3

Please sign in to comment.
You can’t perform that action at this time.