Could not find a JavaScript runtime #115

Open
kdelchev opened this Issue Jun 6, 2012 · 2 comments

Projects

None yet

3 participants

@kdelchev

Running bundle exec rake fulcrum:setup db:setup gives the error:

rake aborted!
Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes.

(See full trace by running task with --trace)

Adding the following gems resolves the issue.
gem 'execjs'
gem 'therubyracer'

Run bundle install after adding them. Here is link

http://stackoverflow.com/questions/6282307/execjs-and-could-not-find-a-javascript-runtime

@malclocke

Hi Konstantin,

Best solution would be to install nodejs. therubyracer is problematic, and I won't be adding it to the project Gemfile.

I'll leave this open as a note to document that a working nodejs install is required.

@cmdillon

hi,

if you are running an older ubuntu like 10.04 you will have to do the fallowing to install nodejs:

sudo git clone git://github.com/ry/node.git

cd node

sudo ./configure

sudo make install

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment