Permalink
Browse files

glorious funtoo updates

merged:

  funtoo-overlay: d6f40b1586920bf4ec6129f006d991c273b6ea39
  foo-overlay: f7749549a67741868fbb3da8781e42cbac533fa7
  bar-overlay: f1e9085ee695ff5b6ce57d430d6b224aaf4fa0a6
  flora: b22e1805524bc8ed122ae4c2ea41593f9c6cec62
  mythtv: 232ca207c520eb294db060a770aafd30ffa25afb
  • Loading branch information...
1 parent 6233f8b commit 673f3db5fbe75b21c72aa0b720ff8eae1d127b0c @danielrobbins danielrobbins committed Jan 15, 2013
Showing 1,060 changed files with 3,751 additions and 2,519 deletions.
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ssh-multiadd/ssh-multiadd-1.3.2.ebuild,v 1.1 2012/10/10 10:47:38 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ssh-multiadd/ssh-multiadd-1.3.2.ebuild,v 1.2 2013/01/14 19:01:54 ago Exp $
EAPI=4
@@ -14,7 +14,7 @@ SRC_URI="http://code.fluffytapeworm.com/projects/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc ~x86"
IUSE="X"
DEPEND=""
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.87.ebuild,v 1.1 2012/12/03 22:04:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.87.ebuild,v 1.2 2013/01/14 20:54:23 ago Exp $
EAPI=5
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3+ FDL-1.3+"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
IUSE="preview-latex"
DEPEND="virtual/latex-base
@@ -1,2 +1,3 @@
DIST libvirt-glib-0.1.3.tar.gz 699833 SHA256 f90c8f78a6e5274ff79df44c22414e307c9d5c5f782fb9bc31af0d2b1b408be5 SHA512 91439cf8c47ad3d4437bf9817f2edffcdea1022a36a94fa304424cd54fab378cc667e5bd191f4e145a1d44adf5ada400bd8d19387aaa6fe4093e9e6a1eb63fa7 WHIRLPOOL d767c0a49dd84d1fb4f8e02ac12b2da5937478041fae790bc9aca3421b05e7005c616eaed06198b5bc9c3464fdec590fa8f836d977e2c5e685cb99d6271c775c
DIST libvirt-glib-0.1.4.tar.gz 707510 SHA256 92935ff19424a75db85d13f30e28f418a38d81565cf1584945dda145a03886a4 SHA512 8845098bbd24aba1b65efb35808e9ca1e7d6aad85a4e07b8f6c74a64e92e3b4620d0dd243590d09b80cbbd5db2fe230d4a9b64fe002ede59fa9633bbbf299608 WHIRLPOOL d7fb858fb8057d5512aeb98bed043c3c6c87abe8c72f10b557043c9ce894d18462f23f0aa6070434bf23c069a69cdd85d4cb6fd2b4c468cab74eb38d2df389c4
+DIST libvirt-glib-0.1.5.tar.gz 709647 SHA256 b3a4fea273cb52890812a5d4033556c5221112c7fe47da2838de72641e547cbb SHA512 1bbb69348f80a8560e6eaffe396e8087fc01fa7a022b009b95a776b34db69a6ee5438e496d2a57cb2cb7273b702962f76d4fe6abc0a721f22bab74438943735d WHIRLPOOL 75d5d232fddcdf0b8d8db78cf5e4b9f160c5a74d932f29adcf5c6bfb1fa012084fd736bb6a2b60ee7d8d2b05ae9dc93a5fa5f62099162e5c7b211627b57417c9
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/libvirt-glib-0.1.5.ebuild,v 1.1 2013/01/14 20:25:03 cardoe Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.14"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit gnome2 python-single-r1 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection python +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.10:=
+ >=dev-libs/glib-2.10:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+pkg_setup() {
+ G2CONF+="--disable-test-coverage
+ --disable-static
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_with python)"
+ use python && python-single-r1_pkg_setup
+}
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.2.2.ebuild,v 1.7 2013/01/13 02:53:28 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.2.2.ebuild,v 1.10 2013/01/14 23:06:16 cardoe Exp $
EAPI="4"
@@ -54,7 +54,7 @@ done
# Block USE flag configurations known to not work
REQUIRED_USE="${REQUIRED_USE}
- static? ( !alsa !pulseaudio !bluetooth )
+ static? ( !alsa !pulseaudio !bluetooth !opengl )
virtfs? ( xattr )"
# Yep, you need both libcap and libcap-ng since virtfs only uses libcap.
@@ -80,10 +80,18 @@ LIB_DEPEND=">=dev-libs/glib-2.0[static-libs(+)]
xfs? ( sys-fs/xfsprogs[static-libs(+)] )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
!app-emulation/kqemu
- sys-firmware/ipxe
- ~sys-firmware/seabios-1.7.1
- ~sys-firmware/sgabios-0.1_pre8
- ~sys-firmware/vgabios-0.7a
+ qemu_softmmu_targets_i386? (
+ sys-firmware/ipxe
+ ~sys-firmware/seabios-1.7.1
+ ~sys-firmware/sgabios-0.1_pre8
+ ~sys-firmware/vgabios-0.7a
+ )
+ qemu_softmmu_targets_x86_64? (
+ sys-firmware/ipxe
+ ~sys-firmware/seabios-1.7.1
+ ~sys-firmware/sgabios-0.1_pre8
+ ~sys-firmware/vgabios-0.7a
+ )
alsa? ( >=media-libs/alsa-lib-1.0.13 )
bluetooth? ( net-wireless/bluez )
brltty? ( app-accessibility/brltty )
@@ -195,6 +203,7 @@ src_prepare() {
Makefile Makefile.target || die
python_convert_shebangs -r 2 "${S}/scripts/kvm/kvm_stat"
+ python_convert_shebangs -r 2 "${S}/scripts/kvm/vmxcap"
epatch "${FILESDIR}"/qemu-1.2.0-cflags.patch
[[ -n ${BACKPORTS} ]] && \
@@ -324,7 +333,7 @@ src_install() {
ewarn "The deprecated '/usr/bin/kvm' symlink is no longer installed"
ewarn "You should use '/usr/bin/qemu-kvm', you may need to edit"
ewarn "your libvirt configs or other wrappers for ${PN}"
- else
+ elif use x86 || use amd64; then
elog "You disabled QEMU_SOFTMMU_TARGETS=x86_64, this disables install"
elog "of the /usr/bin/qemu-kvm symlink."
fi
@@ -334,6 +343,7 @@ src_install() {
newdoc pc-bios/README README.pc-bios
use python && dobin scripts/kvm/kvm_stat
+ use python && dobin scripts/kvm/vmxcap
# Avoid collision with app-emulation/libcacard
use smartcard && mv "${ED}/usr/bin/vscclient" "${ED}/usr/bin/qemu-vscclient"
@@ -344,36 +354,46 @@ src_install() {
# Remove SeaBIOS since we're using the SeaBIOS packaged one
rm "${ED}/usr/share/qemu/bios.bin"
- dosym ../seabios/bios.bin /usr/share/qemu/bios.bin
+ if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386; then
+ dosym ../seabios/bios.bin /usr/share/qemu/bios.bin
+ fi
# Remove vgabios since we're using the vgabios packaged one
rm "${ED}/usr/share/qemu/vgabios.bin"
rm "${ED}/usr/share/qemu/vgabios-cirrus.bin"
rm "${ED}/usr/share/qemu/vgabios-qxl.bin"
rm "${ED}/usr/share/qemu/vgabios-stdvga.bin"
rm "${ED}/usr/share/qemu/vgabios-vmware.bin"
- dosym ../vgabios/vgabios.bin /usr/share/qemu/vgabios.bin
- dosym ../vgabios/vgabios-cirrus.bin /usr/share/qemu/vgabios-cirrus.bin
- dosym ../vgabios/vgabios-qxl.bin /usr/share/qemu/vgabios-qxl.bin
- dosym ../vgabios/vgabios-stdvga.bin /usr/share/qemu/vgabios-stdvga.bin
- dosym ../vgabios/vgabios-vmware.bin /usr/share/qemu/vgabios-vmware.bin
+ if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386; then
+ dosym ../vgabios/vgabios.bin /usr/share/qemu/vgabios.bin
+ dosym ../vgabios/vgabios-cirrus.bin /usr/share/qemu/vgabios-cirrus.bin
+ dosym ../vgabios/vgabios-qxl.bin /usr/share/qemu/vgabios-qxl.bin
+ dosym ../vgabios/vgabios-stdvga.bin /usr/share/qemu/vgabios-stdvga.bin
+ dosym ../vgabios/vgabios-vmware.bin /usr/share/qemu/vgabios-vmware.bin
+ fi
# Remove sgabios since we're using the sgabios packaged one
rm "${ED}/usr/share/qemu/sgabios.bin"
- dosym ../sgabios/sgabios.bin /usr/share/qemu/sgabios.bin
+ if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386; then
+ dosym ../sgabios/sgabios.bin /usr/share/qemu/sgabios.bin
+ fi
# Remove iPXE since we're using the iPXE packaged one
rm "${ED}"/usr/share/qemu/pxe-*.rom
- dosym ../ipxe/808610de.rom /usr/share/qemu/pxe-e1000.rom
- dosym ../ipxe/80861209.rom /usr/share/qemu/pxe-eepro100.rom
- dosym ../ipxe/10500940.rom /usr/share/qemu/pxe-ne2k_pci.rom
- dosym ../ipxe/10222000.rom /usr/share/qemu/pxe-pcnet.rom
- dosym ../ipxe/10ec8139.rom /usr/share/qemu/pxe-rtl8139.rom
- dosym ../ipxe/1af41000.rom /usr/share/qemu/pxe-virtio.rom
+ if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386; then
+ dosym ../ipxe/808610de.rom /usr/share/qemu/pxe-e1000.rom
+ dosym ../ipxe/80861209.rom /usr/share/qemu/pxe-eepro100.rom
+ dosym ../ipxe/10500940.rom /usr/share/qemu/pxe-ne2k_pci.rom
+ dosym ../ipxe/10222000.rom /usr/share/qemu/pxe-pcnet.rom
+ dosym ../ipxe/10ec8139.rom /usr/share/qemu/pxe-rtl8139.rom
+ dosym ../ipxe/1af41000.rom /usr/share/qemu/pxe-virtio.rom
+ fi
}
pkg_postinst() {
- if [[ -n ${softmmu_targets} ]]; then
+ if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386 \
+ use qemu_softmmu_targets_ppc || use qemu_softmmu_targets_ppc64 \
+ use qemu_softmmu_targets_s390x; then
elog "If you don't have kvm compiled into the kernel, make sure you have"
elog "the kernel module loaded before running kvm. The easiest way to"
elog "ensure that the kernel module is loaded is to load it on boot."
@@ -384,7 +404,8 @@ pkg_postinst() {
elog "Make sure your user is in the 'kvm' group"
elog "Just run 'gpasswd -a <USER> kvm', then have <USER> re-login."
elog
- elog "The ssl USE flag was renamed to tls, so adjust your USE flags."
- elog "The nss USE flag was renamed to smartcard, so adjust your USE flags."
fi
+
+ elog "The ssl USE flag was renamed to tls, so adjust your USE flags."
+ elog "The nss USE flag was renamed to smartcard, so adjust your USE flags."
}
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.3.0.ebuild,v 1.1 2013/01/12 23:38:58 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.3.0.ebuild,v 1.4 2013/01/14 23:06:16 cardoe Exp $
EAPI=5
@@ -51,7 +51,7 @@ done
# Block USE flag configurations known to not work
REQUIRED_USE="${REQUIRED_USE}
- static? ( !alsa !pulseaudio !bluetooth )
+ static? ( !alsa !pulseaudio !bluetooth !opengl )
virtfs? ( xattr )"
# Yep, you need both libcap and libcap-ng since virtfs only uses libcap.
@@ -77,9 +77,16 @@ LIB_DEPEND=">=dev-libs/glib-2.0[static-libs(+)]
xfs? ( sys-fs/xfsprogs[static-libs(+)] )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
!app-emulation/kqemu
- sys-firmware/ipxe
- ~sys-firmware/seabios-1.7.2
- ~sys-firmware/sgabios-0.1_pre8
+ qemu_softmmu_targets_i386? (
+ sys-firmware/ipxe
+ ~sys-firmware/seabios-1.7.2
+ ~sys-firmware/sgabios-0.1_pre8
+ )
+ qemu_softmmu_targets_x86_64? (
+ sys-firmware/ipxe
+ ~sys-firmware/seabios-1.7.2
+ ~sys-firmware/sgabios-0.1_pre8
+ )
alsa? ( >=media-libs/alsa-lib-1.0.13 )
bluetooth? ( net-wireless/bluez )
brltty? ( app-accessibility/brltty )
@@ -189,6 +196,7 @@ src_prepare() {
Makefile Makefile.target || die
python_convert_shebangs -r 2 "${S}/scripts/kvm/kvm_stat"
+ python_convert_shebangs -r 2 "${S}/scripts/kvm/vmxcap"
epatch "${FILESDIR}"/qemu-1.2.0-cflags.patch
[[ -n ${BACKPORTS} ]] && \
@@ -318,7 +326,7 @@ src_install() {
ewarn "The deprecated '/usr/bin/kvm' symlink is no longer installed"
ewarn "You should use '/usr/bin/qemu-kvm', you may need to edit"
ewarn "your libvirt configs or other wrappers for ${PN}"
- else
+ elif use x86 || use amd64; then
elog "You disabled QEMU_SOFTMMU_TARGETS=x86_64, this disables install"
elog "of the /usr/bin/qemu-kvm symlink."
fi
@@ -328,6 +336,7 @@ src_install() {
newdoc pc-bios/README README.pc-bios
use python && dobin scripts/kvm/kvm_stat
+ use python && dobin scripts/kvm/vmxcap
# Avoid collision with app-emulation/libcacard
use smartcard && mv "${ED}/usr/bin/vscclient" "${ED}/usr/bin/qemu-vscclient"
@@ -338,36 +347,46 @@ src_install() {
# Remove SeaBIOS since we're using the SeaBIOS packaged one
rm "${ED}/usr/share/qemu/bios.bin"
- dosym ../seabios/bios.bin /usr/share/qemu/bios.bin
+ if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386; then
+ dosym ../seabios/bios.bin /usr/share/qemu/bios.bin
+ fi
# Remove vgabios since we're using the vgabios packaged one
rm "${ED}/usr/share/qemu/vgabios.bin"
rm "${ED}/usr/share/qemu/vgabios-cirrus.bin"
rm "${ED}/usr/share/qemu/vgabios-qxl.bin"
rm "${ED}/usr/share/qemu/vgabios-stdvga.bin"
rm "${ED}/usr/share/qemu/vgabios-vmware.bin"
- dosym ../vgabios/vgabios.bin /usr/share/qemu/vgabios.bin
- dosym ../vgabios/vgabios-cirrus.bin /usr/share/qemu/vgabios-cirrus.bin
- dosym ../vgabios/vgabios-qxl.bin /usr/share/qemu/vgabios-qxl.bin
- dosym ../vgabios/vgabios-stdvga.bin /usr/share/qemu/vgabios-stdvga.bin
- dosym ../vgabios/vgabios-vmware.bin /usr/share/qemu/vgabios-vmware.bin
+ if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386; then
+ dosym ../vgabios/vgabios.bin /usr/share/qemu/vgabios.bin
+ dosym ../vgabios/vgabios-cirrus.bin /usr/share/qemu/vgabios-cirrus.bin
+ dosym ../vgabios/vgabios-qxl.bin /usr/share/qemu/vgabios-qxl.bin
+ dosym ../vgabios/vgabios-stdvga.bin /usr/share/qemu/vgabios-stdvga.bin
+ dosym ../vgabios/vgabios-vmware.bin /usr/share/qemu/vgabios-vmware.bin
+ fi
# Remove sgabios since we're using the sgabios packaged one
rm "${ED}/usr/share/qemu/sgabios.bin"
- dosym ../sgabios/sgabios.bin /usr/share/qemu/sgabios.bin
+ if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386; then
+ dosym ../sgabios/sgabios.bin /usr/share/qemu/sgabios.bin
+ fi
# Remove iPXE since we're using the iPXE packaged one
rm "${ED}"/usr/share/qemu/pxe-*.rom
- dosym ../ipxe/808610de.rom /usr/share/qemu/pxe-e1000.rom
- dosym ../ipxe/80861209.rom /usr/share/qemu/pxe-eepro100.rom
- dosym ../ipxe/10500940.rom /usr/share/qemu/pxe-ne2k_pci.rom
- dosym ../ipxe/10222000.rom /usr/share/qemu/pxe-pcnet.rom
- dosym ../ipxe/10ec8139.rom /usr/share/qemu/pxe-rtl8139.rom
- dosym ../ipxe/1af41000.rom /usr/share/qemu/pxe-virtio.rom
+ if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386; then
+ dosym ../ipxe/808610de.rom /usr/share/qemu/pxe-e1000.rom
+ dosym ../ipxe/80861209.rom /usr/share/qemu/pxe-eepro100.rom
+ dosym ../ipxe/10500940.rom /usr/share/qemu/pxe-ne2k_pci.rom
+ dosym ../ipxe/10222000.rom /usr/share/qemu/pxe-pcnet.rom
+ dosym ../ipxe/10ec8139.rom /usr/share/qemu/pxe-rtl8139.rom
+ dosym ../ipxe/1af41000.rom /usr/share/qemu/pxe-virtio.rom
+ fi
}
pkg_postinst() {
- if [[ -n ${softmmu_targets} ]]; then
+ if use qemu_softmmu_targets_x86_64 || use qemu_softmmu_targets_i386 \
+ use qemu_softmmu_targets_ppc || use qemu_softmmu_targets_ppc64 \
+ use qemu_softmmu_targets_s390x; then
elog "If you don't have kvm compiled into the kernel, make sure you have"
elog "the kernel module loaded before running kvm. The easiest way to"
elog "ensure that the kernel module is loaded is to load it on boot."
@@ -378,7 +397,8 @@ pkg_postinst() {
elog "Make sure your user is in the 'kvm' group"
elog "Just run 'gpasswd -a <USER> kvm', then have <USER> re-login."
elog
- elog "The ssl USE flag was renamed to tls, so adjust your USE flags."
- elog "The nss USE flag was renamed to smartcard, so adjust your USE flags."
fi
+
+ elog "The ssl USE flag was renamed to tls, so adjust your USE flags."
+ elog "The nss USE flag was renamed to smartcard, so adjust your USE flags."
}
Oops, something went wrong.

0 comments on commit 673f3db

Please sign in to comment.