Permalink
Browse files

FL-590: unfork libreoffice, fixed by gentoo

  • Loading branch information...
1 parent f812b19 commit 8ae2424e38fc041252bbb346c4db5520f897b08f @angryvincent angryvincent committed Jun 22, 2013
View
15 app-office/libreoffice/Manifest
@@ -1,15 +0,0 @@
-DIST 17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip 3519470 SHA256 d30b13f4ba2e3b6a2d4f020c0dee0a9fb9fc6fbcc2d561f36b78da4bf3802370 SHA512 a231eba4a1baca11766ef292ab45e302081115477fe23018652882923308856835cf8c9ecba61a5cf22543474ccef3136965d794a90c9e4e9e6dcc21f9af6e1a WHIRLPOOL c4b3b0c3e10171155e1d3431e8ab9b495dbf2fb924882024306bfb53f533f5b0231c06f47e3cfa77052013a816ea4cc5f237cc76fdb44a048fb6d5c177729aec
-DIST 185d60944ea767075d27247c3162b3bc-unowinreg.dll 12288 SHA256 eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6 SHA512 854b8ae29b57b40ba6bb6ff66e723a0e8dad053fcc2849f0ad763cd8a31352f4aeba9636fd4e3f0f2a0cd985a6f49b4261b9ace68d6be821ed42cfa7a73eb13c WHIRLPOOL 16eb79e3674250fcb760b9698b4980414052d20f720d946701d1915c9b8915b4af75378668653d29581b77c19fcdba8f51d1f834c286cfcefcf4a420f8fcc1d5
-DIST 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz 1652670 SHA256 390a5085651828b8fe12aa978b200f59b9155eedbb91a4be89bf7cf39eefdd4a SHA512 5664203e6426880041cdb227e91f79f00d2ca7ae28c6997f61b72cc599aac55838d082d2b2b551bd7a228424c350ddea5d41599b8ca58d444a2cd46c9206ea91 WHIRLPOOL 6486c48b73a4f79760b443cfd397b704eca0fd32b72304ae7e7cfa0f43583b0af15c7384548b5215ae57513ed8366c8f3a74630ab466ba19a63b346af8c5eaca
-DIST 35c94d2df8893241173de1d16b6034c0-swingExSrc.zip 9796 SHA256 64585ac36a81291a58269ec5347e7e3e2e8596dbacb9221015c208191333c6e1 SHA512 4a48f1e32907fb2dee601cda3cd7a0d7198b2d51f2a572b647f1e93f901fd511eef3567676e52dfb1723a2cdfbc01f2015ca0bb22903b0bc1476dd618cc9aa8a WHIRLPOOL a5156d06323699d2cbf539f14f5f44f54ebf33e86c7f14e98acd4c6e29c3e496f91dd6792401148ffa32e3dcb1cd4f087ed804e306b241cef86de0aa347d25d4
-DIST 798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip 1521926 SHA256 1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753 SHA512 ec5ae23c8fe2f5efc377f7a9665039afadf28b4d8f2791379296766a5fbc9a3bf7548f9b0e3b3b07762229ec733a92ccbb69791ee0318c9c6f78f8e847253d3f WHIRLPOOL 8e446eb44188046b0e90694feba232f42c2e9f13d0f43783a18de37c94b86ff919b994931125c5d8001ecd320c1f4db5da482847304aa61646600a3bb33144b4
-DIST a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip 23150 SHA256 75823776fb51a9c526af904f1503a7afaaab900fba83eda64f8a41073724c870 SHA512 2d3835f7ac356805025cafedcad97faa48d0f5da386e6ac7b7451030059df8e2fdb0861ade07a576ebf9fb5b88a973585ab0437944b06aac9289d6898ba8586a WHIRLPOOL 60b98d9af2c83c0cf12a5a60ba30957d335b8b967cac07971e1edbc787b9caecd4b3c5bb480e8b38fe8109c1cf74439ebafae130c976182c2c15399f38f5d28c
-DIST ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.7-bj.zip 2732347 SHA256 64f8d737c32756713d60c22efe3978a59fa167cdeaa2d3d0a1646b1f2232b825 SHA512 bba2fe76d09e3ab99b170685525ceb4ce8ce8d95ffa0df97c05ce18cd7edbe73028861e19c501bf00db369d36f43fe274d4220ad046518d89737249f61c7cf3a WHIRLPOOL 2dd0924defb85dc6a266126fdaabc29f051ccf525d1e1e7a5f74db19f162ee2d17f98ae96fd832dbd1600c006e277b75a4d88d9b3128c7ec9e2365a6704d32e9
-DIST ea91f2fb4212a21d708aced277e6e85a-vigra1.4.0.tar.gz 12735186 SHA256 dc6445d2c0445e5536010b80bd811adda6741ed82b288fe831d5be9902457941 SHA512 a8c39d205051a8f8abaecb7a6fdc0c2c37baf5eee2a082af8819555f442dab525649b86cae569048357eb1e6e651deff4b62183de417e15b403e1ac09c40ba7b WHIRLPOOL fd9b6bbd214113334d3d5e542bbc9b70d5a9505281454e7f4447c6c73af733e10b007a2d4225acb39db0fc17401c2ae36b6628c59d31f09bec485f4cfc009eb5
-DIST libreoffice-4.0.3.3.tar.xz 104219900 SHA256 b490517aba0c7b52c4b537910bb63af01304512342c3d5e553a14eba5f5641a1 SHA512 417dae117c0e719dbaf3050fae7dcb88c9c7e0f1a932f0e497a2f8a8e9add34057e1773e587158cc887d54529081924fa90355ff8127f94ff47dd985d997d30c WHIRLPOOL 651be25621631d0167402fd24e60b9a84fe2c56c0a8f9b66e1b6a362b60e508383db20559a3666252ac95c71ea0ce1e0e6c395e103705b5f6288b1e545a8b8ac
-DIST libreoffice-binfilter-3.6.6.2.tar.xz 5969848 SHA256 b88c297f5cf5459049c0f00074ddf3fdb4946ba4c6880ac786d6236bb1636e67 SHA512 577c7e403046d185fceb092287f3ad99856010b9f18b43490f4d05c48815eef314d7554f24e0c064695fc05bff922a5d0924a10e7ffbe483338a54ddd73539a4 WHIRLPOOL 933574d32df1104a91e8489572b5a41204fde97c55896c4177c99e3b261169d830eab096258f23954854eb9b8900575aac9ef5df76bffcfee90387bf38f7ed97
-DIST libreoffice-branding-gentoo-0.6.tar.xz 49756 SHA256 d5c2d12031a807d18e981a6df7e945e1787b96c7ee65fa3d9bb9eac17cf8ade9 SHA512 1126d92b6b8722fc8b7865ed42c98876922ce26c71ebff61faf03e07b338d5278ff41ba29ff296d281cbdee6a9a0965ccf8e2101fc0f4846eaddcf511ac74eed WHIRLPOOL 40f18619246ca0b6f91ff248d65e4a36639c6faee719a842fb57c6bd8fc871686156e1c991776877d5df0811088ca8f3f4390b60f10565deefa2739c99242c91
-DIST libreoffice-branding-gentoo-0.7.tar.xz 72556 SHA256 57912157fe8874f9d628dd971cb68941ad605f2d8beba05327e7ce7a721080be SHA512 fdfd8190c1155e95a8874f07d6893d94e28dd7482b195e22f704f4b1621ef76ee99e5ae1fcdb41c392d2e37e05da32830c42d47b4e62e14a9526d67ffd2d279f WHIRLPOOL 6c1886dfc31b918180b78797a41c0dff042ef4ddab50f284d9f9ee7aca7733dc73795dcad35262cf6c5608a5f99cf8d85a3a0d23316e15bb6650bdc437a4226b
-DIST libreoffice-core-3.6.6.2.tar.xz 107650196 SHA256 f6a20418a36678550241f66b2a005b25d5ad6ed95787edc61cf3b17194368377 SHA512 5fad2db063e8a2297f9935bf71d66abaa57d3f20dc31b09c486c9c9e7a39453c553232f7beaa497fda373bc78adc1033b0a266e483d090b118dee464562ceba1 WHIRLPOOL b0e8d545ba63e08ac6f47e54d6770378e14135db0991a9e6ab6269a7876d646b4983ab096b075b6ed87dffa3d65560dc0289b2869908e228c116e6dd065f24ff
-DIST libreoffice-help-3.6.6.2.tar.xz 1860668 SHA256 b3ebb29bb6077ccdeb65e5ae883ac349c7e81c263277f5030f242e6d782d2b8b SHA512 425e7ca64e60316a8ee5b05672bc5079400c0c0ccfe0f12079bb4b9867e88191233cc7d5770dad6a92daf50dcbf43aeecdf32dd76994b1393a486d4a5f876272 WHIRLPOOL 6e4583ee7e6d7a68a189853e74c87b60f35e4edb5addd804891082998da23eefa8b28c71975cc10c11f2373a69e95340d2d01e1f4f40ee38dfb97eab3b4282e2
-DIST libreoffice-help-4.0.3.3.tar.xz 1855496 SHA256 7a31dc0cdc69137b3be4c439f961df0d0d12b048f8ae6553f967082d2b16b6ac SHA512 02e0196880750927f0e1b9359ca63abc5b68e5345e2992c33f84c6240338ddf81f26d7e60368f3a06090cc42b3efe1051ce255c0c20abcd2011e5febba558985 WHIRLPOOL 7355d5288a3975d45fb358d4c07cdcb0ddc3f1a709f020b578c064271b6fbc0e92b0410ca0bc270c2d1405abcf12413556136ec08ffe36a218a4dc2ab8b5a61b
View
151 app-office/libreoffice/files/generate_libreoffice_package.sh
@@ -1,151 +0,0 @@
-#!/bin/bash
-
-# important: you need to use the most general CFLAGS to build the packages:
-# * for x86 : CFLAGS="-march=i586 -mtune=generic -O2 -pipe -g"
-# * for amd64: CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -g"
-
-# What you can set:
-VERSION="3.6.6.2"
-BINVERSION="3.6.6.2"
-OPTS="-v"
-USEFILE="/etc/portage/package.use/libreo"
-MYPKGDIR="$( portageq pkgdir )"
-################################################
-
-die() {
- echo "${1}"
- exit 1
-}
-
-if [ "$( uname -m )" = "x86_64" ] ; then
- MYFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -g"
- ARCH="amd64"
-elif [ "$( uname -m )" = "i686" ] ; then
- MYFLAGS="-march=i586 -mtune=generic -O2 -pipe -g"
- ARCH="x86"
-else
- die "Arch $( uname -m ) not supported"
-fi
-
-for i in \
- "/bin/echo" \
- "/bin/mkdir" \
- "/bin/mv" \
- "/bin/rm" \
- "/bin/sed" \
- "/bin/tar" \
- "/usr/bin/emerge" \
- "/usr/bin/portageq" \
- "/usr/bin/quickpkg"
-do
- if [ ! -e "${i}" ] ; then
- die "Missing some basic utility in your system"
- fi
-done
-
-# first the default subset of useflags
-IUSES_BASE="bash-completion branding cups dbus gstreamer gtk opengl vba webdav -aqua -binfilter -jemalloc -mysql -odk -postgres"
-
-ENABLE_EXTENSIONS="presenter-console presenter-minimizer"
-DISABLE_EXTENSIONS="nlpsolver pdfimport scripting-beanshell scripting-javascript wiki-publisher"
-
-for lo_xt in ${ENABLE_EXTENSIONS}; do
- IUSES_BASE+=" libreoffice_extensions_${lo_xt}"
-done
-for lo_xt in ${DISABLE_EXTENSIONS}; do
- IUSES_BASE+=" -libreoffice_extensions_${lo_xt}"
-done
-unset lo_xt
-
-# now for the options
-IUSES_J="java libreoffice_extensions_nlpsolver"
-IUSES_NJ="-java"
-IUSES_G="gnome eds"
-IUSES_NG="-gnome -eds"
-IUSES_K="kde"
-IUSES_NK="-kde"
-
-if [ -f /etc/portage/package.use ] ; then
- die "Please save your package.use and re-create it as a directory"
-fi
-
-mkdir -p /etc/portage/package.use/ || die
-
-mkdir -p "${MYPKGDIR}"
-if [ -z "${MYPKGDIR}" -o ! -d "${MYPKGDIR}" ] ; then
- die "Anything goes wrong"
-fi
-
-# compile the flavor
-echo "Base"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_NJ} ${IUSES_NG} ${IUSES_NK}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ./libreoffice-base-${BINVERSION}.tbz2 || die "Moving package failed"
-
-echo "Base - java"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_J} ${IUSES_NG} ${IUSES_NK}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ./libreoffice-base-java-${BINVERSION}.tbz2 || die "Moving package failed"
-
-# kde flavor
-echo "KDE"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_NJ} ${IUSES_NG} ${IUSES_K}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ./libreoffice-kde-${BINVERSION}.tbz2 || die "Moving package failed"
-
-echo "KDE - java"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_J} ${IUSES_NG} ${IUSES_K}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ./libreoffice-kde-java-${BINVERSION}.tbz2 || die "Moving package failed"
-
-# gnome flavor
-echo "Gnome"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_NJ} ${IUSES_G} ${IUSES_NK}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ./libreoffice-gnome-${BINVERSION}.tbz2 || die "Moving package failed"
-
-echo "Gnome -java"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_J} ${IUSES_G} ${IUSES_NK}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ./libreoffice-gnome-java-${BINVERSION}.tbz2 || die "Moving package failed"
-
-
-for name in ./libreoffice-*-${BINVERSION}.tbz2 ; do
-
- BN=`basename $name .tbz2`
-
- rm -rf tmp.lo
- mkdir -vp tmp.lo/p1 tmp.lo/p2
- cd tmp.lo/p1
-
- echo "Unpacking complete archive $BN.tbz2"
- tar xfvjp ../../$BN.tbz2
-
- echo "Moving debug info"
- mkdir -vp ../p2/usr/lib
- mv -v usr/lib/debug ../p2/usr/lib/
-
- echo "Re-packing program"
- tar cfvJ ../../$ARCH-bin-$BN.tar.xz --owner root --group root ./*
-
- echo "Re-packing debug info"
- cd ../p2
- tar cfvJ ../../$ARCH-debug-$BN.tar.xz --owner root --group root ./*
-
- echo "Removing unpacked files"
- cd ../..
- rm -rf tmp.lo
-
- echo "Done with $BN.tbz2"
-
-done
-
-rm -f ${USEFILE} || die "Removing ${USEFILE} failed"
-
-rm -f libreoffice*${VERSION}*.tbz2 || die "Removing un-split package files failed"
View
74 app-office/libreoffice/files/libreoffice-3.6-separate-checks.patch
@@ -1,74 +0,0 @@
-From 4fb35cfbf4b10d5644fd636ddfe3e07b5a932d45 Mon Sep 17 00:00:00 2001
-From: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
-Date: Sun, 24 Jun 2012 14:01:54 +0200
-Subject: [PATCH] dont run check targets in build, to allow running them
- separately later
-
-Change-Id: Idb46ebcb427522c74632a1813afcbb841fb61243
----
- Makefile.top | 10 ++++++++--
- solenv/bin/build.pl | 2 +-
- solenv/gbuild/Module.mk | 2 +-
- 3 files changed, 10 insertions(+), 4 deletions(-)
-
-diff --git a/Makefile.top b/Makefile.top
-index 7362bbc..ae849fb 100644
---- a/Makefile.top
-+++ b/Makefile.top
-@@ -243,7 +243,7 @@ xsltml\
- zlib\
-
- gb_TAILBUILDMODULES := $(shell $(GNUMAKE) -r -f $(SRCDIR)/tail_build/Makefile showmodules)
--export gb_TAILBUILDTARGET=all slowcheck
-+export gb_TAILBUILDTARGET=all
-
- define gbuild_module_rules
- .PHONY: $(1) $(1).all $(1).clean $(1).deliver
-@@ -480,11 +480,17 @@ findunusedcode:
- | grep -v WPX \
- > unusedcode.easy
-
--check: dev-install subsequentcheck
-+check: unitcheck slowcheck dev-install subsequentcheck
-
- subsequentcheck :| $(if $(filter-out subsequentcheck,$(MAKECMDGOALS)),dev-install)
- $(GNUMAKE) -j $(GMAKE_PARALLELISM) $(GMAKE_OPTIONS) -f Makefile.post $@
-
-+unitcheck:
-+ $(GNUMAKE) -j $(GMAKE_PARALLELISM) $(GMAKE_OPTIONS) -f Makefile.post $@
-+
-+slowcheck:
-+ $(GNUMAKE) -j $(GMAKE_PARALLELISM) $(GMAKE_OPTIONS) -f Makefile.post $@
-+
- debugrun:
- $(GNUMAKE) -j $(GMAKE_PARALLELISM) $(GMAKE_OPTIONS) -f Makefile.post $@
-
-diff --git a/solenv/bin/build.pl b/solenv/bin/build.pl
-index 74d0f32..daa4ae0 100755
---- a/solenv/bin/build.pl
-+++ b/solenv/bin/build.pl
-@@ -1901,7 +1901,7 @@ sub run_job {
- return 1 if (! $path =~ /prj$/ );
- mkpath("$workdir/Logs");
- my $gbuild_flags = '-j' . $ENV{GMAKE_MODULE_PARALLELISM};
-- my $gbuild_target = 'all slowcheck';
-+ my $gbuild_target = 'all';
- if ($registered_name =~ /tail_build\/prj$/ )
- {
- $gbuild_flags = '-j' . $ENV{GMAKE_PARALLELISM};
-diff --git a/solenv/gbuild/Module.mk b/solenv/gbuild/Module.mk
-index e5f87f0..9c2608c 100644
---- a/solenv/gbuild/Module.mk
-+++ b/solenv/gbuild/Module.mk
-@@ -129,7 +129,7 @@ gb_Module_DEVINSTALLHINT=
- debugrun :| build
- endif
-
--all : build unitcheck
-+all : build
- $(info $(gb_Module_BUILDHINT))
-
- build :
---
-1.7.9.5
-
View
44 app-office/libreoffice/files/libreoffice-3.6-system-pyuno.patch
@@ -1,44 +0,0 @@
-diff --git a/desktop/scripts/soffice.sh.in b/desktop/scripts/soffice.sh.in
-index defd7b2..ea2a809 100755
---- a/desktop/scripts/soffice.sh
-+++ b/desktop/scripts/soffice.sh
-@@ -128,6 +128,9 @@ if echo "$checks" | grep -q "cc" ; then
- exit 1;
- fi
-
-+PYTHONPATH=$sd_prog${PYTHONPATH+:$PYTHONPATH}
-+export PYTHONPATH
-+
- case "`uname -s`" in
- NetBSD|OpenBSD|FreeBSD|DragonFly)
- # this is a temporary hack until we can live with the default search paths
-diff --git a/pyuno/source/module/uno.py b/pyuno/source/module/uno.py
-index f93ac5e..92a2891 100644
---- a/pyuno/source/module/uno.py
-+++ b/pyuno/source/module/uno.py
-@@ -26,8 +26,12 @@
- # for a copy of the LGPLv3 License.
- #
- #*************************************************************************
-+import os
- import sys
-
-+sys.path.append('%eprefix%/usr/%libdir%/libreoffice/program')
-+if getattr(os.environ, 'URE_BOOTSTRAP', None) is None:
-+ os.environ['URE_BOOTSTRAP'] = "vnd.sun.star.pathname:%eprefix%/usr/%libdir%/libreoffice/program/fundamentalrc"
- import pyuno
-
- try:
-diff --git a/scripting/source/pyprov/officehelper.py b/scripting/source/pyprov/officehelper.py
-index 610ac5f..df243d0 100755
---- a/scripting/source/pyprov/officehelper.py
-+++ b/scripting/source/pyprov/officehelper.py
-@@ -53,7 +53,7 @@ def bootstrap():
- if "UNO_PATH" in os.environ:
- sOffice = os.environ["UNO_PATH"]
- else:
-- sOffice = "" # lets hope for the best
-+ sOffice = "%eprefix%/usr/%libdir%/libreoffice/program"
- sOffice = os.path.join(sOffice, "soffice")
- if platform.startswith("win"):
- sOffice += ".exe"
View
48 app-office/libreoffice/files/libreoffice-3.7-separate-checks.patch
@@ -1,48 +0,0 @@
-diff --git a/Makefile.top b/Makefile.top
-index 9e67a71..64a7b6c 100644
---- a/Makefile.top
-+++ b/Makefile.top
-@@ -244,7 +244,7 @@ stlport\
- sysui\
- xpdf\
-
--export gb_TAILBUILDTARGET=all slowcheck
-+export gb_TAILBUILDTARGET=all
-
- define gbuild_module_rules
- .PHONY: $(1) $(1).all $(1).build $(1).check $(1).clean $(1).subsequentcheck $(1).deliver
-@@ -546,7 +546,7 @@ findunusedcode:
- | grep -v ^WSObject \
- > unusedcode.easy
-
--check: dev-install subsequentcheck
-+check: unitcheck slowcheck dev-install subsequentcheck
-
- subsequentcheck :| $(if $(filter-out subsequentcheck,$(MAKECMDGOALS)),dev-install)
- $(GNUMAKE) -j $(CHECK_PARALLELISM) $(GMAKE_OPTIONS) -f Makefile.post $@
-diff --git a/solenv/bin/build.pl b/solenv/bin/build.pl
-index c8e62ee..11a9069 100755
---- a/solenv/bin/build.pl
-+++ b/solenv/bin/build.pl
-@@ -1902,7 +1902,7 @@ sub run_job {
- return 1 if (! $path =~ /prj$/ );
- mkpath("$workdir/Logs");
- my $gbuild_flags = '-j' . $ENV{PARALLELISM};
-- my $gbuild_target = 'all slowcheck';
-+ my $gbuild_target = 'all';
- if ($registered_name =~ /tail_build\/prj$/ )
- {
- $gbuild_target = $ENV{gb_TAILBUILDTARGET};
-diff --git a/solenv/gbuild/Module.mk b/solenv/gbuild/Module.mk
-index 97f1a81..c7ae7f4 100644
---- a/solenv/gbuild/Module.mk
-+++ b/solenv/gbuild/Module.mk
-@@ -139,7 +139,7 @@ gb_Module_DEVINSTALLHINT=
- debugrun :| build
- endif
-
--all : build unitcheck
-+all : build
- $(info $(gb_Module_BUILDHINT))
-
- build :
View
44 app-office/libreoffice/files/libreoffice-3.7-system-pyuno.patch
@@ -1,44 +0,0 @@
-diff --git a/desktop/scripts/soffice.sh b/desktop/scripts/soffice.sh
-index a259bf6..672fa23 100755
---- a/desktop/scripts/soffice.sh
-+++ b/desktop/scripts/soffice.sh
-@@ -129,6 +129,9 @@ if echo "$checks" | grep -q "cc" ; then
- exit 1;
- fi
-
-+PYTHONPATH=$sd_prog${PYTHONPATH+:$PYTHONPATH}
-+export PYTHONPATH
-+
- case "`uname -s`" in
- NetBSD|OpenBSD|FreeBSD|DragonFly)
- # this is a temporary hack until we can live with the default search paths
-diff --git a/pyuno/source/module/uno.py b/pyuno/source/module/uno.py
-index 4ff2606..6a05eed 100644
---- a/pyuno/source/module/uno.py
-+++ b/pyuno/source/module/uno.py
-@@ -16,8 +16,12 @@
- # except in compliance with the License. You may obtain a copy of
- # the License at http://www.apache.org/licenses/LICENSE-2.0 .
- #
-+import os
- import sys
-
-+sys.path.append('%eprefix%/usr/%libdir%/libreoffice/program')
-+if getattr(os.environ, 'URE_BOOTSTRAP', None) is None:
-+ os.environ['URE_BOOTSTRAP'] = "vnd.sun.star.pathname:%eprefix%/usr/%libdir%/libreoffice/program/fundamentalrc"
- import pyuno
-
- try:
-diff --git a/scripting/source/pyprov/officehelper.py b/scripting/source/pyprov/officehelper.py
-index 99d3b03..704edab 100755
---- a/scripting/source/pyprov/officehelper.py
-+++ b/scripting/source/pyprov/officehelper.py
-@@ -44,7 +44,7 @@ def bootstrap():
- if "UNO_PATH" in os.environ:
- sOffice = os.environ["UNO_PATH"]
- else:
-- sOffice = "" # lets hope for the best
-+ sOffice = "%eprefix%/usr/%libdir%/libreoffice/program"
- sOffice = os.path.join(sOffice, "soffice")
- if platform.startswith("win"):
- sOffice += ".exe"
View
146 app-office/libreoffice/files/libreoffice-4.0.0.3-boost-1.53.0.patch
@@ -1,146 +0,0 @@
---- libreoffice-4.0.0.3-orig/comphelper/inc/comphelper/scoped_disposing_ptr.hxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/comphelper/inc/comphelper/scoped_disposing_ptr.hxx 2013-02-16 00:09:02.325443592 +1100
-@@ -78,7 +78,7 @@
-
- operator bool () const
- {
-- return m_aItem;
-+ return static_cast< bool >(m_aItem);
- }
-
- virtual ~scoped_disposing_ptr()
---- libreoffice-4.0.0.3-orig/slideshow/source/engine/animatedsprite.cxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/slideshow/source/engine/animatedsprite.cxx 2013-02-16 00:09:02.356444129 +1100
-@@ -151,7 +151,7 @@
- }
- }
-
-- return mpSprite;
-+ return static_cast< bool >(mpSprite);
- }
-
- void AnimatedSprite::setPixelOffset( const ::basegfx::B2DSize& rPixelOffset )
---- libreoffice-4.0.0.3-orig/slideshow/source/inc/shapeattributelayer.hxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/slideshow/source/inc/shapeattributelayer.hxx 2013-02-16 00:09:02.372444407 +1100
-@@ -467,7 +467,7 @@
- // ShapeAttributeLayer(const ShapeAttributeLayer&);
- // ShapeAttributeLayer& operator=( const ShapeAttributeLayer& );
-
-- bool haveChild() const { return mpChild; }
-+ bool haveChild() const { return static_cast< bool >(mpChild); }
- void updateStateIds();
-
- template< typename T > T calcValue( const T& rCurrValue,
---- libreoffice-4.0.0.3-orig/slideshow/source/inc/shapeattributelayerholder.hxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/slideshow/source/inc/shapeattributelayerholder.hxx 2013-02-16 00:09:02.374444442 +1100
-@@ -83,7 +83,7 @@
- if( mpShape )
- mpAttributeLayer = mpShape->createAttributeLayer();
-
-- return mpAttributeLayer;
-+ return static_cast< bool >(mpAttributeLayer);
- }
-
- ShapeAttributeLayerSharedPtr get() const
---- libreoffice-4.0.0.3-orig/slideshow/source/engine/shapesubset.cxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/slideshow/source/engine/shapesubset.cxx 2013-02-16 00:09:02.366444303 +1100
-@@ -104,7 +104,7 @@
- maTreeNode );
- }
-
-- return mpSubsetShape;
-+ return static_cast< bool >(mpSubsetShape);
- }
-
- void ShapeSubset::disableSubsetShape()
---- libreoffice-4.0.0.3-orig/slideshow/source/engine/shapes/viewshape.cxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/slideshow/source/engine/shapes/viewshape.cxx 2013-02-16 00:09:02.363444251 +1100
-@@ -178,7 +178,7 @@
- }
- }
-
-- return io_rCacheEntry.mpRenderer;
-+ return static_cast< bool >(io_rCacheEntry.mpRenderer);
- }
-
- bool ViewShape::draw( const ::cppcanvas::CanvasSharedPtr& rDestinationCanvas,
---- libreoffice-4.0.0.3-orig/slideshow/source/engine/slide/slideanimations.cxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/slideshow/source/engine/slide/slideanimations.cxx 2013-02-16 00:09:02.369444355 +1100
-@@ -74,7 +74,7 @@
-
- SHOW_NODE_TREE( mpRootNode );
-
-- return mpRootNode;
-+ return static_cast< bool >(mpRootNode);
- }
-
- bool SlideAnimations::isAnimated() const
---- libreoffice-4.0.0.3-orig/sw/source/core/inc/bookmrk.hxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/sw/source/core/inc/bookmrk.hxx 2013-02-16 00:09:02.377444493 +1100
-@@ -75,7 +75,7 @@
-
- virtual bool IsCoveringPosition(const SwPosition& rPos) const;
- virtual bool IsExpanded() const
-- { return m_pPos2; }
-+ { return static_cast< bool >(m_pPos2); }
-
- virtual void SetName(const ::rtl::OUString& rName)
- { m_aName = rName; }
---- libreoffice-4.0.0.3-orig/sc/source/filter/excel/xechart.cxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/sc/source/filter/excel/xechart.cxx 2013-02-16 00:09:02.336443783 +1100
-@@ -682,7 +682,7 @@
-
- bool XclExpChEscherFormat::IsValid() const
- {
-- return maData.mxEscherSet;
-+ return static_cast< bool >(maData.mxEscherSet);
- }
-
- void XclExpChEscherFormat::Save( XclExpStream& rStrm )
---- libreoffice-4.0.0.3-orig/sc/source/filter/excel/xehelper.cxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/sc/source/filter/excel/xehelper.cxx 2013-02-16 00:09:02.341443869 +1100
-@@ -303,7 +303,7 @@
- if( GetBiff() == EXC_BIFF8 ) // no HLINK records in BIFF2-BIFF7
- {
- // there was/is already a HLINK record
-- mbMultipleUrls = mxLinkRec;
-+ mbMultipleUrls = static_cast< bool >(mxLinkRec);
-
- mxLinkRec.reset( new XclExpHyperlink( GetRoot(), rUrlField, maScPos ) );
-
---- libreoffice-4.0.0.3-orig/sc/source/filter/excel/xichart.cxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/sc/source/filter/excel/xichart.cxx 2013-02-16 00:09:02.348443991 +1100
-@@ -2688,7 +2688,7 @@
- maType.Finalize( bStockChart );
-
- // extended type info
-- maTypeInfo.Set( maType.GetTypeInfo(), mxChart3d, false );
-+ maTypeInfo.Set( maType.GetTypeInfo(), static_cast< bool >(mxChart3d), false );
-
- // reverse series order for some unstacked 2D chart types
- if( maTypeInfo.mbReverseSeries && !Is3dChart() && !maType.IsStacked() && !maType.IsPercent() )
---- libreoffice-4.0.0.3-orig/sc/source/filter/inc/xichart.hxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/sc/source/filter/inc/xichart.hxx 2013-02-16 00:09:02.353444077 +1100
-@@ -1230,9 +1230,9 @@
- /** Returns true, if the axis contains caption labels. */
- inline bool HasLabels() const { return !mxTick || mxTick->HasLabels(); }
- /** Returns true, if the axis shows its major grid lines. */
-- inline bool HasMajorGrid() const { return mxMajorGrid; }
-+ inline bool HasMajorGrid() const { return static_cast< bool >(mxMajorGrid); }
- /** Returns true, if the axis shows its minor grid lines. */
-- inline bool HasMinorGrid() const { return mxMinorGrid; }
-+ inline bool HasMinorGrid() const { return static_cast< bool >(mxMinorGrid); }
-
- /** Creates an API axis object. */
- XAxisRef CreateAxis( const XclImpChTypeGroup& rTypeGroup, const XclImpChAxis* pCrossingAxis ) const;
---- libreoffice-4.0.0.3-orig/vcl/source/gdi/svgdata.cxx 2013-01-31 21:54:53.000000000 +1100
-+++ libreoffice-4.0.0.3/vcl/source/gdi/svgdata.cxx 2013-02-16 00:07:00.382345866 +1100
-@@ -166,7 +166,7 @@
-
- //////////////////////////////////////////////////////////////////////////////
- SvgData::SvgData(const OUString& rPath):
-- maSvgDataArray(NULL),
-+ maSvgDataArray(static_cast< unsigned char * >(NULL)),
- mnSvgDataArrayLength(0),
- maPath(rPath),
- maRange(),
View
157 app-office/libreoffice/files/libreoffice-4.0.1.2-boost-1.53.0.patch
@@ -1,157 +0,0 @@
---- libreoffice-4.0.1.2-orig/sw/source/core/inc/bookmrk.hxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/sw/source/core/inc/bookmrk.hxx 2013-03-17 12:37:03.452642148 +1100
-@@ -75,7 +75,7 @@
-
- virtual bool IsCoveringPosition(const SwPosition& rPos) const;
- virtual bool IsExpanded() const
-- { return m_pPos2; }
-+ { return static_cast< bool >(m_pPos2); }
-
- virtual void SetName(const ::rtl::OUString& rName)
- { m_aName = rName; }
---- libreoffice-4.0.1.2-orig/sc/source/filter/inc/xichart.hxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/sc/source/filter/inc/xichart.hxx 2013-03-17 13:57:07.129596337 +1100
-@@ -1230,9 +1230,9 @@
- /** Returns true, if the axis contains caption labels. */
- inline bool HasLabels() const { return !mxTick || mxTick->HasLabels(); }
- /** Returns true, if the axis shows its major grid lines. */
-- inline bool HasMajorGrid() const { return mxMajorGrid; }
-+ inline bool HasMajorGrid() const { return static_cast< bool >(mxMajorGrid); }
- /** Returns true, if the axis shows its minor grid lines. */
-- inline bool HasMinorGrid() const { return mxMinorGrid; }
-+ inline bool HasMinorGrid() const { return static_cast< bool >(mxMinorGrid); }
-
- /** Creates an API axis object. */
- XAxisRef CreateAxis( const XclImpChTypeGroup& rTypeGroup, const XclImpChAxis* pCrossingAxis ) const;
---- libreoffice-4.0.1.2-orig/sc/source/filter/excel/xichart.cxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/sc/source/filter/excel/xichart.cxx 2013-03-17 13:57:07.897596329 +1100
-@@ -2688,7 +2688,7 @@
- maType.Finalize( bStockChart );
-
- // extended type info
-- maTypeInfo.Set( maType.GetTypeInfo(), mxChart3d, false );
-+ maTypeInfo.Set( maType.GetTypeInfo(), static_cast< bool >(mxChart3d), false );
-
- // reverse series order for some unstacked 2D chart types
- if( maTypeInfo.mbReverseSeries && !Is3dChart() && !maType.IsStacked() && !maType.IsPercent() )
---- libreoffice-4.0.1.2-orig/sc/source/filter/excel/xehelper.cxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/sc/source/filter/excel/xehelper.cxx 2013-03-17 13:08:11.384624334 +1100
-@@ -303,7 +303,7 @@
- if( GetBiff() == EXC_BIFF8 ) // no HLINK records in BIFF2-BIFF7
- {
- // there was/is already a HLINK record
-- mbMultipleUrls = mxLinkRec;
-+ mbMultipleUrls = static_cast< bool >(mxLinkRec);
-
- mxLinkRec.reset( new XclExpHyperlink( GetRoot(), rUrlField, maScPos ) );
-
---- libreoffice-4.0.1.2-orig/sc/source/filter/excel/xechart.cxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/sc/source/filter/excel/xechart.cxx 2013-03-17 13:07:50.392624534 +1100
-@@ -682,7 +682,7 @@
-
- bool XclExpChEscherFormat::IsValid() const
- {
-- return maData.mxEscherSet;
-+ return static_cast< bool >(maData.mxEscherSet);
- }
-
- void XclExpChEscherFormat::Save( XclExpStream& rStrm )
---- libreoffice-4.0.1.2-orig/slideshow/source/engine/slide/slideanimations.cxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/slideshow/source/engine/slide/slideanimations.cxx 2013-03-17 12:27:11.738647791 +1100
-@@ -74,7 +74,7 @@
-
- SHOW_NODE_TREE( mpRootNode );
-
-- return mpRootNode;
-+ return static_cast< bool >(mpRootNode);
- }
-
- bool SlideAnimations::isAnimated() const
---- libreoffice-4.0.1.2-orig/editeng/source/editeng/eerdll.cxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/editeng/source/editeng/eerdll.cxx 2013-03-17 10:57:01.036699391 +1100
-@@ -195,7 +195,7 @@
-
- OutputDevice* GlobalEditData::GetStdRefDevice()
- {
-- if ( !m_aStdRefDevice )
-+ if ( !static_cast< bool >(m_aStdRefDevice) )
- {
- m_aStdRefDevice.reset(new VirtualDevice);
- m_aStdRefDevice->SetMapMode( MAP_TWIP );
---- libreoffice-4.0.1.2-orig/slideshow/source/engine/shapes/viewshape.cxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/slideshow/source/engine/shapes/viewshape.cxx 2013-03-17 12:18:21.453652848 +1100
-@@ -178,7 +178,7 @@
- }
- }
-
-- return io_rCacheEntry.mpRenderer;
-+ return static_cast< bool >(io_rCacheEntry.mpRenderer);
- }
-
- bool ViewShape::draw( const ::cppcanvas::CanvasSharedPtr& rDestinationCanvas,
---- libreoffice-4.0.1.2-orig/slideshow/source/engine/shapesubset.cxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/slideshow/source/engine/shapesubset.cxx 2013-03-17 12:18:07.405652982 +1100
-@@ -104,7 +104,7 @@
- maTreeNode );
- }
-
-- return mpSubsetShape;
-+ return static_cast< bool >(mpSubsetShape);
- }
-
- void ShapeSubset::disableSubsetShape()
---- libreoffice-4.0.1.2-orig/slideshow/source/inc/shapeattributelayerholder.hxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/slideshow/source/inc/shapeattributelayerholder.hxx 2013-03-17 12:13:31.544655613 +1100
-@@ -83,7 +83,7 @@
- if( mpShape )
- mpAttributeLayer = mpShape->createAttributeLayer();
-
-- return mpAttributeLayer;
-+ return static_cast< bool >(mpAttributeLayer);
- }
-
- ShapeAttributeLayerSharedPtr get() const
---- libreoffice-4.0.1.2-orig/slideshow/source/engine/animatedsprite.cxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/slideshow/source/engine/animatedsprite.cxx 2013-03-17 11:58:29.991664211 +1100
-@@ -151,7 +151,7 @@
- }
- }
-
-- return mpSprite;
-+ return static_cast< bool >(mpSprite);
- }
-
- void AnimatedSprite::setPixelOffset( const ::basegfx::B2DSize& rPixelOffset )
---- libreoffice-4.0.1.2-orig/slideshow/source/inc/shapeattributelayer.hxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/slideshow/source/inc/shapeattributelayer.hxx 2013-03-17 11:16:36.685688180 +1100
-@@ -467,7 +467,7 @@
- // ShapeAttributeLayer(const ShapeAttributeLayer&);
- // ShapeAttributeLayer& operator=( const ShapeAttributeLayer& );
-
-- bool haveChild() const { return mpChild; }
-+ bool haveChild() const { return static_cast< bool >(mpChild); }
- void updateStateIds();
-
- template< typename T > T calcValue( const T& rCurrValue,
---- libreoffice-4.0.1.2-orig/comphelper/inc/comphelper/scoped_disposing_ptr.hxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/comphelper/inc/comphelper/scoped_disposing_ptr.hxx 2013-03-17 10:57:51.543698910 +1100
-@@ -78,7 +78,7 @@
-
- operator bool () const
- {
-- return m_aItem;
-+ return static_cast< bool >(m_aItem);
- }
-
- virtual ~scoped_disposing_ptr()
---- libreoffice-4.0.1.2-orig/vcl/source/gdi/svgdata.cxx 2013-02-28 01:02:37.000000000 +1100
-+++ libreoffice-4.0.1.2/vcl/source/gdi/svgdata.cxx 2013-03-17 10:37:49.026710378 +1100
-@@ -166,7 +166,7 @@
-
- //////////////////////////////////////////////////////////////////////////////
- SvgData::SvgData(const OUString& rPath):
-- maSvgDataArray(NULL),
-+ maSvgDataArray(static_cast< unsigned char * >(NULL)),
- mnSvgDataArrayLength(0),
- maPath(rPath),
- maRange(),
View
569 app-office/libreoffice/libreoffice-3.6.6.2.ebuild
@@ -1,569 +0,0 @@
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-KDE_REQUIRED="optional"
-QT_MINIMAL="4.7.4"
-KDE_SCM="git"
-CMAKE_REQUIRED="never"
-
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-PYTHON_REQ_USE="threads,xml"
-
-# experimental ; release ; old
-# Usually the tarballs are moved a lot so this should make
-# everyone happy.
-DEV_URI="
- http://dev-builds.libreoffice.org/pre-releases/src
- http://download.documentfoundation.org/libreoffice/src/${PV:0:5}/
- http://download.documentfoundation.org/libreoffice/old/${PV}/
-"
-EXT_URI="http://ooo.itc.hu/oxygenoffice/download/libreoffice"
-ADDONS_URI="http://dev-www.libreoffice.org/src/"
-
-BRANDING="${PN}-branding-gentoo-0.6.tar.xz"
-# PATCHSET="${P}-patchset-01.tar.xz"
-
-[[ ${PV} == *9999* ]] && SCM_ECLASS="git-2"
-inherit base autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils python-single-r1 multilib toolchain-funcs flag-o-matic ${SCM_ECLASS}
-unset SCM_ECLASS
-
-DESCRIPTION="LibreOffice, a full office productivity suite."
-HOMEPAGE="http://www.libreoffice.org"
-SRC_URI="branding? ( http://dev.gentoo.org/~dilfridge/distfiles/${BRANDING} )"
-[[ -n ${PATCHSET} ]] && SRC_URI+=" http://dev.gentooexperimental.org/~scarabeus/${PATCHSET}"
-
-# Split modules following git/tarballs
-# Core MUST be first!
-# Help is used for the image generator
-MODULES="core binfilter help"
-# Only release has the tarballs
-if [[ ${PV} != *9999* ]]; then
- for i in ${DEV_URI}; do
- for mod in ${MODULES}; do
- if [[ ${mod} == binfilter ]]; then
- SRC_URI+=" binfilter? ( ${i}/${PN}-${mod}-${PV}.tar.xz )"
- else
- SRC_URI+=" ${i}/${PN}-${mod}-${PV}.tar.xz"
- fi
- done
- unset mod
- done
- unset i
-fi
-unset DEV_URI
-
-# Really required addons
-# These are bundles that can't be removed for now due to huge patchsets.
-# If you want them gone, patches are welcome.
-ADDONS_SRC+=" ${ADDONS_URI}/ea91f2fb4212a21d708aced277e6e85a-vigra1.4.0.tar.gz"
-ADDONS_SRC+=" ${ADDONS_URI}/1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz" # modifies source code
-ADDONS_SRC+=" java? ( ${ADDONS_URI}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip )"
-ADDONS_SRC+=" java? ( ${ADDONS_URI}/ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.7-bj.zip )"
-ADDONS_SRC+=" libreoffice_extensions_wiki-publisher? ( ${ADDONS_URI}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip )" # no release for 8 years, should we package it?
-ADDONS_SRC+=" libreoffice_extensions_scripting-javascript? ( ${ADDONS_URI}/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip )" # Does not build with 1.6 rhino at all
-ADDONS_SRC+=" libreoffice_extensions_scripting-javascript? ( ${ADDONS_URI}/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip )" # requirement of rhino
-ADDONS_SRC+=" odk? ( http://download.go-oo.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll )" # not packageable
-SRC_URI+=" ${ADDONS_SRC}"
-
-unset ADDONS_URI
-unset EXT_URI
-unset ADDONS_SRC
-
-IUSE="binfilter binfilterdebug +branding +cups dbus eds gnome gstreamer +gtk
-jemalloc kde mysql odk opengl postgres test +vba +webdav"
-
-LO_EXTS="nlpsolver pdfimport presenter-console presenter-minimizer scripting-beanshell scripting-javascript wiki-publisher"
-# Unpackaged separate extensions:
-# diagram: lo has 0.9.5 upstream is weirdly patched 0.9.4 -> wtf?
-# hunart: only on ooo extensions -> fubared download path somewhere on sf
-# numbertext, typo, validator, watch-window: ^^
-# oooblogger: no homepage or anything
-# Extensions that need extra work:
-# report-builder: missing java packages
-for lo_xt in ${LO_EXTS}; do
- IUSE+=" libreoffice_extensions_${lo_xt}"
-done
-unset lo_xt
-
-LICENSE="|| ( LGPL-3 MPL-1.1 )"
-SLOT="0"
-[[ ${PV} == *9999* ]] || \
-KEYWORDS="*"
-
-COMMON_DEPEND="
- ${PYTHON_DEPS}
- app-arch/zip
- app-arch/unzip
- >=app-text/hunspell-1.3.2-r3
- app-text/mythes
- >=app-text/libexttextcat-3.2
- app-text/libwpd:0.9[tools]
- app-text/libwpg:0.2
- >=app-text/libwps-0.2.2
- >=dev-cpp/clucene-2.3.3.4-r2
- >=dev-cpp/libcmis-0.2:0.2
- dev-db/unixODBC
- dev-libs/expat
- >=dev-libs/glib-2.28
- >=dev-libs/hyphen-2.7.1
- >=dev-libs/icu-4.8.1.1
- >=dev-libs/nspr-4.8.8
- >=dev-libs/nss-3.12.9
- >=dev-lang/perl-5.0
- >=dev-libs/openssl-1.0.0d
- >=dev-libs/redland-1.0.14[ssl]
- gnome-base/librsvg
- media-gfx/graphite2
- >=media-libs/fontconfig-2.8.0
- media-libs/freetype:2
- media-libs/lcms:2
- >=media-libs/libpng-1.4
- >=media-libs/libcdr-0.0.5
- media-libs/libvisio
- >=net-misc/curl-7.21.4
- sci-mathematics/lpsolve
- >=sys-libs/db-4.8
- virtual/jpeg
- >=x11-libs/cairo-1.10.0[X]
- x11-libs/libXinerama
- x11-libs/libXrandr
- x11-libs/libXrender
- cups? ( net-print/cups )
- dbus? ( >=dev-libs/dbus-glib-0.92 )
- eds? ( gnome-extra/evolution-data-server )
- gnome? ( gnome-base/gconf:2 )
- gtk? (
- x11-libs/gdk-pixbuf[X]
- >=x11-libs/gtk+-2.24:2
- )
- gstreamer? (
- >=media-libs/gstreamer-0.10:0.10
- >=media-libs/gst-plugins-base-0.10:0.10
- )
- jemalloc? ( dev-libs/jemalloc )
- libreoffice_extensions_pdfimport? ( >=app-text/poppler-0.16:=[xpdf-headers(+),cxx] )
- libreoffice_extensions_scripting-beanshell? ( >=dev-java/bsh-2.0_beta4 )
- libreoffice_extensions_scripting-javascript? ( dev-java/rhino:1.6 )
- libreoffice_extensions_wiki-publisher? (
- dev-java/commons-codec:0
- dev-java/commons-httpclient:3
- dev-java/commons-lang:2.1
- dev-java/commons-logging:0
- dev-java/tomcat-servlet-api:3.0
- )
- mysql? ( >=dev-db/mysql-connector-c++-1.1.0 )
- opengl? (
- virtual/glu
- virtual/opengl
- )
- postgres? ( >=dev-db/postgresql-base-9.0[kerberos] )
- webdav? ( net-libs/neon )
-"
-
-RDEPEND="${COMMON_DEPEND}
- !app-office/libreoffice-bin
- !app-office/libreoffice-bin-debug
- !<app-office/openoffice-bin-3.4.0-r1
- !app-office/openoffice
- media-fonts/libertine-ttf
- media-fonts/liberation-fonts
- media-fonts/urw-fonts
- java? ( >=virtual/jre-1.6 )
-"
-
-PDEPEND="
- =app-office/libreoffice-l10n-3.6*
-"
-
-# FIXME: cppunit should be moved to test conditional
-# after everything upstream is under gbuild
-# as dmake execute tests right away
-DEPEND="${COMMON_DEPEND}
- >=dev-libs/boost-1.46
- >=dev-libs/libxml2-2.7.8
- dev-libs/libxslt
- dev-perl/Archive-Zip
- dev-util/cppunit
- >=dev-util/gperf-3
- dev-util/intltool
- <dev-util/mdds-0.8.0
- virtual/pkgconfig
- net-misc/npapi-sdk
- >=sys-apps/findutils-4.4.2
- sys-devel/bison
- sys-apps/coreutils
- sys-devel/flex
- sys-devel/gettext
- >=sys-devel/make-3.82
- sys-libs/zlib
- x11-libs/libXt
- x11-libs/libXtst
- x11-proto/randrproto
- x11-proto/xextproto
- x11-proto/xineramaproto
- x11-proto/xproto
- java? (
- >=virtual/jdk-1.6
- >=dev-java/ant-core-1.7
- )
- odk? ( app-doc/doxygen )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- # not upstreamable stuff
- "${FILESDIR}/${PN}-3.6-system-pyuno.patch"
- "${FILESDIR}/${PN}-3.6-separate-checks.patch"
-)
-
-REQUIRED_USE="
- gnome? ( gtk )
- eds? ( gnome )
- libreoffice_extensions_nlpsolver? ( java )
- libreoffice_extensions_scripting-beanshell? ( java )
- libreoffice_extensions_scripting-javascript? ( java )
- libreoffice_extensions_wiki-publisher? ( java )
-"
-
-S="${WORKDIR}/${PN}-core-${PV}"
-
-CHECKREQS_MEMORY="512M"
-CHECKREQS_DISK_BUILD="6G"
-
-pkg_pretend() {
- local pgslot
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- check-reqs_pkg_pretend
-
- if [[ $(gcc-major-version) -lt 4 ]] || \
- ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 5 ]] ) \
- ; then
- eerror "Compilation with gcc older than 4.5 is not supported"
- die "Too old gcc found."
- fi
- fi
-
-}
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
- kde4-base_pkg_setup
- python-single-r1_pkg_setup
-
- [[ ${MERGE_TYPE} != binary ]] && check-reqs_pkg_setup
-}
-
-src_unpack() {
- local mod dest tmplfile tmplname mypv
-
- [[ -n ${PATCHSET} ]] && unpack ${PATCHSET}
- if use branding; then
- unpack "${BRANDING}"
- fi
-
- if [[ ${PV} != *9999* ]]; then
- for mod in ${MODULES}; do
- if [[ ${mod} == binfilter ]] && ! use binfilter; then
- continue
- fi
- unpack "${PN}-${mod}-${PV}.tar.xz"
- if [[ ${mod} != core ]]; then
- mv -n "${WORKDIR}/${PN}-${mod}-${PV}"/* "${S}"
- rm -rf "${WORKDIR}/${PN}-${mod}-${PV}"
- fi
- done
- else
- for mod in ${MODULES}; do
- if [[ ${mod} == binfilter ]] && ! use binfilter; then
- continue
- fi
- mypv=${PV/.9999}
- [[ ${mypv} != ${PV} ]] && EGIT_BRANCH="${PN}-${mypv/./-}"
- EGIT_PROJECT="${PN}/${mod}"
- EGIT_SOURCEDIR="${WORKDIR}/${PN}-${mod}-${PV}"
- EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}/${mod}"
- EGIT_NOUNPACK="true"
- git-2_src_unpack
- if [[ ${mod} != core ]]; then
- mv -n "${WORKDIR}/${PN}-${mod}-${PV}"/* "${S}"
- rm -rf "${WORKDIR}/${PN}-${mod}-${PV}"
- fi
- done
- unset EGIT_PROJECT EGIT_SOURCEDIR EGIT_REPO_URI EGIT_BRANCH
- fi
-}
-
-src_prepare() {
- # optimization flags
- export ARCH_FLAGS="${CXXFLAGS}"
- export LINKFLAGSOPTIMIZE="${LDFLAGS}"
- export GMAKE_OPTIONS="${MAKEOPTS}"
-
- # patchset
- if [[ -n ${PATCHSET} ]]; then
- EPATCH_FORCE="yes" \
- EPATCH_SOURCE="${WORKDIR}/${PATCHSET/.tar.xz/}" \
- EPATCH_SUFFIX="patch" \
- epatch
- fi
-
- base_src_prepare
-
- # please no debug in binfilter, it blows up things insanely
- if use binfilter && ! use binfilterdebug ; then
- for name in $(find "${S}/binfilter" -name makefile.mk) ; do
- sed -i -e '1i\CFLAGS+= -g0' $name || die
- done
- fi
-
- AT_M4DIR="m4"
- eautoreconf
- # hack in the autogen.sh
- touch autogen.lastrun
-
- # system pyuno mess
- sed \
- -e "s:%eprefix%:${EPREFIX}:g" \
- -e "s:%libdir%:$(get_libdir):g" \
- -i pyuno/source/module/uno.py \
- -i scripting/source/pyprov/officehelper.py || die
-}
-
-src_configure() {
- local java_opts
- local internal_libs
- local lo_ext
- local ext_opts
- local jbs=$(sed -ne 's/.*\(-j[[:space:]]*\|--jobs=\)\([[:digit:]]\+\).*/\2/;T;p' <<< "${MAKEOPTS}")
-
- # Workaround the boost header include issue for older gccs
- if [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]]; then
- append-cppflags -DBOOST_NO_0X_HDR_TYPEINDEX
- append-cppflags -DBOOST_NO_CXX11_HDR_TYPEINDEX
- fi
-
- # recheck that there is some value in jobs
- [[ -z ${jbs} ]] && jbs="1"
-
- # sane: just sane.h header that is used for scan in writer, not
- # linked or anything else, worthless to depend on
- # vigra: just uses templates from there
- # it is serious pain in the ass for packaging
- # should be replaced by boost::gil if someone interested
- internal_libs+="
- --without-system-sane
- --without-system-vigra
- "
-
- # libreoffice extensions handling
- for lo_xt in ${LO_EXTS}; do
- ext_opts+=" $(use_enable libreoffice_extensions_${lo_xt} ext-${lo_xt})"
- done
-
- if use java; then
- # hsqldb: system one is too new
- # saxon: system one does not work properly
- java_opts="
- --without-junit
- --without-system-hsqldb
- --without-system-saxon
- --with-ant-home="${ANT_HOME}"
- --with-jdk-home=$(java-config --jdk-home 2>/dev/null)
- --with-java-target-version=$(java-pkg_get-target)
- --with-jvm-path="${EPREFIX}/usr/$(get_libdir)/"
- "
-
- use libreoffice_extensions_scripting-beanshell && \
- java_opts+=" --with-beanshell-jar=$(java-pkg_getjar bsh bsh.jar)"
-
- use libreoffice_extensions_scripting-javascript && \
- java_opts+=" --with-rhino-jar=$(java-pkg_getjar rhino-1.6 js.jar)"
-
- if use libreoffice_extensions_wiki-publisher; then
- java_opts+="
- --with-commons-codec-jar=$(java-pkg_getjar commons-codec commons-codec.jar)
- --with-commons-httpclient-jar=$(java-pkg_getjar commons-httpclient-3 commons-httpclient.jar)
- --with-commons-lang-jar=$(java-pkg_getjar commons-lang-2.1 commons-lang.jar)
- --with-commons-logging-jar=$(java-pkg_getjar commons-logging commons-logging.jar)
- --with-servlet-api-jar=$(java-pkg_getjar tomcat-servlet-api-3.0 servlet-api.jar)
- "
- fi
- fi
-
- if use branding; then
- # hack...
- mv -v "${WORKDIR}/branding-intro.png" "${S}/icon-themes/galaxy/brand/intro.png" || die
- fi
-
- # system headers/libs/...: enforce using system packages
- # --enable-unix-qstart-libpng: use libpng splashscreen that is faster
- # --enable-cairo: ensure that cairo is always required
- # --enable-*-link: link to the library rather than just dlopen on runtime
- # --enable-release-build: build the libreoffice as release
- # --disable-fetch-external: prevent dowloading during compile phase
- # --disable-gnome-vfs: old gnome virtual fs support
- # --disable-kdeab: kde3 adressbook
- # --disable-kde: kde3 support
- # --disable-ldap: ldap requires internal mozilla stuff, same like mozab
- # --disable-mozilla: disable mozilla build that is used for adresbook, not
- # affecting the nsplugin that is always ON
- # --disable-pch: precompiled headers cause build crashes
- # --disable-rpath: relative runtime path is not desired
- # --disable-systray: quickstarter does not actually work at all so do not
- # promote it
- # --disable-zenity: disable build icon
- # --enable-extension-integration: enable any extension integration support
- # --with-{max-jobs,num-cpus}: ensuring parallel building
- # --without-{afms,fonts,myspell-dicts,ppsd}: prevent install of sys pkgs
- # --without-stlport: disable deprecated extensions framework
- # --disable-ext-report-builder: too much java packages pulled in
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}/" \
- --with-system-headers \
- --with-system-libs \
- --with-system-jars \
- --with-system-dicts \
- --enable-graphite \
- --enable-cairo-canvas \
- --enable-largefile \
- --enable-mergelibs \
- --enable-python=system \
- --enable-librsvg=system \
- --enable-randr \
- --enable-randr-link \
- --enable-release-build \
- --enable-unix-qstart-libpng \
- --enable-xmlsec \
- --disable-ccache \
- --disable-crashdump \
- --disable-dependency-tracking \
- --disable-epm \
- --disable-fetch-external \
- --disable-gnome-vfs \
- --disable-ext-report-builder \
- --disable-kdeab \
- --disable-kde \
- --disable-ldap \
- --disable-mozilla \
- --disable-nsplugin \
- --disable-online-update \
- --disable-pch \
- --disable-rpath \
- --disable-systray \
- --disable-zenity \
- --with-alloc=$(use jemalloc && echo "jemalloc" || echo "system") \
- --with-build-version="Gentoo official package" \
- --enable-extension-integration \
- --with-external-dict-dir="${EPREFIX}/usr/share/myspell" \
- --with-external-hyph-dir="${EPREFIX}/usr/share/myspell" \
- --with-external-thes-dir="${EPREFIX}/usr/share/myspell" \
- --with-external-tar="${DISTDIR}" \
- --with-lang="" \
- --with-max-jobs=${jbs} \
- --with-num-cpus=${jbs} \
- --with-unix-wrapper=libreoffice \
- --with-vendor="Gentoo Foundation" \
- --with-x \
- --without-afms \
- --without-fonts \
- --without-myspell-dicts \
- --without-stlport \
- --without-system-mozilla \
- --without-help \
- --with-helppack-integration \
- --without-sun-templates \
- --disable-gtk3 \
- $(use_enable binfilter) \
- $(use_enable cups) \
- $(use_enable dbus) \
- $(use_enable eds evolution2) \
- $(use_enable gnome gconf) \
- $(use_enable gnome gio) \
- $(use_enable gnome lockdown) \
- $(use_enable gstreamer) \
- $(use_enable gtk) \
- $(use_enable kde kde4) \
- $(use_enable mysql ext-mysql-connector) \
- $(use_enable odk) \
- $(use_enable opengl) \
- $(use_enable postgres postgresql-sdbc) \
- $(use_enable test linkoo) \
- $(use_enable vba) \
- $(use_enable webdav neon) \
- $(use_with java) \
- $(use_with mysql system-mysql-cppconn) \
- $(use_with odk doxygen) \
- ${internal_libs} \
- ${java_opts} \
- ${ext_opts}
-}
-
-src_compile() {
- # hack for offlinehelp, this needs fixing upstream at some point
- # it is broken because we send --without-help
- # https://bugs.freedesktop.org/show_bug.cgi?id=46506
- (
- source "${S}/config_host.mk" 2&> /dev/null
-
- local path="${SOLARVER}/${INPATH}/res/img"
- mkdir -p "${path}" || die
-
- echo "perl \"${S}/helpcontent2/helpers/create_ilst.pl\" -dir=icon-themes/galaxy/res/helpimg > \"${path}/helpimg.ilst\""
- perl "${S}/helpcontent2/helpers/create_ilst.pl" \
- -dir=icon-themes/galaxy/res/helpimg \
- > "${path}/helpimg.ilst"
- [[ -s "${path}/helpimg.ilst" ]] || ewarn "The help images list is empty, something is fishy, report a bug."
- )
-
- # this is not a proper make script
- make build || die
-}
-
-src_test() {
- make unitcheck || die
- make slowcheck || die
-}
-
-src_install() {
- # This is not Makefile so no buildserver
- make DESTDIR="${D}" distro-pack-install -o build -o check || die
-
- # Fix bash completion placement
- newbashcomp "${ED}"/etc/bash_completion.d/libreoffice.sh ${PN}
- rm -rf "${ED}"/etc/
-
- if use branding; then
- insinto /usr/$(get_libdir)/${PN}/program
- newins "${WORKDIR}/branding-sofficerc" sofficerc
- fi
-
- # Hack for offlinehelp, this needs fixing upstream at some point.
- # It is broken because we send --without-help
- # https://bugs.freedesktop.org/show_bug.cgi?id=46506
- insinto /usr/$(get_libdir)/libreoffice/help
- doins xmlhelp/util/*.xsl
-
- # Remove desktop files for support to old installs that can't parse mime
- rm -rf "${ED}"/usr/share/mimelnk/
-}
-
-pkg_preinst() {
- # Cache updates - all handled by kde eclass for all environments
- kde4-base_pkg_preinst
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
- pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
-
- use java || \
- ewarn 'If you plan to use lbase application you should enable java or you will get various crashes.'
-}
-
-pkg_postrm() {
- kde4-base_pkg_postrm
-}
View
567 app-office/libreoffice/libreoffice-4.0.3.3.ebuild
@@ -1,567 +0,0 @@
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-KDE_REQUIRED="optional"
-QT_MINIMAL="4.7.4"
-KDE_SCM="git"
-CMAKE_REQUIRED="never"
-
-PYTHON_COMPAT=( python2_7 python3_3 )
-PYTHON_REQ_USE="threads,xml"
-
-# experimental ; release ; old
-# Usually the tarballs are moved a lot so this should make
-# everyone happy.
-DEV_URI="
- http://dev-builds.libreoffice.org/pre-releases/src
- http://download.documentfoundation.org/libreoffice/src/${PV:0:5}/
- http://download.documentfoundation.org/libreoffice/old/${PV}/
-"
-EXT_URI="http://ooo.itc.hu/oxygenoffice/download/libreoffice"
-ADDONS_URI="http://dev-www.libreoffice.org/src/"
-
-BRANDING="${PN}-branding-gentoo-0.7.tar.xz"
-# PATCHSET="${P}-patchset-01.tar.xz"
-
-[[ ${PV} == *9999* ]] && SCM_ECLASS="git-2"
-inherit base autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils python-single-r1 multilib toolchain-funcs flag-o-matic nsplugins ${SCM_ECLASS}
-unset SCM_ECLASS
-
-DESCRIPTION="LibreOffice, a full office productivity suite."
-HOMEPAGE="http://www.libreoffice.org"
-SRC_URI="branding? ( http://dev.gentoo.org/~dilfridge/distfiles/${BRANDING} )"
-[[ -n ${PATCHSET} ]] && SRC_URI+=" http://dev.gentooexperimental.org/~scarabeus/${PATCHSET}"
-
-# Help is used for the image generator
-# We can also build translations and others if needed.
-# Core must be first
-MODULES="core help"
-# Only release has the tarballs
-if [[ ${PV} != *9999* ]]; then
- for i in ${DEV_URI}; do
- for mod in ${MODULES}; do
- if [[ ${mod} == core ]]; then
- # core is now packed without it in the name, git reponame stay
- SRC_URI+=" ${i}/${P}.tar.xz"
- else
- SRC_URI+=" ${i}/${PN}-${mod}-${PV}.tar.xz"
- fi
- done
- unset mod
- done
- unset i
-fi
-unset DEV_URI
-
-# Really required addons
-# These are bundles that can't be removed for now due to huge patchsets.
-# If you want them gone, patches are welcome.
-ADDONS_SRC+=" ${ADDONS_URI}/ea91f2fb4212a21d708aced277e6e85a-vigra1.4.0.tar.gz"
-ADDONS_SRC+=" ${ADDONS_URI}/1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz" # modifies source code
-ADDONS_SRC+=" java? ( ${ADDONS_URI}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip )"
-ADDONS_SRC+=" libreoffice_extensions_wiki-publisher? ( ${ADDONS_URI}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip )" # no release for 8 years, should we package it?
-ADDONS_SRC+=" libreoffice_extensions_scripting-javascript? ( ${ADDONS_URI}/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip )" # Does not build with 1.6 rhino at all
-ADDONS_SRC+=" libreoffice_extensions_scripting-javascript? ( ${ADDONS_URI}/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip )" # requirement of rhino
-ADDONS_SRC+=" odk? ( http://download.go-oo.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll )" # not packageable
-SRC_URI+=" ${ADDONS_SRC}"
-
-unset ADDONS_URI
-unset EXT_URI
-unset ADDONS_SRC
-
-IUSE="bluetooth +branding +cups dbus debug eds gnome gstreamer +gtk
-jemalloc kde mysql odk opengl postgres telepathy test +vba +webdav"
-
-LO_EXTS="nlpsolver presenter-minimizer scripting-beanshell scripting-javascript wiki-publisher"
-# Unpackaged separate extensions:
-# diagram: lo has 0.9.5 upstream is weirdly patched 0.9.4 -> wtf?
-# hunart: only on ooo extensions -> fubared download path somewhere on sf
-# numbertext, typo, validator, watch-window: ^^
-# oooblogger: no homepage or anything
-# Extensions that need extra work:
-# report-builder: missing java packages
-for lo_xt in ${LO_EXTS}; do
- IUSE+=" libreoffice_extensions_${lo_xt}"
-done
-unset lo_xt
-
-LICENSE="|| ( LGPL-3 MPL-1.1 )"
-SLOT="0"
-[[ ${PV} == *9999* ]] || \
-KEYWORDS="~*"
-
-COMMON_DEPEND="
- ${PYTHON_DEPS}
- app-arch/zip
- app-arch/unzip
- >=app-text/hunspell-1.3.2-r3
- app-text/mythes
- >=app-text/libexttextcat-3.2
- app-text/liblangtag
- app-text/libmspub
- app-text/libwpd:0.9[tools]
- app-text/libwpg:0.2
- >=app-text/libwps-0.2.2
- >=app-text/poppler-0.16:=[xpdf-headers(+),cxx]
- >=dev-cpp/clucene-2.3.3.4-r2
- >=dev-cpp/libcmis-0.3.1:0.3
- dev-db/unixODBC
- dev-libs/expat
- >=dev-libs/hyphen-2.7.1
- >=dev-libs/icu-4.8.1.1:=
- =dev-libs/liborcus-0.3*
- >=dev-libs/nspr-4.8.8
- >=dev-libs/nss-3.12.9
- >=dev-lang/perl-5.0
- >=dev-libs/openssl-1.0.0d
- >=dev-libs/redland-1.0.14[ssl]
- media-gfx/graphite2
- >=media-libs/fontconfig-2.8.0
- media-libs/freetype:2
- media-libs/lcms:2
- >=media-libs/libpng-1.4
- >=media-libs/libcdr-0.0.5
- media-libs/libvisio
- >=net-misc/curl-7.21.4
- net-nds/openldap
- sci-mathematics/lpsolve
- virtual/jpeg
- >=x11-libs/cairo-1.10.0[X]
- x11-libs/libXinerama
- x11-libs/libXrandr
- x11-libs/libXrender
- bluetooth? ( net-wireless/bluez )
- cups? ( net-print/cups )
- dbus? ( >=dev-libs/dbus-glib-0.92 )
- eds? ( gnome-extra/evolution-data-server )
- gnome? ( gnome-base/gconf:2 )
- gtk? (
- x11-libs/gdk-pixbuf[X]
- >=x11-libs/gtk+-2.24:2
- )
- gstreamer? (
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0
- )
- jemalloc? ( dev-libs/jemalloc )
- libreoffice_extensions_scripting-beanshell? ( >=dev-java/bsh-2.0_beta4 )
- libreoffice_extensions_scripting-javascript? ( dev-java/rhino:1.6 )
- libreoffice_extensions_wiki-publisher? (
- dev-java/commons-codec:0
- dev-java/commons-httpclient:3
- dev-java/commons-lang:2.1
- dev-java/commons-logging:0
- dev-java/tomcat-servlet-api:3.0
- )
- mysql? ( >=dev-db/mysql-connector-c++-1.1.0 )
- opengl? (
- virtual/glu
- virtual/opengl
- )
- postgres? ( >=dev-db/postgresql-base-9.0[kerberos] )
- telepathy? (
- dev-libs/glib:2
- >=net-libs/telepathy-glib-0.18.0
- >=x11-libs/gtk+-2.24:2
- )
- webdav? ( net-libs/neon )
-"
-
-RDEPEND="${COMMON_DEPEND}
- !app-office/libreoffice-bin
- !app-office/libreoffice-bin-debug
- !<app-office/openoffice-bin-3.4.0-r1
- !app-office/openoffice
- media-fonts/libertine-ttf
- media-fonts/liberation-fonts
- media-fonts/urw-fonts
- java? ( >=virtual/jre-1.6 )
-"
-
-if [[ ${PV} != *9999* ]]; then
- PDEPEND="~app-office/libreoffice-l10n-${PV}"
-else
- # Translations are not reliable on live ebuilds
- # rather force people to use english only.
- PDEPEND="!app-office/libreoffice-l10n"
-fi
-
-# FIXME: cppunit should be moved to test conditional
-# after everything upstream is under gbuild
-# as dmake execute tests right away
-DEPEND="${COMMON_DEPEND}
- >=dev-libs/boost-1.46
- >=dev-libs/libxml2-2.7.8
- dev-libs/libxslt
- dev-perl/Archive-Zip
- dev-util/cppunit
- >=dev-util/gperf-3
- dev-util/intltool
- <dev-util/mdds-0.8.0
- virtual/pkgconfig
- net-misc/npapi-sdk
- >=sys-apps/findutils-4.4.2
- sys-devel/bison
- sys-apps/coreutils
- sys-devel/flex
- sys-devel/gettext
- >=sys-devel/make-3.82
- sys-devel/ucpp
- sys-libs/zlib
- x11-libs/libXt
- x11-libs/libXtst
- x11-proto/randrproto
- x11-proto/xextproto
- x11-proto/xineramaproto
- x11-proto/xproto
- java? (
- >=virtual/jdk-1.6
- >=dev-java/ant-core-1.7
- )
- odk? ( app-doc/doxygen )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- # not upstreamable stuff
- "${FILESDIR}/${PN}-3.7-system-pyuno.patch"
- "${FILESDIR}/${PN}-3.7-separate-checks.patch"
-)
-
-REQUIRED_USE="
- bluetooth? ( dbus )
- gnome? ( gtk )
- eds? ( gnome )
- libreoffice_extensions_nlpsolver? ( java )
- libreoffice_extensions_scripting-beanshell? ( java )
- libreoffice_extensions_scripting-javascript? ( java )
- libreoffice_extensions_wiki-publisher? ( java )
-"
-
-CHECKREQS_MEMORY="512M"
-CHECKREQS_DISK_BUILD="6G"
-
-pkg_pretend() {
- local pgslot
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- check-reqs_pkg_pretend
-
- if [[ $(gcc-major-version) -lt 4 ]] || \
- ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
- ; then
- eerror "Compilation with gcc older than 4.6 is not supported"
- die "Too old gcc found."
- fi
- fi
-
-}
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
- kde4-base_pkg_setup
- python-single-r1_pkg_setup
-
- [[ ${MERGE_TYPE} != binary ]] && check-reqs_pkg_setup
-}
-
-src_unpack() {
- local mod mod2 dest tmplfile tmplname mypv
-
- [[ -n ${PATCHSET} ]] && unpack ${PATCHSET}
- use branding && unpack "${BRANDING}"
-
- if [[ ${PV} != *9999* ]]; then
- unpack "${P}.tar.xz"
- for mod in ${MODULES}; do
- [[ ${mod} == core ]] && continue
- unpack "${PN}-${mod}-${PV}.tar.xz"
- done
- else
- for mod in ${MODULES}; do
- mypv=${PV/.9999}
- [[ ${mypv} != ${PV} ]] && EGIT_BRANCH="${PN}-${mypv/./-}"
- EGIT_PROJECT="${PN}/${mod}"
- EGIT_SOURCEDIR="${WORKDIR}/${P}"
- [[ ${mod} != core ]] && EGIT_SOURCEDIR="${WORKDIR}/${PN}-${mod}-${PV}"
- EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}/${mod}"
- EGIT_NOUNPACK="true"
- git-2_src_unpack
- if [[ ${mod} != core ]]; then
- mod2=${mod}
- # mapping does not match on help
- [[ ${mod} == help ]] && mod2="helpcontent2"
- mkdir -p "${S}/${mod2}/" || die
- mv -n "${WORKDIR}/${PN}-${mod}-${PV}"/* "${S}/${mod2}" || die
- rm -rf "${WORKDIR}/${PN}-${mod}-${PV}"
- fi
- done
- unset EGIT_PROJECT EGIT_SOURCEDIR EGIT_REPO_URI EGIT_BRANCH
- fi
-}
-
-src_prepare() {
- # fixed in master, flags order in bridges compilation
- filter-flags -fomit-frame-pointer
-
- # optimization flags
- export ARCH_FLAGS="${CXXFLAGS}"
- export LINKFLAGSOPTIMIZE="${LDFLAGS}"
- export GMAKE_OPTIONS="${MAKEOPTS}"
- # System python 2.7 enablement:
- export PYTHON="${PYTHON}"
- export PYTHON_CFLAGS=$(python_get_CFLAGS)
- export PYTHON_LIBS=$(python_get_LIBS)
-
- # patchset
- if [[ -n ${PATCHSET} ]]; then
- EPATCH_FORCE="yes" \
- EPATCH_SOURCE="${WORKDIR}/${PATCHSET/.tar.xz/}" \
- EPATCH_SUFFIX="patch" \
- epatch
- fi
-
- base_src_prepare
-
- AT_M4DIR="m4"
- eautoreconf
- # hack in the autogen.sh
- touch autogen.lastrun
-
- # system pyuno mess
- sed \
- -e "s:%eprefix%:${EPREFIX}:g" \
- -e "s:%libdir%:$(get_libdir):g" \
- -i pyuno/source/module/uno.py \
- -i scripting/source/pyprov/officehelper.py || die
-
- if use branding; then
- # hack...
- mv -v "${WORKDIR}/branding-intro.png" "${S}/icon-themes/galaxy/brand/intro.png" || die
- fi
-}
-
-src_configure() {
- local java_opts
- local internal_libs
- local lo_ext
- local ext_opts
- local jbs=$(sed -ne 's/.*\(-j[[:space:]]*\|--jobs=\)\([[:digit:]]\+\).*/\2/;T;p' <<< "${MAKEOPTS}")
-
- # recheck that there is some value in jobs
- [[ -z ${jbs} ]] && jbs="1"
-
- # sane: just sane.h header that is used for scan in writer, not
- # linked or anything else, worthless to depend on
- # vigra: just uses templates from there
- # it is serious pain in the ass for packaging
- # should be replaced by boost::gil if someone interested
- internal_libs+="
- --without-system-sane
- --without-system-vigra
- "
-
- # libreoffice extensions handling
- for lo_xt in ${LO_EXTS}; do
- if [[ "${lo_xt}" == "scripting-beanshell" || "${lo_xt}" == "scripting-javascript" ]]; then
- ext_opts+=" $(use_enable libreoffice_extensions_${lo_xt} ${lo_xt})"
- else
- ext_opts+=" $(use_enable libreoffice_extensions_${lo_xt} ext-${lo_xt})"
- fi
- done
-
- if use java; then
- # hsqldb: system one is too new
- java_opts="
- --without-junit
- --without-system-hsqldb
- --with-ant-home="${ANT_HOME}"
- --with-jdk-home=$(java-config --jdk-home 2>/dev/null)
- --with-java-target-version=$(java-pkg_get-target)
- --with-jvm-path="${EPREFIX}/usr/$(get_libdir)/"
- "
-
- use libreoffice_extensions_scripting-beanshell && \
- java_opts+=" --with-beanshell-jar=$(java-pkg_getjar bsh bsh.jar)"
-
- use libreoffice_extensions_scripting-javascript && \
- java_opts+=" --with-rhino-jar=$(java-pkg_getjar rhino-1.6 js.jar)"
-
- if use libreoffice_extensions_wiki-publisher; then
- java_opts+="
- --with-commons-codec-jar=$(java-pkg_getjar commons-codec commons-codec.jar)
- --with-commons-httpclient-jar=$(java-pkg_getjar commons-httpclient-3 commons-httpclient.jar)
- --with-commons-lang-jar=$(java-pkg_getjar commons-lang-2.1 commons-lang.jar)
- --with-commons-logging-jar=$(java-pkg_getjar commons-logging commons-logging.jar)
- --with-servlet-api-jar=$(java-pkg_getjar tomcat-servlet-api-3.0 servlet-api.jar)
- "
- fi
- fi
-
- # system headers/libs/...: enforce using system packages
- # --enable-unix-qstart-libpng: use libpng splashscreen that is faster
- # --enable-cairo: ensure that cairo is always required
- # --enable-graphite: disabling causes build breakages
- # --enable-*-link: link to the library rather than just dlopen on runtime
- # --enable-release-build: build the libreoffice as release
- # --disable-fetch-external: prevent dowloading during compile phase
- # --disable-gnome-vfs: old gnome virtual fs support
- # --disable-kdeab: kde3 adressbook
- # --disable-kde: kde3 support
- # --disable-pch: precompiled headers cause build crashes
- # --disable-rpath: relative runtime path is not desired
- # --disable-systray: quickstarter does not actually work at all so do not
- # promote it
- # --disable-zenity: disable build icon
- # --enable-extension-integration: enable any extension integration support
- # --without-{afms,fonts,myspell-dicts,ppsd}: prevent install of sys pkgs
- # --disable-ext-report-builder: too much java packages pulled in
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}/" \
- --with-system-headers \
- --with-system-libs \
- --with-system-jars \
- --with-system-dicts \
- --enable-cairo-canvas \
- --enable-graphite \
- --enable-largefile \
- --enable-mergelibs \
- --enable-python=system \
- --enable-randr \
- --enable-randr-link \
- --enable-release-build \
- --enable-unix-qstart-libpng \
- --enable-hardlink-deliver \
- --disable-ccache \
- --disable-crashdump \
- --disable-dependency-tracking \
- --disable-epm \
- --disable-fetch-external \
- --disable-gnome-vfs \
- --disable-gstreamer-0-10 \
- --disable-ext-report-builder \
- --disable-kdeab \
- --disable-kde \
- --disable-online-update \
- --disable-pch \
- --disable-rpath \
- --disable-systray \
- --disable-zenity \
- --with-alloc=$(use jemalloc && echo "jemalloc" || echo "system") \
- --with-build-version="Gentoo official package" \
- --enable-extension-integration \
- --with-external-dict-dir="${EPREFIX}/usr/share/myspell" \
- --with-external-hyph-dir="${EPREFIX}/usr/share/myspell" \
- --with-external-thes-dir="${EPREFIX}/usr/share/myspell" \
- --with-external-tar="${DISTDIR}" \
- --with-lang="" \
- --with-parallelism=${jbs} \
- --with-system-ucpp \
- --with-unix-wrapper=libreoffice \
- --with-vendor="Gentoo Foundation" \
- --with-x \
- --without-afms \
- --without-fonts \
- --without-myspell-dicts \
- --without-system-mozilla \
- --without-help \
- --with-helppack-integration \
- --without-sun-templates \
- $(use_enable bluetooth sdremote-bluetooth) \
- $(use_enable cups) \
- $(use_enable debug) \
- $(use_enable dbus) \
- $(use_enable eds evolution2) \
- $(use_enable gnome gconf) \
- $(use_enable gnome gio) \
- $(use_enable gnome lockdown) \
- $(use_enable gtk) \
- $(use_enable kde kde4) \
- $(use_enable mysql ext-mysql-connector) \
- $(use_enable odk) \
- $(use_enable opengl) \
- $(use_enable postgres postgresql-sdbc) \
- $(use_enable telepathy) \
- $(use_enable test linkoo) \
- $(use_enable vba) \
- $(use_enable webdav neon) \
- $(use_with java) \
- $(use_with mysql system-mysql-cppconn) \
- $(use_with odk doxygen) \
- ${internal_libs} \
- ${java_opts} \
- ${ext_opts}
-}
-
-src_compile() {
- # hack for offlinehelp, this needs fixing upstream at some point
- # it is broken because we send --without-help
- # https://bugs.freedesktop.org/show_bug.cgi?id=46506
- (
- grep "^export" "${S}/config_host.mk" > "${T}/config_host.mk"
- source "${T}/config_host.mk" 2&> /dev/null
-
- local path="${SOLARVER}/${INPATH}/res/img"
- mkdir -p "${path}" || die
-
- echo "perl \"${S}/helpcontent2/helpers/create_ilst.pl\" -dir=icon-themes/galaxy/res/helpimg > \"${path}/helpimg.ilst\""
- perl "${S}/helpcontent2/helpers/create_ilst.pl" \
- -dir=icon-themes/galaxy/res/helpimg \
- > "${path}/helpimg.ilst"
- [[ -s "${path}/helpimg.ilst" ]] || ewarn "The help images list is empty, something is fishy, report a bug."
- )
-
- # this is not a proper make script
- make build || die
-}
-
-src_test() {
- make unitcheck || die
- make slowcheck || die
-}
-
-src_install() {
- # This is not Makefile so no buildserver
- make DESTDIR="${D}" distro-pack-install -o build -o check || die
-
- # Fix bash completion placement
- newbashcomp "${ED}"/etc/bash_completion.d/libreoffice.sh ${PN}
- rm -rf "${ED}"/etc/
-
- if use branding; then
- insinto /usr/$(get_libdir)/${PN}/program
- newins "${WORKDIR}/branding-sofficerc" sofficerc
- fi
-
- # symlink the nsplugin to proper location
- use gtk && inst_plugin /usr/$(get_libdir)/libreoffice/program/libnpsoplugin.so
-
- # Hack for offlinehelp, this needs fixing upstream at some point.
- # It is broken because we send --without-help
- # https://bugs.freedesktop.org/show_bug.cgi?id=46506
- insinto /usr/$(get_libdir)/libreoffice/help
- doins xmlhelp/util/*.xsl
-
- # Remove desktop files for support to old installs that can't parse mime
- rm -rf "${ED}"/usr/share/mimelnk/
-}
-
-pkg_preinst() {
- # Cache updates - all handled by kde eclass for all environments
- kde4-base_pkg_preinst
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
- pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
-
- use java || \
- ewarn 'If you plan to use lbase application you should enable java or you will get various crashes.'
-}
-
-pkg_postrm() {
- kde4-base_pkg_postrm
-}

0 comments on commit 8ae2424

Please sign in to comment.