Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

glorious funtoo updates

merged:

  gentoo: df8ee1468c5772b80ad56afe4f2ab9e677ac3a4c
  funtoo-overlay: ebff793f9d1cebe091dd683ed23720bb96a1befd
  foo-overlay: 6d128ac65f6ebc196314bc1fa6473281b3cae87c
  bar-overlay: f4de124575d7b52467a0bfa4839a96eac3098528
  flora: 2b2bf01f174202e892041b6aaf2a08b58114b84f
  • Loading branch information...
commit e132f90982b21b0a840bee674350e6d0a4980e58 1 parent c32c304
@danielrobbins danielrobbins authored
View
15 metadata/md5-cache/sys-apps/portage-2.3.3-r3
@@ -0,0 +1,15 @@
+DEFINED_PHASES=compile install postinst postrm preinst prepare setup test unpack
+DEPEND=python3? ( =dev-lang/python-3* ) !python2? ( !python3? ( build? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] ) ) !build? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] >=dev-lang/python-3 ) ) ) ) python2? ( !python3? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] ) ) ) !build? ( >=sys-apps/sed-4.0.5 ) doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 ) epydoc? ( >=dev-python/epydoc-2.0 !<=dev-python/pysqlite-2.4.1 )
+DESCRIPTION=Portage is the package management and distribution system for Gentoo
+EAPI=2
+HOMEPAGE=http://www.gentoo.org/proj/en/portage/index.xml
+IUSE=build doc epydoc +ipc linguas_pl python2 python3 selinux
+KEYWORDS=*
+LICENSE=GPL-2
+PDEPEND=!build? ( >=net-misc/rsync-1.6.4 userland_GNU? ( >=sys-apps/coreutils-5.4 ) ) >=sys-devel/libtool-2.4-r3
+RDEPEND=python3? ( =dev-lang/python-3* ) !python2? ( !python3? ( build? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] ) ) !build? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] >=dev-lang/python-3 ) ) ) ) python2? ( !python3? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] ) ) ) !build? ( >=sys-apps/sed-4.0.5 >=app-shells/bash-3.2_p17 >=app-admin/eselect-1.2 ) elibc_FreeBSD? ( sys-freebsd/freebsd-bin ) elibc_glibc? ( >=sys-apps/sandbox-2.2 ) elibc_uclibc? ( >=sys-apps/sandbox-2.2 ) >=app-misc/pax-utils-0.1.17 selinux? ( || ( >=sys-libs/libselinux-2.0.94[python] <sys-libs/libselinux-2.0.94 ) ) !<app-shells/bash-3.2_p17
+RESTRICT=mirror
+SLOT=0
+SRC_URI=https://www.github.com/funtoo/portage-funtoo/tarball/funtoo-2.3.3-r3 -> portage-funtoo-2.3.3-r3.tar.gz linguas_pl? ( mirror://gentoo/portage-man-pl-2.1.2.tar.bz2 )
+_eclasses_=eutils 4e234f0a75d16eabe69191b391892d7b multilib 5f4ad6cf85e365e8f0c6050ddd21659e python cb2844e25e38800105564c14a716c805 toolchain-funcs 6526ac6fc9aedf391efb91fcd75ace68 user 32a09e82e2f592bf88ad2fd08525166e
+_md5_=15c8fecd58d496ade7c3fbad1a0df7bd
View
383 sys-apps/portage/portage-2.3.3-r3.ebuild
@@ -0,0 +1,383 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.2.0_alpha41.ebuild,v 1.1 2011/06/14 00:42:00 zmedico Exp $
+
+# Require EAPI 2 since we now require at least python-2.6 (for python 3
+# syntax support) which also requires EAPI 2.
+EAPI=2
+inherit eutils multilib python
+
+DESCRIPTION="Portage is the package management and distribution system for Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
+LICENSE="GPL-2"
+KEYWORDS="*"
+SLOT="0"
+IUSE="build doc epydoc +ipc linguas_pl python2 python3 selinux"
+GITHUB_REPO="portage-funtoo"
+GITHUB_USER="funtoo"
+GITHUB_TAG="funtoo-${PVR}"
+RESTRICT="mirror"
+
+python_dep="python3? ( =dev-lang/python-3* )
+ !python2? ( !python3? (
+ build? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] ) )
+ !build? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] >=dev-lang/python-3 ) )
+ ) )
+ python2? ( !python3? ( || ( dev-lang/python:2.7 dev-lang/python:2.6[threads] ) ) )"
+
+# The pysqlite blocker is for bug #282760.
+DEPEND="${python_dep}
+ !build? ( >=sys-apps/sed-4.0.5 )
+ doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
+ epydoc? ( >=dev-python/epydoc-2.0 !<=dev-python/pysqlite-2.4.1 )"
+# Require sandbox-2.2 for bug #288863.
+RDEPEND="${python_dep}
+ !build? ( >=sys-apps/sed-4.0.5
+ >=app-shells/bash-3.2_p17
+ >=app-admin/eselect-1.2 )
+ elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
+ elibc_glibc? ( >=sys-apps/sandbox-2.2 )
+ elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
+ >=app-misc/pax-utils-0.1.17
+ selinux? ( || ( >=sys-libs/libselinux-2.0.94[python] <sys-libs/libselinux-2.0.94 ) )
+ !<app-shells/bash-3.2_p17"
+PDEPEND="
+ !build? (
+ >=net-misc/rsync-1.6.4
+ userland_GNU? ( >=sys-apps/coreutils-5.4 )
+ )
+ >=sys-devel/libtool-2.4-r3"
+# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
+# NOTE: FEATURES=install-sources requires debugedit and rsync
+
+SRC_ARCHIVES="http://dev.gentoo.org/~zmedico/portage/archives"
+
+prefix_src_archives() {
+ local x y
+ for x in ${@}; do
+ for y in ${SRC_ARCHIVES}; do
+ echo ${y}/${x}
+ done
+ done
+}
+
+PV_PL="2.1.2"
+PATCHVER_PL=""
+SRC_URI="https://www.github.com/${GITHUB_USER}/${GITHUB_REPO}/tarball/${GITHUB_TAG} -> portage-${GITHUB_TAG}.tar.gz"
+SRC_URI="$SRC_URI linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}.tar.bz2 )"
+S_PL="${WORKDIR}"/${PN}-${PV_PL}
+
+compatible_python_is_selected() {
+ [[ $(/usr/bin/python -c 'import sys ; sys.stdout.write(sys.hexversion >= 0x2060000 and "good" or "bad")') = good ]]
+}
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}/${GITHUB_USER}-${PN}-funtoo"-??????? "${S}" || die
+}
+
+pkg_setup() {
+ # Bug #359731 - Die early if get_libdir fails.
+ [[ -z $(get_libdir) ]] && \
+ die "get_libdir returned an empty string"
+
+ if use python2 && use python3 ; then
+ ewarn "Both python2 and python3 USE flags are enabled, but only one"
+ ewarn "can be in the shebangs. Using python3."
+ fi
+ if ! use python2 && ! use python3 && ! compatible_python_is_selected ; then
+ ewarn "Attempting to select a compatible default python interpreter"
+ local x success=0
+ for x in /usr/bin/python2.* ; do
+ x=${x#/usr/bin/python2.}
+ if [[ $x -ge 6 ]] 2>/dev/null ; then
+ eselect python set python2.$x
+ if compatible_python_is_selected ; then
+ elog "Default python interpreter is now set to python-2.$x"
+ success=1
+ break
+ fi
+ fi
+ done
+ if [ $success != 1 ] ; then
+ eerror "Unable to select a compatible default python interpreter!"
+ die "This version of portage requires at least python-2.6 to be selected as the default python interpreter (see \`eselect python --help\`)."
+ fi
+ fi
+
+ if use python3; then
+ python_set_active_version 3
+ elif use python2; then
+ python_set_active_version 2
+ fi
+}
+
+src_prepare() {
+ if [ -n "${PATCHVER}" ] ; then
+ if [[ -L $S/bin/ebuild-helpers/portageq ]] ; then
+ rm "$S/bin/ebuild-helpers/portageq" \
+ || die "failed to remove portageq helper symlink"
+ fi
+ epatch "${WORKDIR}/${PN}-${PATCHVER}.patch"
+ fi
+ einfo "Setting portage.VERSION to ${PVR} ..."
+ sed -e "s/^VERSION=.*/VERSION=\"${PVR}\"/" -i pym/portage/__init__.py || \
+ die "Failed to patch portage.VERSION"
+ sed -e "1s/VERSION/${PVR}/" -i doc/fragment/version || \
+ die "Failed to patch VERSION in doc/fragment/version"
+ sed -e "1s/VERSION/${PVR}/" -i man/* || \
+ die "Failed to patch VERSION in man page headers"
+
+ if ! use ipc ; then
+ einfo "Disabling ipc..."
+ sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
+ -i pym/_emerge/AbstractEbuildProcess.py || \
+ die "failed to patch AbstractEbuildProcess.py"
+ fi
+
+ if use python3; then
+ einfo "Converting shebangs for python3..."
+ python_convert_shebangs -r 3 .
+ elif use python2; then
+ einfo "Converting shebangs for python2..."
+ python_convert_shebangs -r 2 .
+ fi
+}
+
+src_compile() {
+ if use doc; then
+ cd "${S}"/doc
+ touch fragment/date
+ make xhtml xhtml-nochunks || die "failed to make docs"
+ fi
+
+ if use epydoc; then
+ einfo "Generating api docs"
+ mkdir "${WORKDIR}"/api
+ local my_modules epydoc_opts=""
+ my_modules="$(find "${S}/pym" -name "*.py" \
+ | sed -e 's:/__init__.py$::' -e 's:\.py$::' -e "s:^${S}/pym/::" \
+ -e 's:/:.:g' | sort)" || die "error listing modules"
+ # workaround for bug 282760
+ > "$S/pym/pysqlite2.py"
+ PYTHONPATH=${S}/pym:${PYTHONPATH:+:}${PYTHONPATH} \
+ epydoc -o "${WORKDIR}"/api \
+ -qqqqq --no-frames --show-imports $epydoc_opts \
+ --name "${PN}" --url "${HOMEPAGE}" \
+ ${my_modules} || die "epydoc failed"
+ rm "$S/pym/pysqlite2.py"
+ fi
+}
+
+src_test() {
+ # make files executable, in case they were created by patch
+ find bin -type f | xargs chmod +x
+ PYTHONPATH=${S}/pym:${PYTHONPATH:+:}${PYTHONPATH} \
+ ./pym/portage/tests/runTests || die "test(s) failed"
+}
+
+src_install() {
+ local libdir=$(get_libdir)
+ local portage_base="/usr/${libdir}/portage"
+ local portage_share_config=/usr/share/portage/config
+
+ cd "${S}"/cnf
+ insinto /etc
+ doins etc-update.conf dispatch-conf.conf || die
+
+ insinto "$portage_share_config/sets"
+ doins "$S"/cnf/sets/*.conf || die
+ insinto "$portage_share_config"
+ doins "$S/cnf/make.globals" || die
+ if [ -f "make.conf.${ARCH}".diff ]; then
+ patch make.conf "make.conf.${ARCH}".diff || \
+ die "Failed to patch make.conf.example"
+ newins make.conf make.conf.example || die
+ else
+ eerror ""
+ eerror "Portage does not have an arch-specific configuration for this arch."
+ eerror "Please notify the arch maintainer about this issue. Using generic."
+ eerror ""
+ newins make.conf make.conf.example || die
+ fi
+
+ dosym ..${portage_share_config}/make.globals /etc/make.globals
+
+ insinto /etc/logrotate.d
+ doins "${S}"/cnf/logrotate.d/elog-save-summary || die
+
+ # BSD and OSX need a sed wrapper so that find/xargs work properly
+ # This does not exist in Funtoo Linux.
+ if use userland_GNU; then
+ if [ -e "${S}"/bin/ebuild-helpers/sed ]; then
+ rm "${S}"/bin/ebuild-helpers/sed || die "Failed to remove sed wrapper"
+ fi
+ fi
+
+ local x symlinks files
+
+ cd "$S" || die "cd failed"
+ for x in $(find bin -type d) ; do
+ exeinto $portage_base/$x || die "exeinto failed"
+ cd "$S"/$x || die "cd failed"
+ files=$(find . -mindepth 1 -maxdepth 1 -type f ! -type l)
+ if [ -n "$files" ] ; then
+ doexe $files || die "doexe failed"
+ fi
+ symlinks=$(find . -mindepth 1 -maxdepth 1 -type l)
+ if [ -n "$symlinks" ] ; then
+ cp -P $symlinks "$D$portage_base/$x" || die "cp failed"
+ fi
+ done
+
+ cd "$S" || die "cd failed"
+ for x in $(find pym/* -type d) ; do
+ insinto $portage_base/$x || die "insinto failed"
+ cd "$S"/$x || die "cd failed"
+ # __pycache__ directories contain no py files
+ [[ "*.py" != $(echo *.py) ]] || continue
+ doins *.py || die "doins failed"
+ symlinks=$(find . -mindepth 1 -maxdepth 1 -type l)
+ if [ -n "$symlinks" ] ; then
+ cp -P $symlinks "$D$portage_base/$x" || die "cp failed"
+ fi
+ done
+
+ # Symlinks to directories cause up/downgrade issues and the use of these
+ # modules outside of portage is probably negligible.
+ for x in "${D}${portage_base}/pym/"{cache,elog_modules} ; do
+ [ ! -L "${x}" ] && continue
+ die "symlink to directory will cause upgrade/downgrade issues: '${x}'"
+ done
+
+ exeinto ${portage_base}/pym/portage/tests
+ doexe "${S}"/pym/portage/tests/runTests
+
+ doman "${S}"/man/*.[0-9]
+ if use linguas_pl; then
+ doman -i18n=pl "${S_PL}"/man/pl/*.[0-9]
+ doman -i18n=pl_PL.UTF-8 "${S_PL}"/man/pl_PL.UTF-8/*.[0-9]
+ fi
+
+ dodoc "${S}"/{NEWS,RELEASE-NOTES}
+ use doc && dohtml -r "${S}"/doc/*
+ use epydoc && dohtml -r "${WORKDIR}"/api
+
+ dodir /usr/bin
+ for x in ebuild egencache emerge portageq quickpkg repoman ; do
+ dosym ../${libdir}/portage/bin/${x} /usr/bin/${x}
+ done
+
+ dodir /usr/sbin
+ local my_syms="archive-conf
+ dispatch-conf
+ emaint
+ env-update
+ etc-update
+ fixpackages
+ regenworld"
+ local x
+ for x in ${my_syms}; do
+ dosym ../${libdir}/portage/bin/${x} /usr/sbin/${x}
+ done
+ dosym env-update /usr/sbin/update-env
+ dosym etc-update /usr/sbin/update-etc
+
+ dodir /etc/portage
+ keepdir /etc/portage
+}
+
+pkg_preinst() {
+ if ! use build && ! has_version dev-python/pycrypto && \
+ ! has_version '>=dev-lang/python-2.6[ssl]' ; then
+ ewarn "If you are an ebuild developer and you plan to commit ebuilds"
+ ewarn "with this system then please install dev-python/pycrypto or"
+ ewarn "enable the ssl USE flag for >=dev-lang/python-2.6 in order"
+ ewarn "to enable RMD160 hash support."
+ ewarn "See bug #198398 for more information."
+ fi
+ if [ -f "${ROOT}/etc/make.globals" ]; then
+ rm "${ROOT}/etc/make.globals"
+ fi
+
+ has_version "<${CATEGORY}/${PN}-2.2_alpha"
+ MINOR_UPGRADE=$?
+
+ has_version "<=${CATEGORY}/${PN}-2.2_pre5"
+ WORLD_MIGRATION_UPGRADE=$?
+
+ # If portage-2.1.6 is installed and the preserved_libs_registry exists,
+ # assume that the NEEDED.ELF.2 files have already been generated.
+ has_version "<=${CATEGORY}/${PN}-2.2_pre7" && \
+ ! ( [ -e "$ROOT"var/lib/portage/preserved_libs_registry ] && \
+ has_version ">=${CATEGORY}/${PN}-2.1.6_rc" )
+ NEEDED_REBUILD_UPGRADE=$?
+
+ [[ -n $PORTDIR_OVERLAY ]] && has_version "<${CATEGORY}/${PN}-2.1.6.12"
+ REPO_LAYOUT_CONF_WARN=$?
+}
+
+pkg_postinst() {
+ # Compile all source files recursively. Any orphans
+ # will be identified and removed in postrm.
+ python_mod_optimize /usr/$(get_libdir)/portage/pym
+
+ if [ $WORLD_MIGRATION_UPGRADE = 0 ] ; then
+ einfo "moving set references from the worldfile into world_sets"
+ cd "${ROOT}/var/lib/portage/"
+ grep "^@" world >> world_sets
+ sed -i -e '/^@/d' world
+ fi
+
+ if [ $NEEDED_REBUILD_UPGRADE = 0 ] ; then
+ einfo "rebuilding NEEDED.ELF.2 files"
+ for cpv in "${ROOT}/var/db/pkg"/*/*; do
+ if [ -f "${cpv}/NEEDED" ]; then
+ rm -f "${cpv}/NEEDED.ELF.2"
+ while read line; do
+ filename=${line% *}
+ needed=${line#* }
+ needed=${needed//+/++}
+ needed=${needed//#/##}
+ needed=${needed//%/%%}
+ newline=$(scanelf -BF "%a;%F;%S;%r;${needed}" $filename)
+ newline=${newline// - }
+ echo "${newline:3}" >> "${cpv}/NEEDED.ELF.2"
+ done < "${cpv}/NEEDED"
+ fi
+ done
+ fi
+
+ if [ $REPO_LAYOUT_CONF_WARN = 0 ] ; then
+ ewarn
+ echo "If you want overlay eclasses to override eclasses from" \
+ "other repos then see the portage(5) man page" \
+ "for information about the new layout.conf and repos.conf" \
+ "configuration files." \
+ | fmt -w 75 | while read -r ; do ewarn "$REPLY" ; done
+ ewarn
+ fi
+
+ einfo
+ einfo "For help with using portage please consult the Gentoo Handbook"
+ einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+ einfo
+
+ if [ $MINOR_UPGRADE = 0 ] ; then
+ elog "If you're upgrading from a pre-2.2 version of portage you might"
+ elog "want to remerge world (emerge -e world) to take full advantage"
+ elog "of some of the new features in 2.2."
+ elog "This is not required however for portage to function properly."
+ elog
+ fi
+
+ if [ -z "${PV/*_alpha*}" ]; then
+ elog "If you always want to use the latest development version of portage"
+ elog "please read http://www.gentoo.org/proj/en/portage/doc/testing.xml"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/portage/pym
+}
Please sign in to comment.
Something went wrong with that request. Please try again.