Skip to content
Browse files

glorious funtoo updates

merged:

  gentoo: 45c799d61e856095faf460ecbd2961f2c44bb648
  funtoo-overlay: 4424865e703c0939f8349077dc7ccbe20a17f8c3
  foo-overlay: 4e928d47e22991dc209ec57d02372c56ceff4275
  bar-overlay: 6c956f1ca6178fed85bda46013da787239706d7c
  flora: 19e4f26bfcc59bd95e10a3a55fa9c40cf83e02d4
  lcd-filtering: dd3d9b094dbfc726ee9b3d886783a18b92f899fd
  mythtv: 1500bdb1a6ca4b93a7bd05e4266e0b4c7d094a34
  • Loading branch information...
1 parent 218332c commit 2c1b22fdc94364286bdb9ac6842e0cc6282b7bc9 @danielrobbins danielrobbins committed Aug 10, 2012
Showing with 3,595 additions and 1,622 deletions.
  1. +2 −2 app-admin/lib_users/lib_users-0.5.ebuild
  2. +3 −3 app-dicts/prime-dict/prime-dict-1.0.0-r1.ebuild
  3. +2 −2 app-editors/dhex/dhex-0.67.ebuild
  4. +2 −2 app-misc/tmux/tmux-1.6.ebuild
  5. +3 −5 app-office/libreoffice-l10n/libreoffice-l10n-3.6.0.4.ebuild
  6. +0 −100 app-office/libreoffice-l10n/libreoffice-l10n-3.6.0.ebuild
  7. +2 −2 app-office/libreoffice/libreoffice-3.6.0.4.ebuild
  8. +2 −2 app-office/libreoffice/libreoffice-3.6.9999.ebuild
  9. +5 −3 app-office/libreoffice/libreoffice-9999-r2.ebuild
  10. +2 −2 app-office/pybliographer/pybliographer-1.2.15.ebuild
  11. +2 −0 app-text/ghostscript-gpl/Manifest
  12. +226 −0 app-text/ghostscript-gpl/ghostscript-gpl-9.06.ebuild
  13. +19 −0 app-text/leechcraft-monocle/files/monocle-poppler.patch
  14. +3 −1 app-text/leechcraft-monocle/leechcraft-monocle-0.5.75.ebuild
  15. +5 −5 app-text/sigil/sigil-0.4.2.ebuild
  16. +5 −5 app-text/sigil/sigil-0.4.905_beta1.ebuild
  17. +5 −5 app-text/sigil/sigil-0.5.0.ebuild
  18. +5 −5 app-text/sigil/sigil-0.5.3.ebuild
  19. +2 −2 app-text/ttf2pk2/ttf2pk2-1.5_p20120701.ebuild
  20. +1 −0 dev-ruby/actionmailer/Manifest
  21. +36 −0 dev-ruby/actionmailer/actionmailer-3.2.8.ebuild
  22. +1 −0 dev-ruby/actionpack/Manifest
  23. +67 −0 dev-ruby/actionpack/actionpack-3.2.8.ebuild
  24. +1 −0 dev-ruby/activemodel/Manifest
  25. +42 −0 dev-ruby/activemodel/activemodel-3.2.8.ebuild
  26. +1 −0 dev-ruby/activerecord/Manifest
  27. +74 −0 dev-ruby/activerecord/activerecord-3.2.8.ebuild
  28. +1 −0 dev-ruby/activeresource/Manifest
  29. +40 −0 dev-ruby/activeresource/activeresource-3.2.8.ebuild
  30. +1 −0 dev-ruby/activesupport/Manifest
  31. +47 −0 dev-ruby/activesupport/activesupport-3.2.8.ebuild
  32. +1 −4 dev-ruby/aws-sdk/Manifest
  33. +0 −63 dev-ruby/aws-sdk/aws-sdk-1.5.6.ebuild
  34. +0 −59 dev-ruby/aws-sdk/aws-sdk-1.5.8.ebuild
  35. +0 −59 dev-ruby/aws-sdk/aws-sdk-1.6.0.ebuild
  36. +5 −4 dev-ruby/aws-sdk/{aws-sdk-1.6.2.ebuild → aws-sdk-1.6.3.ebuild}
  37. +38 −0 dev-ruby/aws-sdk/files/aws-sdk-1.6.3-no-simplecov.patch
  38. +2 −2 dev-ruby/bacon/bacon-1.1.0-r1.ebuild
  39. +2 −2 dev-ruby/mail/mail-2.3.3.ebuild
  40. +2 −2 dev-ruby/rack/rack-1.1.3-r1.ebuild
  41. +2 −2 dev-ruby/rack/rack-1.3.6-r1.ebuild
  42. +2 −2 dev-ruby/rack/rack-1.4.1.ebuild
  43. +1 −0 dev-ruby/rails/Manifest
  44. +37 −0 dev-ruby/rails/rails-3.2.8.ebuild
  45. +1 −0 dev-ruby/railties/Manifest
  46. +75 −0 dev-ruby/railties/railties-3.2.8.ebuild
  47. +2 −2 dev-ruby/ruby-fcgi/ruby-fcgi-0.8.8-r2.ebuild
  48. +2 −2 dev-ruby/test-spec/test-spec-0.10.0-r4.ebuild
  49. +2 −2 dev-ruby/treetop/treetop-1.4.10-r1.ebuild
  50. +18 −0 dev-tcltk/tcl-mccp/files/tcl-mccp-0.6-flags.patch
  51. +1 −1 dev-tcltk/tcl-mccp/metadata.xml
  52. +9 −6 dev-tcltk/tcl-mccp/tcl-mccp-0.6.ebuild
  53. +2 −2 dev-util/dmake/dmake-4.12.2.ebuild
  54. +2 −2 dev-util/global/global-6.2.4.ebuild
  55. +2 −2 dev-util/re2c/re2c-0.13.5-r1.ebuild
  56. +3 −3 dev-vcs/rapidsvn/rapidsvn-0.12.1_pre8247.ebuild
  57. +2 −3 gnome-base/gnome-common/Manifest
  58. +0 −19 gnome-base/gnome-common/gnome-common-2.28.0.ebuild
  59. +0 −19 gnome-base/gnome-common/gnome-common-2.34.0.ebuild
  60. +21 −0 gnome-base/gnome-common/gnome-common-3.4.0.1.ebuild
  61. +1 −0 media-libs/fdk-aac/Manifest
  62. +45 −0 media-libs/fdk-aac/fdk-aac-0.1.0.ebuild
  63. +6 −0 media-libs/fdk-aac/metadata.xml
  64. +1 −1 media-libs/giblib/Manifest
  65. +31 −0 media-libs/giblib/giblib-1.2.4-r1.ebuild
  66. +1 −1 media-libs/libcdr/Manifest
  67. +2 −1 media-libs/libcdr/libcdr-0.0.8.ebuild
  68. +2 −1 media-libs/libcdr/libcdr-9999.ebuild
  69. +1 −2 media-plugins/kipi-plugins/kipi-plugins-2.6.0-r1.ebuild
  70. +1 −2 media-plugins/kipi-plugins/kipi-plugins-2.6.0.ebuild
  71. +2 −2 media-sound/alsa-utils/Manifest
  72. +86 −0 media-sound/alsa-utils/alsa-utils-1.0.25-r3.ebuild
  73. +1 −1 metadata/dtd/timestamp.chk
  74. +1 −1 metadata/glsa/timestamp.chk
  75. +2 −2 metadata/md5-cache/app-admin/lib_users-0.5
  76. +2 −2 metadata/md5-cache/app-dicts/prime-dict-1.0.0-r1
  77. +2 −2 metadata/md5-cache/app-editors/dhex-0.67
  78. +2 −2 metadata/md5-cache/app-misc/tmux-1.6
  79. +2 −2 metadata/md5-cache/app-office/libreoffice-3.6.0.4
  80. +2 −2 metadata/md5-cache/app-office/libreoffice-3.6.9999
  81. +2 −2 metadata/md5-cache/app-office/libreoffice-9999-r2
  82. +0 −14 metadata/md5-cache/app-office/libreoffice-l10n-3.6.0
  83. +2 −2 metadata/md5-cache/app-office/libreoffice-l10n-3.6.0.4
  84. +2 −2 metadata/md5-cache/app-office/pybliographer-1.2.15
  85. +13 −0 metadata/md5-cache/app-text/ghostscript-gpl-9.06
  86. +1 −1 metadata/md5-cache/app-text/leechcraft-monocle-0.5.75
  87. +3 −3 metadata/md5-cache/app-text/sigil-0.4.2
  88. +3 −3 metadata/md5-cache/app-text/sigil-0.4.905_beta1
  89. +3 −3 metadata/md5-cache/app-text/sigil-0.5.0
  90. +3 −3 metadata/md5-cache/app-text/sigil-0.5.3
  91. +2 −2 metadata/md5-cache/app-text/ttf2pk2-1.5_p20120701
  92. +14 −0 metadata/md5-cache/dev-ruby/actionmailer-3.2.8
  93. +14 −0 metadata/md5-cache/dev-ruby/actionpack-3.2.8
  94. +14 −0 metadata/md5-cache/dev-ruby/activemodel-3.2.8
  95. +14 −0 metadata/md5-cache/dev-ruby/activerecord-3.2.8
  96. +14 −0 metadata/md5-cache/dev-ruby/activeresource-3.2.8
  97. +14 −0 metadata/md5-cache/dev-ruby/activesupport-3.2.8
  98. +0 −14 metadata/md5-cache/dev-ruby/aws-sdk-1.5.6
  99. +0 −14 metadata/md5-cache/dev-ruby/aws-sdk-1.5.8
  100. +0 −14 metadata/md5-cache/dev-ruby/aws-sdk-1.6.0
  101. +2 −2 metadata/md5-cache/dev-ruby/{aws-sdk-1.6.2 → aws-sdk-1.6.3}
  102. +2 −2 metadata/md5-cache/dev-ruby/bacon-1.1.0-r1
  103. +2 −2 metadata/md5-cache/dev-ruby/mail-2.3.3
  104. +2 −2 metadata/md5-cache/dev-ruby/rack-1.1.3-r1
  105. +2 −2 metadata/md5-cache/dev-ruby/rack-1.3.6-r1
  106. +2 −2 metadata/md5-cache/dev-ruby/rack-1.4.1
  107. +14 −0 metadata/md5-cache/dev-ruby/rails-3.2.8
  108. +15 −0 metadata/md5-cache/dev-ruby/railties-3.2.8
  109. +2 −2 metadata/md5-cache/dev-ruby/ruby-fcgi-0.8.8-r2
  110. +2 −2 metadata/md5-cache/dev-ruby/test-spec-0.10.0-r4
  111. +2 −2 metadata/md5-cache/dev-ruby/treetop-1.4.10-r1
  112. +5 −2 metadata/md5-cache/dev-tcltk/tcl-mccp-0.6
  113. +2 −2 metadata/md5-cache/dev-util/dmake-4.12.2
  114. +2 −2 metadata/md5-cache/dev-util/global-6.2.4
  115. +2 −2 metadata/md5-cache/dev-util/re2c-0.13.5-r1
  116. +1 −1 metadata/md5-cache/dev-vcs/rapidsvn-0.12.1_pre8247
  117. +0 −9 metadata/md5-cache/gnome-base/gnome-common-2.28.0
  118. +0 −9 metadata/md5-cache/gnome-base/gnome-common-2.34.0
  119. +11 −0 metadata/md5-cache/gnome-base/gnome-common-3.4.0.1
  120. +12 −0 metadata/md5-cache/media-libs/fdk-aac-0.1.0
  121. +13 −0 metadata/md5-cache/media-libs/giblib-1.2.4-r1
  122. +1 −1 metadata/md5-cache/media-libs/libcdr-0.0.8
  123. +1 −1 metadata/md5-cache/media-libs/libcdr-9999
  124. +1 −1 metadata/md5-cache/media-plugins/kipi-plugins-2.6.0
  125. +1 −1 metadata/md5-cache/media-plugins/kipi-plugins-2.6.0-r1
  126. +13 −0 metadata/md5-cache/media-sound/alsa-utils-1.0.25-r3
  127. +15 −0 metadata/md5-cache/net-fs/samba-3.6.7
  128. +2 −1 metadata/md5-cache/net-im/{leechcraft-azoth-0.5.75 → leechcraft-azoth-0.5.75-r1}
  129. +2 −1 metadata/md5-cache/net-im/leechcraft-azoth-9999
  130. +2 −2 metadata/md5-cache/net-im/pidgin-2.10.6
  131. +2 −2 metadata/md5-cache/net-irc/loqui-0.5.3
  132. +2 −2 metadata/md5-cache/net-libs/libkolabxml-0.6.0
  133. +13 −0 metadata/md5-cache/net-libs/libkolabxml-0.8.0
  134. +13 −0 metadata/md5-cache/net-misc/leechcraft-core-0.5.70-r1
  135. +1 −1 metadata/md5-cache/net-misc/{leechcraft-core-0.5.75 → leechcraft-core-0.5.75-r1}
  136. +3 −2 metadata/md5-cache/net-misc/leechcraft-core-9999
  137. +3 −3 metadata/md5-cache/net-misc/leechcraft-liznoo-0.5.70
  138. +3 −3 metadata/md5-cache/net-misc/leechcraft-liznoo-0.5.75
  139. +3 −3 metadata/md5-cache/net-misc/leechcraft-liznoo-9999
  140. +4 −4 metadata/md5-cache/net-misc/leechcraft-netstoremanager-9999
  141. +0 −12 metadata/md5-cache/net-misc/uftp-3.3.3
  142. +13 −0 metadata/md5-cache/net-misc/uftp-3.7
  143. +1 −1 metadata/md5-cache/net-proxy/{adzapper-20110915 → adzapper-20110915-r1}
  144. +13 −0 metadata/md5-cache/net-wireless/bluez-4.101-r2
  145. +2 −2 metadata/md5-cache/net-wireless/crda-1.1.2-r3
  146. +12 −0 metadata/md5-cache/net-wireless/crda-1.1.2-r4
  147. +2 −2 metadata/md5-cache/net-wireless/iwl6000-ucode-9.221.4.1
  148. +1 −1 metadata/md5-cache/sci-libs/gdal-1.9.1
  149. +4 −4 metadata/md5-cache/sci-mathematics/spass-3.7
  150. +2 −2 metadata/md5-cache/sys-apps/unscd-0.49
  151. +2 −2 metadata/md5-cache/sys-auth/nss-mdns-0.10-r1
  152. +0 −11 metadata/md5-cache/sys-block/ms-sys-2.2.1
  153. +2 −2 metadata/md5-cache/sys-block/ms-sys-2.3.0
  154. +1 −1 metadata/md5-cache/{sys-apps → sys-block}/whdd-1.0
  155. +1 −1 metadata/md5-cache/{sys-apps → sys-block}/whdd-9999
  156. +14 −0 metadata/md5-cache/sys-devel/binutils-apple-3.2
  157. +2 −2 metadata/md5-cache/sys-fs/dd-rescue-1.25
  158. +2 −2 metadata/md5-cache/sys-fs/ddrescue-1.16
  159. +13 −0 metadata/md5-cache/sys-fs/fuse-2.9.1-r1
  160. +13 −0 metadata/md5-cache/sys-fs/ntfs3g-2012.1.15-r2
  161. +15 −0 metadata/md5-cache/sys-kernel/hardened-sources-3.5.1
  162. +2 −2 metadata/md5-cache/www-client/{opera-next-12.50.1513 → opera-next-12.50.1546}
  163. +0 −14 metadata/md5-cache/x11-drivers/nvidia-drivers-173.14.34
  164. +3 −3 metadata/md5-cache/x11-drivers/nvidia-drivers-173.14.35
  165. +2 −2 metadata/md5-cache/x11-drivers/nvidia-drivers-295.59
  166. +3 −3 metadata/md5-cache/x11-drivers/nvidia-drivers-295.59-r1
  167. +2 −2 metadata/md5-cache/x11-drivers/nvidia-drivers-295.71
  168. +3 −3 metadata/md5-cache/x11-drivers/nvidia-drivers-302.17-r1
  169. +3 −3 metadata/md5-cache/x11-drivers/nvidia-drivers-304.22
  170. +3 −3 metadata/md5-cache/x11-drivers/nvidia-drivers-96.43.20
  171. +1 −1 metadata/md5-cache/x11-misc/colord-0.1.18
  172. +1 −1 metadata/md5-cache/x11-misc/colord-0.1.21
  173. +14 −0 metadata/md5-cache/x11-misc/colord-0.1.21-r1
  174. +13 −0 metadata/md5-cache/x11-misc/dmenu-4.5-r2
  175. +0 −11 metadata/md5-cache/x11-misc/synergy-1.3.1
  176. +0 −12 metadata/md5-cache/x11-misc/synergy-1.3.6
  177. +5 −5 metadata/md5-cache/x11-misc/{synergy-1.4.2 → synergy-1.4.10}
  178. +13 −0 metadata/md5-cache/x11-plugins/compiz-plugins-extra-0.8.8
  179. +2 −2 metadata/md5-cache/x11-plugins/gkrellfire-0.4.2
  180. +2 −2 metadata/md5-cache/x11-plugins/gkrelltop-2.2.11-r1
  181. +2 −2 metadata/md5-cache/x11-terms/mlterm-3.0.11-r1
  182. +11 −0 metadata/md5-cache/x11-themes/gnome-backgrounds-3.4.2
  183. +1 −1 metadata/news/timestamp.chk
  184. +1 −1 metadata/timestamp
  185. +1 −1 metadata/timestamp.chk
  186. +1 −1 metadata/timestamp.x
  187. +9 −8 net-fs/samba/Manifest
  188. +1 −0 net-fs/samba/metadata.xml
  189. +441 −0 net-fs/samba/samba-3.6.7.ebuild
  190. +3 −1 net-im/leechcraft-azoth/{leechcraft-azoth-0.5.75.ebuild → leechcraft-azoth-0.5.75-r1.ebuild}
  191. +3 −1 net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild
  192. +2 −2 net-im/pidgin/pidgin-2.10.6.ebuild
  193. +2 −2 net-irc/loqui/loqui-0.5.3.ebuild
  194. +1 −0 net-libs/libkolabxml/Manifest
  195. +5 −5 net-libs/libkolabxml/libkolabxml-0.6.0.ebuild
  196. +41 −0 net-libs/libkolabxml/libkolabxml-0.8.0.ebuild
  197. +42 −0 net-misc/leechcraft-core/leechcraft-core-0.5.70-r1.ebuild
  198. +6 −3 net-misc/leechcraft-core/{leechcraft-core-0.5.75.ebuild → leechcraft-core-0.5.75-r1.ebuild}
  199. +8 −6 net-misc/leechcraft-core/leechcraft-core-9999.ebuild
  200. +2 −2 net-misc/leechcraft-liznoo/leechcraft-liznoo-0.5.70.ebuild
  201. +2 −2 net-misc/leechcraft-liznoo/leechcraft-liznoo-0.5.75.ebuild
  202. +2 −2 net-misc/leechcraft-liznoo/leechcraft-liznoo-9999.ebuild
  203. +11 −6 net-misc/leechcraft-netstoremanager/leechcraft-netstoremanager-9999.ebuild
  204. +1 −0 net-misc/leechcraft-netstoremanager/metadata.xml
  205. +1 −1 net-misc/uftp/Manifest
  206. +16 −0 net-misc/uftp/files/logrotate
  207. +79 −0 net-misc/uftp/files/uftp-3.7_makefile.patch
  208. +6 −13 net-misc/uftp/files/uftpd.conf
  209. +11 −8 net-misc/uftp/files/uftpd.init
  210. +5 −0 net-misc/uftp/files/uftpproxyd.conf
  211. +24 −0 net-misc/uftp/files/uftpproxyd.init
  212. +12 −0 net-misc/uftp/metadata.xml
  213. +0 −35 net-misc/uftp/uftp-3.3.3.ebuild
  214. +46 −0 net-misc/uftp/uftp-3.7.ebuild
  215. +2 −2 net-proxy/adzapper/{adzapper-20110915.ebuild → adzapper-20110915-r1.ebuild}
  216. +173 −0 net-wireless/bluez/bluez-4.101-r2.ebuild
  217. +2 −2 net-wireless/crda/Manifest
  218. +3 −2 net-wireless/crda/crda-1.1.2-r3.ebuild
  219. +58 −0 net-wireless/crda/crda-1.1.2-r4.ebuild
  220. +1 −1 net-wireless/iwl6000-ucode/Manifest
  221. +2 −2 net-wireless/iwl6000-ucode/iwl6000-ucode-9.221.4.1.ebuild
  222. +1 −0 profiles/updates/3Q-2012
  223. +3 −0 profiles/use.local.desc
  224. +3 −3 sci-libs/gdal/Manifest
  225. +143 −0 sci-libs/gdal/files/gdal-1.9.1-poppler-0.20.1.patch
  226. +9 −5 sci-libs/gdal/gdal-1.9.1.ebuild
  227. +8 −8 sci-mathematics/spass/metadata.xml
  228. +16 −15 sci-mathematics/spass/spass-3.7.ebuild
  229. +5 −5 sys-apps/unscd/Manifest
  230. +2 −2 sys-apps/unscd/unscd-0.49.ebuild
  231. +2 −2 sys-auth/nss-mdns/nss-mdns-0.10-r1.ebuild
  232. +0 −1 sys-block/ms-sys/Manifest
  233. +0 −30 sys-block/ms-sys/ms-sys-2.2.1.ebuild
  234. +2 −2 sys-block/ms-sys/ms-sys-2.3.0.ebuild
  235. 0 {sys-apps → sys-block}/whdd/Manifest
  236. 0 {sys-apps → sys-block}/whdd/metadata.xml
  237. +1 −1 {sys-apps → sys-block}/whdd/whdd-1.0.ebuild
  238. +1 −1 {sys-apps → sys-block}/whdd/whdd-9999.ebuild
  239. +15 −13 sys-devel/binutils-apple/Manifest
  240. +234 −0 sys-devel/binutils-apple/binutils-apple-3.2.ebuild
  241. +10 −0 sys-devel/binutils-apple/files/binutils-apple-3.2-armv7-defines.patch
  242. +2 −2 sys-fs/dd-rescue/dd-rescue-1.25.ebuild
  243. +2 −2 sys-fs/ddrescue/ddrescue-1.16.ebuild
  244. +1 −1 sys-fs/fuse/Manifest
  245. +85 −0 sys-fs/fuse/fuse-2.9.1-r1.ebuild
  246. +1 −1 sys-fs/ntfs3g/Manifest
  247. +80 −0 sys-fs/ntfs3g/ntfs3g-2012.1.15-r2.ebuild
  248. +16 −15 sys-kernel/hardened-sources/Manifest
  249. +50 −0 sys-kernel/hardened-sources/hardened-sources-3.5.1.ebuild
  250. +3 −3 www-client/opera-next/Manifest
  251. +3 −4 www-client/opera-next/{opera-next-12.50.1513.ebuild → opera-next-12.50.1546.ebuild}
  252. +0 −3 x11-drivers/nvidia-drivers/Manifest
  253. +1 −1 x11-drivers/nvidia-drivers/files/nvidia-autostart.desktop
  254. +0 −1 x11-drivers/nvidia-drivers/metadata.xml
  255. +0 −526 x11-drivers/nvidia-drivers/nvidia-drivers-173.14.34.ebuild
  256. +5 −4 x11-drivers/nvidia-drivers/nvidia-drivers-173.14.35.ebuild
  257. +13 −6 x11-drivers/nvidia-drivers/nvidia-drivers-295.59-r1.ebuild
  258. +4 −3 x11-drivers/nvidia-drivers/nvidia-drivers-295.59.ebuild
  259. +4 −3 x11-drivers/nvidia-drivers/nvidia-drivers-295.71.ebuild
  260. +13 −6 x11-drivers/nvidia-drivers/nvidia-drivers-302.17-r1.ebuild
  261. +13 −7 x11-drivers/nvidia-drivers/nvidia-drivers-304.22.ebuild
  262. +4 −3 x11-drivers/nvidia-drivers/nvidia-drivers-96.43.20.ebuild
  263. +2 −2 x11-misc/colord/Manifest
  264. +2 −2 x11-misc/colord/colord-0.1.18.ebuild
  265. +105 −0 x11-misc/colord/colord-0.1.21-r1.ebuild
  266. +2 −2 x11-misc/colord/colord-0.1.21.ebuild
  267. +1 −1 x11-misc/dmenu/Manifest
  268. +51 −0 x11-misc/dmenu/dmenu-4.5-r2.ebuild
  269. +1 −3 x11-misc/synergy/Manifest
  270. +0 −58 x11-misc/synergy/synergy-1.3.1.ebuild
  271. +0 −42 x11-misc/synergy/synergy-1.3.6.ebuild
  272. +15 −12 x11-misc/synergy/{synergy-1.4.2.ebuild → synergy-1.4.10.ebuild}
  273. +1 −0 x11-plugins/compiz-plugins-extra/Manifest
  274. +65 −0 x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild
  275. +2 −2 x11-plugins/gkrellfire/gkrellfire-0.4.2.ebuild
  276. +2 −2 x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
  277. +4 −4 x11-terms/mlterm/Manifest
  278. +2 −2 x11-terms/mlterm/mlterm-3.0.11-r1.ebuild
  279. +4 −3 x11-themes/gnome-backgrounds/Manifest
  280. +22 −0 x11-themes/gnome-backgrounds/gnome-backgrounds-3.4.2.ebuild
View
4 app-admin/lib_users/lib_users-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/lib_users/lib_users-0.5.ebuild,v 1.6 2012/06/13 17:34:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/lib_users/lib_users-0.5.ebuild,v 1.7 2012/08/10 07:47:53 jlec Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -14,7 +14,7 @@ SRC_URI="http://schwarzvogel.de/pkgs/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc x86"
+KEYWORDS="alpha amd64 hppa ppc x86 ~amd64-linux ~x86-linux"
IUSE="test"
DEPEND="test? ( dev-python/nose )"
View
6 app-dicts/prime-dict/prime-dict-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/prime-dict/prime-dict-1.0.0-r1.ebuild,v 1.1 2010/05/27 16:08:48 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/prime-dict/prime-dict-1.0.0-r1.ebuild,v 1.2 2012/08/10 12:50:15 blueness Exp $
EAPI="2"
USE_RUBY="ruby18 ruby19 ree18 jruby"
@@ -13,7 +13,7 @@ SRC_URI="http://prime.sourceforge.jp/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ppc ppc64 ~sparc ~x86"
IUSE=""
each_ruby_configure() {
View
4 app-editors/dhex/dhex-0.67.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/dhex/dhex-0.67.ebuild,v 1.2 2012/08/03 13:28:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/dhex/dhex-0.67.ebuild,v 1.3 2012/08/10 13:06:12 johu Exp $
EAPI=4
@@ -14,7 +14,7 @@ SRC_URI="http://www.dettus.net/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
DEPEND="sys-libs/ncurses"
View
4 app-misc/tmux/tmux-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.6.ebuild,v 1.4 2012/08/05 14:17:06 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.6.ebuild,v 1.5 2012/08/10 10:09:26 ryao Exp $
EAPI=4
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="vim-syntax"
DEPEND="
View
8 app-office/libreoffice-l10n/libreoffice-l10n-3.6.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/libreoffice-l10n-3.6.0.4.ebuild,v 1.1 2012/08/09 09:12:48 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/libreoffice-l10n-3.6.0.4.ebuild,v 1.2 2012/08/10 12:03:10 scarabeus Exp $
EAPI=4
@@ -41,10 +41,8 @@ unset lang helppack langpack lang2
RDEPEND+="
app-text/hunspell
- || (
- >=app-office/libreoffice-$(get_version_component_range 1-2)
- >=app-office/libreoffice-bin-$(get_version_component_range 1-2)
- )
+ !<app-office/libreoffice-$(get_version_component_range 1-2)
+ !<app-office/libreoffice-bin-$(get_version_component_range 1-2)
"
RESTRICT="strip"
View
100 app-office/libreoffice-l10n/libreoffice-l10n-3.6.0.ebuild
@@ -1,100 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/libreoffice-l10n-3.6.0.ebuild,v 1.2 2012/08/08 15:54:27 scarabeus Exp $
-
-EAPI=4
-
-MY_PV="3.6.0"
-
-RC_VERSION=".4" # CHECK ME WITH EVERY BUMP!
-BASE_SRC_URI="http://download.documentfoundation.org/${PN/-l10n/}/stable/${MY_PV}/rpm"
-
-inherit rpm eutils multilib versionator
-
-DESCRIPTION="Translations for the Libreoffice suite."
-HOMEPAGE="http://www.libreoffice.org"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="offlinehelp"
-
-LANGUAGES_HELP="ast bg bn_IN bn bo bs ca_XV ca cs da de dz el en_GB en en_ZA eo
-es et eu fi fr gl gu he hi hr hu id is it ja ka km ko lb mk nb ne nl nn om pl
-pt_BR pt ru si sk sl sq sv tg tr ug uk vi zh_CN zh_TW"
-LANGUAGES="${LANGUAGES_HELP} af am ar as be br brx cy dgo fa ga gd kk kn kok ks
-ku lo lt lv mai ml mn mni mr my nr nso oc or pa_IN ro rw sa_IN sat sd sh sr ss
-st sw_TZ ta te th tn ts tt uz ve xh zu"
-
-for lang in ${LANGUAGES_HELP}; do
- helppack=""
- [[ ${lang} == en ]] && lang2=${lang/en/en_US} || lang2=${lang}
- helppack=" offlinehelp? ( ${BASE_SRC_URI}/x86/LibO_${MY_PV}_Linux_x86_helppack-rpm_${lang2/_/-}.tar.gz ) "
- SRC_URI+=" linguas_${lang}? ( ${helppack} )"
-done
-
-for lang in ${LANGUAGES}; do
- langpack=""
- [[ ${lang} == en ]] \
- || langpack=" ${BASE_SRC_URI}/x86/LibO_${MY_PV}_Linux_x86_langpack-rpm_${lang/_/-}.tar.gz "
- [[ -z ${langpack} ]] || SRC_URI+=" linguas_${lang}? ( ${langpack} )"
- IUSE+=" linguas_${lang}"
-done
-unset lang helppack langpack lang2 i
-
-RDEPEND+="
- app-text/hunspell
- || (
- >=app-office/libreoffice-$(get_version_component_range 1-2 ${MY_PV})
- >=app-office/libreoffice-bin-$(get_version_component_range 1-2 ${MY_PV})
- )
-"
-
-RESTRICT="strip"
-
-S="${WORKDIR}"
-
-src_unpack() {
- default
-
- local lang dir rpmdir i
- local ooextused=()
-
- for lang in ${LANGUAGES}; do
- # break away if not enabled; paludis support
- use_if_iuse linguas_${lang} || continue
-
- dir=${lang/_/-}
-
- # for english we provide just helppack, as translation is always there
- if [[ ${lang} != en ]]; then
- rpmdir="LibO_${MY_PV}${RC_VERSION}_Linux_x86_langpack-rpm_${dir}/RPMS/"
- [[ -d ${rpmdir} ]] || die "Missing directory: \"${rpmdir}\""
- # First remove dictionaries, we want to use system ones.
- rm -rf "${S}/${rpmdir}/"*dict*.rpm
- rpm_unpack "./${rpmdir}/"*.rpm
- fi
- if [[ "${LANGUAGES_HELP}" =~ "${lang}" ]] && use offlinehelp; then
- [[ ${lang} == en ]] && dir="en-US"
- rpmdir="LibO_${MY_PV}${RC_VERSION}_Linux_x86_helppack-rpm_${dir}/RPMS/"
- [[ -d ${rpmdir} ]] || die "Missing directory: \"${rpmdir}\""
- rpm_unpack ./"${rpmdir}/"*.rpm
- fi
- done
-}
-
-src_prepare() { :; }
-src_configure() { :; }
-src_compile() { :; }
-
-src_install() {
- local dir="${S}"/opt/${PN/-l10n/}$(get_version_component_range 1-2 ${MY_PV})/
- # Condition required for people that do not install anything eg no linguas
- # or just english with no offlinehelp.
- if [[ -d "${dir}" ]] ; then
- insinto /usr/$(get_libdir)/${PN/-l10n/}/
- doins -r "${dir}"/*
- fi
- # remove extensions that are in the l10n for some weird reason
- rm -rf "${ED}"/usr/$(get_libdir)/${PN/-l10n/}/share/extensions/
-}
View
4 app-office/libreoffice/libreoffice-3.6.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.6.0.4.ebuild,v 1.5 2012/08/09 15:44:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.6.0.4.ebuild,v 1.6 2012/08/10 11:53:20 scarabeus Exp $
EAPI=4
@@ -172,7 +172,7 @@ RDEPEND="${COMMON_DEPEND}
"
PDEPEND="
- >=app-office/libreoffice-l10n-3.6
+ =app-office/libreoffice-l10n-3.6*
"
# FIXME: cppunit should be moved to test conditional
View
4 app-office/libreoffice/libreoffice-3.6.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.6.9999.ebuild,v 1.15 2012/08/09 15:44:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.6.9999.ebuild,v 1.16 2012/08/10 11:53:20 scarabeus Exp $
EAPI=4
@@ -172,7 +172,7 @@ RDEPEND="${COMMON_DEPEND}
"
PDEPEND="
- >=app-office/libreoffice-l10n-3.6
+ =app-office/libreoffice-l10n-3.6*
"
# FIXME: cppunit should be moved to test conditional
View
8 app-office/libreoffice/libreoffice-9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.96 2012/08/09 11:35:19 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.98 2012/08/10 11:53:20 scarabeus Exp $
EAPI=4
@@ -176,7 +176,7 @@ RDEPEND="${COMMON_DEPEND}
"
PDEPEND="
- >=app-office/libreoffice-l10n-3.6
+ =app-office/libreoffice-l10n-3.6*
"
# FIXME: cppunit should be moved to test conditional
@@ -419,6 +419,7 @@ src_configure() {
# --enable-release-build: build the libreoffice as release
# --disable-fetch-external: prevent dowloading during compile phase
# --disable-gnome-vfs: old gnome virtual fs support
+ # --disable-gstreamer: support for 1.0 api, we use gstreamer-0.10 for now
# --disable-kdeab: kde3 adressbook
# --disable-kde: kde3 support
# --disable-mozilla: mozilla internal is for contact integration, never
@@ -455,6 +456,7 @@ src_configure() {
--disable-epm \
--disable-fetch-external \
--disable-gnome-vfs \
+ --disable-gstreamer \
--disable-ext-report-builder \
--disable-kdeab \
--disable-kde \
@@ -494,7 +496,7 @@ src_configure() {
$(use_enable gnome gio) \
$(use_enable gnome lockdown) \
$(use_enable graphite) \
- $(use_enable gstreamer) \
+ $(use_enable gstreamer gstreamer-0-10) \
$(use_enable gtk) \
$(use_enable gtk3) \
$(use_enable kde kde4) \
View
4 app-office/pybliographer/pybliographer-1.2.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/pybliographer/pybliographer-1.2.15.ebuild,v 1.2 2012/08/08 15:03:55 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/pybliographer/pybliographer-1.2.15.ebuild,v 1.3 2012/08/10 11:21:47 blueness Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
+KEYWORDS="~amd64 ppc x86"
IUSE=""
DOCS="AUTHORS ChangeLog* NEWS TODO README"
View
2 app-text/ghostscript-gpl/Manifest
@@ -1,6 +1,8 @@
DIST ghostscript-9.04.tar.bz2 29869900 SHA256 f82c20b44ad3c204e2b78afbcd03a32dd523d26f5e18bf4508f3dfcbbfd30bc4 SHA512 f4fd2b5d82a1f9aa918f21a85571f3684778be5b6fe868ae19165717b212aac99b515bb94e3589c3a01b7f836829a283da2162583d4d2dc3c7c267b1926a17ed WHIRLPOOL fdbff23bcbcab63877e9b6e3056af8c47d121103b41dc4774392b90ce7775737d31dfb80dd4e5a26a5caeeab7dbbfd2fb096cc928e8ecfa5feab81ff715dd9fc
DIST ghostscript-9.05.tar.bz2 28279634 SHA256 0f41212af3a5a552ab2302cd90606dc8245be34490a699726dc95ed3cd89ceac SHA512 4a83c42a73fdb5139f02d1b9c8364d0b0f24e8d2952a622f94a8398d71ced8839ee868562d0bf3be048e34cae5ab0adc5eb43d2fb50f5154fe186e8329257913 WHIRLPOOL b5eb32c3551a82bd740674288471c0f050e612ecb709e38339e5eb6d7691f11af760dbc37f6002cf99e969b9ecc2fa296e7a35d97f3e647f86e4e194a91e29e8
+DIST ghostscript-9.06.tar.bz2 29246039 SHA256 05acd1b576899572ef8ecbc25637cf73cbd0be267e651732db3012db33088e04 SHA512 99f7a56316bf96d55c0cd7b07c0791ad4e6ee0d3a8f3bfa04ea28890ea9ed822ebcd7084cc8118cc38dc5def27c91c24eebc08a20a630463a9bf9d0193d0923b WHIRLPOOL a44e19c15440b3fa43233f05b3236ea6834a9f6ac2e7be5174685e6a377ad4a4e7a7cc58fa3df7072ed893d0d76e4bb83b0e890a2d8c45f496c753cb958c7b32
DIST ghostscript-gpl-9.04-patchset-3.tar.bz2 7760 SHA256 b3c20adc111b8ddf3bc7d60a01fa1b31eadb9d6d9eb8ac474d9aa1604bd51b6f SHA512 d8565b04cfd90a064d32aaa241d4ab4e477a04458aec1a27f273ae61ed7dd064758d7c77f3926b9baf759855953e4e178ca4d83a25e652a9263b62f5ffb137ae WHIRLPOOL 659ccace6e08bc12b0006281b08b5b63bedbee6ded9efd6055c8c6d56d01ee39f10d1974de1dcc31b4bedbedab4e79cf4a088b05a56de7bed467caf3b0ee1ad7
DIST ghostscript-gpl-9.05-patchset-1.tar.bz2 4480 SHA256 30e31b11e72a115ee2cd3d01f6a638bc808427bc9579e8c9e1f84b073a19fa9f SHA512 f9613c07c7a67f8dab5b3e67530c9b2686cf5903ed541e659ecb1e0245b2bc85a18eb4a0a6c21e51c0575eaceabd68983c5a605924a53d9e3236c05534d88daf WHIRLPOOL 5fe85b045d0318308d217ed461362a029475bd0c529490aca5b21160bcd8c4cd7eba2807c42114dd42c25e2a01e58b708563547eb8d314e3c4f70b086689ad85
DIST ghostscript-gpl-9.05-patchset-2.tar.bz2 5525 SHA256 1deadf8ed034353ffc14230b66cd438774bd6def03e6f93943f5200bbd01695b SHA512 c14ee057c7c1769e4bc4b3c52d910172dd45524318d6278f8f62f3f4535160412010ad8d426f96ee6fdf24a662859e3079205b9250496d6d69943f3972065d0c WHIRLPOOL 2de3c1bb38aff30c572a2f8ffffb31029215fcd30e075256cae7fb71044a1a635c20df77ef043f20f5ddf91668b820ddbb8052ea43dc326f2af3ecacffbb9568
+DIST ghostscript-gpl-9.06-patchset-1.tar.bz2 4887 SHA256 ddf952730a6eec7885150faa8cb221d4a8d4a07b9ecb38043a7eb97f61f9c263 SHA512 d49f9b7454c7d4513620736dcd7163c347bc25210ab2b63edaa021d91ea3fa91d0c14fef4bb15e88c516562b0bb67ac0b81826c826daf946ac872d093a5e8ce4 WHIRLPOOL fc223217a662c1d7741e883c120afe0509bf767e3fd9afacc0ae5bca7869cda7b3c2c6f12a56b6a1c408487516fa3a8ffb3554d22f7962f934253cad7dbfd732
DIST gsdjvu-1.5.tar.gz 207583 SHA256 d4f01d605ff086835005e79d5fcead2def8aafafc106e170dc5f2dc618593ab4 SHA512 8b59e38f754b325717b0b299e64479688f31fafb7a40f7d9cc32243c45fcf1de88e6f9367c4f77c17395cebbfbe7865eb21fc9c328b4f9f97e0f398c7cc0aafe WHIRLPOOL 08267e1ada37ef8ea7cc7d6a4f264515b964d8e87bad4320d9c2b5e8117bc89dcb5f4885656d5904c0ced4d91393b875a7e9618b2f6bfd71788aba46d823bcf8
View
226 app-text/ghostscript-gpl/ghostscript-gpl-9.06.ebuild
@@ -0,0 +1,226 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ghostscript-gpl-9.06.ebuild,v 1.1 2012/08/10 15:44:27 tgurr Exp $
+
+EAPI=4
+
+inherit autotools eutils multilib versionator flag-o-matic
+
+DESCRIPTION="Ghostscript is an interpreter for the PostScript language and for PDF"
+HOMEPAGE="http://ghostscript.com/"
+
+MY_P=${P/-gpl}
+GSDJVU_PV=1.5
+PVM=$(get_version_component_range 1-2)
+SRC_URI="
+ mirror://sourceforge/ghostscript/${MY_P}.tar.bz2
+ mirror://gentoo/${P}-patchset-1.tar.bz2
+ !bindist? ( djvu? ( mirror://sourceforge/djvu/gsdjvu-${GSDJVU_PV}.tar.gz ) )"
+
+LICENSE="GPL-3 CPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="bindist cups dbus djvu gtk idn jpeg2k linguas_de static-libs X"
+
+COMMON_DEPEND="
+ app-text/libpaper
+ media-libs/fontconfig
+ >=media-libs/freetype-2.4.2:2
+ media-libs/jbig2dec
+ media-libs/lcms:2
+ media-libs/libpng:0
+ media-libs/tiff:0
+ >=sys-libs/zlib-1.2.3
+ virtual/jpeg
+ !bindist? ( djvu? ( app-text/djvu ) )
+ cups? ( >=net-print/cups-1.3.8 )
+ dbus? ( sys-apps/dbus )
+ gtk? ( || ( x11-libs/gtk+:3 x11-libs/gtk+:2 ) )
+ idn? ( net-dns/libidn )
+ jpeg2k? ( >=media-libs/openjpeg-1.5.0 )
+ X? ( x11-libs/libXt x11-libs/libXext )"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ >=app-text/poppler-data-0.4.5-r1
+ >=media-fonts/urw-fonts-2.4.9
+ linguas_ja? ( media-fonts/kochi-substitute )
+ linguas_ko? ( media-fonts/baekmuk-fonts )
+ linguas_zh_CN? ( media-fonts/arphicfonts )
+ linguas_zh_TW? ( media-fonts/arphicfonts )
+ !!media-fonts/gnu-gs-fonts-std
+ !!media-fonts/gnu-gs-fonts-other
+"
+
+S="${WORKDIR}/${MY_P}"
+
+LANGS="ja ko zh_CN zh_TW"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+pkg_setup() {
+ if use bindist && use djvu; then
+ ewarn "You have bindist in your USE, djvu support will NOT be compiled!"
+ ewarn "See http://djvu.sourceforge.net/gsdjvu/COPYING for details on licensing issues."
+ fi
+}
+
+src_prepare() {
+ # remove internal copies of various libraries
+ rm -rf "${S}"/expat
+ rm -rf "${S}"/freetype
+ rm -rf "${S}"/jasper
+ rm -rf "${S}"/jbig2dec
+ rm -rf "${S}"/jpeg
+ rm -rf "${S}"/lcms{,2}
+ rm -rf "${S}"/libpng
+ rm -rf "${S}"/openjpeg
+ rm -rf "${S}"/tiff
+ rm -rf "${S}"/zlib
+ # remove internal urw-fonts
+ rm -rf "${S}"/Resource/Font
+ # remove internal CMaps (CMaps from poppler-data are used instead)
+ rm -rf "${S}"/Resource/CMap
+
+ # apply various patches, many borrowed from Fedora
+ # http://pkgs.fedoraproject.org/gitweb/?p=ghostscript.git
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes"
+ EPATCH_SOURCE="${WORKDIR}/patches/"
+ epatch
+
+ if ! use bindist && use djvu ; then
+ unpack gsdjvu-${GSDJVU_PV}.tar.gz
+ cp gsdjvu-${GSDJVU_PV}/gsdjvu "${S}"
+ cp gsdjvu-${GSDJVU_PV}/gdevdjvu.c "${S}/base"
+ epatch "${WORKDIR}/patches-gsdjvu/gsdjvu-1.3-${PN}-8.64.patch"
+ epatch "${WORKDIR}/patches-gsdjvu/gsdjvu-1.5-${PN}-9.05.patch"
+ cp gsdjvu-${GSDJVU_PV}/ps2utf8.ps "${S}/lib"
+ cp "${S}/base/contrib.mak" "${S}/base/contrib.mak.gsdjvu"
+ grep -q djvusep "${S}/base/contrib.mak" || \
+ cat gsdjvu-${GSDJVU_PV}/gsdjvu.mak >> "${S}/base/contrib.mak"
+
+ # install ps2utf8.ps, bug #197818
+ sed -i -e '/$(EXTRA_INIT_FILES)/ a\ps2utf8.ps \\' "${S}/base/unixinst.mak" \
+ || die "sed failed"
+ fi
+
+ if ! use gtk ; then
+ sed -i "s:\$(GSSOX)::" base/*.mak || die "gsx sed failed"
+ sed -i "s:.*\$(GSSOX_XENAME)$::" base/*.mak || die "gsxso sed failed"
+ fi
+
+ # search path fix
+ sed -i -e "s:\$\(gsdatadir\)/lib:/usr/share/ghostscript/${PVM}/$(get_libdir):" \
+ -e "s:exdir=.*:exdir=/usr/share/doc/${PF}/examples:" \
+ -e "s:docdir=.*:docdir=/usr/share/doc/${PF}/html:" \
+ -e "s:GS_DOCDIR=.*:GS_DOCDIR=/usr/share/doc/${PF}/html:" \
+ -e 's:-L$(BINDIR):$(LDFLAGS) &:g' \
+ base/Makefile.in base/*.mak || die "sed failed"
+
+ cd "${S}"
+ eautoreconf
+
+ cd "${S}/ijs"
+ eautoreconf
+}
+
+src_configure() {
+ local FONTPATH
+ for path in \
+ /usr/share/fonts/urw-fonts \
+ /usr/share/fonts/Type1 \
+ /usr/share/fonts \
+ /usr/share/poppler/cMap/Adobe-CNS1 \
+ /usr/share/poppler/cMap/Adobe-GB1 \
+ /usr/share/poppler/cMap/Adobe-Japan1 \
+ /usr/share/poppler/cMap/Adobe-Japan2 \
+ /usr/share/poppler/cMap/Adobe-Korea1
+ do
+ FONTPATH="$FONTPATH${FONTPATH:+:}$path"
+ done
+
+ econf \
+ --enable-dynamic \
+ --enable-freetype \
+ --enable-fontconfig \
+ --disable-compile-inits \
+ --with-drivers=ALL \
+ --with-fontpath="$FONTPATH" \
+ --with-ijs \
+ --with-jbig2dec \
+ --with-libpaper \
+ --with-system-libtiff \
+ --without-jasper \
+ --without-lcms \
+ --without-luratech \
+ $(use_enable cups) \
+ $(use_enable dbus) \
+ $(use_enable gtk) \
+ $(use_enable jpeg2k openjpeg ) \
+ $(use_with cups install-cups) \
+ $(use_with cups pdftoraster) \
+ $(use_with idn libidn) \
+ $(use_with X x)
+
+ if ! use bindist && use djvu ; then
+ sed -i -e 's!$(DD)bbox.dev!& $(DD)djvumask.dev $(DD)djvusep.dev!g' Makefile
+ fi
+
+ cd "${S}/ijs"
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake so all
+
+ cd "${S}/ijs"
+ emake
+}
+
+src_install() {
+ # workaround: -j1 -> see bug #356303
+ emake -j1 DESTDIR="${D}" install-so install
+
+ # workaround: some printer drivers still require pstoraster, bug #383831
+ use cups && dosym /usr/libexec/cups/filter/gstoraster /usr/libexec/cups/filter/pstoraster
+ # workaround: do the same for pstopxl as of gs 9.05
+ use cups && dosym /usr/libexec/cups/filter/gstopxl /usr/libexec/cups/filter/pstopxl
+
+ if ! use bindist && use djvu ; then
+ dobin gsdjvu
+ fi
+
+ # remove gsc in favor of gambit, bug #253064
+ rm -rf "${D}/usr/bin/gsc"
+
+ rm -rf "${D}/usr/share/doc/${PF}/html/"{README,PUBLIC}
+ dodoc doc/GS9_Color_Management.pdf
+
+ cd "${S}/ijs"
+ emake DESTDIR="${D}" install
+
+ # rename the original cidfmap to cidfmap.GS
+ mv "${D}/usr/share/ghostscript/${PVM}/Resource/Init/cidfmap"{,.GS} || die
+
+ # install our own cidfmap to handle CJK fonts
+ insinto "/usr/share/ghostscript/${PVM}/Resource/Init"
+ doins "${WORKDIR}/fontmaps/CIDFnmap"
+ doins "${WORKDIR}/fontmaps/cidfmap"
+ for X in ${LANGS} ; do
+ if use linguas_${X} ; then
+ doins "${WORKDIR}/fontmaps/cidfmap.${X}"
+ fi
+ done
+
+ # install the CMaps from poppler-data properly, bug 409361
+ dosym /usr/share/poppler/cMaps /usr/share/ghostscript/${PVM}/Resource/CMap
+
+ use static-libs || find "${D}" -name '*.la' -delete
+
+ use linguas_de || rm -r "${D}"/usr/share/man/de
+}
View
19 app-text/leechcraft-monocle/files/monocle-poppler.patch
@@ -0,0 +1,19 @@
+commit cbc0455a366739cf7911cf80de517aab6152da98
+Author: 0xd34df00d <0xd34df00d@gmail.com>
+Date: Fri Jul 13 08:13:27 2012 +0400
+
+ Monocle PDF: fixed include dir.
+
+diff --git a/src/plugins/monocle/plugins/pdf/links.h b/src/plugins/monocle/plugins/pdf/links.h
+index 1ca7ee3..b7f6c1d 100644
+--- a/src/plugins/monocle/plugins/pdf/links.h
++++ b/src/plugins/monocle/plugins/pdf/links.h
+@@ -19,7 +19,7 @@
+ #pragma once
+
+ #include <QObject>
+-#include <poppler-link.h>
++#include <poppler-qt4.h>
+ #include <interfaces/monocle/ilink.h>
+
+ namespace LeechCraft
View
4 app-text/leechcraft-monocle/leechcraft-monocle-0.5.75.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/leechcraft-monocle/leechcraft-monocle-0.5.75.ebuild,v 1.1 2012/07/19 19:54:26 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/leechcraft-monocle/leechcraft-monocle-0.5.75.ebuild,v 1.2 2012/08/10 09:10:00 maksbotan Exp $
EAPI="4"
@@ -16,6 +16,8 @@ DEPEND="~net-misc/leechcraft-core-${PV}
pdf? ( app-text/poppler[qt4] )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/monocle-poppler.patch )
+
src_configure() {
local mycmakeargs="
$(cmake-utils_use_enable fb2 MONOCLE_FXB)
View
10 app-text/sigil/sigil-0.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/sigil-0.4.2.ebuild,v 1.1 2012/01/10 03:11:52 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/sigil-0.4.2.ebuild,v 1.2 2012/08/10 13:40:45 kensington Exp $
EAPI=4
CMAKE_BUILD_TYPE="Release"
@@ -19,10 +19,10 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="
- >=x11-libs/qt-xmlpatterns-4.7.2
- >=x11-libs/qt-webkit-4.7.2
- >=x11-libs/qt-svg-4.7.2
- >=x11-libs/qt-gui-4.7.2"
+ >=x11-libs/qt-xmlpatterns-4.7.2:4
+ >=x11-libs/qt-webkit-4.7.2:4
+ >=x11-libs/qt-svg-4.7.2:4
+ >=x11-libs/qt-gui-4.7.2:4"
RDEPEND="${DEPEND}"
S="${WORKDIR}"
View
10 app-text/sigil/sigil-0.4.905_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/sigil-0.4.905_beta1.ebuild,v 1.1 2012/01/10 03:11:52 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/sigil-0.4.905_beta1.ebuild,v 1.2 2012/08/10 13:40:45 kensington Exp $
EAPI=4
CMAKE_BUILD_TYPE="Release"
@@ -19,10 +19,10 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="
- >=x11-libs/qt-xmlpatterns-4.7.2
- >=x11-libs/qt-webkit-4.7.2
- >=x11-libs/qt-svg-4.7.2
- >=x11-libs/qt-gui-4.7.2"
+ >=x11-libs/qt-xmlpatterns-4.7.2:4
+ >=x11-libs/qt-webkit-4.7.2:4
+ >=x11-libs/qt-svg-4.7.2:4
+ >=x11-libs/qt-gui-4.7.2:4"
RDEPEND="${DEPEND}"
S="${WORKDIR}"
View
10 app-text/sigil/sigil-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/sigil-0.5.0.ebuild,v 1.1 2012/01/26 23:04:46 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/sigil-0.5.0.ebuild,v 1.2 2012/08/10 13:40:45 kensington Exp $
EAPI=4
CMAKE_BUILD_TYPE="Release"
@@ -19,10 +19,10 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="
- >=x11-libs/qt-xmlpatterns-4.7.2
- >=x11-libs/qt-webkit-4.7.2
- >=x11-libs/qt-svg-4.7.2
- >=x11-libs/qt-gui-4.7.2"
+ >=x11-libs/qt-xmlpatterns-4.7.2:4
+ >=x11-libs/qt-webkit-4.7.2:4
+ >=x11-libs/qt-svg-4.7.2:4
+ >=x11-libs/qt-gui-4.7.2:4"
RDEPEND="${DEPEND}"
S="${WORKDIR}"
View
10 app-text/sigil/sigil-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/sigil-0.5.3.ebuild,v 1.1 2012/03/19 12:50:52 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/sigil-0.5.3.ebuild,v 1.2 2012/08/10 13:40:45 kensington Exp $
EAPI=4
CMAKE_BUILD_TYPE="Release"
@@ -19,10 +19,10 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="
- >=x11-libs/qt-xmlpatterns-4.7.2
- >=x11-libs/qt-webkit-4.7.2
- >=x11-libs/qt-svg-4.7.2
- >=x11-libs/qt-gui-4.7.2"
+ >=x11-libs/qt-xmlpatterns-4.7.2:4
+ >=x11-libs/qt-webkit-4.7.2:4
+ >=x11-libs/qt-svg-4.7.2:4
+ >=x11-libs/qt-gui-4.7.2:4"
RDEPEND="${DEPEND}"
S="${WORKDIR}"
View
4 app-text/ttf2pk2/ttf2pk2-1.5_p20120701.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pk2/ttf2pk2-1.5_p20120701.ebuild,v 1.2 2012/08/09 17:17:21 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pk2/ttf2pk2-1.5_p20120701.ebuild,v 1.3 2012/08/10 10:55:38 blueness Exp $
EAPI=4
@@ -10,7 +10,7 @@ SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~s390 ~sh ~sparc ~x86
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos
~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
View
1 dev-ruby/actionmailer/Manifest
@@ -3,3 +3,4 @@ DIST rails-3.0.16.tgz 3508179 SHA256 d7aa9ba5a06a9d96763695c874016f254f6902a3476
DIST rails-3.1.3.tgz 3638313 SHA256 412c8a3ae4e0d5283ace45a2ee95127418d6b70fb1a954087b09755ab3a25e99 SHA512 286434f02c16f9cde51c160a5f84ac9b53d9d3aaf44c6c8018cef3250213cd39909013006223cceea8bd68ffe0bdc8ce50b0695e57756d8bb9ec44ab5986a711 WHIRLPOOL 710aa7c64c71b46741e19be41023aa6acf7dfeb25b94f8f14c10748f4a4a4cacd61ecf51a9db0b4eae1d0a1797f4287fd9b0f139a874f1659cab8fa5f252c200
DIST rails-3.1.7.tgz 3647533 SHA256 e32b2fa7ee535eec857ba88710ca80b1a7b05554d8c92506cb0dbd3510a8dc69 SHA512 ac4a164be32bc46a603a76490768fc639fb157d88547eec943d0bdec872ca00c3f008f60e796a7bf27e645fcd73d51f3fb63ba0875ae6f5d34b05e5587d39f33 WHIRLPOOL 8cdc05154f61826a85beec2f7052375b6fc3ef550362eebd3d65839abcec3fb99eb3b09a48cbde44dda769f4e2dc27bcd8aa1fd00ef63d100f57ef819c0fb326
DIST rails-3.2.7.tgz 3802538 SHA256 3a16047cd010d5834d5c33a0a9f1843a0ae21e63f2322d9bb0a5820dd9ddd099 SHA512 cf46c3b3684f3493b37fb62bf78c05f28452d6e37d2fc097527a6c9d21fd839aa940c45e816363aaad4cf5d25fbac099e445eecabfad95d1c1de1b291d12fb7c WHIRLPOOL d2ad4e00728d5603b0b85154fa2783646f7749591b529506a4425c727748bff72a02b72e2f5ba9f762c13ea149f847430472ad76fce43a3096e93e334f57fee9
+DIST rails-3.2.8.tgz 3802639 SHA256 312b8c3b42be96015f24354c48cc11e9c3f84da61b426cf271c8dac961e9603c SHA512 d03a4bd95b34ed796097ac9b8c0d37fb612c008a03d29032f2384f15e306ef998537c84ef8a30e5608263efad457ddc76480cedcf5ce1aeeff374c4384f7ff8c WHIRLPOOL c07273181e6b599de7d6b8e873c3935b92c41f76552198f0bf440009cc1a882749e84cf822ddd2fa3ed89df705a6cd1fc219e0629c8312311f9a10b448f43e93
View
36 dev-ruby/actionmailer/actionmailer-3.2.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.2.8.ebuild,v 1.1 2012/08/10 06:44:07 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.4.4"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.12.1
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}
View
1 dev-ruby/actionpack/Manifest
@@ -3,3 +3,4 @@ DIST rails-3.0.16.tgz 3508179 SHA256 d7aa9ba5a06a9d96763695c874016f254f6902a3476
DIST rails-3.1.3.tgz 3638313 SHA256 412c8a3ae4e0d5283ace45a2ee95127418d6b70fb1a954087b09755ab3a25e99 SHA512 286434f02c16f9cde51c160a5f84ac9b53d9d3aaf44c6c8018cef3250213cd39909013006223cceea8bd68ffe0bdc8ce50b0695e57756d8bb9ec44ab5986a711 WHIRLPOOL 710aa7c64c71b46741e19be41023aa6acf7dfeb25b94f8f14c10748f4a4a4cacd61ecf51a9db0b4eae1d0a1797f4287fd9b0f139a874f1659cab8fa5f252c200
DIST rails-3.1.7.tgz 3647533 SHA256 e32b2fa7ee535eec857ba88710ca80b1a7b05554d8c92506cb0dbd3510a8dc69 SHA512 ac4a164be32bc46a603a76490768fc639fb157d88547eec943d0bdec872ca00c3f008f60e796a7bf27e645fcd73d51f3fb63ba0875ae6f5d34b05e5587d39f33 WHIRLPOOL 8cdc05154f61826a85beec2f7052375b6fc3ef550362eebd3d65839abcec3fb99eb3b09a48cbde44dda769f4e2dc27bcd8aa1fd00ef63d100f57ef819c0fb326
DIST rails-3.2.7.tgz 3802538 SHA256 3a16047cd010d5834d5c33a0a9f1843a0ae21e63f2322d9bb0a5820dd9ddd099 SHA512 cf46c3b3684f3493b37fb62bf78c05f28452d6e37d2fc097527a6c9d21fd839aa940c45e816363aaad4cf5d25fbac099e445eecabfad95d1c1de1b291d12fb7c WHIRLPOOL d2ad4e00728d5603b0b85154fa2783646f7749591b529506a4425c727748bff72a02b72e2f5ba9f762c13ea149f847430472ad76fce43a3096e93e334f57fee9
+DIST rails-3.2.8.tgz 3802639 SHA256 312b8c3b42be96015f24354c48cc11e9c3f84da61b426cf271c8dac961e9603c SHA512 d03a4bd95b34ed796097ac9b8c0d37fb612c008a03d29032f2384f15e306ef998537c84ef8a30e5608263efad457ddc76480cedcf5ce1aeeff374c4384f7ff8c WHIRLPOOL c07273181e6b599de7d6b8e873c3935b92c41f76552198f0bf440009cc1a882749e84cf822ddd2fa3ed89df705a6cd1fc219e0629c8312311f9a10b448f43e93
View
67 dev-ruby/actionpack/actionpack-3.2.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.2.8.ebuild,v 1.1 2012/08/10 06:43:45 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-cache-1.2
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/i18n-0.6:0.6
+ >=dev-ruby/rack-1.4.0:1.4
+ >=dev-ruby/rack-test-0.6.1:0.6
+ >=dev-ruby/journey-1.0.4:1.0
+ >=dev-ruby/sprockets-2.1.3:2.1"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.12.1
+ dev-ruby/bundler
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ >=dev-ruby/tzinfo-0.3.29
+ >=dev-ruby/uglifier-1.0.3
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\)/d" ../Gemfile || die
+
+ sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ # Avoid fragile tests depending on hash ordering
+ sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
+ sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
+ sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+}
View
1 dev-ruby/activemodel/Manifest
@@ -2,3 +2,4 @@ DIST rails-3.0.16.tgz 3508179 SHA256 d7aa9ba5a06a9d96763695c874016f254f6902a3476
DIST rails-3.1.3.tgz 3638313 SHA256 412c8a3ae4e0d5283ace45a2ee95127418d6b70fb1a954087b09755ab3a25e99 SHA512 286434f02c16f9cde51c160a5f84ac9b53d9d3aaf44c6c8018cef3250213cd39909013006223cceea8bd68ffe0bdc8ce50b0695e57756d8bb9ec44ab5986a711 WHIRLPOOL 710aa7c64c71b46741e19be41023aa6acf7dfeb25b94f8f14c10748f4a4a4cacd61ecf51a9db0b4eae1d0a1797f4287fd9b0f139a874f1659cab8fa5f252c200
DIST rails-3.1.7.tgz 3647533 SHA256 e32b2fa7ee535eec857ba88710ca80b1a7b05554d8c92506cb0dbd3510a8dc69 SHA512 ac4a164be32bc46a603a76490768fc639fb157d88547eec943d0bdec872ca00c3f008f60e796a7bf27e645fcd73d51f3fb63ba0875ae6f5d34b05e5587d39f33 WHIRLPOOL 8cdc05154f61826a85beec2f7052375b6fc3ef550362eebd3d65839abcec3fb99eb3b09a48cbde44dda769f4e2dc27bcd8aa1fd00ef63d100f57ef819c0fb326
DIST rails-3.2.7.tgz 3802538 SHA256 3a16047cd010d5834d5c33a0a9f1843a0ae21e63f2322d9bb0a5820dd9ddd099 SHA512 cf46c3b3684f3493b37fb62bf78c05f28452d6e37d2fc097527a6c9d21fd839aa940c45e816363aaad4cf5d25fbac099e445eecabfad95d1c1de1b291d12fb7c WHIRLPOOL d2ad4e00728d5603b0b85154fa2783646f7749591b529506a4425c727748bff72a02b72e2f5ba9f762c13ea149f847430472ad76fce43a3096e93e334f57fee9
+DIST rails-3.2.8.tgz 3802639 SHA256 312b8c3b42be96015f24354c48cc11e9c3f84da61b426cf271c8dac961e9603c SHA512 d03a4bd95b34ed796097ac9b8c0d37fb612c008a03d29032f2384f15e306ef998537c84ef8a30e5608263efad457ddc76480cedcf5ce1aeeff374c4384f7ff8c WHIRLPOOL c07273181e6b599de7d6b8e873c3935b92c41f76552198f0bf440009cc1a882749e84cf822ddd2fa3ed89df705a6cd1fc219e0629c8312311f9a10b448f43e93
View
42 dev-ruby/activemodel/activemodel-3.2.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.8.ebuild,v 1.1 2012/08/10 06:42:53 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
View
1 dev-ruby/activerecord/Manifest
@@ -3,3 +3,4 @@ DIST rails-3.0.16.tgz 3508179 SHA256 d7aa9ba5a06a9d96763695c874016f254f6902a3476
DIST rails-3.1.3.tgz 3638313 SHA256 412c8a3ae4e0d5283ace45a2ee95127418d6b70fb1a954087b09755ab3a25e99 SHA512 286434f02c16f9cde51c160a5f84ac9b53d9d3aaf44c6c8018cef3250213cd39909013006223cceea8bd68ffe0bdc8ce50b0695e57756d8bb9ec44ab5986a711 WHIRLPOOL 710aa7c64c71b46741e19be41023aa6acf7dfeb25b94f8f14c10748f4a4a4cacd61ecf51a9db0b4eae1d0a1797f4287fd9b0f139a874f1659cab8fa5f252c200
DIST rails-3.1.7.tgz 3647533 SHA256 e32b2fa7ee535eec857ba88710ca80b1a7b05554d8c92506cb0dbd3510a8dc69 SHA512 ac4a164be32bc46a603a76490768fc639fb157d88547eec943d0bdec872ca00c3f008f60e796a7bf27e645fcd73d51f3fb63ba0875ae6f5d34b05e5587d39f33 WHIRLPOOL 8cdc05154f61826a85beec2f7052375b6fc3ef550362eebd3d65839abcec3fb99eb3b09a48cbde44dda769f4e2dc27bcd8aa1fd00ef63d100f57ef819c0fb326
DIST rails-3.2.7.tgz 3802538 SHA256 3a16047cd010d5834d5c33a0a9f1843a0ae21e63f2322d9bb0a5820dd9ddd099 SHA512 cf46c3b3684f3493b37fb62bf78c05f28452d6e37d2fc097527a6c9d21fd839aa940c45e816363aaad4cf5d25fbac099e445eecabfad95d1c1de1b291d12fb7c WHIRLPOOL d2ad4e00728d5603b0b85154fa2783646f7749591b529506a4425c727748bff72a02b72e2f5ba9f762c13ea149f847430472ad76fce43a3096e93e334f57fee9
+DIST rails-3.2.8.tgz 3802639 SHA256 312b8c3b42be96015f24354c48cc11e9c3f84da61b426cf271c8dac961e9603c SHA512 d03a4bd95b34ed796097ac9b8c0d37fb612c008a03d29032f2384f15e306ef998537c84ef8a30e5608263efad457ddc76480cedcf5ce1aeeff374c4384f7ff8c WHIRLPOOL c07273181e6b599de7d6b8e873c3935b92c41f76552198f0bf440009cc1a882749e84cf822ddd2fa3ed89df705a6cd1fc219e0629c8312311f9a10b448f43e93
View
74 dev-ruby/activerecord/activerecord-3.2.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.2.8.ebuild,v 1.1 2012/08/10 06:44:33 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+RUBY_S="rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-3.0.2:3.0
+ >=dev-ruby/tzinfo-0.3.29
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.5 )
+ mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
+ postgres? ( >=dev-ruby/pg-0.11.0 )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.5
+ >=dev-ruby/mocha-0.12.1
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\)/d" ../Gemfile || die
+ sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ # Avoid tests depending on hash ordering
+ sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
+
+ # Avoid test depending on mysql adapter which we don't support for
+ # this Rails version to simplify our dependencies.
+ rm test/cases/connection_specification/resolver_test.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *rubyee18)
+ # Turn on travis support to avoid tripping bugs in ree18.
+ TRAVIS=true ${RUBY} -S rake test_sqlite3
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}
View
1 dev-ruby/activeresource/Manifest
@@ -3,3 +3,4 @@ DIST rails-3.0.16.tgz 3508179 SHA256 d7aa9ba5a06a9d96763695c874016f254f6902a3476
DIST rails-3.1.3.tgz 3638313 SHA256 412c8a3ae4e0d5283ace45a2ee95127418d6b70fb1a954087b09755ab3a25e99 SHA512 286434f02c16f9cde51c160a5f84ac9b53d9d3aaf44c6c8018cef3250213cd39909013006223cceea8bd68ffe0bdc8ce50b0695e57756d8bb9ec44ab5986a711 WHIRLPOOL 710aa7c64c71b46741e19be41023aa6acf7dfeb25b94f8f14c10748f4a4a4cacd61ecf51a9db0b4eae1d0a1797f4287fd9b0f139a874f1659cab8fa5f252c200
DIST rails-3.1.7.tgz 3647533 SHA256 e32b2fa7ee535eec857ba88710ca80b1a7b05554d8c92506cb0dbd3510a8dc69 SHA512 ac4a164be32bc46a603a76490768fc639fb157d88547eec943d0bdec872ca00c3f008f60e796a7bf27e645fcd73d51f3fb63ba0875ae6f5d34b05e5587d39f33 WHIRLPOOL 8cdc05154f61826a85beec2f7052375b6fc3ef550362eebd3d65839abcec3fb99eb3b09a48cbde44dda769f4e2dc27bcd8aa1fd00ef63d100f57ef819c0fb326
DIST rails-3.2.7.tgz 3802538 SHA256 3a16047cd010d5834d5c33a0a9f1843a0ae21e63f2322d9bb0a5820dd9ddd099 SHA512 cf46c3b3684f3493b37fb62bf78c05f28452d6e37d2fc097527a6c9d21fd839aa940c45e816363aaad4cf5d25fbac099e445eecabfad95d1c1de1b291d12fb7c WHIRLPOOL d2ad4e00728d5603b0b85154fa2783646f7749591b529506a4425c727748bff72a02b72e2f5ba9f762c13ea149f847430472ad76fce43a3096e93e334f57fee9
+DIST rails-3.2.8.tgz 3802639 SHA256 312b8c3b42be96015f24354c48cc11e9c3f84da61b426cf271c8dac961e9603c SHA512 d03a4bd95b34ed796097ac9b8c0d37fb612c008a03d29032f2384f15e306ef998537c84ef8a30e5608263efad457ddc76480cedcf5ce1aeeff374c4384f7ff8c WHIRLPOOL c07273181e6b599de7d6b8e873c3935b92c41f76552198f0bf440009cc1a882749e84cf822ddd2fa3ed89df705a6cd1fc219e0629c8312311f9a10b448f43e93
View
40 dev-ruby/activeresource/activeresource-3.2.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.2.8.ebuild,v 1.1 2012/08/10 06:43:21 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}
View
1 dev-ruby/activesupport/Manifest
@@ -3,3 +3,4 @@ DIST rails-3.0.16.tgz 3508179 SHA256 d7aa9ba5a06a9d96763695c874016f254f6902a3476
DIST rails-3.1.3.tgz 3638313 SHA256 412c8a3ae4e0d5283ace45a2ee95127418d6b70fb1a954087b09755ab3a25e99 SHA512 286434f02c16f9cde51c160a5f84ac9b53d9d3aaf44c6c8018cef3250213cd39909013006223cceea8bd68ffe0bdc8ce50b0695e57756d8bb9ec44ab5986a711 WHIRLPOOL 710aa7c64c71b46741e19be41023aa6acf7dfeb25b94f8f14c10748f4a4a4cacd61ecf51a9db0b4eae1d0a1797f4287fd9b0f139a874f1659cab8fa5f252c200
DIST rails-3.1.7.tgz 3647533 SHA256 e32b2fa7ee535eec857ba88710ca80b1a7b05554d8c92506cb0dbd3510a8dc69 SHA512 ac4a164be32bc46a603a76490768fc639fb157d88547eec943d0bdec872ca00c3f008f60e796a7bf27e645fcd73d51f3fb63ba0875ae6f5d34b05e5587d39f33 WHIRLPOOL 8cdc05154f61826a85beec2f7052375b6fc3ef550362eebd3d65839abcec3fb99eb3b09a48cbde44dda769f4e2dc27bcd8aa1fd00ef63d100f57ef819c0fb326
DIST rails-3.2.7.tgz 3802538 SHA256 3a16047cd010d5834d5c33a0a9f1843a0ae21e63f2322d9bb0a5820dd9ddd099 SHA512 cf46c3b3684f3493b37fb62bf78c05f28452d6e37d2fc097527a6c9d21fd839aa940c45e816363aaad4cf5d25fbac099e445eecabfad95d1c1de1b291d12fb7c WHIRLPOOL d2ad4e00728d5603b0b85154fa2783646f7749591b529506a4425c727748bff72a02b72e2f5ba9f762c13ea149f847430472ad76fce43a3096e93e334f57fee9
+DIST rails-3.2.8.tgz 3802639 SHA256 312b8c3b42be96015f24354c48cc11e9c3f84da61b426cf271c8dac961e9603c SHA512 d03a4bd95b34ed796097ac9b8c0d37fb612c008a03d29032f2384f15e306ef998537c84ef8a30e5608263efad457ddc76480cedcf5ce1aeeff374c4384f7ff8c WHIRLPOOL c07273181e6b599de7d6b8e873c3935b92c41f76552198f0bf440009cc1a882749e84cf822ddd2fa3ed89df705a6cd1fc219e0629c8312311f9a10b448f43e93
View
47 dev-ruby/activesupport/activesupport-3.2.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.8.ebuild,v 1.1 2012/08/10 06:42:29 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8
+ >=dev-ruby/multi_json-1.0
+ dev-ruby/i18n:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# libxml-ruby, nokogiri, and builder are not strictly needed, but there
+# are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/libxml-2.0.0
+ dev-ruby/nokogiri
+ dev-ruby/builder:0
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}
View
5 dev-ruby/aws-sdk/Manifest
@@ -1,4 +1 @@
-DIST aws-sdk-for-ruby-1.5.6.tar.gz 1220994 SHA256 55ae6fb3434e825891a8fd73a5012bb0f31e98a474ba79b765bf1a414b00afc8 SHA512 1b2787524fbe65c8f89b10d10d4a61faef6919d015722e127d855d5498b4c9fd6140c1c0343f74a32e023713bc406740c3fd4465519477cb5114050137195b99 WHIRLPOOL af9f83ca8be8cf52d255e4d739f53aaacfb103b17842c4fdc7927df8994ba59d0a3a60f7977624766fad92694370da53b27cb0509f81b9124a0b9a7a81857aa9
-DIST aws-sdk-for-ruby-1.5.8.tar.gz 1249362 SHA256 31630fbe3b8ac1b2d2d3d324b52d6102bb5fc3e4b89d3aaaf32f2c8818a1c73f SHA512 851b0b0d1fc0d86aed4307bb2b2eac2603ede4d72d94b9288964760b9be0613f3c4df1c59643b2419c67b8c58dc4bf2c9743a1b264b790fe0b80139e58dad054 WHIRLPOOL 55a1ebb4b3bd72fb0dffeb5ac121aedbf9d4513cc3421aa9a958a2bc2ce7e2233a75998bf0ddac9be18302a70420e6a0efff337244267afaae21330d83b7af8e
-DIST aws-sdk-for-ruby-1.6.0.tar.gz 1264422 SHA256 43b1690edc2edf444a259f6eb5056b29886c3d2ea8e421efa3c66f6851103b4e SHA512 18a4574e49070d9dd20c5abee75a6ba6d4516548f54b21ed0c8473b2557ec0f1887d3fbc1f9a586209eb434d85e17db252b87e071efc684250b5e67ef5ff8aac WHIRLPOOL 07c952ad0af9f40e74804d5288c27cc324888085c07e8a7d8935547f3f65f2b8447347a6d26f961bdddae034314b5f36af185228fe35bb178a00e5792e4eb840
-DIST aws-sdk-for-ruby-1.6.2.tar.gz 1264417 SHA256 f8df60f239e3031dcbc454b5abbd070a1eacb95c11fdfd9991c777ef6f9714ec SHA512 3364ab9e6fd510a2d167cb19c0d8a24fda58ed145d3753fd1c1efd1ef263caaec2cbd8eef4325d7d44760dfef1c38f4f1b9b405f60d7dd8b6d750e1f9e9b777a WHIRLPOOL 38acfb0fd61371fbaf81cd15d297ca25d71b1ce0702186ca0a218608d82d01fe07dfd7619b1d516df5d3c8a2300ece6c58d632904356ef65e215a9ad24278041
+DIST aws-sdk-for-ruby-1.6.3.tar.gz 1282646 SHA256 7285b30f504e357331e4a2e4bdfe5aa2e9903f752f1e9fa4e4385a39d3fbe550 SHA512 fceb4c28484c1546e81da2751e2e1d101ce9a2b9bd2ddbe23bb5c836c6f798153d0fbb65446d658237e5414819e72fdcad581741785ae3a578c2456c6ac058c4 WHIRLPOOL ded96885d16df8a45d6cf09ff217ccd616e1f568e45bdb40b9449e0ebf0e3238fccb842516a6316f954deb439aa0c772be5f76d60a898e963971f83eb0afcaff
View
63 dev-ruby/aws-sdk/aws-sdk-1.5.6.ebuild
@@ -1,63 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/aws-sdk-1.5.6.ebuild,v 1.2 2012/07/05 21:36:58 flameeyes Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="ca-bundle.crt"
-
-GITHUB_USER="amazonwebservices"
-GITHUB_PROJECT="${PN}-for-ruby"
-RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-RUBY_FAKEGEM_GEMSPEC="${T}/${P}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Official SDK for Amazon Web Services"
-HOMEPAGE="http://aws.amazon.com/sdkforruby"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl
- >=dev-ruby/httparty-0.7
- >=dev-ruby/json-1.4
- >=dev-ruby/nokogiri-1.4.4
- >=dev-ruby/uuidtools-2.1"
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-1.5.3-disabletest.patch
-}
-
-all_ruby_compile() {
- if use doc; then
- rdoc || die
- fi
-}
-
-each_ruby_test() {
- ruby-ng_rspec -Ilib -raws
-}
-
-each_ruby_install() {
- sed -e "s:VERSION:${PV}:" "${FILESDIR}"/${PN}.gemspec > "${RUBY_FAKEGEM_GEMSPEC}"
- each_fakegem_install
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- insinto /usr/share/doc/${PF}
- doins -r recipebook samples
-}
View
59 dev-ruby/aws-sdk/aws-sdk-1.5.8.ebuild
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/aws-sdk-1.5.8.ebuild,v 1.1 2012/07/27 01:29:46 flameeyes Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="ca-bundle.crt"
-
-GITHUB_USER="amazonwebservices"
-GITHUB_PROJECT="${PN}-for-ruby"
-RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-RUBY_FAKEGEM_GEMSPEC="${T}/${P}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Official SDK for Amazon Web Services"
-HOMEPAGE="http://aws.amazon.com/sdkforruby"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl
- >=dev-ruby/httparty-0.7
- >=dev-ruby/json-1.4
- >=dev-ruby/nokogiri-1.4.4
- >=dev-ruby/uuidtools-2.1"
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-1.5.3-disabletest.patch
-}
-
-all_ruby_compile() {
- if use doc; then
- rdoc || die
- fi
-}
-
-each_ruby_install() {
- sed -e "s:VERSION:${PV}:" "${FILESDIR}"/${PN}.gemspec > "${RUBY_FAKEGEM_GEMSPEC}"
- each_fakegem_install
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- insinto /usr/share/doc/${PF}
- doins -r recipebook samples
-}
View
59 dev-ruby/aws-sdk/aws-sdk-1.6.0.ebuild
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/aws-sdk-1.6.0.ebuild,v 1.1 2012/07/31 00:10:19 flameeyes Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="ca-bundle.crt"
-
-GITHUB_USER="amazonwebservices"
-GITHUB_PROJECT="${PN}-for-ruby"
-RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-RUBY_FAKEGEM_GEMSPEC="${T}/${P}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Official SDK for Amazon Web Services"
-HOMEPAGE="http://aws.amazon.com/sdkforruby"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl
- >=dev-ruby/httparty-0.7
- >=dev-ruby/json-1.4
- >=dev-ruby/nokogiri-1.4.4
- >=dev-ruby/uuidtools-2.1"
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-1.5.3-disabletest.patch
-}
-
-all_ruby_compile() {
- if use doc; then
- rdoc || die
- fi
-}
-
-each_ruby_install() {
- sed -e "s:VERSION:${PV}:" "${FILESDIR}"/${PN}.gemspec > "${RUBY_FAKEGEM_GEMSPEC}"
- each_fakegem_install
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- insinto /usr/share/doc/${PF}
- doins -r recipebook samples
-}
View
9 dev-ruby/aws-sdk/aws-sdk-1.6.2.ebuild → dev-ruby/aws-sdk/aws-sdk-1.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/aws-sdk-1.6.2.ebuild,v 1.1 2012/08/08 21:02:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/aws-sdk-1.6.3.ebuild,v 1.1 2012/08/10 15:40:58 flameeyes Exp $
EAPI=4
@@ -36,9 +36,10 @@ ruby_add_rdepend "virtual/ruby-ssl
>=dev-ruby/nokogiri-1.4.4
>=dev-ruby/uuidtools-2.1"
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-1.5.3-disabletest.patch
-}
+RUBY_PATCHES=(
+ ${PN}-1.5.3-disabletest.patch
+ ${PN}-1.6.3-no-simplecov.patch
+)
all_ruby_compile() {
if use doc; then
View
38 dev-ruby/aws-sdk/files/aws-sdk-1.6.3-no-simplecov.patch
@@ -0,0 +1,38 @@
+From d507e8f8a03e4a5e517d1b6cad9b1a7a8dbbd7f6 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20Petten=C3=B2?= <flameeyes@flameeyes.eu>
+Date: Fri, 10 Aug 2012 08:28:06 -0700
+Subject: [PATCH] spec: do not force simplecov presence.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+For Gentoo packaging for instance we don't want to know how much of
+the code is covered by the tests, we just want to make sure that the
+tests pass properly.
+
+Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
+---
+ spec/spec_helper.rb | 7 +++++--
+ 1 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/spec/spec_helper.rb b/spec/spec_helper.rb
+index 0214460..8001b3a 100644
+--- a/spec/spec_helper.rb
++++ b/spec/spec_helper.rb
+@@ -11,8 +11,11 @@
+ # ANY KIND, either express or implied. See the License for the specific
+ # language governing permissions and limitations under the License.
+
+-require 'simplecov'
+-SimpleCov.start
++begin
++ require 'simplecov'
++ SimpleCov.start
++rescue LoadError
++end
+
+ $: << File.join(File.dirname(File.dirname(__FILE__)), "lib")
+
+--
+1.7.8.6
+
View
4 dev-ruby/bacon/bacon-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bacon/bacon-1.1.0-r1.ebuild,v 1.13 2012/08/07 17:39:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bacon/bacon-1.1.0-r1.ebuild,v 1.14 2012/08/10 10:32:43 blueness Exp $
EAPI=2
USE_RUBY="ruby18 ruby19 ree18 jruby"
@@ -15,7 +15,7 @@ HOMEPAGE="http://chneukirchen.org/repos/bacon"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
RUBY_PATCHES="${FILESDIR}/${P}+ruby-1.9.2.patch"
View
4 dev-ruby/mail/mail-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mail/mail-2.3.3.ebuild,v 1.1 2012/06/14 06:21:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mail/mail-2.3.3.ebuild,v 1.2 2012/08/10 06:13:08 graaff Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 ree18"
@@ -22,7 +22,7 @@ SRC_URI="https://github.com/${GITHUB_USER}/mail/tarball/${PV} -> ${P}-git.tar.gz
LICENSE="MIT"
SLOT="2.3"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
RUBY_S="${GITHUB_USER}-${PN}-*"
View
4 dev-ruby/rack/rack-1.1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.1.3-r1.ebuild,v 1.4 2012/08/07 17:42:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.1.3-r1.ebuild,v 1.6 2012/08/10 10:35:25 blueness Exp $
EAPI="2"
USE_RUBY="ruby18 ree18 jruby"
@@ -17,7 +17,7 @@ SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
IUSE=""
# The gem has automagic dependencies over mongrel, ruby-openid,
View
4 dev-ruby/rack/rack-1.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.3.6-r1.ebuild,v 1.5 2012/08/07 17:41:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.3.6-r1.ebuild,v 1.7 2012/08/10 10:34:09 blueness Exp $
EAPI="2"
USE_RUBY="ruby18 ree18 ruby19 jruby"
@@ -18,7 +18,7 @@ SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
ruby_add_rdepend "virtual/ruby-ssl"
View
4 dev-ruby/rack/rack-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.4.1.ebuild,v 1.5 2012/08/07 17:40:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.4.1.ebuild,v 1.7 2012/08/10 10:35:25 blueness Exp $
EAPI="2"
USE_RUBY="ruby18 ree18 ruby19 jruby"
@@ -16,7 +16,7 @@ SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
ruby_add_rdepend "virtual/ruby-ssl"
View
1 dev-ruby/rails/Manifest
@@ -3,3 +3,4 @@ DIST rails-3.0.16.gem 3584 SHA256 7b14ba4cea871bebaed72e08cf79416422fe95120b1401
DIST rails-3.1.3.gem 3584 SHA256 e817252efd196b32a16b0af6a92eecd8b2e0b1cbe1511b36fab6c8acdc53e81e SHA512 f3217a24d0f91a298a0aa43f08a3c346e3c71622fcd6dfa66191b483cb848517efd61bdcd1f6ca94cda421c5cc0434df2516929a922dacb7ae2efe7280b53942 WHIRLPOOL 2283a34cfecff079a761366fbf7f06b48a0c4343cd8c8fff6c792c167f0deaeb4b6d6612f4f051be2a242a5e21deb9b4019a11d5c9f83e9dfece004dccf64ab7
DIST rails-3.1.7.gem 3584 SHA256 dc9a69eb2baf2e76e8342bf63c2f10e8cdf1935c53696e41df3923d937a7f60e SHA512 52d34e60f6e2d01db0e572fed22c4f488908a5a74a37c53362b06d541f4ef2649f7ce8f0eb04da240ae850c949bb268b92383295e9f677e9d0f7530a91b99eac WHIRLPOOL 03198dffa2ee5746032c1cf5c356b2c64be9fc4431ccfe16a94623eac6358cf724b6a0a842b39023c4307f2db313678f54c0fbded2c8762810dfc2dfbcbfcc36
DIST rails-3.2.7.gem 3584 SHA256 8aad4faaabd497b3c4f07a02b9720e3111c7fa0967cf7d4d7a9c18b88d13997f SHA512 c9ec54df9805f050cdf09386613b0694549d35eeaa8dc27d445f2bd5eea8b966f2bc8d4e176c384a77341704828bc543fa06a95df1e7a4cf4c64051f53377cfd WHIRLPOOL 946c24edc6428284f7702271af9dd76207997312eac23445dfa37ce7e19a85e179319f498b39c7c9f92d1bf9215172a8886e92427292f0f48d3e97d2f490d3a4
+DIST rails-3.2.8.gem 3584 SHA256 f671d492f91e52e203c99cd989682df89993abaca8b4861732afe1413ead7fcc SHA512 e56c019cb4341bb2e59c4144e7e59b29f66f515e5b63873dc709935ccb1a20f7ae729d2b75c3a54924da883818be3a84442bbec708d6c2b39a99216d9a90543b WHIRLPOOL 095b279ecb1a2a23928ce7ae7a69d200ccb6805c30139747b29f4402d763fbd4980b6d32fc1d8251d55d767e7e4a4d89e3042e4b6e441a86ac4f9de0df7ec7f2
View
37 dev-ruby/rails/rails-3.2.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-3.2.8.ebuild,v 1.1 2012/08/10 06:45:58 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="+asset-pipeline"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ =dev-ruby/bundler-1*
+ ~dev-ruby/railties-${PV}
+ asset-pipeline? (
+ dev-ruby/jquery-rails
+ >=dev-ruby/sass-rails-3.2.3:3.2
+ >=dev-ruby/uglifier-1.0.3
+ >=dev-ruby/coffee-rails-3.2.1:3.2
+ )"
View
1 dev-ruby/railties/Manifest
@@ -2,3 +2,4 @@ DIST rails-3.0.16.tgz 3508179 SHA256 d7aa9ba5a06a9d96763695c874016f254f6902a3476
DIST rails-3.1.3.tgz 3638313 SHA256 412c8a3ae4e0d5283ace45a2ee95127418d6b70fb1a954087b09755ab3a25e99 SHA512 286434f02c16f9cde51c160a5f84ac9b53d9d3aaf44c6c8018cef3250213cd39909013006223cceea8bd68ffe0bdc8ce50b0695e57756d8bb9ec44ab5986a711 WHIRLPOOL 710aa7c64c71b46741e19be41023aa6acf7dfeb25b94f8f14c10748f4a4a4cacd61ecf51a9db0b4eae1d0a1797f4287fd9b0f139a874f1659cab8fa5f252c200
DIST rails-3.1.7.tgz 3647533 SHA256 e32b2fa7ee535eec857ba88710ca80b1a7b05554d8c92506cb0dbd3510a8dc69 SHA512 ac4a164be32bc46a603a76490768fc639fb157d88547eec943d0bdec872ca00c3f008f60e796a7bf27e645fcd73d51f3fb63ba0875ae6f5d34b05e5587d39f33 WHIRLPOOL 8cdc05154f61826a85beec2f7052375b6fc3ef550362eebd3d65839abcec3fb99eb3b09a48cbde44dda769f4e2dc27bcd8aa1fd00ef63d100f57ef819c0fb326
DIST rails-3.2.7.tgz 3802538 SHA256 3a16047cd010d5834d5c33a0a9f1843a0ae21e63f2322d9bb0a5820dd9ddd099 SHA512 cf46c3b3684f3493b37fb62bf78c05f28452d6e37d2fc097527a6c9d21fd839aa940c45e816363aaad4cf5d25fbac099e445eecabfad95d1c1de1b291d12fb7c WHIRLPOOL d2ad4e00728d5603b0b85154fa2783646f7749591b529506a4425c727748bff72a02b72e2f5ba9f762c13ea149f847430472ad76fce43a3096e93e334f57fee9
+DIST rails-3.2.8.tgz 3802639 SHA256 312b8c3b42be96015f24354c48cc11e9c3f84da61b426cf271c8dac961e9603c SHA512 d03a4bd95b34ed796097ac9b8c0d37fb612c008a03d29032f2384f15e306ef998537c84ef8a30e5608263efad457ddc76480cedcf5ce1aeeff374c4384f7ff8c WHIRLPOOL c07273181e6b599de7d6b8e873c3935b92c41f76552198f0bf440009cc1a882749e84cf822ddd2fa3ed89df705a6cd1fc219e0629c8312311f9a10b448f43e93
View
75 dev-ruby/railties/railties-3.2.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/railties-3.2.8.ebuild,v 1.1 2012/08/10 06:45:19 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test:regular"
+RUBY_FAKEGEM_TASK_DOC="generate_guides"
+RUBY_FAKEGEM_DOCDIR="guides/output"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="railties.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Tools for creating, working with, and running Rails applications."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/railties"
+
+# The test suite has many failures, most likely due to a mismatch in
+# exact dependencies or environment specifics. Needs further
+# investigation.
+RESTRICT="test"
+
+RDEPEND+=">=app-admin/eselect-rails-0.18"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/rdoc-3.4
+ >=dev-ruby/thor-0.14.6
+ >=dev-ruby/rack-ssl-1.3.2:1.3
+ >=dev-ruby/rake-0.8.7"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )
+ doc? (
+ >=dev-ruby/redcloth-4.1.1
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\)/d' ../Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm</