Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

glorious funtoo updates

merged:

  funtoo-overlay: e579f0dd69f51f2a56f1e6514f6cb7a31e2e395b
  foo-overlay: e258a2c560b99d0e05d6520058510503ec7206ca
  bar-overlay: f1e9085ee695ff5b6ce57d430d6b224aaf4fa0a6
  flora: 9be3a8e4438918b7f2a80779b49d084ad879b22e
  for-gentoo: 3d603fed78988bb56c965cc9f0322b0e3c7cd05f
  • Loading branch information...
commit 4c3b8e9065a5575f1881dea818bbb131f61eb001 1 parent 3305aff
@danielrobbins danielrobbins authored
Showing with 886 additions and 7,433 deletions.
  1. +0 −1  app-accessibility/accerciser/Manifest
  2. +0 −62 app-accessibility/accerciser/accerciser-3.4.1.ebuild
  3. +3 −3 app-accessibility/accerciser/accerciser-3.6.2-r1.ebuild
  4. +0 −2  app-accessibility/at-spi2-atk/Manifest
  5. +0 −53 app-accessibility/at-spi2-atk/at-spi2-atk-2.4.0.ebuild
  6. +0 −45 app-accessibility/at-spi2-atk/at-spi2-atk-2.6.1.ebuild
  7. +0 −1  app-accessibility/at-spi2-core/Manifest
  8. +3 −3 app-accessibility/at-spi2-core/at-spi2-core-2.2.3.ebuild
  9. +0 −43 app-accessibility/at-spi2-core/at-spi2-core-2.4.2-r1.ebuild
  10. +3 −3 app-accessibility/at-spi2-core/at-spi2-core-2.4.2.ebuild
  11. +0 −46 app-accessibility/at-spi2-core/at-spi2-core-2.6.2-r2.ebuild
  12. +0 −28 app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-deregister.patch
  13. +0 −28 app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-1.patch
  14. +0 −26 app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-2.patch
  15. +0 −1  app-accessibility/caribou/Manifest
  16. +0 −93 app-accessibility/caribou/caribou-0.4.6.ebuild
  17. +0 −86 app-accessibility/gnome-speech/gnome-speech-0.4.25.ebuild
  18. +0 −1  app-accessibility/orca/Manifest
  19. +0 −68 app-accessibility/orca/orca-3.4.2.ebuild
  20. +0 −1  app-admin/abrt/Manifest
  21. +0 −117 app-admin/abrt/abrt-2.0.6.ebuild
  22. +1 −0  app-admin/collectd/Manifest
  23. +361 −0 app-admin/collectd/collectd-5.2.1.ebuild
  24. +0 −1  app-admin/eselect-gnome-shell-extensions/Manifest
  25. +0 −50 app-admin/eselect-gnome-shell-extensions/eselect-gnome-shell-extensions-20111211.ebuild
  26. +0 −1  app-admin/gnome-system-log/Manifest
  27. +0 −38 app-admin/gnome-system-log/gnome-system-log-3.4.1.ebuild
  28. +0 −30 app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-gold.patch
  29. +0 −55 app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r2.ebuild
  30. +0 −1  app-admin/system-config-printer-common/Manifest
  31. +0 −26 app-admin/system-config-printer-common/files/system-config-printer-common-1.3.9-cups_filters_path.patch
  32. +0 −93 app-admin/system-config-printer-common/system-config-printer-common-1.3.9-r2.ebuild
  33. +0 −1  app-admin/system-tools-backends/Manifest
  34. +0 −63 app-admin/system-tools-backends/system-tools-backends-2.10.1.ebuild
  35. +0 −2  app-arch/file-roller/Manifest
  36. +0 −87 app-arch/file-roller/file-roller-3.4.2.ebuild
  37. +0 −89 app-arch/file-roller/file-roller-3.6.2.ebuild
  38. +2 −2 app-arch/file-roller/file-roller-3.6.3.ebuild
  39. +0 −1  app-cdr/brasero/Manifest
  40. +0 −92 app-cdr/brasero/brasero-3.4.1.ebuild
  41. +0 −49 app-cdr/brasero/files/0001-Fix-build-link-libbrasero-burn-against-libm-for-ceil.patch
  42. +0 −294 app-cdr/brasero/files/brasero-2.91.6-build-plugins-against-local-library.patch
  43. +0 −1  app-crypt/libsecret/Manifest
  44. +0 −71 app-crypt/libsecret/libsecret-0.11.ebuild
  45. +0 −1  app-crypt/seahorse-sharing/Manifest
  46. +0 −51 app-crypt/seahorse-sharing/seahorse-sharing-3.4.0.ebuild
  47. +0 −1  app-crypt/seahorse/Manifest
  48. +0 −25 app-crypt/seahorse/files/seahorse-3.4.1-g_clear_object.patch
  49. +0 −72 app-crypt/seahorse/seahorse-3.4.1.ebuild
  50. +0 −1  app-dicts/gnome-dictionary/Manifest
  51. +0 −38 app-dicts/gnome-dictionary/gnome-dictionary-3.4.0.ebuild
  52. +0 −1  app-editors/gedit-plugins/Manifest
  53. +0 −93 app-editors/gedit-plugins/gedit-plugins-3.4.0.ebuild
  54. +0 −1  app-editors/gedit/Manifest
  55. +0 −107 app-editors/gedit/gedit-3.4.2.ebuild
  56. +0 −1  app-editors/latexila/Manifest
  57. +0 −43 app-editors/latexila/latexila-2.6.1.ebuild
  58. +0 −2  app-emulation/libvirt-glib/Manifest
  59. +0 −49 app-emulation/libvirt-glib/libvirt-glib-0.1.3.ebuild
  60. +0 −40 app-emulation/libvirt-glib/libvirt-glib-0.1.4.ebuild
  61. +0 −1  app-misc/gnote/Manifest
  62. +0 −50 app-misc/gnote/gnote-3.6.1.ebuild
  63. +0 −1  app-office/dia/Manifest
  64. +0 −115 app-office/dia/dia-0.97.1.ebuild
  65. +0 −104 app-office/dia/dia-0.97.2.ebuild
  66. +0 −51 app-office/dia/files/dia-0.97-acinclude-python-fixes.patch
  67. +0 −24 app-office/dia/files/dia-0.97.1-libpng15.patch
  68. +0 −1  app-office/dia2code/Manifest
  69. +0 −24 app-office/dia2code/dia2code-0.8.3.ebuild
  70. +0 −60 app-office/gnumeric/gnumeric-1.12.0.ebuild
  71. +0 −1  app-office/planner/Manifest
  72. +0 −12 app-office/planner/files/planner-0.14.3-eds-plugin.patch
  73. +0 −19 app-office/planner/files/planner-0.14.5-find-python.patch
  74. +0 −77 app-office/planner/planner-0.14.5.ebuild
  75. +0 −1  app-pda/gnome-pilot/Manifest
  76. +0 −53 app-pda/gnome-pilot/gnome-pilot-2.32.0.ebuild
  77. +1 −0  app-shells/mksh/Manifest
  78. +37 −0 app-shells/mksh/mksh-44.ebuild
  79. +0 −1  app-text/evince/Manifest
  80. +0 −113 app-text/evince/evince-3.4.0.ebuild
  81. +0 −54 app-text/evince/files/evince-3.4.0-glib-gold.patch
  82. +0 −2  app-text/gnome-doc-utils/Manifest
  83. +0 −87 app-text/gnome-doc-utils/gnome-doc-utils-0.20.6.ebuild
  84. +0 −82 app-text/gnome-doc-utils/gnome-doc-utils-0.20.9.ebuild
  85. +0 −1  app-text/gtranslator/Manifest
  86. +0 −92 app-text/gtranslator/gtranslator-2.91.5.ebuild
  87. +0 −1  app-text/iso-codes/Manifest
  88. +0 −51 app-text/iso-codes/iso-codes-3.30.ebuild
  89. +0 −2  app-text/libgxps/Manifest
  90. +0 −70 app-text/libgxps/files/libgxps-0.2.0-libm.patch
  91. +0 −29 app-text/libgxps/files/libgxps-0.2.0-libpng15.patch
  92. +0 −43 app-text/libgxps/libgxps-0.1.0.ebuild
  93. +0 −52 app-text/libgxps/libgxps-0.2.1.ebuild
  94. +0 −2  app-text/wv/Manifest
  95. +0 −50 app-text/wv/wv-1.2.3-r1.ebuild
  96. +0 −53 app-text/wv/wv-1.2.7.ebuild
  97. +0 −47 app-text/wv/wv-1.2.9.ebuild
  98. +0 −1  dev-cpp/atkmm/Manifest
  99. +0 −35 dev-cpp/atkmm/atkmm-2.22.5.ebuild
  100. +0 −2  dev-cpp/cairomm/Manifest
  101. +0 −42 dev-cpp/cairomm/cairomm-1.8.6.ebuild
  102. +0 −48 dev-cpp/cairomm/cairomm-1.9.8.ebuild
  103. +0 −1  dev-cpp/gconfmm/Manifest
  104. +0 −50 dev-cpp/gconfmm/gconfmm-2.28.2-r1.ebuild
  105. +0 −1  dev-cpp/gtksourceviewmm/Manifest
  106. +0 −45 dev-cpp/gtksourceviewmm/files/gtksourceviewmm-2.10.2-glib-2.31.patch
  107. +0 −50 dev-cpp/gtksourceviewmm/gtksourceviewmm-2.10.2.ebuild
  108. +0 −25 dev-cpp/libpanelappletmm/libpanelappletmm-2.26.0.ebuild
  109. +0 −2  dev-cpp/pangomm/Manifest
  110. +0 −43 dev-cpp/pangomm/pangomm-2.28.2.ebuild
  111. +0 −38 dev-cpp/pangomm/pangomm-2.28.3.ebuild
  112. +7 −3 dev-lang/luajit/luajit-2.0.0.ebuild
  113. +0 −2  dev-libs/gjs/Manifest
  114. +0 −65 dev-libs/gjs/gjs-1.30.1.ebuild
  115. +0 −67 dev-libs/gjs/gjs-1.32.0.ebuild
  116. +0 −1  dev-libs/gmime/Manifest
  117. +0 −58 dev-libs/gmime/gmime-2.6.12.ebuild
  118. +0 −2  dev-libs/gobject-introspection/Manifest
  119. +0 −94 dev-libs/gobject-introspection/gobject-introspection-1.30.0-r2.ebuild
  120. +0 −97 dev-libs/gobject-introspection/gobject-introspection-1.34.2.ebuild
  121. +0 −1  dev-libs/libcroco/Manifest
  122. +0 −39 dev-libs/libcroco/libcroco-0.6.7.ebuild
  123. +0 −2  dev-libs/libgee/Manifest
  124. +0 −29 dev-libs/libgee/libgee-0.6.6.1.ebuild
  125. +0 −31 dev-libs/libgee/libgee-0.8.3.ebuild
  126. +0 −1  dev-libs/libgweather/Manifest
  127. +0 −46 dev-libs/libgweather/libgweather-3.4.1.ebuild
  128. +0 −1  dev-libs/liboobs/Manifest
  129. +0 −29 dev-libs/liboobs/liboobs-2.32.0.ebuild
  130. +0 −72 dev-libs/libpeas/libpeas-1.6.2.ebuild
  131. +0 −54 dev-libs/libpwquality/libpwquality-1.2.0-r1.ebuild
  132. +0 −1  dev-libs/libreport/Manifest
  133. +0 −154 dev-libs/libreport/files/libreport-2.0.7-gentoo.patch
  134. +0 −46 dev-libs/libreport/files/libreport-2.0.7-multiple-tabs.patch
  135. +0 −80 dev-libs/libreport/files/libreport-2.0.7-no-bugzilla.patch
  136. +0 −106 dev-libs/libreport/libreport-2.0.9.ebuild
  137. +1 −0  dev-lua/luvit/Manifest
  138. +82 −0 dev-lua/luvit/luvit-0.6.1.ebuild
  139. +2 −2 dev-lua/luvit/luvit-9999.ebuild
  140. +1 −0  dev-python/PyGithub/Manifest
  141. +24 −0 dev-python/PyGithub/PyGithub-1.12.2.ebuild
  142. +1 −1  dev-python/d2to1/Manifest
  143. +19 −3 dev-python/d2to1/{d2to1-0.2.7.ebuild → d2to1-0.2.9-r1000.ebuild}
  144. +0 −1  dev-python/pysqlite/Manifest
  145. +0 −8 dev-python/pysqlite/metadata.xml
  146. +0 −33 dev-python/pysqlite/pysqlite-1.0.1.ebuild
  147. +0 −57 dev-python/pysqlite/pysqlite-2.6.3-r1.ebuild
  148. +1 −1  dev-python/rdflib/Manifest
  149. +10 −7 dev-python/rdflib/{rdflib-3.2.3-r1000.ebuild → rdflib-3.4.0-r1000.ebuild}
  150. +1 −0  dev-ruby/ffi/Manifest
  151. +47 −0 dev-ruby/ffi/ffi-1.4.0.ebuild
  152. +5 −1 dev-ruby/metasploit_data_models/Manifest
  153. +2 −2 dev-ruby/metasploit_data_models/metasploit_data_models-0.3.1-r1.ebuild
  154. +40 −0 dev-ruby/metasploit_data_models/metasploit_data_models-0.4.0.ebuild
  155. +40 −0 dev-ruby/metasploit_data_models/metasploit_data_models-0.5.0.ebuild
  156. +40 −0 dev-ruby/metasploit_data_models/metasploit_data_models-0.5.1.ebuild
  157. +40 −0 dev-ruby/metasploit_data_models/metasploit_data_models-0.6.0.ebuild
  158. +2 −1  dev-util/catalyst/catalyst-9999.ebuild
  159. +0 −2  dev-util/gdbus-codegen/Manifest
  160. +0 −70 dev-util/gdbus-codegen/gdbus-codegen-2.30.3.ebuild
  161. +0 −45 dev-util/gdbus-codegen/gdbus-codegen-2.34.2.ebuild
  162. +0 −45 dev-util/gdbus-codegen/gdbus-codegen-2.34.3.ebuild
  163. +0 −5 dev-util/gdbus-codegen/metadata.xml
  164. +2 −2 dev-util/ninja/ninja-1.1.0.ebuild
  165. +4 −4 eclass/kernel-2.eclass
  166. +6 −5 eclass/readme.gentoo.eclass
  167. +2 −0  media-gfx/pngcrush/Manifest
  168. +42 −0 media-gfx/pngcrush/pngcrush-1.7.52.ebuild
  169. +0 −2  media-libs/gst-plugins-bad/Manifest
  170. +0 −45 media-libs/gst-plugins-bad/gst-plugins-bad-0.10.22.ebuild
  171. +0 −45 media-libs/gst-plugins-bad/gst-plugins-bad-0.10.23.ebuild
  172. +0 −43 media-libs/gst-plugins-bad/gst-plugins-bad-1.0.3.ebuild
  173. +0 −2  media-libs/gst-plugins-base/Manifest
  174. +0 −55 media-libs/gst-plugins-base/gst-plugins-base-0.10.35.ebuild
  175. +0 −86 media-libs/gst-plugins-base/gst-plugins-base-1.0.3.ebuild
  176. +0 −91 media-libs/gst-plugins-base/gst-plugins-base-1.0.5-r1.ebuild
  177. +2 −2 media-libs/gst-plugins-base/gst-plugins-base-1.0.5.ebuild
  178. +0 −2  media-libs/gst-plugins-good/Manifest
  179. +0 −57 media-libs/gst-plugins-good/gst-plugins-good-0.10.30.ebuild
  180. +0 −55 media-libs/gst-plugins-good/gst-plugins-good-1.0.3.ebuild
  181. +0 −2  media-libs/gst-plugins-ugly/Manifest
  182. +0 −45 media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.18.ebuild
  183. +0 −44 media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.3.ebuild
  184. +0 −2  media-libs/gstreamer/Manifest
  185. +0 −72 media-libs/gstreamer/gstreamer-0.10.35.ebuild
  186. +0 −67 media-libs/gstreamer/gstreamer-1.0.3.ebuild
  187. +0 −68 media-libs/gstreamer/gstreamer-1.0.5.ebuild
  188. +2 −2 media-libs/soxr/soxr-0.1.0.ebuild
  189. +0 −2  media-plugins/gst-plugins-soup/Manifest
  190. +0 −16 media-plugins/gst-plugins-soup/gst-plugins-soup-0.10.30.ebuild
  191. +0 −16 media-plugins/gst-plugins-soup/gst-plugins-soup-1.0.3.ebuild
  192. +0 −2  media-plugins/gst-plugins-speex/Manifest
  193. +0 −15 media-plugins/gst-plugins-speex/gst-plugins-speex-0.10.30.ebuild
  194. +0 −14 media-plugins/gst-plugins-speex/gst-plugins-speex-1.0.3.ebuild
  195. +0 −2  media-plugins/gst-plugins-taglib/Manifest
  196. +0 −14 media-plugins/gst-plugins-taglib/gst-plugins-taglib-0.10.30.ebuild
  197. +0 −14 media-plugins/gst-plugins-taglib/gst-plugins-taglib-1.0.3.ebuild
  198. +0 −1  media-plugins/gst-plugins-theora/Manifest
  199. +0 −20 media-plugins/gst-plugins-theora/gst-plugins-theora-0.10.35.ebuild
  200. +0 −2  media-plugins/gst-plugins-twolame/Manifest
  201. +0 −15 media-plugins/gst-plugins-twolame/gst-plugins-twolame-0.10.18.ebuild
  202. +0 −13 media-plugins/gst-plugins-twolame/gst-plugins-twolame-1.0.3.ebuild
  203. +0 −2  media-plugins/gst-plugins-v4l2/Manifest
  204. +0 −28 media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.30.ebuild
  205. +0 −27 media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-1.0.3.ebuild
  206. +0 −1  media-plugins/gst-plugins-voaacenc/Manifest
  207. +0 −14 media-plugins/gst-plugins-voaacenc/gst-plugins-voaacenc-1.0.3.ebuild
  208. +0 −1  media-plugins/gst-plugins-voamrwbenc/Manifest
  209. +0 −14 media-plugins/gst-plugins-voamrwbenc/gst-plugins-voamrwbenc-1.0.3.ebuild
  210. +0 −1  media-plugins/gst-plugins-vorbis/Manifest
  211. +0 −20 media-plugins/gst-plugins-vorbis/gst-plugins-vorbis-0.10.35.ebuild
  212. +0 −1  media-plugins/gst-plugins-vp8/Manifest
  213. +0 −23 media-plugins/gst-plugins-vp8/gst-plugins-vp8-0.10.22.ebuild
  214. +0 −21 media-plugins/gst-plugins-vp8/gst-plugins-vp8-0.10.23.ebuild
  215. +0 −1  media-plugins/gst-plugins-vpx/Manifest
  216. +0 −14 media-plugins/gst-plugins-vpx/gst-plugins-vpx-1.0.3.ebuild
  217. +0 −1  media-plugins/gst-plugins-x/Manifest
  218. +0 −31 media-plugins/gst-plugins-x/gst-plugins-x-0.10.35-r1.ebuild
  219. +0 −31 media-plugins/gst-plugins-x/gst-plugins-x-0.10.35.ebuild
  220. +0 −2  media-plugins/gst-plugins-x264/Manifest
  221. +0 −16 media-plugins/gst-plugins-x264/gst-plugins-x264-0.10.18.ebuild
  222. +0 −14 media-plugins/gst-plugins-x264/gst-plugins-x264-1.0.3.ebuild
  223. +0 −2  media-plugins/gst-plugins-ximagesrc/Manifest
  224. +0 −21 media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-0.10.30.ebuild
  225. +0 −27 media-plugins/gst-plugins-ximagesrc/gst-plugins-ximagesrc-1.0.3.ebuild
  226. +0 −1  media-plugins/gst-plugins-xvid/Manifest
  227. +0 −15 media-plugins/gst-plugins-xvid/gst-plugins-xvid-0.10.22.ebuild
  228. +0 −1  media-plugins/gst-plugins-xvideo/Manifest
  229. +0 −33 media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35-r1.ebuild
  230. +0 −33 media-plugins/gst-plugins-xvideo/gst-plugins-xvideo-0.10.35.ebuild
  231. +1 −1  metadata/dtd/timestamp.chk
  232. +1 −1  metadata/glsa/timestamp.chk
  233. +0 −12 metadata/md5-cache/app-accessibility/accerciser-3.4.1
  234. +3 −3 metadata/md5-cache/app-accessibility/accerciser-3.6.2-r1
  235. +0 −13 metadata/md5-cache/app-accessibility/at-spi2-atk-2.4.0
  236. +0 −13 metadata/md5-cache/app-accessibility/at-spi2-atk-2.6.1
  237. +2 −2 metadata/md5-cache/app-accessibility/at-spi2-core-2.2.3
  238. +2 −2 metadata/md5-cache/app-accessibility/at-spi2-core-2.4.2
  239. +0 −13 metadata/md5-cache/app-accessibility/at-spi2-core-2.4.2-r1
  240. +0 −13 metadata/md5-cache/app-accessibility/at-spi2-core-2.6.2-r2
  241. +0 −13 metadata/md5-cache/app-accessibility/caribou-0.4.6
  242. +0 −13 metadata/md5-cache/app-accessibility/gnome-speech-0.4.25
  243. +0 −12 metadata/md5-cache/app-accessibility/orca-3.4.2
  244. +0 −13 metadata/md5-cache/app-admin/abrt-2.0.6
  245. +13 −0 metadata/md5-cache/app-admin/collectd-5.2.1
  246. +0 −11 metadata/md5-cache/app-admin/eselect-gnome-shell-extensions-20111211
  247. +0 −12 metadata/md5-cache/app-admin/gnome-system-log-3.4.1
  248. +0 −13 metadata/md5-cache/app-admin/gnome-system-tools-2.32.0-r2
  249. +0 −14 metadata/md5-cache/app-admin/system-config-printer-common-1.3.9-r2
  250. +0 −12 metadata/md5-cache/app-admin/system-tools-backends-2.10.1
  251. +0 −13 metadata/md5-cache/app-arch/file-roller-3.4.2
  252. +0 −13 metadata/md5-cache/app-arch/file-roller-3.6.2
  253. +2 −2 metadata/md5-cache/app-arch/file-roller-3.6.3
  254. +1 −1  metadata/md5-cache/app-benchmarks/ltp-20120903
  255. +0 −14 metadata/md5-cache/app-cdr/brasero-3.4.1
  256. +0 −14 metadata/md5-cache/app-crypt/libsecret-0.11
  257. +0 −13 metadata/md5-cache/app-crypt/seahorse-3.4.1
  258. +0 −13 metadata/md5-cache/app-crypt/seahorse-sharing-3.4.0
  259. +0 −13 metadata/md5-cache/app-dicts/gnome-dictionary-3.4.0
  260. +1 −1  metadata/md5-cache/app-doc/devmanual-9999
  261. +1 −1  metadata/md5-cache/app-editors/emacs-23.4-r5
  262. +1 −1  metadata/md5-cache/app-editors/emacs-24.3_rc1
  263. +1 −1  metadata/md5-cache/app-editors/emacs-vcs-24.3.9999
  264. +0 −13 metadata/md5-cache/app-editors/gedit-3.4.2
  265. +0 −14 metadata/md5-cache/app-editors/gedit-plugins-3.4.0
  266. +1 −1  metadata/md5-cache/app-editors/gummi-0.6.5
  267. +0 −13 metadata/md5-cache/app-editors/latexila-2.6.1
  268. +0 −14 metadata/md5-cache/app-emulation/libvirt-glib-0.1.3
  269. +0 −14 metadata/md5-cache/app-emulation/libvirt-glib-0.1.4
  270. +1 −1  metadata/md5-cache/app-emulation/phpvirtualbox-4.2.4
  271. +1 −1  metadata/md5-cache/app-i18n/fcitx-4.2.7
  272. +1 −1  metadata/md5-cache/app-i18n/xsunpinyin-2.0.4_pre20130108
  273. +1 −1  metadata/md5-cache/app-laptop/configure-trackpoint-0.7
  274. +1 −1  metadata/md5-cache/app-laptop/hdapsd-20090401-r2
  275. +1 −1  metadata/md5-cache/app-laptop/prey-0.5.4-r1
  276. +0 −13 metadata/md5-cache/app-misc/gnote-3.6.1
  277. +1 −1  metadata/md5-cache/app-misc/recoll-1.18.1
  278. +1 −1  metadata/md5-cache/app-mobilephone/qtadb-0.8.1
  279. +0 −13 metadata/md5-cache/app-office/dia-0.97.1
  280. +0 −13 metadata/md5-cache/app-office/dia-0.97.2
  281. +0 −11 metadata/md5-cache/app-office/dia2code-0.8.3
  282. +0 −14 metadata/md5-cache/app-office/gnumeric-1.12.0
  283. +0 −13 metadata/md5-cache/app-office/planner-0.14.5
  284. +0 −13 metadata/md5-cache/app-pda/gnome-pilot-2.32.0
  285. +1 −1  metadata/md5-cache/app-portage/gentoolkit-0.3.0.7-r1001
  286. +11 −0 metadata/md5-cache/app-shells/mksh-44
  287. +0 −14 metadata/md5-cache/app-text/evince-3.4.0
  288. +0 −12 metadata/md5-cache/app-text/gnome-doc-utils-0.20.6
  289. +0 −12 metadata/md5-cache/app-text/gnome-doc-utils-0.20.9
  290. +0 −13 metadata/md5-cache/app-text/gtranslator-2.91.5
  291. +0 −12 metadata/md5-cache/app-text/iso-codes-3.30
  292. +0 −14 metadata/md5-cache/app-text/libgxps-0.1.0
  293. +0 −14 metadata/md5-cache/app-text/libgxps-0.2.1
  294. +0 −12 metadata/md5-cache/app-text/wv-1.2.3-r1
  295. +0 −13 metadata/md5-cache/app-text/wv-1.2.7
  296. +0 −13 metadata/md5-cache/app-text/wv-1.2.9
  297. +0 −13 metadata/md5-cache/dev-cpp/atkmm-2.22.5
  298. +0 −13 metadata/md5-cache/dev-cpp/cairomm-1.8.6
  299. +0 −13 metadata/md5-cache/dev-cpp/cairomm-1.9.8
  300. +0 −13 metadata/md5-cache/dev-cpp/gconfmm-2.28.2-r1
Sorry, we could not display the entire diff because too many files (846) changed.
View
1  app-accessibility/accerciser/Manifest
@@ -1,3 +1,2 @@
DIST accerciser-1.12.1.tar.bz2 1554921 SHA256 addbc940a05c0dacb6131c8e0b136c14eab73c57bfe50c110cef4d3723d07807 SHA512 f769af63a3cfe3e868769205fc270ff2948ceebd0e8965016f18ec0062dfdc398c6bd82dbe5ef40d555ea711bd6be529235803fe86dffd3828fd8183e095a06b WHIRLPOOL 0cf90b3d83a9a6e595af23aaacdcc28d57ab20b08bc97252a252e39ad9f20a6114da5f777996f6e36c23f8c3bcf097f8b63d7769d7b578dc50f556e68a95d834
-DIST accerciser-3.4.1.tar.xz 3060608 SHA256 7f8deef3129060c5103f43bb94e29723747060c8feb5bb66a278ae48c44b3030 SHA512 30dcbe76b317dcb24d9a046b3f801d8ae85fb8819bdc3350f03bd1940ddaafeda4e38fb1d10d9d1884d814b881ec697f11a6e44909f10b049d19e37730cf5375 WHIRLPOOL 78c769d11976294a89091ee5123feaa262fcebd02406ee5014edf3afe09daba2bcee221bda598948e946de840ffb0881a87ea5a6e9cd28a4281ef01b0fdd7c0e
DIST accerciser-3.6.2.tar.xz 3076756 SHA256 4ed3a9a508b0109772a992666b87a5ca80dcb9cb83bf6878977129f25f499879 SHA512 734486426d681f965ddbf3fdb88017d9d5af5d2304add1fb1b17c2e61ad0624e63876f8581ef9992194361003e889c5da5a3609194418652284f159dc03fddb4 WHIRLPOOL 8b125010b66151c24a08d6af373627d04615ed764552a7ea7993cbde8b0d476e3375c2c1d7e2f5ce4f488741314b6b5436fddef953e857232d5a6733e585705a
View
62 app-accessibility/accerciser/accerciser-3.4.1.ebuild
@@ -1,62 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/accerciser-3.4.1.ebuild,v 1.1 2012/05/20 08:41:00 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-PYTHON_DEPEND="2:2.5"
-PYTHON_USE_WITH="xml"
-
-inherit gnome2 python
-
-DESCRIPTION="Interactive Python accessibility explorer"
-HOMEPAGE="http://live.gnome.org/Accerciser"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=app-accessibility/at-spi2-core-2.1.5:2
- >=dev-python/pygobject-2.90.3:3
- >=x11-libs/gtk+-3.1.13:3[introspection]
-
- dev-libs/atk[introspection]
- >=dev-libs/glib-2.28:2
- dev-libs/gobject-introspection
- >=dev-python/ipython-0.11
- >=dev-python/pyatspi-2.1.5
- dev-python/pycairo
- x11-libs/gdk-pixbuf[introspection]
- x11-libs/libwnck:3[introspection]
- x11-libs/pango[introspection]"
-DEPEND="${RDEPEND}
- >=app-text/gnome-doc-utils-0.17.3
- app-text/scrollkeeper
- >=dev-util/intltool-0.35
- sys-devel/gettext
- virtual/pkgconfig"
-
-pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README"
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- python_clean_py-compile_files
- python_convert_shebangs -r 2 .
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- python_need_rebuild
- python_mod_optimize "${PN}" /usr/share/${PN}
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup "${PN}" /usr/share/${PN}
-}
View
6 app-accessibility/accerciser/accerciser-3.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/accerciser-3.6.2-r1.ebuild,v 1.2 2013/02/07 21:12:41 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/accerciser/accerciser-3.6.2-r1.ebuild,v 1.3 2013/03/05 22:21:17 eva Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -25,9 +25,9 @@ RDEPEND="
dev-libs/atk[introspection]
>=dev-libs/glib-2.28:2
dev-libs/gobject-introspection
- >=dev-python/ipython-0.11
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
>=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
- dev-python/pycairo
+ dev-python/pycairo[${PYTHON_USEDEP}]
x11-libs/gdk-pixbuf[introspection]
x11-libs/libwnck:3[introspection]
x11-libs/pango[introspection]
View
2  app-accessibility/at-spi2-atk/Manifest
@@ -1,3 +1 @@
-DIST at-spi2-atk-2.4.0.tar.xz 303684 SHA256 28e9c21ec8a76cae4914bdbc011c4f6bf1beeaa27751a88534d87364e6a888bf SHA512 78a4b3e731e3e2722b82402bab88c2ef05fb66f29d7fa66b2ee0b167fa177797b647ed485af7d27687a636d0265d6e2e835a85c6349556b24f5ed76255444b0e WHIRLPOOL df025133af0df70fbb7c7cef782c482bf6eca9f86cdd4c2e3aeb029c311c57d0515cfc91692216f53cb8511dade8ca59f05653d9f272b9058b1884a803f4d429
-DIST at-spi2-atk-2.6.1.tar.xz 274796 SHA256 0a796c3635b23d094d488ac3aeee1bd785debfde433640687d4b17dfeaeb3398 SHA512 dc7bbacac72867a0263e2d2546fca841a2740195c9aad496ffc602ce29a572a58ad2b7e9314f0a0833d147a416d34163f1236e63ae4e9fb56d8b946ce779724f WHIRLPOOL 2a66a8c47e5731347b00ec830202ccf5492d5c93af8ca55f3c15d05ccc8b350b48ceedff7cb23a2f0efee5a725cba96c1e17e5e2e6263e0c0c6b93b8c98dfae9
DIST at-spi2-atk-2.6.2.tar.xz 274748 SHA256 496c8432e8ab82735145f9af5d45209e9b708bf3c94e527ee091d08641a9bcfa SHA512 1ccfb0be6ebcd2a128b4ede45061cd4742ed861bd3167f60cbc52ce5daf043e30d10811726bb4918dfb8acd48fedcffdb78d416dee0af98955e8759a8d3cee90 WHIRLPOOL d9e9e20dcbfd3b56cff3db203c02ce047c3ff3989b4e24bb860ccf36d7d362c93ec1db14209dfb45e1824ceacb7d767fb8b8f0084e2e00f801a1db41a92928e0
View
53 app-accessibility/at-spi2-atk/at-spi2-atk-2.4.0.ebuild
@@ -1,53 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-atk/at-spi2-atk-2.4.0.ebuild,v 1.5 2012/12/18 18:01:46 ago Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2 virtualx
-
-DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
-HOMEPAGE="http://live.gnome.org/Accessibility"
-
-LICENSE="LGPL-2+"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-COMMON_DEPEND="
- >=app-accessibility/at-spi2-core-2.4
- >=dev-libs/atk-2.1.0
- dev-libs/glib:2
- >=sys-apps/dbus-1
- x11-libs/libX11
-"
-RDEPEND="${COMMON_DEPEND}
- !<gnome-extra/at-spi-1.32.0-r1
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- >=dev-util/intltool-0.40
-"
-
-pkg_setup() {
- DOCS="AUTHORS NEWS README"
- # xevie is deprecated/broken since xorg-1.6/1.7
- G2CONF="${G2CONF} --enable-p2p"
-}
-
-src_prepare() {
- # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
- epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
-
- # FIXME: droute test fails
-# sed -e 's:TESTS = droute-test\.*:TESTS = :' -i droute/Makefile.* ||
-# die "sed droute/Makefile.* failed"
-
- gnome2_src_prepare
-}
-
-src_test() {
- Xemake check
-}
View
45 app-accessibility/at-spi2-atk/at-spi2-atk-2.6.1.ebuild
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-atk/at-spi2-atk-2.6.1.ebuild,v 1.3 2012/12/18 18:01:46 ago Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2 virtualx
-
-DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
-HOMEPAGE="http://live.gnome.org/Accessibility"
-
-LICENSE="LGPL-2+"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-COMMON_DEPEND="
- >=app-accessibility/at-spi2-core-2.6
- >=dev-libs/atk-2.1.0
- dev-libs/glib:2
- >=sys-apps/dbus-1
-"
-RDEPEND="${COMMON_DEPEND}
- !<gnome-extra/at-spi-1.32.0-r1
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
-"
-
-src_prepare() {
- DOCS="AUTHORS NEWS README"
- # xevie is deprecated/broken since xorg-1.6/1.7
- G2CONF="${G2CONF} --enable-p2p"
-
- # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
- epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
-
- gnome2_src_prepare
-}
-
-src_test() {
- Xemake check
-}
View
1  app-accessibility/at-spi2-core/Manifest
@@ -1,4 +1,3 @@
DIST at-spi2-core-2.2.3.tar.xz 429444 SHA256 fb97f0a02fa378795e50857e22e640e099be1768081e28ca2dbdb3835f5b6af1 SHA512 4ff634339c7aecd90d1ec8b16478aae4da0db319ae1ee1ac5bcecc93098f797dc58359b718b9800bffa6da81afc41fed21eff71456a165aa6428f7a64179d631 WHIRLPOOL a698a217f99af089a9041b7162ebcff66d5d8a38050dd74750c77792380e368f57d91d2b1494a080674fb57560e566cd924cf930a5e7785f9ccdeb12a34504ab
DIST at-spi2-core-2.4.2.tar.xz 441204 SHA256 61d926ffc49c7f9236580468c5c9dabda16cec37ef3aee78ca6f2751595518fd SHA512 38968eb9a135b3f7badae2a87e7ba6b3323bfd43f8494ac81fb6696f7056d0e0ab04679173f9f8f595284611327da83fcf5ada3a406080c3faf5ada98a5d6599 WHIRLPOOL aa0902f6992dc38610599d2ccabb7796699ee4ebe0ded3b5123a4c85e290565d0a8812dec82851be69bad4afcf29f2eda120265f1707792c06f36f96cba95e95
-DIST at-spi2-core-2.6.2.tar.xz 443900 SHA256 0d5321ce9fdd7d036b072ef28cba14088394606e1687183ec5d0ae6adea8c87e SHA512 946e46bcba025d298051d99e229dfc5a3ff0b477b9c4e1a97c1ea3cee8a86832e2ee7fe34a986a9fb8e1138389e8f9ad3e27c2638769f1251e12ce4df6ccda9d WHIRLPOOL b01abdaa0f749f113e10a19ce1eab9d7bd120975a738acdf96fa25776258c51749af77f44375800724067b5b9ced253e49cd0c87225e7baee4e522b628657a1c
DIST at-spi2-core-2.6.3.tar.xz 445084 SHA256 fc4487ae46e847cfd057b329b852cf99923772ecd2ddc29f29670c9f2b15d0ea SHA512 8b72a7587506ab2f9891518c99c7393ae427bf0da74ea3c0c3fd83ec64217dd171e739fd00bc946a600fd50de2f234c7ee51642d9a6e51ca7825d3a4fcb0beed WHIRLPOOL c1d9eafe5c4a1b1f133ba7ee0db71c7d2e22efd7f0537e055c6d7ba479fddc807ff6446c46c9b7c50963bf232da2b746c4b69903117610072c31a1e847c069b5
View
6 app-accessibility/at-spi2-core/at-spi2-core-2.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.2.3.ebuild,v 1.11 2012/12/23 02:49:08 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.2.3.ebuild,v 1.12 2013/03/05 22:28:08 eva Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -13,7 +13,7 @@ HOMEPAGE="http://live.gnome.org/Accessibility"
LICENSE="LGPL-2+"
SLOT="2"
-KEYWORDS="amd64 arm ~hppa ~ia64 ~ppc64 x86 ~amd64-fbsd"
+KEYWORDS="amd64 arm x86"
IUSE="+introspection"
RDEPEND=">=dev-libs/glib-2.28:2
View
43 app-accessibility/at-spi2-core/at-spi2-core-2.4.2-r1.ebuild
@@ -1,43 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.4.2-r1.ebuild,v 1.1 2012/12/23 02:49:08 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2
-
-DESCRIPTION="D-Bus accessibility specifications and registration daemon"
-HOMEPAGE="http://live.gnome.org/Accessibility"
-
-LICENSE="LGPL-2+"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-IUSE="+introspection"
-
-RDEPEND=">=dev-libs/glib-2.28:2
- >=sys-apps/dbus-1
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXtst
- introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
-"
-DEPEND="${RDEPEND}
- dev-util/gtk-doc-am
- >=dev-util/intltool-0.40
- virtual/pkgconfig
-"
-
-src_prepare() {
- DOCS="AUTHORS ChangeLog NEWS README"
- # xevie is deprecated/broken since xorg-1.6/1.7
- G2CONF="${G2CONF}
- --disable-xevie
- $(use_enable introspection)"
-
- # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
- epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
-
- gnome2_src_prepare
-}
View
6 app-accessibility/at-spi2-core/at-spi2-core-2.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.4.2.ebuild,v 1.10 2012/12/23 02:49:08 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.4.2.ebuild,v 1.11 2013/03/05 22:28:08 eva Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -13,7 +13,7 @@ HOMEPAGE="http://live.gnome.org/Accessibility"
LICENSE="LGPL-2+"
SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ppc ppc64 ~x86 ~amd64-fbsd"
+KEYWORDS="ppc ppc64"
IUSE="+introspection"
RDEPEND=">=dev-libs/glib-2.28:2
View
46 app-accessibility/at-spi2-core/at-spi2-core-2.6.2-r2.ebuild
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.6.2-r2.ebuild,v 1.3 2013/01/06 09:10:21 ago Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2
-
-DESCRIPTION="D-Bus accessibility specifications and registration daemon"
-HOMEPAGE="http://live.gnome.org/Accessibility"
-
-LICENSE="LGPL-2+"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
-IUSE="+introspection"
-
-RDEPEND=">=dev-libs/glib-2.28:2
- >=sys-apps/dbus-1
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXtst
- introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.9
- >=dev-util/intltool-0.40
- virtual/pkgconfig
-"
-
-src_prepare() {
- # xevie is deprecated/broken since xorg-1.6/1.7
- G2CONF="${G2CONF}
- --disable-xevie
- $(use_enable introspection)"
-
- # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
- epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
-
- # important patches from 2.6.3
- epatch "${FILESDIR}/${P}-hung-crash-"{1,2}.patch
- epatch "${FILESDIR}/${P}-deregister.patch"
-
- gnome2_src_prepare
-}
View
28 app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-deregister.patch
@@ -1,28 +0,0 @@
-From ca6778ba2a6c4fed24d5468213f8ed918f3dcbe4 Mon Sep 17 00:00:00 2001
-From: Mike Gorse <mgorse@suse.com>
-Date: Fri, 7 Dec 2012 11:21:19 -0600
-Subject: [PATCH 3/3] Fix deregistering of applications
-
----
- registryd/registry.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/registryd/registry.c b/registryd/registry.c
-index a64e094..e283a90 100644
---- a/registryd/registry.c
-+++ b/registryd/registry.c
-@@ -290,9 +290,10 @@ handle_disconnection (DBusConnection *bus, DBusMessage *message, void *user_data
- for (i = 0; i < reg->apps->len; i++)
- {
- SpiReference *ref = g_ptr_array_index (reg->apps, i);
-- while (!g_strcmp0 (old, ref->name))
-+ if (!g_strcmp0 (old, ref->name))
- {
- remove_application (reg, bus, i);
-+ i--;
- }
- }
-
---
-1.8.0
-
View
28 app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-1.patch
@@ -1,28 +0,0 @@
-From 860ccecf3de3fdca6742060174cab1f90d708fb3 Mon Sep 17 00:00:00 2001
-From: Mike Gorse <mgorse@suse.com>
-Date: Thu, 6 Dec 2012 09:50:18 -0600
-Subject: [PATCH 1/3] Remove the correct datum when clearing a hung process
-
-When clearing hung processes, we were passing the wrong variable to
-g_list_remove, meaning that the datum would never be removed from the
-list, even though it had been freed, resulting in a crash.
----
- registryd/deviceeventcontroller.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/registryd/deviceeventcontroller.c b/registryd/deviceeventcontroller.c
-index b8c1bc7..101dc6f 100644
---- a/registryd/deviceeventcontroller.c
-+++ b/registryd/deviceeventcontroller.c
-@@ -1205,7 +1205,7 @@ reset_hung_process_from_ping (DBusPendingCall *pending, void *data)
- if (!strcmp (l->data, data))
- {
- g_free (l->data);
-- hung_processes = g_slist_remove (hung_processes, data);
-+ hung_processes = g_slist_remove (hung_processes, l->data);
- break;
- }
- }
---
-1.8.0
-
View
26 app-accessibility/at-spi2-core/files/at-spi2-core-2.6.2-hung-crash-2.patch
@@ -1,26 +0,0 @@
-From 00c94530c0d57808ac1f9e9b1525341654278ba3 Mon Sep 17 00:00:00 2001
-From: Mike Gorse <mgorse@suse.com>
-Date: Fri, 7 Dec 2012 10:27:58 -0600
-Subject: [PATCH 2/3] Fix another crash when removing hung processes
-
-There was another instance where we were freeing the wrong data.
----
- registryd/deviceeventcontroller.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/registryd/deviceeventcontroller.c b/registryd/deviceeventcontroller.c
-index 101dc6f..b14cd1e 100644
---- a/registryd/deviceeventcontroller.c
-+++ b/registryd/deviceeventcontroller.c
-@@ -1179,7 +1179,7 @@ reset_hung_process (DBusPendingCall *pending, void *data)
- if (!strcmp (l->data, dest))
- {
- g_free (l->data);
-- hung_processes = g_slist_remove (hung_processes, data);
-+ hung_processes = g_slist_remove (hung_processes, l->data);
- break;
- }
- }
---
-1.8.0
-
View
1  app-accessibility/caribou/Manifest
@@ -1,2 +1 @@
-DIST caribou-0.4.6.tar.xz 380844 SHA256 449890d53401c15ae7118ebc8ca1eebb7f9a60ad717bca35f822d7f895142226 SHA512 43dcb270a6d05cead322a537ec98363199018e7ef8d5169c8f3c7d9ec1ce04737ec1634bf944756a9ed14fa843e0b0ab5fafa3bc93ad1f7501129be21b4dface WHIRLPOOL a43045d1618c82adab912e9eb1ba5f279ae5b2eb1e0964876f74238c60b314f212afaac478f9c5a119bc32ec7983be059df055755760589de46300c24ad790a3
DIST caribou-0.4.7.tar.xz 384856 SHA256 580406d72536ff23ee61cab416113fbc068cdc1fcaaedf1a4621f1d9ef9cf2e9 SHA512 52153e3ba305060823a61b29f13751cbaf6b67225a00f39895cab9054c40fc64f8153f289b5d1b967354ec1f6676b2a989a8a0710f5a95d7a299588e73f25b60 WHIRLPOOL 233f5f630c05b8b2fe68105ddca72a269adb46a87cbdd29344f14c80be4185e8bb99660800815d6834765371d434adb391ddf95907250c59b6499069e98f4499
View
93 app-accessibility/caribou/caribou-0.4.6.ebuild
@@ -1,93 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/caribou/caribou-0.4.6.ebuild,v 1.1 2013/01/13 15:41:08 eva Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_{6,7} )
-PYTHON_REQ_USE="xml"
-
-inherit gnome2 python-r1
-
-DESCRIPTION="Input assistive technology intended for switch and pointer users"
-HOMEPAGE="https://live.gnome.org/Caribou"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-COMMON_DEPEND="
- >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
- >=x11-libs/gtk+-3:3[introspection]
- x11-libs/gtk+:2
- >=dev-libs/gobject-introspection-0.10.7
- dev-libs/libgee:0.8
- dev-libs/libxml2
- >=media-libs/clutter-1.5.11:1.0[introspection]
- x11-libs/libX11
- x11-libs/libxklavier
- x11-libs/libXtst
-"
-# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
-# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
-# librsvg needed to load svg images in css styles
-RDEPEND="${COMMON_DEPEND}
- >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
- >=gnome-base/gsettings-desktop-schemas-3
- gnome-base/librsvg:2
- sys-apps/dbus
- virtual/python-argparse[${PYTHON_USEDEP}]
-"
-DEPEND="${COMMON_DEPEND}
- dev-libs/libxslt
- >=dev-util/intltool-0.35.5
- virtual/pkgconfig"
-
-src_prepare() {
- # delete custom PYTHONPATH, useless on Gentoo and potential bug source
- # + caribou is python2 only so fix the shell scripts
- sed -e '/export PYTHONPATH=.*python/ d' \
- -e "s:@PYTHON@:${EPREFIX}/usr/bin/python2:" \
- -i bin/{antler-keyboard,caribou,caribou-preferences}.in ||
- die "sed failed"
-
- gnome2_src_prepare
-
- prepare_caribou() {
- mkdir -p "${BUILD_DIR}" || die
- }
- python_foreach_impl prepare_caribou
-}
-
-src_configure() {
- ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir \
- gnome2_src_configure \
- --disable-static \
- --enable-gtk3-module \
- --enable-gtk2-module \
- VALAC=$(type -P true)
- # PYTHON=${EPREFIX}/usr/bin/python2
- # PYTHON is substituted into several installed shell scripts
- # vala is not needed for tarball builds, but configure checks for it...
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir gnome2_src_compile
-}
-
-src_test() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- python_foreach_impl run_in_build_dir gnome2_src_install
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-run_in_build_dir() {
- pushd "${BUILD_DIR}" > /dev/null || die
- "$@"
- popd > /dev/null
-}
View
86 app-accessibility/gnome-speech/gnome-speech-0.4.25.ebuild
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-speech/gnome-speech-0.4.25.ebuild,v 1.9 2012/05/03 01:48:59 jdhore Exp $
-
-EAPI="1"
-
-JAVA_PKG_OPT_USE="freetts"
-
-inherit java-pkg-opt-2 gnome2
-
-DESCRIPTION="Simple general API for producing text-to-speech output"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="LGPL-2"
-SLOT="1"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="+espeak festival freetts"
-
-COMMON_DEPEND=">=gnome-base/orbit-2.3.94
- >=gnome-base/libbonobo-1.97
- >=dev-libs/glib-2
- espeak? ( app-accessibility/espeak )
- freetts? (
- =app-accessibility/freetts-1.2*
- >=app-accessibility/java-access-bridge-1.4.6 )"
-
-RDEPEND="$COMMON_DEPEND
- freetts? ( >=virtual/jre-1.4 )
- festival? ( app-accessibility/festival )"
-
-DEPEND="$COMMON_DEPEND
- freetts? ( >=virtual/jdk-1.4 )
- virtual/pkgconfig"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-pkg_setup() {
- G2CONF="${G2CONF} $(use_with festival) --with-speech-dispatcher"
-
- if ! use espeak; then
- G2CONF="${G2CONF} --without-espeak-dir"
- fi
-
- if use freetts; then
- java-pkg-opt-2_pkg_setup
-
- local JABDIR="${ROOT}usr/share/java-access-bridge/lib"
-
- G2CONF="${G2CONF} --with-java-home=${JAVA_HOME} \
- --with-jab-dir=${JABDIR} \
- --with-freetts-dir=${ROOT}usr/share/freetts/lib"
- else
- export JAVAC=no
- fi
-}
-
-src_unpack() {
- gnome2_src_unpack
-
- if use freetts; then
- sed -i -e \
- 's/@GNOME_SPEECH_INSTALLED_CLASSPATH@/$(java-config -p gnome-speech-1,java-access-bridge)/' \
- drivers/freetts/freetts-synthesis-driver.in || die "sed error"
- fi
-
- sed -i \
- -e 's:\(GNOME_SPEECH_JAR_DIR=\).*:\1"/usr/share/java-access-bridge/lib/":' \
- -e 's:\(FREETTS_DRIVER_JAR_DIR=\).*:\1"/usr/share/java-access-bridge/lib/":' \
- "${S}"/configure
-}
-
-src_install() {
- gnome2_src_install
-
- if use freetts; then
- java-pkg_dojar "${D}"/usr/share/jar/*.jar
- rm -rf "${D}"/usr/share/jar
- fi
-}
-
-pkg_postinst() {
- elog
- elog "Gnome Speech has been successfully installed. You may now use the"
- elog "speech interface using app-accessibility/orca."
- elog
-}
View
1  app-accessibility/orca/Manifest
@@ -1,3 +1,2 @@
DIST orca-2.32.1.tar.bz2 2653300 SHA256 44da9da70c1b47bc87fda8f3b9da4cc1df9993d92388434f5707d39b5a832629 SHA512 d51c5ddfc979e57404b44961bd244dd639551bf9fd086326a4274a9713ec6eebe9aee6a381ee4abf47f211e034ebd2985c8a90303590094997bc10021364f796 WHIRLPOOL 2dcc5168947a25c5b918a6e98daeec246d712c34bc12ce55aa1edc1258c73b83aa7cba23d94f521bc9aec8e763601f7523a9cd91d6abc6119eb2defc47835c55
-DIST orca-3.4.2.tar.xz 3624688 SHA256 004f12ae0fb11e8cacb0851b312f63a9b8950672868c626a5e1563d044bd4996 SHA512 0b69daa1179bdcbb5a63744ad388c60b57b77a6c44a5aada228f0e7d31bca8c513a76169daf26e0f11d53f2b1ffc19370e8eb18e1075ae9ff1f98046268462aa WHIRLPOOL 606339b2a25e003d3de1697a8484c7e1ddefff6b1ed63f7414d487b4399c71619d2ca317460744c6a5d2310079f008b2558344e1235be23e681763cfd30391a6
DIST orca-3.6.3.tar.xz 3699564 SHA256 403d2328b5fdbf8ccdd5759cdaf8c757ba897330339ef4429b3695d775d05763 SHA512 0e903946688a395a894530fa8aea5a7709fc3029aa284bcc819f6f12a623996ba4914ce1948caf297775ad17b15859bc5f5e39c30115597f4e309ef835812171 WHIRLPOOL 69d857bf27fa940d413dc781304d2acf81f6b90cfc06f481042545b4fe301587b6e9b4d67f309c04f026bf03ed4f0c791965b7021e30a04a1249d50059bf8caa
View
68 app-accessibility/orca/orca-3.4.2.ebuild
@@ -1,68 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/orca-3.4.2.ebuild,v 1.2 2012/12/16 07:53:08 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_DEPEND="2:2.7"
-PYTHON_USE_WITH="threads"
-# FIXME: multiple python support
-
-inherit gnome2 python
-
-DESCRIPTION="Extensible screen reader that provides access to the desktop"
-HOMEPAGE="http://projects.gnome.org/orca/"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE=""
-
-# liblouis is not in portage yet
-# it is used to provide contracted braille support
-# XXX: Check deps for correctness
-COMMON_DEPEND=">=app-accessibility/at-spi2-core-2.3.5:2
- >=dev-libs/glib-2.28:2
- >=dev-python/pygobject-3.0.2:3
- >=x11-libs/gtk+-3.1.13:3[introspection]"
-RDEPEND="${COMMON_DEPEND}
- app-accessibility/speech-dispatcher[python]
- dev-libs/atk[introspection]
- >=dev-python/dbus-python-0.83
- dev-python/pyatspi
- dev-python/pycairo
- dev-python/pyxdg
- dev-python/setproctitle
- x11-libs/libwnck:3[introspection]
- x11-libs/pango[introspection]"
-DEPEND="${COMMON_DEPEND}
- >=app-text/gnome-doc-utils-0.17.3
- >=dev-util/intltool-0.40
- virtual/pkgconfig"
-
-pkg_setup() {
- DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
- python_set_active_version 2
- python_pkg_setup
- G2CONF="${G2CONF} PYTHON=$(PYTHON -2 -a)"
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- python_clean_py-compile_files
-
- # Workaround missing file in po files
- # echo "src/orca/scripts/toolkits/WebKitGtk/script.py" >> "${S}"/po/POTFILES.in
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- python_mod_optimize "${PN}"
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup "${PN}"
-}
View
1  app-admin/abrt/Manifest
@@ -1,3 +1,2 @@
DIST abrt-2.0.12.tar.gz 1090121 SHA256 2957f4136958078c3c8c9b2031febd8b322ef8705ca25a51592279b3ccd5c9e2 SHA512 5432205edb4483fb1883b9bcebab48784b16dd9e72c3a929ea0d50c48dab638d80f136b6b0d7648d8ec9fcb79d5ce8c1be37d36301d3b2b151868901be82a63a WHIRLPOOL 9b39fe91f77e2de5b3816d5cfc10f75c7c3d7dedfc354ed4e052b50e6cebb94bd26fec94aaba6cfd1cc79b71f1cc34b77bfd70d27d25761fa853a6a2af5ef7ce
-DIST abrt-2.0.6.tar.gz 996676 SHA256 0413a6b6143d0e667bb9c2c34a8ddfdb82d0dff04050acd254eb86943dd181a1 SHA512 3a4715c18fe04fb7f4b6dc921b08380795a55628926b7cfb7b33750db3dfb9d8c0ce6c975edc945c2c8f030ae1095ebef5397e9ccbedeb34a08a1798d462c07c WHIRLPOOL a5d1b231502f860a12a06f302889786349bd3e1ec84651d33443eb8214977e7cc943d6140865c17aef2a76a61a66e4cbb052e17acb1db053a506a2d8183bc57d
DIST abrt-2.0.8.tar.gz 960737 SHA256 aaad9f6914e40bda8783ff10e34f62a9712bfebda06373a7c056e3ca8bad4e5b SHA512 3b4dbb09309a45d3596c6d890f103e95aff12a4246bcea1dc5ae558869ff138c87559f0362534156a5d628a642e43621a5147a6eeaa5abbb3d3b5299d42ced17 WHIRLPOOL 51f82e8913708c7398889ccff0e2a0d41fe9e037c20a32547bae7f859ff2e04004f399fd5f118b20c14dc4438d7bd56fa6fc6318ad99f474f218dd6e5bb0d32c
View
117 app-admin/abrt/abrt-2.0.6.ebuild
@@ -1,117 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/abrt/abrt-2.0.6.ebuild,v 1.8 2012/05/31 02:21:27 zmedico Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2:2.6"
-
-# Need gnome2-utils for gnome2_icon_cache_update
-inherit autotools eutils gnome2-utils python systemd user
-
-DESCRIPTION="Automatic bug detection and reporting tool"
-HOMEPAGE="https://fedorahosted.org/abrt/"
-SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug"
-
-COMMON_DEPEND="dev-libs/btparser
- >=dev-libs/glib-2.21:2
- dev-libs/libreport
- dev-libs/libxml2
- dev-libs/nss
- sys-apps/dbus
- sys-fs/inotify-tools
- x11-libs/gtk+:2
- x11-libs/libnotify"
-RDEPEND="${COMMON_DEPEND}
- app-arch/cpio
- dev-libs/elfutils
- sys-devel/gdb"
-DEPEND="${COMMON_DEPEND}
- app-text/asciidoc
- app-text/xmlto
- >=dev-util/intltool-0.35.0
- virtual/pkgconfig
- >=sys-devel/gettext-0.17"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-
- enewgroup abrt
- enewuser abrt -1 -1 -1 abrt
-}
-
-src_prepare() {
- # Disable redhat-specific code not usable in gentoo, or that requires
- # bugs.gentoo.org infra support.
- epatch "${FILESDIR}/${PN}-2.0.6-gentoo.patch"
-
- # Using a server response as a format string is a bad idea
- epatch "${FILESDIR}/${PN}-2.0.6-format-security.patch"
-
- # Fixes building with glib-2.31, will be in next release
- epatch "${FILESDIR}/${P}-glib-2.31.patch"
-
- # -Werror should not be used by default
- sed -e 's/-Werror\( \|$\)//g' \
- -i src/applet/Makefile.* src/cli/Makefile.* src/daemon/Makefile.* \
- src/gui-gtk/Makefile.* src/hooks/Makefile.* src/lib/Makefile.* \
- src/plugins/Makefile.* || die "sed failed"
-
- mkdir m4
- eautoreconf
-
- echo '#!/bin/sh' > py-compile
- python_convert_shebangs -r 2 src
-}
-
-src_configure() {
- # Configure checks for python.pc; our python-2.7 installs python-2.7.pc,
- # while python-2.6 does not install any pkgconfig file.
- export PYTHON_CFLAGS=$(python-config --includes)
- export PYTHON_LIBS=$(python-config --libs)
-
- myeconfargs=( "--localstatedir=${EPREFIX}/var" )
- # --disable-debug enables debug!
- use debug && myeconfargs=( "${myeconfargs[@]}" --enable-debug )
- systemd_to_myeconfargs
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- keepdir /var/run/abrt
- # /var/spool/abrt is created by dev-libs/libreport
-
- diropts -m 700 -o abrt -g abrt
- keepdir /var/spool/abrt-upload
-
- diropts -m 775 -o abrt -g abrt
- keepdir /var/cache/abrt-di
-
- find "${D}" -name '*.la' -exec rm -f {} + || die
-
- newinitd "${FILESDIR}/${PN}-2.0.5-init" abrt
- newconfd "${FILESDIR}/${PN}-2.0.5-conf" abrt
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- python_mod_optimize abrt_exception_handler.py
- elog "To start the bug detection service on an openrc-based system, do"
- elog "# /etc/init.d/abrt start"
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- python_mod_cleanup abrt_exception_handler.py
-}
View
1  app-admin/collectd/Manifest
@@ -1,3 +1,4 @@
DIST collectd-5.1.0.tar.bz2 1305538 SHA256 521d4be7df5bc1124b7b9ea88227e95839a5f7c1b704a5bde0f60f058ec6eecb SHA512 c107bdad66d90d6e299ba0da68cc0726e3b0541efd7d672687713f5a414765d2afbd66a8c834da36dafe201dc0ec97caf80844d5f0354503fa67fcbfe0d43725 WHIRLPOOL 3de7d344d622ac20cb63fc0ce78e5d18c7d57d52e76ea09a47fc58bc339cf1108baa521e142a3d386f56dbf7a83311f2f93489241f2061da90900617f1715e8c
DIST collectd-5.1.1.tar.bz2 1331678 SHA256 0eeb8e45c83ba13fa00bd4f6875528e8a13769ba218205785d40b861489bf1fd SHA512 5d5f30ddb9ded3b48b64efdc1a4dbbbfe1601c16fc2450a7d1a1786493b12e01da66f23eca4d59853326b3c598b2fa9475f036e78e0d9e50b3f5ddd3a37c3c9b WHIRLPOOL 6a7256f1dc526bd0b6cb4c4845d511257c2c61c0de9c17ecff6751ad89698eb4127fe1cba4919920772bacd2a3c6966201ea162e61caf8e9f4e5baeaa0fb20e2
DIST collectd-5.2.0.tar.bz2 1391762 SHA256 3f8dd235b8e2493a4ad558e3cd15b89007a0deaaef5481782d1e8e048dd43e4f SHA512 c98fe0b64df0c4dcbc254fb0781d3aae15985c89a8b9121d2e79fafbac0d8b290b02b27c3eca0e471305086a36db10dcecb2d27c71eb87b0c9dc9e2eff1c02f2 WHIRLPOOL 1ed6b089870879bf294b53154738a9cce480885250c10d61b7b5a6502ff191a9e3942e312bcd3de530cb6e9486165dd4d6d2ad7659e6e051aa135c26f2c68f65
+DIST collectd-5.2.1.tar.bz2 1395740 SHA256 d82a5c302d2cfa0c3f7a3c7b7e37fb3faf42b17d2addae036cb819b6b25b9d98 SHA512 f97c9367ed45dc01f187ee8ec2cfdb27e26380b1369383c4d2b5569fc13ec660ffaf074a4b2929c1fb6633ad97aef87ef2fe2a633da5527bb26703f8ca625736 WHIRLPOOL 21127c27f1ac146699b4a7c355e8f60e9d78784e3f7908b7208feaaecb687c64de05f03877265f58ecc852cbad906b4acfb0026493e61372ddb03cc3419a599e
View
361 app-admin/collectd/collectd-5.2.1.ebuild
@@ -0,0 +1,361 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/collectd/collectd-5.2.1.ebuild,v 1.1 2013/03/05 21:26:50 hwoarang Exp $
+
+EAPI="4"
+
+inherit autotools base eutils linux-info multilib perl-app systemd user
+
+DESCRIPTION="A a daemon which collects system statistic and provides mechanisms to store the values"
+
+HOMEPAGE="http://collectd.org"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="contrib debug kernel_linux kernel_FreeBSD kernel_Darwin perl static-libs"
+
+# The plugin lists have to follow here since they extend IUSE
+
+# Plugins that to my knowledge cannot be supported (eg. dependencies not in gentoo)
+COLLECTD_IMPOSSIBLE_PLUGINS="netapp pinba xmms"
+
+# Plugins that still need some work
+COLLECTD_UNTESTED_PLUGINS="amqp apple_sensors genericjmx ipvs lpar modbus redis
+ tape v5upgrade write_redis zfs_arc"
+
+# Plugins that have been (compile) tested and can be enabled via COLLECTD_PLUGINS
+COLLECTD_TESTED_PLUGINS="aggregation apache apcups ascent battery bind conntrack
+ contextswitch cpu cpufreq csv curl curl_json curl_xml dbi df disk dns email
+ entropy ethstat exec filecount fscache gmond hddtemp interface ipmi iptables
+ irq java libvirt load logfile madwifi match_empty_counter match_hashed
+ match_regex match_timediff match_value mbmon md memcachec memcached memory
+ multimeter mysql netlink network network nfs nginx notify_desktop notify_email
+ ntpd numa nut olsrd onewire openvpn oracle perl perl ping postgresql powerdns
+ processes protocols python python routeros rrdcached rrdcached rrdtool sensors
+ serial snmp swap syslog table tail target_notification target_replace
+ target_scale target_set tcpconns teamspeak2 ted thermal threshold tokyotyrant
+ unixsock uptime users uuid varnish vmem vserver wireless write_graphite
+ write_http write_mongodb"
+
+COLLECTD_DISABLED_PLUGINS="${COLLECTD_IMPOSSIBLE_PLUGINS} ${COLLECTD_UNTESTED_PLUGINS}"
+
+COLLECTD_ALL_PLUGINS=${COLLECTD_TESTED_PLUGINS}
+
+for plugin in ${COLLECTD_ALL_PLUGINS}; do
+ IUSE="${IUSE} collectd_plugins_${plugin}"
+done
+unset plugin
+
+# Now come the dependencies.
+
+COMMON_DEPEND="
+ dev-libs/libgcrypt
+ sys-devel/libtool
+ perl? ( dev-lang/perl[ithreads] ( || ( sys-devel/libperl[ithreads] >=sys-devel/libperl-5.10 ) ) )
+ collectd_plugins_apache? ( net-misc/curl )
+ collectd_plugins_ascent? ( net-misc/curl dev-libs/libxml2 )
+ collectd_plugins_bind? ( dev-libs/libxml2 )
+ collectd_plugins_curl? ( net-misc/curl )
+ collectd_plugins_curl_json? ( net-misc/curl dev-libs/yajl )
+ collectd_plugins_curl_xml? ( net-misc/curl dev-libs/libxml2 )
+ collectd_plugins_dbi? ( dev-db/libdbi )
+ collectd_plugins_dns? ( net-libs/libpcap )
+ collectd_plugins_gmond? ( sys-cluster/ganglia )
+ collectd_plugins_ipmi? ( >=sys-libs/openipmi-2.0.16-r1 )
+ collectd_plugins_iptables? ( >=net-firewall/iptables-1.4.13 )
+ collectd_plugins_java? ( virtual/jre dev-java/java-config-wrapper )
+ collectd_plugins_libvirt? ( app-emulation/libvirt dev-libs/libxml2 )
+ collectd_plugins_memcachec? ( dev-libs/libmemcached )
+ collectd_plugins_mysql? ( >=virtual/mysql-5.0 )
+ collectd_plugins_netlink? ( >=sys-apps/iproute2-3.3.0 )
+ collectd_plugins_nginx? ( net-misc/curl )
+ collectd_plugins_notify_desktop? ( x11-libs/libnotify )
+ collectd_plugins_notify_email? ( >=net-libs/libesmtp-1.0.4 dev-libs/openssl )
+ collectd_plugins_nut? ( sys-power/nut )
+ collectd_plugins_onewire? ( sys-fs/owfs )
+ collectd_plugins_oracle? ( >=dev-db/oracle-instantclient-basic-11.2.0.1.0 )
+ collectd_plugins_perl? ( dev-lang/perl[ithreads] ( || ( sys-devel/libperl[ithreads] >=sys-devel/libperl-5.10 ) ) )
+ collectd_plugins_ping? ( net-libs/liboping )
+ collectd_plugins_postgresql? ( >=dev-db/postgresql-base-8.2 )
+ collectd_plugins_python? ( =dev-lang/python-2* )
+ collectd_plugins_routeros? ( net-libs/librouteros )
+ collectd_plugins_rrdcached? ( >=net-analyzer/rrdtool-1.4 )
+ collectd_plugins_rrdtool? ( >=net-analyzer/rrdtool-1.2.27 )
+ collectd_plugins_sensors? ( sys-apps/lm_sensors )
+ collectd_plugins_snmp? ( net-analyzer/net-snmp )
+ collectd_plugins_tokyotyrant? ( net-misc/tokyotyrant )
+ collectd_plugins_varnish? ( www-servers/varnish )
+ collectd_plugins_write_http? ( net-misc/curl )
+ collectd_plugins_write_mongodb? ( dev-libs/mongo-c-driver )
+
+ kernel_FreeBSD? (
+ collectd_plugins_disk? ( >=sys-libs/libstatgrab-0.16 )
+ collectd_plugins_interface? ( >=sys-libs/libstatgrab-0.16 )
+ collectd_plugins_load? ( >=sys-libs/libstatgrab-0.16 )
+ collectd_plugins_memory? ( >=sys-libs/libstatgrab-0.16 )
+ collectd_plugins_swap? ( >=sys-libs/libstatgrab-0.16 )
+ collectd_plugins_users? ( >=sys-libs/libstatgrab-0.16 )
+ )"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ kernel_linux? (
+ collectd_plugins_vserver? ( sys-kernel/vserver-sources )
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ collectd_plugins_syslog? ( virtual/logger )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.10.2"-{libocci,nohal}.patch
+ "${FILESDIR}/${PN}-4.10.3"-werror.patch
+ "${FILESDIR}/${PN}-5.1.0"-libperl.patch
+ "${FILESDIR}/${PN}-5.1.1"-lt.patch
+)
+
+# @FUNCTION: collectd_plugin_kernel_linux
+# @DESCRIPTION:
+# USAGE: <plug-in name> <kernel_options> <severity>
+# kernel_options is a list of kernel configurations options; the check tests whether at least
+# one of them is enabled. If no, depending on the third argument an elog, ewarn, or eerror message
+# is emitted.
+collectd_plugin_kernel_linux() {
+ local multi_opt opt
+ if has ${1} ${COLLECTD_ALL_PLUGINS}; then
+ if use collectd_plugins_${1}; then
+ for opt in ${2}; do
+ if linux_chkconfig_present ${opt}; then return 0; fi
+ done
+ multi_opt=${2//\ /\ or\ }
+ case ${3} in
+ (info)
+ elog "The ${1} plug-in can use kernel features that are disabled now; enable ${multi_opt} in your kernel"
+ ;;
+ (warn)
+ ewarn "The ${1} plug-in uses kernel features that are disabled now; enable ${multi_opt} in your kernel"
+ ;;
+ (error)
+ eerror "The ${1} plug-in needs kernel features that are disabled now; enable ${multi_opt} in your kernel"
+ ;;
+ (*)
+ die "function collectd_plugin_kernel_linux called with invalid third argument"
+ ;;
+ esac
+ fi
+ fi
+}
+
+collectd_linux_kernel_checks() {
+ linux-info_pkg_setup
+
+ # battery.c:/proc/pmu/battery_%i
+ # battery.c:/proc/acpi/battery
+ collectd_plugin_kernel_linux battery ACPI_BATTERY warn
+
+ # cpufreq.c:/sys/devices/system/cpu/cpu%d/cpufreq/
+ collectd_plugin_kernel_linux cpufreq SYSFS warn
+ collectd_plugin_kernel_linux cpufreq CPU_FREQ_STAT warn
+
+ # nfs.c:/proc/net/rpc/nfs
+ # nfs.c:/proc/net/rpc/nfsd
+ collectd_plugin_kernel_linux nfs NFS_COMMON warn
+
+ # serial.c:/proc/tty/driver/serial
+ # serial.c:/proc/tty/driver/ttyS
+ collectd_plugin_kernel_linux serial SERIAL_CORE warn
+
+ # swap.c:/proc/meminfo
+ collectd_plugin_kernel_linux swap SWAP warn
+
+ # thermal.c:/proc/acpi/thermal_zone
+ # thermal.c:/sys/class/thermal
+ collectd_plugin_kernel_linux thermal "PROC_FS SYSFS" warn
+ collectd_plugin_kernel_linux thermal ACPI_THERMAL warn
+
+ # vmem.c:/proc/vmstat
+ collectd_plugin_kernel_linux vmem VM_EVENT_COUNTERS warn
+
+ # uuid.c:/sys/hypervisor/uuid
+ collectd_plugin_kernel_linux uuid SYSFS info
+
+ # wireless.c:/proc/net/wireless
+ collectd_plugin_kernel_linux wireless "MAC80211 IEEE80211" warn
+}
+
+pkg_setup() {
+ if use kernel_linux; then
+ if linux_config_exists; then
+ einfo "Checking your linux kernel configuration:"
+ collectd_linux_kernel_checks
+ else
+ elog "Cannot find a linux kernel configuration. Continuing anyway."
+ fi
+ fi
+
+ enewgroup collectd
+ enewuser collectd -1 -1 /var/lib/collectd collectd
+}
+
+src_prepare() {
+ base_src_prepare
+
+ # There's some strange prefix handling in the default config file, resulting in
+ # paths like "/usr/var/..."
+ sed -i -e "s:@prefix@/var:/var:g" src/collectd.conf.in || die
+
+ sed -i -e "s:/etc/collectd/collectd.conf:/etc/collectd.conf:g" contrib/collectd.service || die
+
+ # fix installdirs for perl, bug 444360
+ sed -i -e 's/INSTALL_BASE=$(DESTDIR)$(prefix) //' bindings/Makefile.am || die
+
+ rm -r libltdl || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # Now come the lists of os-dependent plugins. Any plugin that is not listed anywhere here
+ # should work independent of the operating system.
+
+ local linux_plugins="battery cpu cpufreq disk entropy ethstat interface iptables ipvs irq load
+ memory md netlink nfs numa processes serial swap tcpconns thermal users vmem vserver
+ wireless"
+
+ local libstatgrab_plugins="cpu disk interface load memory swap users"
+ local bsd_plugins="cpu tcpconns ${libstatgrab_plugins}"
+
+ local darwin_plugins="apple_sensors battery cpu disk interface memory processes tcpconns"
+
+ local osdependent_plugins="${linux_plugins} ${bsd_plugins} ${darwin_plugins}"
+ local myos_plugins=""
+ if use kernel_linux; then
+ einfo "Enabling Linux plugins."
+ myos_plugins=${linux_plugins}
+ elif use kernel_FreeBSD; then
+ einfo "Enabling FreeBSD plugins."
+ myos_plugins=${bsd_plugins}
+ elif use kernel_Darwin; then
+ einfo "Enabling Darwin plugins."
+ myos_plugins=${darwin_plugins}
+ fi
+
+ # Do we debug?
+ local myconf="$(use_enable debug)"
+
+ local plugin
+
+ # Disable what needs to be disabled.
+ for plugin in ${COLLECTD_DISABLED_PLUGINS}; do
+ myconf+=" --disable-${plugin}"
+ done
+
+ # Set enable/disable for each single plugin.
+ for plugin in ${COLLECTD_ALL_PLUGINS}; do
+ if has ${plugin} ${osdependent_plugins}; then
+ # plugin is os-dependent ...
+ if has ${plugin} ${myos_plugins}; then
+ # ... and available in this os
+ myconf+=" $(use_enable collectd_plugins_${plugin} ${plugin})"
+ else
+ # ... and NOT available in this os
+ if use collectd_plugins_${plugin}; then
+ ewarn "You try to enable the ${plugin} plugin, but it is not available for this"
+ ewarn "kernel. Disabling it automatically."
+ fi
+ myconf+=" --disable-${plugin}"
+ fi
+ elif [[ "${plugin}" = "collectd_plugins_perl" ]]; then
+ if use collectd_plugins_perl && ! use perl; then
+ ewarn "Perl plugin disabled as perl bindings disabled by -perl use flag"
+ myconf+= --disable-perl
+ else
+ myconf+=" $(use_enable collectd_plugins_${plugin} ${plugin})"
+ fi
+ else
+ myconf+=" $(use_enable collectd_plugins_${plugin} ${plugin})"
+ fi
+ done
+
+ # Need JAVA_HOME for java.
+ if use collectd_plugins_java; then
+ myconf+=" --with-java=$(java-config -g JAVA_HOME)"
+ fi
+
+ # Need libiptc ONLY for iptables. If we try to use it otherwise bug 340109 happens.
+ if ! use collectd_plugins_iptables; then
+ myconf+=" --with-libiptc=no"
+ fi
+
+ # The perl bindings
+ myconf+=" $(use_with perl perl-bindings=INSTALLDIRS=vendor)"
+
+ # Finally, run econf.
+ KERNEL_DIR="${KERNEL_DIR}" econf --config-cache --without-included-ltdl $(use_enable static-libs static) --localstatedir=/var ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ fixlocalpod
+
+ find "${D}/usr/" -name "*.la" -exec rm -f {} +
+
+ # use collectd_plugins_ping && setcap cap_net_raw+ep ${D}/usr/sbin/collectd
+ # we cannot do this yet
+
+ fowners root:collectd /etc/collectd.conf
+ fperms u=rw,g=r,o= /etc/collectd.conf
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use contrib ; then
+ insinto /usr/share/doc/${PF}
+ doins -r contrib
+ fi
+
+ keepdir /var/lib/${PN}
+ fowners collectd:collectd /var/lib/${PN}
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ systemd_dounit "contrib/${PN}.service"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate" collectd
+
+ sed -i -e 's:^.*PIDFile "/var/run/collectd.pid":PIDFile "/var/run/collectd/collectd.pid":' "${D}"/etc/collectd.conf || die
+ sed -i -e 's:^# SocketFile "/var/run/collectd-unixsock":# SocketFile "/var/run/collectd/collectd-unixsock":' "${D}"/etc/collectd.conf || die
+ sed -i -e 's:^.*LoadPlugin perl$:# The new, correct way to load the perl plugin -- \n# <LoadPlugin perl>\n# Globals true\n# </LoadPlugin>:' "${D}"/etc/collectd.conf || die
+ sed -i -e 's:^.*LoadPlugin python$:# The new, correct way to load the python plugin -- \n# <LoadPlugin python>\n# Globals true\n# </LoadPlugin>:' "${D}"/etc/collectd.conf || die
+}
+
+collectd_rdeps() {
+ if (use collectd_plugins_${1} && ! has_version "${2}"); then
+ elog "The ${1} plug-in needs ${2} to be installed locally or remotely to work."
+ fi
+}
+
+pkg_postinst() {
+ collectd_rdeps apcups sys-power/apcupsd
+ collectd_rdeps hddtemp app-admin/hddtemp
+ collectd_rdeps mbmon sys-apps/xmbmon
+ collectd_rdeps memcached ">=net-misc/memcached-1.2.2-r2"
+ collectd_rdeps ntpd net-misc/ntp
+ collectd_rdeps openvpn ">=net-misc/openvpn-2.0.9"
+ collectd_rdeps write_mongodb "dev-db/mongodb"
+
+ echo
+ elog "collectd is now started as unprivileged user by default."
+ elog "You may want to recheck the configuration."
+ elog
+
+ if use collectd_plugins_email; then
+ ewarn "The email plug-in is deprecated. To submit statistics please use the unixsock plugin."
+ fi
+ if use contrib; then
+ elog "The scripts in /usr/share/doc/${PF}/collection3 for generating graphs need dev-perl/HTML-Parser,"
+ elog "dev-perl/config-general, dev-perl/regexp-common, and net-analyzer/rrdtool[perl] to be installed."
+ fi
+}
View
1  app-admin/eselect-gnome-shell-extensions/Manifest
@@ -1,2 +1 @@
-DIST eselect-gnome-shell-extensions-20111211.tar.xz 2784 SHA256 020eee06656becc0b03b1f9b13cc653e64db344383e69c8502cd6e9803ddd30a SHA512 048f43f509351c58c60858f4169f4075e8033cedcfdf3be0a020c0b09cce83b1379e7a451e76be234cd7c6d767be22f73d8ee0580fd21f9264f4d37e8f8cb0d0 WHIRLPOOL a55f51d9f62706b319bf62feb9ea90a52005a0f4a13d244101f842bb7d3805c9c8efab73f754311ffd9c04550b0c50df6555f0962205957abde86d2050db0553
DIST eselect-gnome-shell-extensions-20120911.tar.xz 2792 SHA256 1f763aab3a80f85805ad5ed30010cf0c26afb7ad3b81c4f698662ad3e33bf91c SHA512 da54e2a0b74f3e8f8eaa26b1858d26c56fbaa398ec54b079f504377a4079df19ff52485991a9ea153f92c93a9fe871d70c3c2b841bad4b8dba402ad83c9297e2 WHIRLPOOL abdfea55dd0c2429900e17919bab21ed5893e44a41dba152ae3c093e14bdc2d2695551a193d77c86753c623466b6bd46beb51323900ebdb3351b7b756a31b9fe
View
50 app-admin/eselect-gnome-shell-extensions/eselect-gnome-shell-extensions-20111211.ebuild
@@ -1,50 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-gnome-shell-extensions/eselect-gnome-shell-extensions-20111211.ebuild,v 1.1 2011/12/11 23:44:12 tetromino Exp $
-
-EAPI="4"
-
-DESCRIPTION="Manages system defaults for GNOME Shell extensions"
-HOMEPAGE="http://www.gentoo.org"
-SRC_URI="http://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# gnome-shell schemas are used in pkg_postinst
-COMMON_DEPEND="app-admin/eselect
- >=dev-libs/glib-2.26:2
- gnome-base/gsettings-desktop-schemas
- gnome-base/gnome-shell"
-RDEPEND="${COMMON_DEPEND}
- dev-lang/perl
- dev-perl/JSON"
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils"
-
-src_install() {
- insinto "/usr/share/eselect/modules"
- doins gnome-shell-extensions.eselect
- keepdir "/etc/eselect/gnome-shell-extensions"
- # The actual gschema override file will be greated in pkg_postinst.
- dosym "/etc/eselect/gnome-shell-extensions/${PN}.gschema.override" \
- "/usr/share/glib-2.0/schemas/${PN}.gschema.override"
-}
-
-pkg_postinst() {
- einfo "Updating list of installed extensions"
- eselect gnome-shell-extensions update || die
- local keyname="disabled-extensions"
- has_version ">=gnome-base/gnome-shell-3.1.90" &&
- keyname="enabled-extensions"
- elog
- elog "eselect gnome-shell-extensions manages the system default value of"
- elog "the org.gnome.shell ${keyname} key. To override the default"
- elog "for an individual user, use the gsettings command, e.g."
- elog "\$ gsettings set org.gnome.shell ${keyname} \"['foo', 'bar']\""
- elog "To undo per-user changes and use the system default, do"
- elog "\$ gsettings reset org.gnome.shell ${keyname}"
- elog
-}
View
1  app-admin/gnome-system-log/Manifest
@@ -1,2 +1 @@
-DIST gnome-system-log-3.4.1.tar.xz 930200 SHA256 288bb4db72d5e86874198f3a879a89cd0ddec373db9838d8ea772df1c5267736 SHA512 f07aa5432b8cc90864fca4e4de7b534b37c2529406eb3dc41847882dc147b23629338a44d3aa82c2834b80c78c56c2a1330054d77c06e9303f4aa8baec5786e9 WHIRLPOOL c6fb054e13c93115a214b3a3685c1337a909b9020dc3828476bd523c8e89d3f01a818f2ef84f493246433b9efb34c3f4d74717dc7fabd6b48fb1290564f7de74
DIST gnome-system-log-3.6.1.tar.xz 1210700 SHA256 7b20e59ca271c755400f68446f1f818d4ee3cc7e7e8fa7ba67a843a4eabdecc1 SHA512 ae40c00598bfac06c017c50f12b08d0af7e0d2b50dfc8731bd41af7aa6884ab4a7c8dd48555f1512c4ea19071fcf71d12f6f2c763f7d4a19736b1c5ed145a5ca WHIRLPOOL de2d4e61603e8948cb12546499103f540117b0cc155276fa690f34e206abc3f58b82a9019d5ad96b0cce0a712659d67484ad418d70c92e9a040f04137c966a44
View
38 app-admin/gnome-system-log/gnome-system-log-3.4.1.ebuild
@@ -1,38 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gnome-system-log/gnome-system-log-3.4.1.ebuild,v 1.2 2012/12/16 18:57:02 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2
-
-DESCRIPTION="System log viewer for GNOME 3"
-HOMEPAGE="https://live.gnome.org/GnomeUtils"
-
-LICENSE="GPL-2+ FDL-1.1+"
-SLOT="0"
-IUSE=""
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-
-COMMON_DEPEND=">=dev-libs/glib-2.31.0:2
- sys-libs/zlib
- >=x11-libs/gtk+-3.0.0:3
- x11-libs/pango"
-RDEPEND="${COMMON_DEPEND}
- gnome-base/gsettings-desktop-schemas
- !<gnome-extra/gnome-utils-3.4"
-# ${PN} was part of gnome-utils before 3.4
-DEPEND="${COMMON_DEPEND}
- app-text/gnome-doc-utils
- >=dev-util/intltool-0.40
- >=sys-devel/gettext-0.17
- virtual/pkgconfig"
-
-pkg_setup() {
- DOCS="NEWS TODO"
- G2CONF="${G2CONF}
- --disable-schemas-compile
- --enable-zlib"
-}
View
30 app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-gold.patch
@@ -1,30 +0,0 @@
- src/time/Makefile.am | 2 +-
- src/time/Makefile.in | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/time/Makefile.am b/src/time/Makefile.am
-index e9adaf4..eacd0d6 100644
---- a/src/time/Makefile.am
-+++ b/src/time/Makefile.am
-@@ -15,7 +15,7 @@ INCLUDES += $(GST_TOOL_CFLAGS) $(DBUS_CFLAGS)
- CLEANFILES = $(GST_TOOL_CLEANFILES)
- EXTRA_DIST = $(GST_TOOL_EXTRA_DIST)
-
--time_admin_LDADD = $(GST_TOOL_LIBS) $(DBUS_LIBS) ./e-map/libemap.a
-+time_admin_LDADD = $(GST_TOOL_LIBS) $(DBUS_LIBS) ./e-map/libemap.a -lm
- time_admin_DEPENDENCIES = $(GST_TOOL_DEPENDENCIES) ./e-map/libemap.a
- time_admin_SOURCES = \
- time-tool.c time-tool.h \
-diff --git a/src/time/Makefile.in b/src/time/Makefile.in
-index b6d917a..99dfb68 100644
---- a/src/time/Makefile.in
-+++ b/src/time/Makefile.in
-@@ -339,7 +339,7 @@ toolname = time
- SUBDIRS = e-map
- CLEANFILES = $(GST_TOOL_CLEANFILES)
- EXTRA_DIST = $(GST_TOOL_EXTRA_DIST)
--time_admin_LDADD = $(GST_TOOL_LIBS) $(DBUS_LIBS) ./e-map/libemap.a
-+time_admin_LDADD = $(GST_TOOL_LIBS) $(DBUS_LIBS) ./e-map/libemap.a -lm
- time_admin_DEPENDENCIES = $(GST_TOOL_DEPENDENCIES) ./e-map/libemap.a
- time_admin_SOURCES = \
- time-tool.c time-tool.h \
View
55 app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r2.ebuild
@@ -1,55 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r2.ebuild,v 1.8 2012/10/17 10:34:08 tetromino Exp $
-
-EAPI="3"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2
-
-DESCRIPTION="Tools aimed to make easy the administration of UNIX systems"
-HOMEPAGE="http://www.gnome.org/projects/gst/"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc sparc x86"
-IUSE="nfs policykit samba"
-
-RDEPEND="
- >=app-admin/system-tools-backends-2.10.1
- >=dev-libs/liboobs-2.31.91
- >=x11-libs/gtk+-2.19.7:2
- >=dev-libs/glib-2.25.3:2
- dev-libs/dbus-glib
- >=gnome-base/nautilus-2.9.90
- sys-libs/cracklib
- nfs? ( net-fs/nfs-utils )
- samba? ( >=net-fs/samba-3 )
- policykit? (
- >=sys-auth/polkit-0.92
- || ( gnome-extra/polkit-gnome:obsolete <gnome-extra/polkit-gnome-0.102 )
- )"
-DEPEND="${RDEPEND}
- app-text/docbook-xml-dtd:4.1.2
- app-text/scrollkeeper
- >=app-text/gnome-doc-utils-0.3.2
- virtual/pkgconfig
- >=dev-util/intltool-0.35.0"
-
-pkg_setup() {
- DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
-
- G2CONF="${G2CONF}
- --disable-static
- $(use_enable policykit polkit-gtk)"
-
- if ! use nfs && ! use samba; then
- G2CONF="${G2CONF} --disable-shares"
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gold.patch
- gnome2_src_prepare
-}
View
1  app-admin/system-config-printer-common/Manifest
@@ -1,3 +1,2 @@
DIST system-config-printer-1.3.11.tar.xz 947488 SHA256 13816276895ca60c11ebc77b4209d30707b18c0489e247ea219474ee4a2f63c3 SHA512 4e50e973e404f959d8cb5b25dd6a38aa40f558408eb9818b3eb3b267b9a54f13aa97f05343cc0353ab36b32ac0a229d77109efd79b5e598fe43173072be02fac WHIRLPOOL d2372eb97263e84be9efd9bd6e190ddab2a75a327b0ece6f44ff8c9d1ee12484a82c3a2c5a2124195b0e45aa21fe3298de1025dce806ad195a7a1a84bdea80ec
DIST system-config-printer-1.3.12.tar.xz 949008 SHA256 1905bd9fd382730a8eab80fa196b1c43bd19ce79c2169142de899697cbb1e9b1 SHA512 4e6c15b52287f2a69fabb6dafe6548874b8608f2f7a2e14534b100fbb46ad0f146b1e03a6aa4c2c9fe66dad96789454bd066616db0dd73b962bffeb478a7c6c5 WHIRLPOOL 0b8afe05a87103ef99dac50ab7db5f3fc6137de9b84e483ee3a481172e4c894e206b6d022303f1f11496a63b5698351a67070fb936f35293e83f5a20c5e21599
-DIST system-config-printer-1.3.9.tar.xz 992152 SHA256 86a655d6599484cafe57f11694d9e2d9767ece03328a8fc8254aa92c8162dfe0 SHA512 98ffcbd36ee7c70fc349a945a75b5d2ed70cc1d08b2fe4eb2dc66d0ca887675956c6dc31728a2ba0e15b5742159dd6a9b11af204090a84d5b54f3237bcae62f1 WHIRLPOOL bd81593a7bc7082157ba9e9635aa3df9d0fe6c8fcd5886933781df3d93de9c889e51df5645d3bea6bd9b8448f57d65ef37ce88445cb695b734155772b794bb23
View
26 app-admin/system-config-printer-common/files/system-config-printer-common-1.3.9-cups_filters_path.patch
@@ -1,26 +0,0 @@
-From a3479278f12ddc905f81050b11c769d74f581aee Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Tiziano=20M=C3=BCller?= <tm@dev-zero.ch>
-Date: Sat, 16 Jun 2012 08:43:30 +0200
-Subject: [PATCH] add /usr/libexec/cups/filter to the filter search paths
-
----
- cupshelpers/cupshelpers.py | 3 ++-
- 1 files changed, 2 insertions(+), 1 deletions(-)
-
-diff --git a/cupshelpers/cupshelpers.py b/cupshelpers/cupshelpers.py
-index 3fc138b..d1d32f1 100755
---- a/cupshelpers/cupshelpers.py
-+++ b/cupshelpers/cupshelpers.py
-@@ -812,7 +812,8 @@ def missingExecutables(ppd):
-
- exepath = pathcheck (exe,
- "/usr/lib/cups/filter:"
-- "/usr/lib64/cups/filter")
-+ "/usr/lib64/cups/filter:"
-+ "/usr/libexec/cups/filter")
- if not exepath:
- add_missing ("/usr/lib/cups/filter/" + exe)
-
---
-1.7.8.6
-
View
93 app-admin/system-config-printer-common/system-config-printer-common-1.3.9-r2.ebuild
@@ -1,93 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-printer-common/system-config-printer-common-1.3.9-r2.ebuild,v 1.5 2012/12/02 22:56:02 ssuominen Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2"
-WANT_AUTOMAKE="1.11"
-inherit eutils python autotools udev
-
-MY_P="${PN%-common}-${PV}"
-
-DESCRIPTION="Common modules of Red Hat's printer administration tool"
-HOMEPAGE="http://cyberelk.net/tim/software/system-config-printer/"
-SRC_URI="http://cyberelk.net/tim/data/system-config-printer/1.3/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 sh sparc x86"
-SLOT="0"
-IUSE="doc policykit"
-
-# Needs cups running, bug 284005
-RESTRICT="test"
-
-# system-config-printer split since 1.1.3
-COMMON_DEPEND="
- dev-libs/glib:2
- dev-libs/libxml2[python]
- dev-python/dbus-python
- >=dev-python/pycups-1.9.60
- dev-python/pycurl
- >=dev-python/pygobject-2.21.5:2
- <net-print/cups-1.6.0[dbus]
- >=virtual/udev-171
- virtual/libusb:0
-"
-DEPEND="${COMMON_DEPEND}
- dev-util/intltool
- virtual/pkgconfig
- doc? ( dev-python/epydoc )
-"
-RDEPEND="${COMMON_DEPEND}
- !<app-admin/system-config-printer-gnome-${PV}
- policykit? ( sys-auth/polkit )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.3.9-split.patch"
- epatch "${FILESDIR}/${PN}-1.3.9-cups_filters_path.patch"
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-nls \
- --with-udev-rules
-}
-
-src_compile() {
- emake || die "emake failed"
- if use doc; then
- emake html || die "emake html failed"
- fi
-}
-
-src_install() {
- dodoc AUTHORS ChangeLog README || die "dodoc failed"
-
- if use doc; then
- dohtml -r html/ || die "installing html docs failed"
- fi
-
- emake DESTDIR="${ED}" install \
- udevrulesdir="$(udev_get_udevdir)/rules.d" \
- udevhelperdir="$(udev_get_udevdir)" \
- || die "emake install failed"
-
- python_convert_shebangs -q -r $(python_get_version) "${ED}"
-}
-
-pkg_postinst() {
- python_mod_optimize cupshelpers
-}
-
-pkg_postrm() {
- python_mod_cleanup cupshelpers /usr/share/system-config-printer
-}
View
1  app-admin/system-tools-backends/Manifest
@@ -1,2 +1 @@
-DIST system-tools-backends-2.10.1.tar.bz2 461966 SHA256 0c1cfdf5f0550c0ccacbbc4f00ed059ab9ea483d48138132db44b3a20575d7b4 SHA512 8a8f7730a454375e9f18c333ef89b48515bf5bfeecae78a0d93744596e49fd361b71ba6372cfc63e51bc0dd0670ba4de01a5f296d6252060e729a54c76105681 WHIRLPOOL 862956a7e1be82be10d8485afd31ae6b46195b7a63bb41b9e64256fee9c421b8dfa5fd93d9d634249ef06be5fb3c05bf8d298289cad4dc1de0c08c302ba352c4
DIST system-tools-backends-2.10.2.tar.bz2 448939 SHA256 1dbe5177df46a9c7250735e05e77129fe7ec04840771accfa87690111ca2c670 SHA512 9ee3e0643122740493265e532350fed9056334de0ea3d6656daa1d42b97f76f0f85024ac87e732fe5122a1e31ad009a1d2f119720081673a06696b81452fb990 WHIRLPOOL 2357ca2249b8f7c7ce3fc7ffcb4c49bcd83040d77910bbb1ce19e47750da999e6d359689d14c284a84b421287d5a8d3d183fc1debd0b119aa520dd125ca1a599
View
63 app-admin/system-tools-backends/system-tools-backends-2.10.1.ebuild
@@ -1,63 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-tools-backends/system-tools-backends-2.10.1.ebuild,v 1.9 2012/05/31 02:45:53 zmedico Exp $
-
-EAPI="2"
-GCONF_DEBUG="no"
-
-inherit eutils gnome2 user
-
-DESCRIPTION="Tools aimed to make easy the administration of UNIX systems"
-HOMEPAGE="http://www.gnome.org/projects/gst/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc sparc x86"
-IUSE=""
-
-RDEPEND="!<app-admin/gnome-system-tools-1.1.91
- >=sys-apps/dbus-1.1.2
- >=dev-libs/dbus-glib-0.74
- >=dev-libs/glib-2.15.2
- >=dev-perl/Net-DBus-0.33.4
- dev-lang/perl
- >=sys-auth/polkit-0.94
- userland_GNU? ( virtual/shadow )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=dev-util/intltool-0.40"
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --localstatedir=/var"
-
- enewgroup stb-admin
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # Change default permission, only people in stb-admin is allowed
- # to speak to the dispatcher.
- epatch "${FILESDIR}/${PN}-2.8.2-default-permissions.patch"
-
- # Apply fix from ubuntu for CVE 2008 4311
- epatch "${FILESDIR}/${PN}-2.8.2-cve-2008-4311.patch"
-}
-
-src_install() {
- gnome2_src_install
- newinitd "${FILESDIR}"/stb.rc system-tools-backends
-}
-
-pkg_postinst() {
- echo
- elog "You need to add yourself to the group stb-admin and"
- elog "add system-tools-backends to the default runlevel."
- elog "You can do this as root like so:"
- elog " # rc-update add system-tools-backends default"
- echo
-}
View
2  app-arch/file-roller/Manifest
@@ -1,4 +1,2 @@
DIST file-roller-2.32.2.tar.bz2 1901661 SHA256 3ddbe4e4134eab4ff8e97789a1626aec6cbc588190f2f520850d0697037e5755 SHA512 c62153871ed0210972d45ed0fa71eb177602cbc48894907c50ff45e8798d07979377ce4cbe1fbc1c37e5762cd005c5846dd9ac9f5ee93fe860de2babdc0933f0 WHIRLPOOL ea0af0538616532fc644f019d133bf5bfff876c95a3998d63ef58b3fa1b5b3d449c29589125ccdaeea18a1c0c1cafb872e996dd2b174b507c2c804d9c73e32dc
-DIST file-roller-3.4.2.tar.xz 1548788 SHA256 7085a351c55171718bbf5b9b614a7b9606efb8cbd2eb44cc6c538545444d0cdd SHA512 1fc9f6cea6c590744d0baa1fa455c032faaa5f131498dca501f2a03b4bac929a41d5f1f4d4f15c3c886357cd0f01faa3a326a64304916eb2c0553698c7a7239b WHIRLPOOL 4f47150a62a4c2ee10c18f05bdf25b3d9768b2289beccceaa9004b4b18cbcbced889bc1c036b0f60a0243dae607aee227a61392efaa873b998959e737a088c05
-DIST file-roller-3.6.2.tar.xz 1483616 SHA256 47b026c827fcb0db4df51bf81c1e90f829f287fe2c9b9e65f167a2ef5bfec5f1 SHA512 15b359cf8197d3d1294dd84e73f7bfbd7649f87b0fae337c83cb2c57335b6cda9da2a9b4a91b91c9cc4236f034e4197040c62410451b09ffaec004fcb41a781c WHIRLPOOL c29f5b22f631d0b694c5257ae870141604cf34bed2fd9d418a7c90cb3cb4684941686acaa756ee1b9a51e7a23d267430895f1f31f135e4ade7e965d2a090349f
DIST file-roller-3.6.3.tar.xz 1488432 SHA256 6d99d7be243d442484ba46505df5e52ffb4e46ea5cd754daba865eccc22c8402 SHA512 61fe0f0a3a28320d2bd1ef5ff464551f697f748c846e4d36fc183b8d1008059e6c801e4591348db86883f564c1a3f6a42006501c06202121c12450994777d9f4 WHIRLPOOL b3585aa514a1b2be8e5a3de2c39f01afd89b0d0423921f870d9a754cba93fe05069654fcbaaa4e9b53ef1de68c9bf9aaf5bf29aedeff2f33aaf1382f805d4b97
View
87 app-arch/file-roller/file-roller-3.4.2.ebuild
@@ -1,87 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-3.4.2.ebuild,v 1.3 2013/01/25 22:47:28 eva Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2
-
-DESCRIPTION="Archive manager for GNOME"
-HOMEPAGE="http://fileroller.sourceforge.net/"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="nautilus packagekit"
-KEYWORDS="~arm"
-
-# gdk-pixbuf used extensively in the source
-# cairo used in eggtreemultidnd.c
-# pango used in fr-window
-RDEPEND=">=dev-libs/glib-2.29.14:2
- sys-apps/file
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- >=x11-libs/gtk+-3.0.2:3
- x11-libs/pango
- nautilus? ( >=gnome-base/nautilus-3 )
- packagekit? ( app-admin/packagekit-base )
-"
-DEPEND="${RDEPEND}
- app-text/gnome-doc-utils
- >=dev-util/intltool-0.40.0
- sys-devel/gettext
- virtual/pkgconfig"
-# eautoreconf needs:
-# gnome-base/gnome-common
-
-pkg_setup() {
- # --disable-debug because enabling it adds -O0 to CFLAGS
- G2CONF="${G2CONF}
- --disable-dependency-tracking
- --disable-scrollkeeper
- --disable-run-in-place
- --disable-static
- --disable-schemas-compile
- --disable-debug
- --enable-magic
- $(use_enable nautilus nautilus-actions)
- $(use_enable packagekit)"
- DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # Use absolute path to GNU tar since star doesn't have the same
- # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
- epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
-
- # File providing Gentoo package names for various archivers
- cp -f "${FILESDIR}/3.1.2-packages.match" data/packages.match || die
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- elog "${PN} is a frontend for several archiving utilities. If you want a"
- elog "particular achive format support, see ${HOMEPAGE}"
- elog "and install the relevant package."
- elog
- elog "for example:"
- elog " 7-zip - app-arch/p7zip"
- elog " ace - app-arch/unace"
- elog " arj - app-arch/arj"
- elog " cpio - app-arch/cpio"
- elog " deb - app-arch/dpkg"
- elog " iso - app-cdr/cdrtools"
- elog " jar,zip - app-arch/zip and app-arch/unzip"
- elog " lha - app-arch/lha"
- elog " lzma - app-arch/xz-utils"
- elog " lzop - app-arch/lzop"
- elog " rar - app-arch/unrar"
- elog " rpm - app-arch/rpm"
- elog " unstuff - app-arch/stuffit"
- elog " zoo - app-arch/zoo"
-}
View
89 app-arch/file-roller/file-roller-3.6.2.ebuild
@@ -1,89 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-3.6.2.ebuild,v 1.8 2013/02/07 21:17:11 ulm Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2
-
-DESCRIPTION="Archive manager for GNOME"
-HOMEPAGE="http://fileroller.sourceforge.net/"
-
-LICENSE="GPL-2+ CC-BY-SA-3.0"
-SLOT="0"
-IUSE="nautilus packagekit"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-
-# gdk-pixbuf used extensively in the source
-# cairo used in eggtreemultidnd.c
-# pango used in fr-window
-RDEPEND=">=dev-libs/glib-2.29.14:2
- sys-apps/file
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/pango
- x11-libs/libSM
- x11-libs/libICE
- >=x11-libs/gtk+-3.4.0:3
- >=app-arch/libarchive-3.0.0:=
- >=x11-libs/libnotify-0.4.3:=
- >=dev-libs/json-glib-0.14.0
- nautilus? ( >=gnome-base/nautilus-3 )
- packagekit? ( app-admin/packagekit-base )
-"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40.0
- sys-devel/gettext
- virtual/pkgconfig"
-# eautoreconf needs:
-# gnome-base/gnome-common
-
-src_prepare() {
- # --disable-debug because enabling it adds -O0 to CFLAGS
- G2CONF="${G2CONF}
- --disable-dependency-tracking
- --disable-run-in-place
- --disable-static
- --disable-debug
- --enable-magic
- --enable-libarchive
- --with-smclient=xsmp
- $(use_enable nautilus nautilus-actions)
- $(use_enable packagekit)
- ITSTOOL=$(type -P true)"
- DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
-
- gnome2_src_prepare
-
- # Use absolute path to GNU tar since star doesn't have the same
- # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
- epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
-
- # File providing Gentoo package names for various archivers
- cp -f "${FILESDIR}/3.6.0-packages.match" data/packages.match || die
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- elog "${PN} is a frontend for several archiving utilities. If you want a"
- elog "particular achive format support, see ${HOMEPAGE}"
- elog "and install the relevant package."
- elog
- elog "for example:"
- elog " 7-zip - app-arch/p7zip"
- elog " ace - app-arch/unace"
- elog " arj - app-arch/arj"
- elog " cpio - app-arch/cpio"
- elog " deb - app-arch/dpkg"
- elog " iso - app-cdr/cdrtools"
- elog " jar,zip - app-arch/zip and app-arch/unzip"
- elog " lha - app-arch/lha"
- elog " lzop - app-arch/lzop"
- elog " rar - app-arch/unrar or app-arch/unar"
- elog " rpm - app-arch/rpm"
- elog " unstuff - app-arch/stuffit"
- elog " zoo - app-arch/zoo"
-}
View
4 app-arch/file-roller/file-roller-3.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-3.6.3.ebuild,v 1.2 2013/02/07 21:17:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-3.6.3.ebuild,v 1.3 2013/03/05 22:46:31 eva Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -14,7 +14,7 @@ HOMEPAGE="http://fileroller.sourceforge.net/"
LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
IUSE="nautilus packagekit"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
# gdk-pixbuf used extensively in the source
# cairo used in eggtreemultidnd.c
View
1  app-cdr/brasero/Manifest
@@ -1,3 +1,2 @@
DIST brasero-2.32.1.tar.bz2 4530933 SHA256 7b1056b6f19398912d51e3e583bc1b4d2a75ce2a8e15a96e1514fe6edb79df3b SHA512 ebd08f5ff21685a853c9b339b19b51ffe62e6050a6373883dee1266b45b490308ea5a25a1167a1ea48b89ff64625114a95c6a9f5f42d0d6defc2edd9c0295f25 WHIRLPOOL b01b935ac042bfa129c2245b0fb351ef4ed7c18e5e230cdf8a058073aa4fc28e78137f2bbae173784dc48b440153dcf21def3757dcd8f52065b3065bb42aa103
-DIST brasero-3.4.1.tar.xz 3233512 SHA256 e4fcd5dca1c7b0a930a43ae59953fa96db3f6beef41ceedb2f0ef8636e26a7a6 SHA512 238baf251982adefc3a206adf6e244d2d6326dc7a5e4768d60acab7d116392e5bd24ca8b15a804e309aeeda0ff5b18f22c2230d8f219c3ea432a1611dfe4b330 WHIRLPOOL 0a858c4c6db489e738d5b8624eb039264ef6fb9bd7ae57be1ecd2e597353c1d6ce53109405bdb4f91e85509da6e55cf96a035597c0b3ddf4ee8afd334db7167a
DIST brasero-3.6.1.tar.xz 3224840 SHA256 d293eb28dc45af3535f09cf91aa6ccc523f3f3d8b7ad3339b5e79b4acc19b932 SHA512 2504b0b3127c1d5a8bcce6b9c95e25e317cc2d95f32e31e048522594366354cca1cc551b61e38ae56000eeadfedb3950ce7f99bfcf8e3b6aba0a96371b69606e WHIRLPOOL f951e7db0e6c2d5c265caa12037cbffcea1ac6489fc5af645628b51162d1a7284c0d81393f3e487963426bd15197f434accbc4746f3f6ac909e6b086b2e71087
View
92 app-cdr/brasero/brasero-3.4.1.ebuild
@@ -1,92 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/brasero/brasero-3.4.1.ebuild,v 1.4 2012/12/17 11:12:54 jlec Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit autotools eutils gnome2
-
-DESCRIPTION="CD/DVD burning application for the GNOME desktop"
-HOMEPAGE="http://projects.gnome.org/brasero/"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+css +introspection +libburn mp3 nautilus packagekit playlist test tracker"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.29.14:2
- >=x11-libs/gtk+-3.0.0:3[introspection?]
- >=media-libs/gstreamer-0.10.15:0.10
- >=media-libs/gst-plugins-base-0.10:0.10
- >=dev-libs/libxml2-2.6:2
- >=x11-libs/libnotify-0.6.1
-
- media-libs/libcanberra[gtk3]
- x11-libs/libICE
- x11-libs/libSM
-