Permalink
Browse files

glorious funtoo updates

merged:

  funtoo-overlay: e1ff3e6c476c5d66d9162188cc99aee0bcf6d075
  foo-overlay: f7dfe75b6d07da7d211e64f6fc213b9c68f6bd49
  bar-overlay: f1e9085ee695ff5b6ce57d430d6b224aaf4fa0a6
  flora: e9070ed3cccc2b75d43f972cde120c1d02e4558c
  for-gentoo: eb94b25ce0edcf93322b32482f69aed502357b4f
  • Loading branch information...
1 parent 9cbdc23 commit e7f5369cf36abc9aa3bfa1e0a5feffd5efe10102 @danielrobbins danielrobbins committed Mar 14, 2013
Showing 542 changed files with 3,421 additions and 1,604 deletions.
@@ -1 +1,2 @@
DIST ec2-ami-tools-1.4.0.2.zip 139153 SHA256 e80cf8b27e35efee516068e84eb2bd2042a8ea870c5c41e3fc83e5a188c18c36 SHA512 95e13c6f50844cee5e1c30a58eb2137bdb4196a5bad17193b53d3c93db833853b4decd675fd403accf1384792010173f5bd9000db01e4e6b5d08b3861252de36 WHIRLPOOL c6b698bb239c8e1b4b9309188a99cfa179592ea9a1c8c000a4c3da0409bb60172b9b1e04ed9479aee34b73d81deda3851bcf4b9c378465531aa6a498e29b382c
+DIST ec2-ami-tools-1.4.0.5.zip 139373 SHA256 e5a8f49826c85c9df2421e36d618fb9bc1951bb0eeb45680c4379a0362c50d6e SHA512 e9754b26b61e168760002ac3c15d83c8d9f702e478c2295df42ae9e08e7d1788c73b60f7292867d8df553225a82e70ac335419dbcc226e3f0e251f1950a66621 WHIRLPOOL c71b102824595ceeeee693ad5cfca5dd7120510b2f4165fd7010f9cf9de3d4bcb5242166ee58b8295f4ff7f2a1dccaa834bb277ccf325928ede9307bd18da980
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-ami-tools/ec2-ami-tools-1.4.0.5.ebuild,v 1.1 2013/03/13 21:01:48 tomwij Exp $
+
+EAPI="5"
+
+inherit versionator
+
+DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service."
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=368&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${P}.zip"
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/ruby:1.8[ssl]
+ net-misc/rsync
+ net-misc/curl"
+
+S="${WORKDIR}/${P}"
+
+src_prepare() {
+ find . -name '*.cmd' -delete || die
+
+ # simplify the scripts to always run ruby18, since that seems to
+ # be what upstream has been using, and we support alternative
+ # implementations as well.
+ sed -i -e '$s:^ruby:exec ruby18:' bin/* || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r lib bin etc
+
+ chmod 0755 "${D}/opt/${PN}/bin/"*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+EC2_AMITOOL_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+}
@@ -1,2 +1,3 @@
DIST ec2-api-tools-1.5.6.1.zip 13995825 SHA256 0ae6d5da0f4715c1279c4a39ffaa1f14cb425bd4ed0fe821f71f00fd138a74bf SHA512 f06c2299fe1772755dfb7037401644e6587012a41c9c98eb941a2ebee33b1ab134bf19d3e271a846c6066dceba4d91d607e55f7ef57d14e83431eb31d4061a98 WHIRLPOOL 676f159b5c6cf46ca5455bae3684237bf76df4cfa1458f5abd3ae074a905c5c183928d900870290c7a5d1207227b074e9c9c7a3c4bc657cef7a2ee0ad9978499
DIST ec2-api-tools-1.6.0.0.zip 13997508 SHA256 c7a67eb92849a6104ef9f118263e545340f54900cc5970f0653837e415f4b72d SHA512 e3b2bbb406941e3ba0403137d81834a9161da6df97b0b92b89a5bfd7f4330d49a981325b6155a8ca272732c9b85c97a8bc8ce1c4d3cc0ede83d5b11029d1979c WHIRLPOOL f62b3fe69651faa44f83c78a2362c8ea8ba62e04065d1a89f0c19b7cbab7b70195fac0b2650ba6356742d0eb5b320febd8e7d70a94595c56d4782d009e124bff
+DIST ec2-api-tools-1.6.0.1.zip 14008355 SHA256 0219bef69eedc9ed28402d2796f13cce59838ceaeb6b938a28891bdbc0439e45 SHA512 fe24d06aa5921a8fc66e63ae821abce0c1f78907e542e7f0a3ac97c67dbea5131aef7db5ab63840e69536445317553cb2e924df4e5c66b33144054ad25cc3bff WHIRLPOOL af396f8ebbdcbcd364e0ed0f6392c458689181aaab07dfb7c13e4dcf2f554181f5db3c1b222bf9c8be6d195a42ecd78d92d79562dfd0bbd0e612e584e4a6bcbc
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ec2-api-tools-1.6.0.1.ebuild,v 1.1 2013/03/13 21:20:04 tomwij Exp $
+
+EAPI="5"
+
+inherit versionator
+
+DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service"
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=351&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PN}-${PV}.zip"
+
+S=${WORKDIR}/${PN}-${PV}
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ find . -name '*.cmd' -delete || die
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+EC2_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc THIRDPARTYLICENSE.TXT
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog ""
+ elog ""
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full paths to your key and certificate."
+ elog ""
+ elog " export EC2_PRIVATE_KEY=/path/to/pk-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+ elog " export EC2_CERT=/path/to/cert-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+}
@@ -1,7 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>maintainer-needed@gentoo.org</email>
-</maintainer>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+ <longdescription>Split-screen terminal/ncurses based log viewer</longdescription>
</pkgmetadata>
@@ -1,4 +1,4 @@
DIST puppet-2.7.18.gem 1920000 SHA256 147cd18ec39d2768bbc40f2735a84f770d9dde1b5679ba21f37edd6f7db19089 SHA512 e51c09baf2eee908f3b4ad1d90c252eb0eca3a1eb550522d0b612db919de305b724a13fdcc7abac51da31291b4a703b2478d2fc9ebfc5aa995ad677aabc42c83 WHIRLPOOL 9f2f4d30acfddd78f0d57ab0a58f400d6c1218e6f5e6541a5f224b9243f5ef5c2dee64bde5a69dff16df42242fa3f44ee226b4aa411a249fc8acafdd1ae17bf3
DIST puppet-2.7.19.gem 1936384 SHA256 aaa225d83a8fe545a6bcd1b1b6c10373f9cec7c41e38caf56bd0d956892cf2f3 SHA512 3d003c22663226996aa6422d18af446768bd81b67e76e8d1aedf18430bb85df73c3695de9d49340e51f948f661f4c6e24bc83d9d428c9f10634219e01fd641b6 WHIRLPOOL 0ffd63338cc55c13f6bb49bf1487f3b890be04a5ce83939848bace35dd51ff4b01b93ddde146197888455cc65cf8fb4228056c749c7802cd471d9b43dcca5c8c
-DIST puppet-3.0.1.tar.gz 1505102 SHA256 5e4d0cfdd6989faf4f6c5c76c0d3bcfa0364e380549be1a2f7c3abd22b0b562b SHA512 a55e7f30d867d72031d8d8ce5f55e1c7447f08227009164579e72974f4af158350ad568b5dee91e15cfd64c74d7df062bc2249244368bba96216ec8310f9d342 WHIRLPOOL a83716081ccabb590bb1cc86f0e666ae608914450abe722613fc9f4c2c94e9f25c657cf113f8145c73cceb4a1f5b79b851d3f084fd70dd19b245b2a3d3cf9688
-DIST puppet-3.1.0.tar.gz 1578045 SHA256 51e490e5aa6ff757d3ccafbff5aeb0cc1936d3d5bf2e9b6a380ffa600cdbe80a SHA512 3a929bad7192301409a0bc1bdebacf718289a5e32b77c4c0489ef677bed9b7e682085793e34aae481e6b649855dd9a4e5b844e832286bb96d57d88123145b31b WHIRLPOOL f6daa545edc9b416df87d5774af2481297772af0fd76abd953346c16d29d0f154e451e16154872415ec387faea138119046f716ff1f2b9e805c2d95300ad9f50
+DIST puppet-2.7.21.gem 2031616 SHA256 a5eecdbe68cde5ebfd576a9af5ddb0c8c17dae224a7d0b3ec240ef54e6bd88a1 SHA512 638c188b945791fe86c1657343f9d7ec3ef7e86342c35e03dacfae4e99e63d8c09160dd1faf840f244b275e6a0aea3b969668debe9dc1b60cef68cb2513068b5 WHIRLPOOL a4bcb4181e57bda6aaf79fdd484903114e94dcf5196105203538d6d8a1bfefcd6db44f74cbef1c209b086d7b2bfab53d62069da1be034e6c35fe686fd00898bc
+DIST puppet-3.1.1.tar.gz 1587190 SHA256 4401f6388bb96b1301a107f247af6fa558127d78467bb5cef1a1e0ff66b4463d SHA512 48759776b68f83a125a0c703ecc9ad3efe34f10e6cfd9ddcd9e596ff082c9f40bdb7e0489bf7eb0bb0ce8bdb4ad0ae87049d2ad3133e839d0a5a6caa8419074e WHIRLPOOL d7152ba5397edadba9784f3c1800c8cf31ddd547691b35567ad52a42e82e741256326d2ee0bccec0642e82f533ffb74babcaddf3a0ee54361626b875cc618b2f
@@ -1,11 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.7.18-r1.ebuild,v 1.4 2013/02/08 16:49:13 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.7.21.ebuild,v 1.2 2013/03/13 18:55:57 jer Exp $
EAPI="4"
-# ruby19: dev-ruby/ruby-ldap has no ruby19
-#USE_RUBY="ruby18 ruby19 ree18"
-USE_RUBY="ruby18"
+USE_RUBY="ruby18 ruby19"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST="test"
@@ -19,7 +17,7 @@ HOMEPAGE="http://puppetlabs.com/"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 hppa ~ppc ~sparc ~x86"
ruby_add_rdepend "
>=dev-ruby/facter-1.5.6
@@ -40,10 +38,12 @@ ruby_add_rdepend "
# stomp? ( dev-ruby/stomp )
DEPEND="${DEPEND}
+ ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
emacs? ( virtual/emacs )
xemacs? ( app-editors/xemacs )
selinux? ( sec-policy/selinux-puppet )"
RDEPEND="${RDEPEND}
+ ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
emacs? ( virtual/emacs )
xemacs? ( app-editors/xemacs )
rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
@@ -83,7 +83,7 @@ each_fakegem_install() {
all_ruby_install() {
all_fakegem_install
- newinitd "${FILESDIR}"/puppet.init-CVE-2012-6120 puppet
+ newinitd "${FILESDIR}"/puppet.init-r1 puppet
doconfd conf/gentoo/conf.d/puppet
# Initial configuration files
@@ -100,8 +100,8 @@ all_ruby_install() {
rm "${ED}/usr/bin/puppetmasterd"
rm "${ED}/etc/puppet/auth.conf"
else
- newinitd "${FILESDIR}"/puppetmaster-2.7.6.init-CVE-2012-6120 puppetmaster
- newconfd "${FILESDIR}"/puppetmaster-2.7.6.confd puppetmaster
+ newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
insinto /etc/puppet
doins conf/redhat/fileserver.conf
@@ -1,159 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.0.1-r1.ebuild,v 1.2 2013/02/09 01:00:03 prometheanfire Exp $
-
-EAPI="4"
-
-USE_RUBY="ruby18 ruby19"
-
-inherit elisp-common xemacs-elisp-common eutils user ruby-ng versionator
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~x86"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- >=dev-ruby/facter-1.6.2
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_ruby_install() {
- ${RUBY} install.rb --destdir="${D}" install || die
-}
-
-all_ruby_install() {
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
-
- # Initial configuration files
- insinto /etc/puppet
-
- # Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
-
- if use minimal ; then
- rm "${ED}/etc/puppet/auth.conf"
- else
- newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fi
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
- docinto conf; dodoc conf/namespaceauth.conf
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Puppet uses eix to get information about currently installed packages,"
- elog "so please keep the eix metadata cache updated so puppet is able to properly"
- elog "handle package installations."
- elog
- elog "Currently puppet only supports adding and removing services to the default"
- elog "runlevel, if you want to add/remove a service from another runlevel you may"
- elog "do so using symlinking."
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.1.0.ebuild,v 1.1 2013/02/11 16:43:38 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.1.1.ebuild,v 1.1 2013/03/13 17:38:32 prometheanfire Exp $
EAPI="4"
@@ -1,2 +1,3 @@
DIST usermin-1.430.tar.gz 6059219 SHA256 2886f30bf843632f386d97b28d77f393af1157bb13b69694553a4d5e509d67a9 SHA512 1b9c9e59072663f0e057a831622893fb1b214d6a51fa8b0eeb292acd9fc82b0903d2dbe0a2f50ff1daffb4d00be1709d3b31f71a5e20c6b26dc2882135edd008 WHIRLPOOL 7efd2b751f7ae14dfa2a2e64035eaff12cc30f2665f92a049d4c6efd86a1fee228361fc3340a949990950045b9d30c1ed856c538f6f0c13dbe6108c42d6bcf09
DIST usermin-1.530.tar.gz 9117223 SHA256 d9196276c2dfe0615964d0e1df89d7a5991abc33c4d1eaa6180733797c466d33 SHA512 6cf5bc062ed09ceb2993a00e47d4bfadba4af4a2263b7cb0d9f37c61e987bdda925435d26ca9258f2c552126116bba0330bc1d63b307783ed6238abe60223f13 WHIRLPOOL 0433c308c481fc8b6ff36305ebca279f361b12d26df24b3ef35057319743de1855b69aac698e7df50377534e9cd34c672bdeb829073a976e5a96f629db27fc38
+DIST usermin-1.540.tar.gz 9135732 SHA256 e3025ebfb455a36599b7bb88afb99fa24b0e263fdea5684448eac6d1a2242028 SHA512 7940de94da5d96060e1feae9f7f47f5d746f4e146792fc8bb595fca2e569eac84925d1018c12ba8d8e9564b3dc005363a7523889b089c058214adb086b888db2 WHIRLPOOL 5a7682a6961da2ba74fb628795a5a6cb44022a35fd8a6280be1278a47b32e74068e6f8732afd689dea1eeefde1170928d38bc4b3116477a5ed260ff6d7f725e8
Oops, something went wrong.

0 comments on commit e7f5369

Please sign in to comment.