Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

undefined method `cattr_accessor' for EncodingQueue:Class (NoMethodError) #3

Closed
kenvunz opened this Issue · 1 comment

2 participants

@kenvunz

Got this error when I try to run 'enigmamachine start' on Mac 10.6.8. Wonder if I'm missing some dependencies, any pointer would be great. Cheers

Full Error stack:

/Library/Ruby/Gems/1.8/gems/enigmamachine-0.6.2/bin/../lib/enigmamachine/../enigmamachine/encoding_queue.rb:3: undefined method cattr_accessor' for EncodingQueue:Class (NoMethodError)
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in
gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in require'
from /Library/Ruby/Gems/1.8/gems/enigmamachine-0.6.2/bin/../lib/enigmamachine/../enigmamachine.rb:27
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in
gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in require'
from /Library/Ruby/Gems/1.8/gems/enigmamachine-0.6.2/bin/../lib/enigmamachine/config.ru:1
from /Library/Ruby/Gems/1.8/gems/rack-1.3.0/lib/rack/builder.rb:51:in
instance_eval'
from /Library/Ruby/Gems/1.8/gems/rack-1.3.0/lib/rack/builder.rb:51:in initialize'
from /Library/Ruby/Gems/1.8/gems/enigmamachine-0.6.2/bin/../lib/enigmamachine/config.ru:1:in
new'
from /Library/Ruby/Gems/1.8/gems/enigmamachine-0.6.2/bin/../lib/enigmamachine/config.ru:1

@futurechimp
Owner

Whoops, sorry about that, I've pushed a new version (0.6.3) to fix this. Thanks for the bug report!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.