Permalink
Browse files

Making rcov install only on mri 1.8 and 1.9. It makes rbx fail and is…

… not required for other purposes than development
  • Loading branch information...
1 parent 6e239dd commit b3dca74cdb1a976cf5d5f0f4c0e051f2bb9d7d92 Marcin Bunsch committed May 30, 2011
Showing with 10 additions and 2 deletions.
  1. +2 −1 Gemfile
  2. +8 −1 Rakefile
View
@@ -5,13 +5,14 @@ gemspec
group :development, :test do
gem 'rake', '0.8.7'
gem 'rspec'
- gem 'rcov'
platforms :mri_18 do
+ gem 'rcov'
gem "ruby-debug"
end
platforms :mri_19 do
+ gem 'rcov'
gem "ruby-debug19"
end
end
View
@@ -19,7 +19,14 @@ begin
task :default => [:spec]
+rescue
+ puts 'Could not load Broadcast RSpec Rake tasks'
+end
+
+begin
+
namespace :spec do
+
task :cleanup do
rm_rf 'coverage.data'
end
@@ -33,5 +40,5 @@ begin
end
rescue
- puts 'Could not load Broadcast RSpec Rake tasks'
+ puts 'Could not load Broadcast RSpec Rcov Rake tasks'
end

0 comments on commit b3dca74

Please sign in to comment.