Skip to content
This repository

Does not work with Node 0.8 #4

Closed
MaximOrlovsky opened this Issue July 13, 2012 · 2 comments

2 participants

Maxim Orlovsky Francois Zaninotto
Maxim Orlovsky

npm WARN engine express@2.5.8: wanted: {"node":">= 0.4.1 < 0.7.0"} (current: {"n
ode":"0.8.2","npm":"1.1.36"})

Should I downgrade to 0.7.0?

after 'node app' I've got:

p:\canvas-9\screenshot-as-a-service>node app

child_process.js:777
var r = this.handle.spawn(options);
________________
^
TypeError: Bad argument
at ChildProcess.spawn (child_process.js:777:24)
at exports.spawn (child_process.js:614:9)
at RasterizerService.startService (p:\canvas-9\screenshot-as-a-service\lib\rasterizerService.js:32:21)
at Object. (p:\canvas-9\screenshot-as-a-service\app.js:11:19)
at Module._compile (module.js:449:26)
at Object.Module._extensions..js (module.js:467:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.runMain (module.js:492:10)
at process.startup.processNextTick.process._tickCallback (node.js:244:9)

The NPM list:

p:\canvas-9\screenshot-as-a-service>npm list
screenshot-as-a-service@1.0.0 p:\canvas-9\screenshot-as-a-service
├─┬ config@0.4.11
│ ├── coffee-script@1.3.3
│ ├─┬ vows@0.5.13
│ │ └── eyes@0.1.7
│ └── yaml@0.2.3
├─┬ express@2.5.8
│ ├─┬ connect@1.9.2
│ │ └── formidable@1.0.11
│ ├── mime@1.2.4
│ ├── mkdirp@0.3.0
│ └── qs@0.4.2
└── request@2.9.153

I tried to run application on Win7 (64) / nodejs 0.8.2

Francois Zaninotto
Owner

yes the app is not yet tested with node 0.8.

Maxim Orlovsky MaximOrlovsky closed this July 16, 2012
Francois Zaninotto
Owner

Precision: I will provide a Node 0.8 version once Mongoose and ExpressJS release their v3.0.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.