Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[16.04] Fix tag_autocomplete issue in workflow editor. #2569

Merged
merged 1 commit into from Jul 8, 2016

Conversation

Projects
None yet
5 participants
@dannon
Copy link
Member

commented Jun 28, 2016

When we swapped to tag manager the signature changed and some of these were missed.

Should fix #2568

Fix tag_autocomplete issue. When we swapped to tag manager the signat…
…ure changed and some of these were missed.

@dannon dannon force-pushed the dannon:workflow_tag_fixes branch from 2d92737 to c3bf89f Jun 28, 2016

@dannon

This comment has been minimized.

Copy link
Member Author

commented Jul 8, 2016

This resolves the back-end issue, but something else is broken causing the autocomplete tags (which are shipped to the client correctly now) to not actually get displayed.

@dannon dannon added status/review and removed status/WIP labels Jul 8, 2016

@dannon

This comment has been minimized.

Copy link
Member Author

commented Jul 8, 2016

Ok, after looking into it more, jquery-autocomplete fixing is going to be a much larger issue. This fixes the server error which is actually disruptive, and is a reasonable bit to backport to 16.04. I'm going to work on a more comprehensive (and scary to backport) autocomplete overhaul in dev.

@carlfeberhard

This comment has been minimized.

Copy link
Contributor

commented Jul 8, 2016

+1

@carlfeberhard

This comment has been minimized.

Copy link
Contributor

commented Jul 8, 2016

Is this similar to what you're seeing: #1079?

@dannon

This comment has been minimized.

Copy link
Member Author

commented Jul 8, 2016

@carlfeberhard Didn't see an indexOf error, it was just silently failing after retrieving the autocomplete tag data from the server (once the patch in this PR is applied, of course -- prior to that it just explodes).

The autocomplete library we were using is deprecated and I was tinkering with using the standard jquery-ui autocomplete widget as a replacement, but it's going to be a little bit of work.

@dannon

This comment has been minimized.

Copy link
Member Author

commented Jul 8, 2016

@carlfeberhard Yeah, just doublechecked. I see the autocomplete request and response:

http://localhost:8080/tag/tag_autocomplete_data?item_id=fb85969571388350&item_class=StoredWorkflow&q=tag
#Header|Your Tags
tag2|tag2
tags|tags

And no errors. (and no autocomplete selection popup, etc.)

@carlfeberhard

This comment has been minimized.

Copy link
Contributor

commented Jul 8, 2016

Ok good: that's progress I'd think. I'll close the other.

@nsoranzo nsoranzo merged commit ab2e48b into galaxyproject:release_16.04 Jul 8, 2016

4 checks passed

api test Build finished. 211 tests run, 0 skipped, 0 failed.
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
framework test Build finished. 106 tests run, 0 skipped, 0 failed.
Details
toolshed test Build finished. 589 tests run, 0 skipped, 0 failed.
Details
@nsoranzo

This comment has been minimized.

Copy link
Member

commented Jul 8, 2016

Wow, that was broken since 15.03!

@galaxybot

This comment has been minimized.

Copy link

commented Jul 8, 2016

This PR was merged without a milestone attached.

@martenson martenson added this to the 16.07 milestone Jul 8, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.