Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix Galaxy for if pyuwsgi is install in .venv. #2836

Merged
merged 1 commit into from Aug 22, 2016

Conversation

Projects
None yet
3 participants
@jmchilton
Copy link
Member

commented Aug 22, 2016

Encountered this issue when playing around with backward compatibility for #2802. I consider it a valid, atomic fix from #2802 even if that PR is never makes it.

@nsoranzo

This comment has been minimized.

Copy link
Member

commented Aug 22, 2016

👍

@dannon dannon merged commit 49560c5 into galaxyproject:dev Aug 22, 2016

3 of 4 checks passed

continuous-integration/travis-ci/pr The Travis CI build is in progress
Details
api test Build finished. 224 tests run, 0 skipped, 0 failed.
Details
framework test Build finished. 115 tests run, 0 skipped, 0 failed.
Details
toolshed test Build finished. 581 tests run, 0 skipped, 0 failed.
Details

@martenson martenson deleted the jmchilton:pyuwsgi_fix branch Aug 22, 2016

jmchilton added a commit to jmchilton/galaxy that referenced this pull request Sep 6, 2017

[16.01] Backport uwsgi fix from galaxyproject#2836.
Now that newer releases require a library that the mere presence of breaks an older version of Galaxy, I think this will be encountered more during development. It is breaking Planemo's ability to switch between different versions of Galaxy.

galaxyproject#2836

dannon added a commit that referenced this pull request Sep 6, 2017

Merge pull request #4565 from jmchilton/backport_uwsgi_fix
[16.01] Backport uwsgi fix from #2836.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.