Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix transiently failing Selenium upload test. #3587

Merged
merged 1 commit into from Feb 10, 2017

Conversation

Projects
None yet
4 participants
@jmchilton
Copy link
Member

commented Feb 10, 2017

Since the merge of #3582 we have had many more completely successful Selenium suite executions.

selenium_trend

A problem with the upload test did just pop up though - I think it is pretty clear what is wrong. I think what happened when this failed is that Galaxy was still processing the upload during the call to the history contents API. Waiting for the box and ensuring it is green in the GUI should definitely prevent that from happening.

I also improved the assertion error message.

@martenson

This comment has been minimized.

Copy link
Member

commented Feb 10, 2017

odd
Expected to find tool panel section *new_column_maker*, but instead found **

@jmchilton

This comment has been minimized.

Copy link
Member Author

commented Feb 10, 2017

@martenson Indeed that is odd - I've updated this issue #1617 to add that test to the list. I'm fairly sure it is unrelated to this PR.

@martenson martenson merged commit 66a24c8 into galaxyproject:dev Feb 10, 2017

4 of 5 checks passed

toolshed test Build finished. 580 tests run, 0 skipped, 1 failed.
Details
api test Build finished. 263 tests run, 0 skipped, 0 failed.
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
framework test Build finished. 138 tests run, 0 skipped, 0 failed.
Details
integration test Build finished. 24 tests run, 0 skipped, 0 failed.
Details
@mvdbeek

This comment has been minimized.

Copy link
Member

commented Feb 10, 2017

odd
Expected to find tool panel section new_column_maker, but instead found **

This is not exactly the same test that I tried to fix here but it's probably related, fwiw.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.