New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

#5187: altered conda version number for using '--offline' option again #5233

Merged
merged 1 commit into from Dec 20, 2017

Conversation

Projects
None yet
5 participants
@NCEichner
Contributor

NCEichner commented Dec 19, 2017

In order to get rid of the conda error described in #5187 I raised the version number, from which conda is allowed to use the '--offline' parameter again, to "4.4" (according to the post of @nsoranzo in #5187).

Annotation:
It seems that a galaxy instance in which the mentioned conda error was raised once may be damaged. After altering the file 'conda_util.py' in an old galaxy instance we still got problems e.g. in starting workflows (first job in workflow started, all the following jobs in the chain immediately went to red color and were aborted).

So I suggest to test this workaround (changed from @natefoo's version in #4701) in newly installed galaxy instances right after cloning fom git and BEFORE first startup. For us this seems to work fine so far.

#5187
In order to get rid of the conda error described in #5187 I raised the version number beginning from which conda is allowed to use the '--offline' parameter again to "4.4"
@bgruening

This comment has been minimized.

Member

bgruening commented Dec 19, 2017

@NCEichner 4.4 is not yet released right? https://github.com/conda/conda/releases

@nsoranzo

This comment has been minimized.

Member

nsoranzo commented Dec 19, 2017

@bgruening No, it's not released yet, but I don't think the --offline bug will ever be fixed in 4.3.

@dannon dannon merged commit 63e2964 into galaxyproject:dev Dec 20, 2017

6 checks passed

api test Build finished. 336 tests run, 4 skipped, 0 failed.
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
framework test Build finished. 165 tests run, 0 skipped, 0 failed.
Details
integration test Build finished. 60 tests run, 0 skipped, 0 failed.
Details
selenium test Build finished. 117 tests run, 3 skipped, 0 failed.
Details
toolshed test Build finished. 577 tests run, 0 skipped, 0 failed.
Details
@dannon

This comment has been minimized.

Member

dannon commented Dec 20, 2017

Thanks!

@nsoranzo

This comment has been minimized.

Member

nsoranzo commented Jan 11, 2018

Should we backport this to 17.09? xref. http://dev.list.galaxyproject.org/Problems-installing-conda-dependencies-for-seq2hla-tool-tp4671234p4671237.html

Edited: I've opened a backport PR at #5298 .

dannon added a commit that referenced this pull request Jan 11, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment