Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix tool image paths #660

Merged
merged 3 commits into from Aug 27, 2015

Conversation

Projects
None yet
4 participants
@martenson
Copy link
Member

commented Aug 27, 2015

This should fix our image-showing issues on TS and Galaxy. The proper way to link images from readme of help is relative path within repo. The distro tools with images should continue working as they won't go through shed_util_common
ping @bgruening
related:
galaxyproject/tools-devteam#212
galaxyproject/tools-devteam#126

martenson added some commits Aug 27, 2015

remove replaces for static prefix in image relpaths
this is not a problem when in Tool Shed and it prevents people form using these paths
ping @bgruening
Eliminate ${static_path} from tool shed image links.
I did not find a reason to use it.
@bgruening

This comment has been minimized.

Copy link
Member

commented Aug 27, 2015

I can not come up with a counter example, so I think this should work in all cases I have seen.
👍

@davebx

This comment has been minimized.

Copy link
Contributor

commented Aug 27, 2015

👍 Looks solid.

bgruening added a commit that referenced this pull request Aug 27, 2015

@bgruening bgruening merged commit 396bcc7 into galaxyproject:dev Aug 27, 2015

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@martenson martenson deleted the martenson:fix-tool-image-paths branch Aug 27, 2015

@jmchilton jmchilton added the kind/bug label Oct 6, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.