Permalink
Browse files

Drop support for Python 2.6.

😒

Add warning if trying to run setup.py on older Python's as suggested by @peterjc.
  • Loading branch information...
jmchilton committed Mar 29, 2016
1 parent 358a42c commit 93b7bda9af78526ca0a491d4090bc32bd8bb095b
Showing with 8 additions and 12 deletions.
  1. +0 βˆ’1 .travis.yml
  2. +2 βˆ’5 CONTRIBUTING.rst
  3. +0 βˆ’3 dev-requirements.txt
  4. +5 βˆ’1 setup.py
  5. +1 βˆ’2 tox.ini
@@ -5,7 +5,6 @@ env:
- TOX_ENV=py27-lint
- TOX_ENV=py34-lint
- TOX_ENV=py27-lint-readme
- TOX_ENV=py26
- TOX_ENV=py27
- TOX_ENV=py34

@@ -106,7 +106,7 @@ Before you submit a pull request, check that it meets these guidelines:

1. If the pull request adds functionality, the docs should be updated. Put
your new functionality into a function with a docstring.
2. The pull request should work for Python 2.6 and 2.7. Check
2. The pull request should work for Python 2.7 and 3.4. Check
https://travis-ci.org/galaxyproject/planemo/pull_requests
and make sure that the tests pass for all supported Python versions.

@@ -118,7 +118,7 @@ To run a subset of tests::
% make tox ENV=py27 ARGS='--tests tests/test_shed_upload.py'

This will use Tox_ to run the specified tests using Python 2.7. ``ENV`` here
can be used to specify different Python version (e.g. ``py26``, ``py27``,
can be used to specify different Python version (e.g. ``py27`` and
``py34``). Python 3.4 is a work in progress.

Even more granularity is also possible by specifying specific test methods.::
@@ -157,9 +157,6 @@ testing environment. Planemo defines the following environments:
``py27-lint-readme``
Lint the README reStructuredText.

``py26``
Run planemo tests in Python 2.6.

``py27``
Run planemo tests in Python 2.7.

@@ -12,9 +12,6 @@ sphinx
# Used to check readme.
readme

# For Python 2.6 tests
unittest2

# Used for code checking.
pyflakes
flake8
@@ -4,11 +4,16 @@
import ast
import os
import re
import sys
try:
from setuptools import setup
except ImportError:
from distutils.core import setup

if sys.version_info < (2, 7):
sys.stderr.write("ERROR: planemo requires at least Python Version 2.7\n")
sys.exit(1)

SOURCE_DIR = "planemo"

_version_re = re.compile(r'__version__\s+=\s+(.*)')
@@ -114,7 +119,6 @@ def get_var(var_name):
'Topic :: Software Development :: Testing',
'Natural Language :: English',
"Programming Language :: Python :: 2",
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
],
test_suite=TEST_DIR,
@@ -1,7 +1,7 @@
# TODO: py34 to envlist
# TODO: implement doc linting
[tox]
envlist = py34-lint, py27-lint, py27-lint-readme, py26, py27
envlist = py34-lint, py27-lint, py27-lint-readme, py27
source_dir = planemo
test_dir = tests

@@ -11,7 +11,6 @@ commands = {envpython} setup.py nosetests []
deps =
-rrequirements.txt
py27: cwltool
py26: unittest2
nose
coverage
flask

0 comments on commit 93b7bda

Please sign in to comment.