Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Revert "gnutls: make it non-wchar friendly"

This reverts commit f1b86ce

While the fix makes gnutls build without wchar, it doesn't actually work as
there's no rpl_wctomb implementation so the .so ends up with an undefined
reference to wctomb:

./host/usr/bin/arm-linux-nm -D staging/usr/lib/libgnutls.so.28|grep wctomb
         U wctomb

Causing linker errors for packages trying to use it:

  CCLD   msmtp
host/usr/arm-buildroot-linux-uclibcgnueabi/sysroot/usr/lib/libgnutls.so:
undefined reference to `wctomb'
collect2: ld returned 1 exit status

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
  • Loading branch information...
commit 68c3f5257d94d0fc0437747014f3c1ff4d02aa8b 1 parent ab6f23b
Peter Korsgaard authored
View
2  package/connman/Config.in
@@ -5,7 +5,7 @@ config BR2_PACKAGE_CONNMAN
select BR2_PACKAGE_IPTABLES
select BR2_PACKAGE_GNUTLS
depends on !(BR2_UCLIBC_VERSION_0_9_31 || BR2_UCLIBC_VERSION_0_9_32)
- depends on BR2_USE_WCHAR # libglib2
+ depends on BR2_USE_WCHAR # libglib2 and gnutls
depends on BR2_INET_IPV6
depends on BR2_TOOLCHAIN_HAS_THREADS # dbus
depends on BR2_USE_MMU # dbus
View
6 package/gnutls/Config.in
@@ -1,6 +1,7 @@
config BR2_PACKAGE_GNUTLS
bool "gnutls"
select BR2_PACKAGE_NETTLE
+ depends on BR2_USE_WCHAR
help
GnuTLS is a secure communications library implementing the SSL
and TLS protocols and technologies around them.
@@ -9,10 +10,9 @@ config BR2_PACKAGE_GNUTLS
config BR2_PACKAGE_GNUTLS_TOOLS
bool "install tools"
- depends on BR2_PACKAGE_GNUTLS
depends on BR2_USE_WCHAR
help
Install GnuTLS command line tools for various cryptographic tasks.
-comment "gnutls tools requires a toolchain with WCHAR support"
- depends on BR2_PACKAGE_GNUTLS && !BR2_USE_WCHAR
+comment "gnutls requires a toolchain with WCHAR support"
+ depends on !BR2_USE_WCHAR
View
4 package/libmicrohttpd/Config.in
@@ -10,6 +10,7 @@ config BR2_PACKAGE_LIBMICROHTTPD
config BR2_PACKAGE_LIBMICROHTTPD_SSL
bool "https support"
depends on BR2_PACKAGE_LIBMICROHTTPD
+ depends on BR2_USE_WCHAR
select BR2_PACKAGE_GNUTLS
select BR2_PACKAGE_LIBGCRYPT
help
@@ -17,3 +18,6 @@ config BR2_PACKAGE_LIBMICROHTTPD_SSL
comment "libmicrohttpd needs a toolchain with thread support"
depends on !BR2_TOOLCHAIN_HAS_THREADS
+
+comment "libmicrohttpd https support needs a toolchain with wchar support"
+ depends on BR2_PACKAGE_LIBMICROHTTPD && !BR2_USE_WCHAR
View
2  package/libsoup/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_LIBSOUP
bool "libsoup"
- depends on BR2_USE_WCHAR # glib2
+ depends on BR2_USE_WCHAR # glib2 and gnutls
select BR2_PACKAGE_LIBXML2
select BR2_PACKAGE_LIBGLIB2
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
View
2  package/network-manager/Config.in
@@ -4,7 +4,7 @@ config BR2_PACKAGE_NETWORK_MANAGER
select BR2_PACKAGE_DBUS
depends on BR2_INET_IPV6
depends on BR2_LARGEFILE # acl
- depends on BR2_USE_WCHAR # libglib2
+ depends on BR2_USE_WCHAR # libglib2 and gnutls
depends on BR2_TOOLCHAIN_HAS_THREADS # dbus
depends on BR2_USE_MMU # dbus
select BR2_PACKAGE_DBUS_GLIB
Please sign in to comment.
Something went wrong with that request. Please try again.