Skip to content
Browse files

pcsc-lite: requires mmu

Fixes:
http://autobuild.buildroot.net/results/14400ae2c9e312729efa9a9026b5fdd487868c8a/

Also add license information while at it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
  • Loading branch information...
1 parent 22f4d99 commit 94a05f966874defe4d678f110c11cb87bce1af4f @gustavoz gustavoz committed with jacmet Jan 30, 2013
Showing with 6 additions and 1 deletion.
  1. +1 −0 package/ccid/Config.in
  2. +1 −0 package/pcsc-lite/Config.in
  3. +4 −1 package/pcsc-lite/pcsc-lite.mk
View
1 package/ccid/Config.in
@@ -3,6 +3,7 @@ config BR2_PACKAGE_CCID
select BR2_PACKAGE_PCSC_LITE
select BR2_PACKAGE_LIBUSB
depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
+ depends on BR2_USE_MMU # pcsc-lite
help
PC/SC driver for USB CCID smart card readers
View
1 package/pcsc-lite/Config.in
@@ -1,6 +1,7 @@
config BR2_PACKAGE_PCSC_LITE
bool "pcsc-lite"
depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_USE_MMU # fork()
help
Middleware to access smart card using SCard API (PC/SC).
View
5 package/pcsc-lite/pcsc-lite.mk
@@ -2,12 +2,15 @@
#
# PCSC-Lite
#
-# ########################################################
+#########################################################
+
PCSC_LITE_VERSION = 1.8.6
PCSC_LITE_SOURCE = pcsc-lite-$(PCSC_LITE_VERSION).tar.bz2
PCSC_LITE_SITE = http://alioth.debian.org/frs/download.php/3757
PCSC_LITE_INSTALL_STAGING = YES
PCSC_LITE_DEPENDENCIES = host-pkgconf
+PCSC_LITE_LICENSE = BSD-3c
+PCSC_LITE_LICENSE_FILES = COPYING
# - libudev and libusb are optional
# - libudev and libusb can't be used together

0 comments on commit 94a05f9

Please sign in to comment.
Something went wrong with that request. Please try again.