Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Version of installed libGammu.so (1.38.1) is different to version of Gammu (1.40.0) #461

Open
stevecohenfr opened this issue Apr 12, 2019 · 3 comments

Comments

Projects
None yet
2 participants
@stevecohenfr
Copy link

commented Apr 12, 2019

I compiled gammu from sources for my Raspberry Pi using:

mkdir build
cd build
cmake ..
make
make test
sudo make install

Everything build success but when I check the gammu version i got this error :

pi@raspberrypi:~ $ gammu -v
Error: Version of installed libGammu.so (1.38.1) is different to version of Gammu (1.40.0)

How to upgrade my libGammu in my Rpi ?

Thanks


Want to back this issue? Post a bounty on it! We accept bounties via Bountysource.

@stevecohenfr

This comment has been minimized.

Copy link
Author

commented Apr 12, 2019

Update :

It seems I have the good version of the lib...

pi@raspberrypi:~ $ ls -l /usr/local/lib/
lrwxrwxrwx 1 root staff      20 avril 12 20:16 libGammu.so -> libGammu.so.8.1.40.0
lrwxrwxrwx 1 root staff      20 avril 12 19:08 libGammu.so.8 -> libGammu.so.8.1.40.0
-rw-r--r-- 1 root staff 1382112 avril 12 19:25 libGammu.so.8.1.40.0
lrwxrwxrwx 1 root staff      13 avril 12 19:08 libgsmsd.so -> libgsmsd.so.8
lrwxrwxrwx 1 root staff      20 avril 12 19:08 libgsmsd.so.8 -> libgsmsd.so.8.1.40.0
-rw-r--r-- 1 root staff  115568 avril 12 19:25 libgsmsd.so.8.1.40.0
@yarmooh

This comment has been minimized.

Copy link

commented May 16, 2019

Haven't you installed any gammu/gammu-smsd from apt?
This looks like typical version mismatch (different from remo, different from make).

@stevecohenfr

This comment has been minimized.

Copy link
Author

commented May 16, 2019

I installed the two libs with make.
But now this error is gone away, without reason... Maybe it was because of the cache or anything else.

Thanks for your answer

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.