Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Raspberry TP-LINK No response in specified timeout. Probably the phone is not connected #480

Open
stevecohenfr opened this issue Jun 29, 2019 · 0 comments

Comments

Projects
None yet
1 participant
@stevecohenfr
Copy link

commented Jun 29, 2019

I use gammu with my TP-LINK dongle for a while in my Raspberry PI 3B+. Everything worked fine (after hard configuration). Yesterday I tried to change the SIM card and gammu stop working. So I switched and put the old SIM card again, tried a lot of configurations but gammu wont reconize my SIM anymore...
I have this error when starting gammu-smsd :

gammu-smsd[1110]: Starting phone communication...
gammu-smsd[1110]: gammu: [Gammu            - 1.40.0]
gammu-smsd[1110]: gammu: [Connection       - "at"]
gammu-smsd[1110]: gammu: [Connection index - 0]
gammu-smsd[1110]: gammu: [Model type       - ""]
gammu-smsd[1110]: gammu: [Device           - "/dev/ttyUSB0"]
gammu-smsd[1110]: gammu: [Running on       - Linux, kernel 4.14.98-v7+ (#1200 SMP Tue Feb 12 20:27:48 GMT 2019)]
gammu-smsd[1110]: gammu: Serial device: DTR is up, RTS is up, CAR is down, CTS is down
gammu-smsd[1110]: gammu: Setting speed to 115200
gammu-smsd[1110]: gammu: [Module           - "auto"]
gammu-smsd[1110]: gammu: Escaping SMS mode
gammu-smsd[1110]: gammu: SENDING frame type 0x00/length 0x02/2
gammu-smsd[1110]: gammu: 1B |0D                                                          ..              
gammu-smsd[1110]: gammu: Sending simple AT command to wake up some devices
gammu-smsd[1110]: gammu: SENDING frame type 0x00/length 0x03/3
gammu-smsd[1110]: gammu: 41A|54T|0D                                                      AT.             
gammu-smsd[1110]: gammu: [Retrying 1 type 0x00]
gammu-smsd[1110]: gammu: SENDING frame type 0x00/length 0x03/3
gammu-smsd[1110]: gammu: 41A|54T|0D                                                      AT.             
gammu-smsd[1110]: gammu: Enabling echo
gammu-smsd[1110]: gammu: SENDING frame type 0x00/length 0x05/5
gammu-smsd[1110]: gammu: 41A|54T|45E|311|0D                                              ATE1.           
gammu-smsd[1110]: gammu: [Retrying 1 type 0x00]
gammu-smsd[1110]: gammu: SENDING frame type 0x00/length 0x05/5
gammu-smsd[1110]: gammu: 41A|54T|45E|311|0D                                              ATE1.           
gammu-smsd[1110]: gammu: Phone does not support enabled echo, it can not work with Gammu!
gammu-smsd[1110]: gammu: It might be caused by other program using the modem.
gammu-smsd[1110]: gammu: See <https://wammu.eu/docs/manual/faq/general.html#echo> for help.
gammu-smsd[1110]: gammu: Init:GSM_TryGetModel failed with error TIMEOUT[14]: No response in specified timeout. Probably the phone is not connected.

My gammu-detect :

root@raspberrypi:/home/pi# gammu-detect 
; Configuration file generated by gammu-detect.
; Please check The Gammu Manual for more information.

[gammu]
device = /dev/ttyUSB0
name = Phone on USB serial port TP-LINK__Incorporated TP-LINK_HSPA+_Modem
connection = at

[gammu1]
device = /dev/ttyUSB1
name = Phone on USB serial port TP-LINK__Incorporated TP-LINK_HSPA+_Modem
connection = at

[gammu2]
device = /dev/ttyUSB2
name = Phone on USB serial port TP-LINK__Incorporated TP-LINK_HSPA+_Modem
connection = at

Here is my gammu-smsdrc :

root@raspberrypi:/home/pi# cat /etc/gammu-smsdrc
; Configuration file generated by gammu-detect.
; Please check The Gammu Manual for more information.

[gammu]
GammuCoding = utf8
GammuLoc = fr_FR.UTF8
device = /dev/ttyUSB0
name = Phone on USB serial port TP-LINK__Incorporated TP-LINK_HSPA+_Modem
connection = at

[gammu1]
GammuCoding = utf8
GammuLoc = fr_FR.UTF8
device = /dev/ttyUSB1
name = Phone on USB serial port TP-LINK__Incorporated TP-LINK_HSPA+_Modem
connection = at

[gammu2]
GammuCoding = utf8
GammuLoc = fr_FR.UTF8
device = /dev/ttyUSB2
name = Phone on USB serial port TP-LINK__Incorporated TP-LINK_HSPA+_Modem
connection = at

# SMSD configuration, see gammu-smsdrc(5)
[smsd]
service = files
CheckSecurity = 0
logfile = /var/log/gammu-smsd.log
# Increase for debugging information
debuglevel = 4
RunOnReceive = /var/www/html/RaspiSMS/parseSMS.sh
RunOnFailure = /var/spool/gammu/on-error.sh
# Paths where messages are stored
inboxpath = /var/spool/gammu/inbox/
outboxpath = /var/spool/gammu/outbox/
sentsmspath = /var/spool/gammu/sent/
errorsmspath = /var/spool/gammu/error/

SMSC=+33695000695

ResetFrequency = 0
ReceiveFrequency = 60
StatusFrequency = 0
CheckBattery = 0
CheckSignal = 0
CheckNetwork = 0
CommTimeout = 60
SendTimeout = 60
LoopSleep = 10
CheckSecurity = 0

But when I try a Gammu identify :

root@raspberrypi:/home/pi# gammu identify
No response in specified timeout. Probably the phone is not connected.

Here are the revelent syslog when I boot the rpi:

raspberrypi kernel: [    5.396897] usb 1-1.4: New USB device found, idVendor=2357, idProduct=f000
raspberrypi kernel: [    5.396917] usb 1-1.4: New USB device strings: Mfr=3, Product=2, SerialNumber=4
raspberrypi kernel: [    5.396926] usb 1-1.4: Product: TP-LINK HSPA+ Modem
raspberrypi kernel: [    5.396935] usb 1-1.4: Manufacturer: TP-LINK, Incorporated
raspberrypi kernel: [    5.396943] usb 1-1.4: SerialNumber: 863745011345804
[...]
usb_modeswitch: switch device 2357:f000 on 001/004
[...]
raspberrypi kernel: [    7.061466] usb 1-1.4: new high-speed USB device number 5 using dwc_otg
raspberrypi kernel: [    7.194309] usb 1-1.4: New USB device found, idVendor=2357, idProduct=9000
raspberrypi kernel: [    7.194326] usb 1-1.4: New USB device strings: Mfr=3, Product=2, SerialNumber=4
raspberrypi kernel: [    7.194335] usb 1-1.4: Product: TP-LINK HSPA+ Modem
raspberrypi kernel: [    7.194345] usb 1-1.4: Manufacturer: TP-LINK, Incorporated
raspberrypi kernel: [    7.194353] usb 1-1.4: SerialNumber: 863745011345804
[...]
raspberrypi kernel: [    7.337716] usbserial: USB Serial support registered for GSM modem (1-port)
raspberrypi kernel: [    7.339617] option 1-1.4:1.0: GSM modem (1-port) converter detected
raspberrypi kernel: [    7.340044] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB0
raspberrypi kernel: [    7.340420] option 1-1.4:1.1: GSM modem (1-port) converter detected
raspberrypi kernel: [    7.340806] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB1
raspberrypi kernel: [    7.341234] option 1-1.4:1.3: GSM modem (1-port) converter detected
raspberrypi kernel: [    7.342861] usb 1-1.4: GSM modem (1-port) converter now attached to ttyUSB2
[...]
raspberrypi systemd[1]: Started USB_ModeSwitch_1-1.4.
raspberrypi dhcpcd[422]: wwan0: soliciting a DHCP lease
raspberrypi kernel: [    8.312614] scsi 0:0:0:0: CD-ROM            TP-LINK  MMC Storage      2.31 PQ: 0 ANSI: 2
raspberrypi kernel: [    8.315256] scsi 0:0:0:1: Direct-Access     TP-LINK  MMC Storage      2.31 PQ: 0 ANSI: 2

I have no more idea to make my dongle work again with gammu...

Any idea ? Thanks


Want to back this issue? Post a bounty on it! We accept bounties via Bountysource.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.