TTT: Fix error when using concommand "wepswitch" #1204

Merged
merged 1 commit into from Jul 17, 2016

Projects

None yet

3 participants

@markusmarkusz
Contributor

If you only run "wepswitch" then an error occurs.
And if you run it as console then the same error occurs.

[ERROR] gamemodes/terrortown/gamemode/weaponry.lua:183: attempt to call method 'GetWeapon' (a nil value)
  1. unknown - gamemodes/terrortown/gamemode/weaponry.lua:183
   2. unknown - lua/includes/modules/concommand.lua:54

This PR is a possible fix.

@robotboy655 robotboy655 added the TTT label Jul 16, 2016
@markusmarkusz markusmarkusz changed the title from TTT: Fixed error when using concommand "wepswitch" to TTT: Fix error when using concommand "wepswitch" Jul 16, 2016
@svdm svdm merged commit 0e5fbb5 into garrynewman:master Jul 17, 2016
@markusmarkusz markusmarkusz deleted the unknown repository branch Jul 25, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment