Skip to content
Branch: master
Find file History
freiksenet chore(release): Publish
 - babel-plugin-remove-graphql-queries@2.7.17
 - babel-preset-gatsby-package@0.2.12
 - babel-preset-gatsby@0.2.23
 - gatsby-cli@2.8.14
 - gatsby-codemods@1.1.16
 - gatsby-core-utils@1.0.21
 - gatsby-cypress@0.2.17
 - gatsby-dev-cli@2.5.39
 - gatsby-graphiql-explorer@0.2.29
 - gatsby-image@2.2.34
 - gatsby-link@2.2.25
 - gatsby-page-utils@0.0.32
 - gatsby-plugin-canonical-urls@2.1.16
 - gatsby-plugin-catch-links@2.1.18
 - gatsby-plugin-coffeescript@2.1.16
 - gatsby-plugin-create-client-paths@2.1.18
 - gatsby-plugin-cxs@2.1.14
 - gatsby-plugin-emotion@4.1.16
 - gatsby-plugin-facebook-analytics@2.2.17
 - gatsby-plugin-feed@2.3.22
 - gatsby-plugin-flow@1.1.15
 - gatsby-plugin-fullstory@2.1.17
 - gatsby-plugin-glamor@2.1.16
 - gatsby-plugin-google-analytics@2.1.29
 - gatsby-plugin-google-gtag@1.1.17
 - gatsby-plugin-google-tagmanager@2.1.18
 - gatsby-plugin-guess-js@1.1.26
 - gatsby-plugin-jss@2.1.15
 - gatsby-plugin-layout@1.1.16
 - gatsby-plugin-less@3.0.15
 - gatsby-plugin-lodash@3.1.16
 - gatsby-plugin-manifest@2.2.30
 - gatsby-plugin-mdx@1.0.58
 - gatsby-plugin-netlify-cms@4.1.29
 - gatsby-plugin-netlify@2.1.27
 - gatsby-plugin-nprogress@2.1.15
 - gatsby-plugin-offline@3.0.24
 - gatsby-plugin-page-creator@2.1.32
 - gatsby-plugin-postcss@2.1.16
 - gatsby-plugin-preact@3.1.22
 - gatsby-plugin-preload-fonts@1.0.18
 - gatsby-plugin-react-css-modules@2.1.16
 - gatsby-plugin-react-helmet@3.1.16
 - gatsby-plugin-remove-trailing-slashes@2.1.15
 - gatsby-plugin-sass@2.1.24
 - gatsby-plugin-sharp@2.3.4
 - gatsby-plugin-sitemap@2.2.22
 - gatsby-plugin-styled-components@3.1.14
 - gatsby-plugin-styled-jsx@3.1.15
 - gatsby-plugin-styletron@4.1.20
 - gatsby-plugin-stylus@2.1.17
 - gatsby-plugin-subfont@1.1.17
 - gatsby-plugin-twitter@2.1.15
 - gatsby-plugin-typescript@2.1.20
 - gatsby-plugin-typography@2.3.18
 - gatsby-react-router-scroll@2.1.17
 - gatsby-remark-autolink-headers@2.1.19
 - gatsby-remark-code-repls@3.0.20
 - gatsby-remark-copy-linked-files@2.1.31
 - gatsby-remark-custom-blocks@2.1.19
 - gatsby-remark-embed-snippet@4.1.16
 - gatsby-remark-graphviz@1.1.18
 - gatsby-remark-images-contentful@2.1.25
 - gatsby-remark-images@3.1.34
 - gatsby-remark-katex@3.1.18
 - gatsby-remark-prismjs@3.3.25
 - gatsby-remark-responsive-iframe@2.2.28
 - gatsby-remark-smartypants@2.1.17
 - gatsby-source-contentful@2.1.64
 - gatsby-source-drupal@3.3.8
 - gatsby-source-faker@2.1.15
 - gatsby-source-filesystem@2.1.39
 - gatsby-source-graphql@2.1.25
 - gatsby-source-hacker-news@2.1.17
 - gatsby-source-lever@2.1.20
 - gatsby-source-medium@2.1.15
 - gatsby-source-mongodb@2.1.24
 - gatsby-source-npm-package-search@2.1.19
 - gatsby-source-shopify@3.0.31
 - gatsby-source-wikipedia@2.1.15
 - gatsby-source-wordpress@3.1.50
 - gatsby-telemetry@1.1.40
 - gatsby-theme-blog-core@1.0.31
 - gatsby-theme-blog@1.2.3
 - gatsby-theme-notes@1.0.27
 - gatsby-theme-workspace@1.0.5
 - gatsby-transformer-asciidoc@1.1.18
 - gatsby-transformer-csv@2.1.19
 - gatsby-transformer-documentationjs@4.1.20
 - gatsby-transformer-excel@2.2.17
 - gatsby-transformer-hjson@2.2.21
 - gatsby-transformer-javascript-frontmatter@2.1.20
 - gatsby-transformer-javascript-static-exports@2.2.20
 - gatsby-transformer-json@2.2.20
 - gatsby-transformer-pdf@1.1.20
 - gatsby-transformer-react-docgen@5.0.22
 - gatsby-transformer-remark@2.6.38
 - gatsby-transformer-screenshot@2.1.42
 - gatsby-transformer-sharp@2.3.6
 - gatsby-transformer-sqip@2.1.48
 - gatsby-transformer-toml@2.2.19
 - gatsby-transformer-xml@2.1.20
 - gatsby-transformer-yaml@2.2.18
 - gatsby@2.18.4
 - graphql-skip-limit@2.1.21
Latest commit 168bb34 Nov 26, 2019

README.md

babel-preset-gatsby

Gatsby uses the phenomenal project Babel to enable support for writing modern JavaScript — while still supporting older browsers. This package contains the default Babel setup for all Gatsby projects.

For more information on how to customize the Babel configuration of your Gatsby site, check out our documentation.

Packages

Usage

Install babel-preset-gatsby and add a .babelrc file with the following content to the root of your project:

npm install --dev babel-preset-gatsby
{
  "presets": ["babel-preset-gatsby"]
}

Options

targets

{ [string]: number | string }, defaults to { "browsers": ["last 4 versions", "safari >= 7", "ie >= 9"] } in production and { "browsers": ["last 2 versions", "not ie <= 11", "not android 4.4.3"] } in development when targeting the browser and { "node": 6 } in production and { "node": "current" } in development when targeting Node.js.

Use this option to configure custom target browsers.

You can’t perform that action at this time.