New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tests may fail (with older PICA::Data?) #54

Closed
eserte opened this Issue Nov 18, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@eserte

eserte commented Nov 18, 2017

On some of my smokers t/04-exporter.t fails:

#   Failed test at t/04-exporter.t line 86.
#          got: '<?xml version="1.0" encoding="UTF-8"?>
# <collection xlmns="info:srw/schema/5/picaXML-v1.0">
# <record>
#   <datafield tag="003@">
#     <subfield code="0">1041318383</subfield>
#   </datafield>
#   <datafield tag="021A">
#     <subfield code="a">Hello $Â¥!</subfield>
#   </datafield>
# </record>
# <record>
#   <datafield tag="028C" occurrence="01">
#     <subfield code="d">Emma</subfield>
#     <subfield code="a">Goldman</subfield>
#   </datafield>
# </record>
# </collection>
# '
#     expected: '<?xml version="1.0" encoding="UTF-8"?>
# 
# <collection xmlns="info:srw/schema/5/picaXML-v1.0">
#   <record>
#     <datafield tag="003@">
#       <subfield code="0">1041318383</subfield>
#     </datafield>
#     <datafield tag="021A">
#       <subfield code="a">Hello $Â¥!</subfield>
#     </datafield>
#   </record>
#   <record>
#     <datafield tag="028C" occurrence="01">
#       <subfield code="d">Emma</subfield>
#       <subfield code="a">Goldman</subfield>
#     </datafield>
#   </record>
# </collection>
# '
# Looks like you failed 1 test of 4.
t/04-exporter.t ........ 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/4 subtests 

Statistical analysis suggests that it passes only with PICA::Data 0.34 --- so probably the minimum prerequisite version should be adjusted.

****************************************************************
Regression 'mod:PICA::Data'
****************************************************************
Name           	       Theta	      StdErr	 T-stat
[0='const']    	      0.0000	      0.0000	  10.09
[1='eq_0.34']  	      1.0000	      0.0000	91646440343380832.00

R^2= 1.000, N= 63, K= 2
****************************************************************

@jorol jorol self-assigned this Dec 8, 2017

@jorol

This comment has been minimized.

Show comment
Hide comment
@jorol

jorol Dec 8, 2017

Contributor

Thanks a lot for your work and bug reports! Fixed with #56

Contributor

jorol commented Dec 8, 2017

Thanks a lot for your work and bug reports! Fixed with #56

@jorol jorol closed this Dec 8, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment