Permalink
Browse files

Manually marge dependent library versions from `python-novaclient` an…

…d `keystoneauth1`

See issue #414 for details.
  • Loading branch information...
riccardomurri committed Apr 28, 2017
1 parent fa501dc commit 7bf55b883db43bbba9802328589ab1dfd4cd85c6
Showing with 2 additions and 0 deletions.
  1. +2 −0 setup.py
@@ -74,6 +74,7 @@ def run_tests(self):
# (at best) among the PyPA tools. An attempt to use the conditional syntax has
# already caused issues #308, #249, #227, and many more headaches to me while
# trying to find a combination of

# `pip`, `setuptools`, `wheel`, and dependency
# specification syntax that would work reliably across all supported Linux
# distributions. I give up, and revert to computing the dependencies via
@@ -179,6 +180,7 @@ def run_tests(self):
'azure',
# OpenStack clouds
'netifaces',
'requests!=2.13.0,!=2.12.2,>=2.10.0', ## see issue #414
#'python-novaclient' ## this needs special treatment depending on Python version, see below
] + version_dependent_requires),
tests_require=['tox', 'mock', 'pytest>=2.10'], # read right-to-left

0 comments on commit 7bf55b8

Please sign in to comment.