Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Don't depend on gems from git repository

  • Loading branch information...
commit 56c7ac832980f3b662ba8efeb8cef676cabe38ec 1 parent 9a8df81
@gcao authored
Showing with 14 additions and 28 deletions.
  1. +2 −8 Gemfile
  2. +6 −16 Gemfile.lock
  3. +6 −4 config/deploy.rb
View
10 Gemfile
@@ -20,14 +20,8 @@ gem "nokogiri"
gem "newrelic_rpm"
gem "jammit"
gem "capistrano"
-
-git "git://github.com/gcao/discuz_robot.git" do
- gem "discuz_robot"
-end
-
-git "git://github.com/gcao/sgf_parser.git" do
- gem "sgf_parser", :require => "sgf"
-end
+gem "discuz_robot", "~>0.1.0"
+gem "sgf_parser", "~>0.1.0"
group :development do
# bundler requires these gems in development
View
22 Gemfile.lock
@@ -1,15 +1,3 @@
-GIT
- remote: git://github.com/gcao/discuz_robot.git
- revision: 7850ee696f9ea125f97923bf66f9be909e0d152b
- specs:
- discuz_robot (0.1.0)
-
-GIT
- remote: git://github.com/gcao/sgf_parser.git
- revision: 070fefb8dd318413c574068331fd6a13481cf6b4
- specs:
- sgf_parser (0.1.0)
-
GEM
remote: http://rubygems.org/
remote: http://gems.github.com/
@@ -43,16 +31,17 @@ GEM
haml (>= 2.2.0)
daemons (1.1.4)
diff-lcs (1.1.3)
+ discuz_robot (0.1.0)
fastthread (1.0.7)
gem_plugin (0.2.3)
- haml (3.1.3)
+ haml (3.1.4)
highline (1.6.8)
hoptoad_notifier (2.4.11)
activesupport
builder
jammit (0.6.3)
yui-compressor (>= 0.9.3)
- json (1.6.1)
+ json (1.6.2)
metaclass (0.0.1)
mislav-will_paginate (2.3.11)
mocha (0.10.0)
@@ -100,6 +89,7 @@ GEM
activesupport
ruby-growl (3.0)
rubyist-aasm (2.1.1)
+ sgf_parser (0.1.0)
spork (0.8.5)
syslog-logger (1.6.4)
thoughtbot-paperclip (2.3.1)
@@ -114,7 +104,7 @@ DEPENDENCIES
calendar_date_select (>= 1.15)
capistrano
chriseppstein-compass (>= 0.8.11)
- discuz_robot!
+ discuz_robot (~> 0.1.0)
haml (>= 2.2.3)
hoptoad_notifier
jammit
@@ -132,7 +122,7 @@ DEPENDENCIES
rubaidh-google_analytics
ruby-growl
rubyist-aasm
- sgf_parser!
+ sgf_parser (~> 0.1.0)
spork
syslog-logger
thoughtbot-paperclip (>= 2.3.0)
View
10 config/deploy.rb
@@ -1,5 +1,9 @@
-raise "Environment variable CHEF_SERVER is not set." unless ENV["CHEF_SERVER"]
-raise "Environment variable CHEF_USER is not set." unless ENV["CHEF_USER"]
+%w(CHEF_SERVER CHEF_USER).each do |env|
+ raise "Environment variable #{env} is not set." unless ENV[env]
+end
+
+require 'hoptoad_notifier/capistrano'
+require 'bundler/capistrano'
set :application, "gocool"
set :deploy_to, "/data/apps/#{application}"
@@ -33,9 +37,7 @@
run "chmod -R a+w #{release_path}/public/stylesheets/cache #{release_path}/public/javascripts/cache"
end
-
Dir[File.join(File.dirname(__FILE__), '..', 'vendor', 'gems', 'hoptoad_notifier-*')].each do |vendored_notifier|
$: << File.join(vendored_notifier, 'lib')
end
-require 'hoptoad_notifier/capistrano'
Please sign in to comment.
Something went wrong with that request. Please try again.