Skip to content
Browse files

Python 2.6 compatibility fix. Thanks @Jamesc359 - closes #400

  • Loading branch information...
1 parent a171dbf commit 9bb8dc8e42da4e47008a0acd2a1d69e00193e02d @FiloSottile FiloSottile committed Aug 19, 2012
Showing with 1 addition and 1 deletion.
  1. BIN youtube-dl
  2. +1 −1 youtube_dl/utils.py
View
BIN youtube-dl
Binary file not shown.
View
2 youtube_dl/utils.py
@@ -223,7 +223,7 @@ def encodeFilename(s):
assert type(s) == type(u'')
- if sys.platform == 'win32' and sys.getwindowsversion().major >= 5:
+ if sys.platform == 'win32' and sys.getwindowsversion()[0] >= 5:
# Pass u'' directly to use Unicode APIs on Windows 2000 and up
# (Detecting Windows NT 4 is tricky because 'major >= 4' would
# match Windows 9x series as well. Besides, NT 4 is obsolete.)

0 comments on commit 9bb8dc8

Please sign in to comment.
Something went wrong with that request. Please try again.