Illformed requirement for 0.6.1 #11

Closed
dingzj opened this Issue Nov 28, 2011 · 6 comments

Comments

Projects
None yet
2 participants

dingzj commented Nov 28, 2011

when install, got the following message:

Successfully installed curb-fu-0.6.1
1 gem installed
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/curb-fu-0.6.1.gemspec]: Illformed requirement ["#Syck::DefaultKey:0x000000030094e0 1.3.2"]
Installing ri documentation for curb-fu-0.6.1...
Installing RDoc documentation for curb-fu-0.6.1...

Actually, it is NOT correctly installed, as I cannot require it.

Contributor

hypomodern commented Nov 28, 2011

what ruby version and on what platform?

-mhw

On Monday, November 28, 2011 at 1:04 PM, dingzj wrote:

when install, got the following message:

Successfully installed curb-fu-0.6.1
1 gem installed
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/curb-fu-0.6.1.gemspec]: Illformed requirement ["#Syck::DefaultKey:0x000000030094e0 1.3.2"]
Installing ri documentation for curb-fu-0.6.1...
Installing RDoc documentation for curb-fu-0.6.1...

Actually, it is NOT correctly installed, as I cannot require it.


Reply to this email directly or view it on GitHub:
#11

dingzj commented Nov 28, 2011

ruby 1.9.2p290 (2011-07-09 revision 32553) [x86_64-linux] on ubuntu 11.10

When I manually edit the gemspec by changing "#Syck::DefaultKey:...." to ">=", it fixed.
But why the "Syck::DefaultKey:...." coming from?

Contributor

hypomodern commented Nov 28, 2011

Sounds like a problem with rubygems + Psych/Syck on your machine. Annoying! Have you tried gem update --system to get the latest rubygems?

-mhw

On Monday, November 28, 2011 at 1:43 PM, dingzj wrote:

ruby 1.9.2p290 (2011-07-09 revision 32553) [x86_64-linux] on ubuntu 11.10

When I manually edit the gemspec by changing "#Syck::DefaultKey:...." to ">=", it fixed.
But why the "Syck::DefaultKey:...." coming from?


Reply to this email directly or view it on GitHub:
#11 (comment)

dingzj commented Nov 28, 2011

Just tried, update to rubygems 1.8.11
and remove gemspec file and re-install curb-fu again, still this same problem.

I believed the gem did get installed, ONLY the spec file is not correct generated, right?

dingzj commented Nov 29, 2011

Hi,

Is this line correct formatted in curb-fu.gemspec?
s.add_development_dependency('rspec', '1.3.2')

How about add ">=" before the version number 1.3.2?
That's the part I got Syck::..... inserted.

Contributor

hypomodern commented Nov 29, 2011

The gem builds fine on the variety of platforms I have access to, so I'm pretty sure that that line isn't the problem so much as your build of ruby or libyaml version, but I'd happily accept a pull request that specified a non-strict version dependency like >= 1.3.2.

-mhw

On Tuesday, November 29, 2011 at 5:52 PM, dingzj wrote:

Hi,

Is this line correct formatted in curb-fu.gemspec?
s.add_development_dependency('rspec', '1.3.2')

How about add ">=" before the version number 1.3.2?
That's the part I got Syck::..... inserted.


Reply to this email directly or view it on GitHub:
#11 (comment)

@hypomodern hypomodern closed this Nov 8, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment