Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 79 lines (52 sloc) 2.336 kb
ecdfd106 »
2011-12-15 multiterm: Add content to README, add TODO items and add COPYING file
1 =========
2 MultiTerm
3 =========
4
5
6 .. contents::
7
8
9 About
10 =====
11
12 MultiTerm is similar to Geany's built-in VTE terminal except that it
13 supports multiple terminals in tabs and supports different shells in
14 each of the terminal tabs.
15
16
17 Requirements
18 ============
19
20 MultiTerm depends on the very common VTE library (libvte). In order
21 to compile the MultiTerm plugin you will need the development files for
22 the VTE library.
23
24 MultiTerm is written in Vala and so requires that you have the Vala
25 compiler (valac) installed as well as your existing C compiler.
26
27
28 Installation
29 ============
30
31 For detailed instructions, see the INSTALL file of the Geany-Plugins package
32 this plugin is part of.
33
34
35 Usage
36 =====
37
38 While the user-interface of the plugin will soon be completely revamped,
39 at present it adds a new tab to the message area which contains the
40 notebook for the Terminals. You can add terminals by clicking on the
41 plus button to the right of the tabs and you can close terminals by
42 clicking the tab's close button.
43
44 The configuration file is also going to change a fair bit soon, but
45 it is stored at `~/.config/geany/plugins/multiterm/multiterm.conf` and
46 can be tweaked to change the behaviour of the plugin. Eventually there
47 will be a GUI to control the preferences, but for now it's just this
48 file.
49
50 Note that until at least the first release of the MultiTerm plugin the
51 configuration file will not be backwards-compatible, so you should
52 transfer your settings to a new default configuration file whenever
53 rebuilding from source. Moving the old config file out of the way will
54 cause a new default config file to be written in its place.
55
56
57 License
58 =======
59
60 MultiTerm is distributed under the terms of the GNU General Public License
61 as published by the Free Software Foundation, either version 2 of the
62 License, or (at your option) any later version. You should have received a copy
63 of the GNU General Public License along with WebHelper. If not, see
64 <http://www.gnu.org/licenses/>.
65
66
67 Contact
68 =======
69
70 You can email me at <matt(at)geany(dor)org>, and I may also be on the
71 #geany channel on FreeNode, under the `codebrainz` nickname.
72
73
74 Bug reports and feature requests
75 --------------------------------
76
77 To report a bug or ask for a new feature, please use the Geany-Plugins tracker
78 on SourceForge: http://sourceforge.net/tracker/?group_id=222729
Something went wrong with that request. Please try again.