Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Geany & Nim-language #1772

Closed
r3d9u11 opened this issue Feb 17, 2018 · 3 comments

Comments

@r3d9u11
Copy link

commented Feb 17, 2018

Hi. Wich status of nim-language support?

I'm found this PR and I'm tried Geany 1.27 (available in repos of Linux Mint 18.3), but it haven't syntax highlighting and autocompletion :(
1

Thanks!

@elextr

This comment has been minimized.

Copy link
Member

commented Feb 17, 2018

@r3d9u11 #193 has not been applied, you will have to apply it yourself. The OP announced no time to continue it back in 2015 and nobody has taken it over, or announced they have tested it or anything.

Basically the biggest problem I suspect is that none of the Geany devs are Nim users, so they don't know enough to test it more than extremely superficially. If Nim users want it, they can take it over (or propose a new PR) and a number of people who use Nim should post that they have tested the PR fairly well and it works for them.

@r3d9u11

This comment has been minimized.

Copy link
Author

commented Feb 17, 2018

@elextr thanks for answer!

@r3d9u11 r3d9u11 closed this Feb 17, 2018
@eht16

This comment has been minimized.

Copy link
Member

commented Sep 28, 2019

JFTR, Nim was added in #2085.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.